notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Want a good monitor light? See my photosAll times are UTC
Ukraine
This referral link gives you 10% off a Fastmail.com account and gives me a discount on my Fastmail account.
New feature planned: get notified when the package is available. Now is the time to contribute ideas/suggestions.
Sanity Test Failures

These are the sanity test failures found by FreshPorts. Sanity tests have been in place for several years, but have only been saved in the database since 10 October 2006.

Thursday, 22 Feb 2024
23:07 Jose Alonso Cardenas Marquez (acm) search for other commits by this committer
finance/odoo: Update to 16.0.20240222
commit hash: ec00176239ea40306fab0b38d3e01e47ad214a16 commit hash: ec00176239ea40306fab0b38d3e01e47ad214a16 commit hash: ec00176239ea40306fab0b38d3e01e47ad214a16 commit hash: ec00176239ea40306fab0b38d3e01e47ad214a16  Sanity Test Failure
Tuesday, 30 Jan 2024
05:36 Emmanuel Vadot (manu) search for other commits by this committer
graphics/drm-kmod: Set default version for 15-CURRENT to 6.1-lts

Switch CURRENT users to 6.1-lts drm port.

Sponsored by:	Beckhoff Automation GmbH & Co. KG
commit hash: 4df670b471998621041d14c4a6d17f8b2ef5e089 commit hash: 4df670b471998621041d14c4a6d17f8b2ef5e089 commit hash: 4df670b471998621041d14c4a6d17f8b2ef5e089 commit hash: 4df670b471998621041d14c4a6d17f8b2ef5e089  Sanity Test Failure
Sunday, 28 Jan 2024
22:04 Palle Girgensohn (girgen) search for other commits by this committer
www/sqlpage: Upgrade to 0.18.1

Release notes:	https://github.com/lovasoa/SQLpage/releases/tag/v0.18.1
commit hash: 6a2ead82fb9d7a1f88a23e5250609529c80a6845 commit hash: 6a2ead82fb9d7a1f88a23e5250609529c80a6845 commit hash: 6a2ead82fb9d7a1f88a23e5250609529c80a6845 commit hash: 6a2ead82fb9d7a1f88a23e5250609529c80a6845  Sanity Test Failure
Sunday, 14 Jan 2024
20:28 Daniel Engberg (diizzy) search for other commits by this committer Author: Pavel Timofeev
games/jaggedalliance2: Update to 0.21.0

Changelog:
https://ja2-stracciatella.github.io/2023/11/06/release-0.21.0.html

PR:		275379
commit hash: d7a3206d8a0b04dd447d6da6a73a4c20067b4afc commit hash: d7a3206d8a0b04dd447d6da6a73a4c20067b4afc commit hash: d7a3206d8a0b04dd447d6da6a73a4c20067b4afc commit hash: d7a3206d8a0b04dd447d6da6a73a4c20067b4afc  Sanity Test Failure
Sunday, 7 Jan 2024
16:18 Diane Bruce (db) search for other commits by this committer
audio/baudline: upstream has removed distribution

baudline has gone to a subscription model and has released 1.09
which is only available via this model. The 1.08 version has
been removed but it is possible this is only temporary. I'm
going to mark the port for removal since we have alternatives.
commit hash: 316bd4fa26281f121f78e2f5baed03892fb83766 commit hash: 316bd4fa26281f121f78e2f5baed03892fb83766 commit hash: 316bd4fa26281f121f78e2f5baed03892fb83766 commit hash: 316bd4fa26281f121f78e2f5baed03892fb83766  Sanity Test Failure
Friday, 5 Jan 2024
15:09 Jan Beich (jbeich) search for other commits by this committer
Saturday, 23 Dec 2023
19:03 Muhammad Moinur Rahman (bofh) search for other commits by this committer
  • www/websh Embeds a TCL8 interpreter in the Apache server Refresh
www/websh: Mark DEPRECATED

- Mark BROKEN on all versions of FreeBSD
- Upstream has marked the project dismissed
- Set EXPIRATION_DATE 2024-01-24
- Add LICENSE APACHE20
- Pet portclippy

Approved by:	portmgr (blanket)
commit hash: 71d48d8d391b099255e295b3b0fc386dbad06005 commit hash: 71d48d8d391b099255e295b3b0fc386dbad06005 commit hash: 71d48d8d391b099255e295b3b0fc386dbad06005 commit hash: 71d48d8d391b099255e295b3b0fc386dbad06005  Sanity Test Failure
Saturday, 16 Dec 2023
22:21 Muhammad Moinur Rahman (bofh) search for other commits by this committer
editors/asedit: Mark DEPRECATED

- Upstream release was last in 2003
- Set EXPIRATION_DATE 2024-03-31
commit hash: 2309ba9ea2fea945a3589c47ca3507dba108126a commit hash: 2309ba9ea2fea945a3589c47ca3507dba108126a commit hash: 2309ba9ea2fea945a3589c47ca3507dba108126a commit hash: 2309ba9ea2fea945a3589c47ca3507dba108126a  Sanity Test Failure
Thursday, 7 Dec 2023
12:21 Alexander Leidinger (netchild) search for other commits by this committer
mail/roundcube-tls_icon: New port

A roundcube plugin to display if a mail was received via TLS.
commit hash: c984d8b061c3d692b2190c7432c89a74cb01e991 commit hash: c984d8b061c3d692b2190c7432c89a74cb01e991 commit hash: c984d8b061c3d692b2190c7432c89a74cb01e991 commit hash: c984d8b061c3d692b2190c7432c89a74cb01e991  Sanity Test Failure
12:20 Alexander Leidinger (netchild) search for other commits by this committer
mail/roundcube-gravatar: New port

A gravatar plugin for roundcube.
commit hash: 32715e208d12b45f7e3220684713aac0abdbefc6 commit hash: 32715e208d12b45f7e3220684713aac0abdbefc6 commit hash: 32715e208d12b45f7e3220684713aac0abdbefc6 commit hash: 32715e208d12b45f7e3220684713aac0abdbefc6  Sanity Test Failure
Tuesday, 28 Nov 2023
16:38 Jose Alonso Cardenas Marquez (acm) search for other commits by this committer
print/fpc-libcups: Remove obsolete port

- It was merged into lang/fpc

(cherry picked from commit 1868ea4b8e0dd14345bbc54ac5845139be413bd8)
commit hash: b2590831280ca05ab8a185b8bd81f497f7b17e11 commit hash: b2590831280ca05ab8a185b8bd81f497f7b17e11 commit hash: b2590831280ca05ab8a185b8bd81f497f7b17e11 commit hash: b2590831280ca05ab8a185b8bd81f497f7b17e11  Sanity Test Failure
Sunday, 26 Nov 2023
01:18 Jose Alonso Cardenas Marquez (acm) search for other commits by this committer
Monday, 13 Nov 2023
00:51 Jose Alonso Cardenas Marquez (acm) search for other commits by this committer
  • www/linux-opera Blazingly fast, full-featured, standards-compliant browser Deleted Refresh Deprecated Expired
www/linux-opera: Mark DEPRECATED

- This port is outdated and not supported anymore
PR:		275037
Reported by:	anniiii _at_ anniiii.xyz
commit hash: 0010bd407b8085836ae24fb06383d69b13bcd981 commit hash: 0010bd407b8085836ae24fb06383d69b13bcd981 commit hash: 0010bd407b8085836ae24fb06383d69b13bcd981 commit hash: 0010bd407b8085836ae24fb06383d69b13bcd981  Sanity Test Failure
Sunday, 12 Nov 2023
20:49 Jose Alonso Cardenas Marquez (acm) search for other commits by this committer
  • archivers/fpc-bzip2 3.2.2_3 Free Pascal bzip2 unit Deleted
    • archivers/fpc-unzip 3.2.2_3 Free Pascal routines for unzipping zip files Deleted
      • archivers/peazip 9.4.0_1 Free archiver and file compressor
        • audio/fpc-a52 3.2.2_3 Free Pascal interface to a52 library Deleted
          • audio/fpc-mad 3.2.2_4 Free Pascal interface to mad library Deleted
            • audio/fpc-modplug 3.2.2_3 Free Pascal interface to modplug library Deleted
              • audio/fpc-oggvorbis 3.2.2_3 Free Pascal interface to ogg & vorbis libraries Deleted
                • audio/fpc-openal 3.2.2_3 Free Pascal interface to openal library Deleted
                  • cad/zcad 0.9.8.5_10 Simple CAD program Broken Ignore
                    • comms/cqrlog 2.5.2_5 Amateur Radio logging application
                                                                                                                                                                                                                                              (Only the first 10 of 119 items in this commit are shown above. View all ports for this commit)
                                                                                                                                                                                                                                              lang/fpc-*: Merge all units to lang/fpc
                                                                                                                                                                                                                                              
                                                                                                                                                                                                                                              - Merge all fpc-* units to lang/fpc. It gives us a better way to maintain fpc
                                                                                                                                                                                                                                                and lazarus ports.
                                                                                                                                                                                                                                              - Update Mk/fpc.mk for reflects new changes
                                                                                                                                                                                                                                              - Update Mk/lazarus.mk for reflects new changes
                                                                                                                                                                                                                                              - Now we can defined WANT_FPC_DEVEL AND WANT_LAZARUS_DEVEL for use devel version
                                                                                                                                                                                                                                                of fpc or lazarus for build apps based on fpc/lazarus
                                                                                                                                                                                                                                              - Add entries to MOVED
                                                                                                                                                                                                                                              - Bump PORTREVISON of affected ports
                                                                                                                                                                                                                                              - Some other minor modifications
                                                                                                                                                                                                                                              commit hash: 0b92f925a3a155ce7b5f4eddfd528553915c6eb8 commit hash: 0b92f925a3a155ce7b5f4eddfd528553915c6eb8 commit hash: 0b92f925a3a155ce7b5f4eddfd528553915c6eb8 commit hash: 0b92f925a3a155ce7b5f4eddfd528553915c6eb8  Sanity Test Failure
Friday, 10 Nov 2023
20:15 Jose Alonso Cardenas Marquez (acm) search for other commits by this committer
  • branches/2023Q4/editors/lazarus-devel 3.0.0.20231028 Portable Delphi-like IDE for the FreePascal compiler (GTK2 devel)
  • editors/lazarus-*-devel: Update to 3.0.0.20231028
    
    - Update pkg-message.in file
    - Add -p to ${INSTALL_DATA} to preserves the access and modification times. It
      avoids issues with checksum changes and it improves compile time when lazarus
      ide is rebuild by users.
    - Update CONFLICTS
    
    (cherry picked from commit c626e9b7f55e7351efe5f2016f3ddd06c37e08d9)
    commit hash: 0b5104aa249fefa3765b614db8fec39b4c2837cd commit hash: 0b5104aa249fefa3765b614db8fec39b4c2837cd commit hash: 0b5104aa249fefa3765b614db8fec39b4c2837cd commit hash: 0b5104aa249fefa3765b614db8fec39b4c2837cd  Sanity Test Failure
Sunday, 5 Nov 2023
23:38 Muhammad Moinur Rahman (bofh) search for other commits by this committer
  • math/geonext Interactive (dynamic) elementary Geometry Software Deleted Refresh Deprecated Expired
math/geonext: Mark DEPRECATED

- Last upstream release was in 2014
- Current WWW redirects to a cloud based application
- Set EXPIRATION_DATE 2023-12-05

Approved by:	portmgr (blanket)
commit hash: 21cea368930f4a0d10c5bc5fca1bfc7efec13ea1 commit hash: 21cea368930f4a0d10c5bc5fca1bfc7efec13ea1 commit hash: 21cea368930f4a0d10c5bc5fca1bfc7efec13ea1 commit hash: 21cea368930f4a0d10c5bc5fca1bfc7efec13ea1  Sanity Test Failure
Wednesday, 25 Oct 2023
20:28 Jose Alonso Cardenas Marquez (acm) search for other commits by this committer
sysutils/bacnet-stack-apps: New port: open source protocol stack for embedded
systems (apps)

BACnet Protocol Stack library provides a BACnet application layer, network
layer and media access (MAC) layer communications services. (Applications)
commit hash: e24e020411794a631511da1ea4120671bdd17a27 commit hash: e24e020411794a631511da1ea4120671bdd17a27 commit hash: e24e020411794a631511da1ea4120671bdd17a27 commit hash: e24e020411794a631511da1ea4120671bdd17a27  Sanity Test Failure
Monday, 16 Oct 2023
15:59 Po-Chuan Hsieh (sunpoet) search for other commits by this committer
  • www/node V8 JavaScript for client and server (meta port) Refresh
www/node: Use the user's default nodejs version
commit hash: e4bae576a4cda2650e3e416fab271a82afe959a9 commit hash: e4bae576a4cda2650e3e416fab271a82afe959a9 commit hash: e4bae576a4cda2650e3e416fab271a82afe959a9 commit hash: e4bae576a4cda2650e3e416fab271a82afe959a9  Sanity Test Failure
Friday, 13 Oct 2023
23:54 Cy Schubert (cy) search for other commits by this committer
sysutils/cfengine-masterfiles321: Update to 3.21.3

(cherry picked from commit 8831802ddec278192e44c85c5d348ce4f7cc871b)
commit hash: 4696d78a42e2e02c0a61f2547033cc5de07eb8d9 commit hash: 4696d78a42e2e02c0a61f2547033cc5de07eb8d9 commit hash: 4696d78a42e2e02c0a61f2547033cc5de07eb8d9 commit hash: 4696d78a42e2e02c0a61f2547033cc5de07eb8d9  Sanity Test Failure
Sunday, 8 Oct 2023
07:18 Dave Cottlehuber (dch) search for other commits by this committer
  • www/h2o-devel Optimized HTTP/2 server including support for TLS 1.3 and HTTP/1.x Refresh
www/h2o-devel: update to 20230928 snapshot, drop fusion on i386
commit hash: a684b12d8fe17f502a4a070fae16a30d4055f501 commit hash: a684b12d8fe17f502a4a070fae16a30d4055f501 commit hash: a684b12d8fe17f502a4a070fae16a30d4055f501 commit hash: a684b12d8fe17f502a4a070fae16a30d4055f501  Sanity Test Failure
Saturday, 30 Sep 2023
15:10 Muhammad Moinur Rahman (bofh) search for other commits by this committer
  • net/intel-em-kmod Gigabit FreeBSD Base Drivers for Intel(R) Ethernet Refresh
    • net/intel-igb-kmod NIC Driver for Intel(R) 82575/6 and 82580-Based cards Refresh
    • net/intel-*-kmod: Remove MAX_NETMAP_OSVERSION
      
      ALl the version mentioned here for MAX_NETMAP_OSVERSION are unsupported
      by the ports tree. So remove the check and also remove the OPTION
      NETMAP_AUTO.
      
      Approved by:	portmgr (blanket)
      commit hash: e717a9367f81224bf402a7b739d9b0e4a06c390b commit hash: e717a9367f81224bf402a7b739d9b0e4a06c390b commit hash: e717a9367f81224bf402a7b739d9b0e4a06c390b commit hash: e717a9367f81224bf402a7b739d9b0e4a06c390b  Sanity Test Failure
Wednesday, 30 Aug 2023
16:52 Muhammad Moinur Rahman (bofh) search for other commits by this committer
devel/libsigrok: Fix build with llvm16

Sponsored by:	The FreeBSD Foundation
commit hash: b8948f86c12cfe8a24ba203634e3a1572eab4ba8 commit hash: b8948f86c12cfe8a24ba203634e3a1572eab4ba8 commit hash: b8948f86c12cfe8a24ba203634e3a1572eab4ba8 commit hash: b8948f86c12cfe8a24ba203634e3a1572eab4ba8  Sanity Test Failure
Wednesday, 16 Aug 2023
06:13 Matthew Seaman (matthew) search for other commits by this committer
security/pam_ssh_agent_auth: mark as broken with OpenSSL 3.x

While this compiles successfully, it doesn't produce a working
pam_ssh_agent_auth.so PAM module.

PR:		272220
Reported by:	madpilot
commit hash: a97d608312ec78a1da88c6a43b060069845d8c5e commit hash: a97d608312ec78a1da88c6a43b060069845d8c5e commit hash: a97d608312ec78a1da88c6a43b060069845d8c5e commit hash: a97d608312ec78a1da88c6a43b060069845d8c5e  Sanity Test Failure
Saturday, 12 Aug 2023
01:37 Piotr Kubaj (pkubaj) search for other commits by this committer
  • games/tome4 Epic tactical turn-based roguelike adventure Refresh
games/tome4: drop bfd on powerpc
commit hash: fb32485df3878eaef581cd2d81b246a2dae0f3d5 commit hash: fb32485df3878eaef581cd2d81b246a2dae0f3d5 commit hash: fb32485df3878eaef581cd2d81b246a2dae0f3d5 commit hash: fb32485df3878eaef581cd2d81b246a2dae0f3d5  Sanity Test Failure
Sunday, 6 Aug 2023
10:16 Daniel Engberg (diizzy) search for other commits by this committer
vapoursynth-fmtconv: Update to version r30

* Drop ARM 32-bit, too slow platform to be usable
* Switch to upstream release archive
commit hash: e255bf2bdaa51438688cdfbf65385856086498f3 commit hash: e255bf2bdaa51438688cdfbf65385856086498f3 commit hash: e255bf2bdaa51438688cdfbf65385856086498f3 commit hash: e255bf2bdaa51438688cdfbf65385856086498f3  Sanity Test Failure
Wednesday, 26 Jul 2023
04:28 Loïc Bartoletti (lbartoletti) search for other commits by this committer
graphics/qt6-3d: fix build on i386

PR:	272422
Exp-run by:	antoine
commit hash: 8f8a9b9357c846475b76853b3925871c3e4a04ce commit hash: 8f8a9b9357c846475b76853b3925871c3e4a04ce commit hash: 8f8a9b9357c846475b76853b3925871c3e4a04ce commit hash: 8f8a9b9357c846475b76853b3925871c3e4a04ce  Sanity Test Failure
Tuesday, 27 Jun 2023
21:13 Christoph Moench-Tegeder (cmt) search for other commits by this committer
  • www/firefox Web browser based on the browser portion of Mozilla Refresh
www/firefox: update to 115.0 (rc1)

Release Notes (soon):
  https://www.mozilla.org/en-US/firefox/115.0/releasenotes/
commit hash: cc72a4893237befed7f631554f489f72f7f130fb commit hash: cc72a4893237befed7f631554f489f72f7f130fb commit hash: cc72a4893237befed7f631554f489f72f7f130fb commit hash: cc72a4893237befed7f631554f489f72f7f130fb  Sanity Test Failure
Monday, 19 Jun 2023
13:18 Piotr Kubaj (pkubaj) search for other commits by this committer
lang/gcc12: fix build on powerpc64* with CPUTYPE?=g[3-5]

GCC doesn't support -mcpu=g4, but it supports -mcpu=G4. Same for g3 and g5.
commit hash: dcbc273b6b19b13eac1b1fbbb013148e1721dc85 commit hash: dcbc273b6b19b13eac1b1fbbb013148e1721dc85 commit hash: dcbc273b6b19b13eac1b1fbbb013148e1721dc85 commit hash: dcbc273b6b19b13eac1b1fbbb013148e1721dc85  Sanity Test Failure
Wednesday, 7 Jun 2023
07:25 Muhammad Moinur Rahman (bofh) search for other commits by this committer
graphics/gdchart: Fix build on 14

- Pet portclippy
- Adopt port
commit hash: 21b9bb46c0c099e008dfb1f8eca5effaf6a258ee commit hash: 21b9bb46c0c099e008dfb1f8eca5effaf6a258ee commit hash: 21b9bb46c0c099e008dfb1f8eca5effaf6a258ee commit hash: 21b9bb46c0c099e008dfb1f8eca5effaf6a258ee  Sanity Test Failure
Monday, 5 Jun 2023
08:47 Matthew Seaman (matthew) search for other commits by this committer Author: Darcy Buskermolen
graphics/tippecanoe: Update to tippecanoe 2.26.1

Maintainer update to Version 2.26.1
Add bash to BUILD_DEPENDS

Suppress clang16 build failure on i386: non-constant-expression cannot
be narrowed from type 'uint64_t'

Changes:	https://github.com/felt/tippecanoe/releases/tag/2.26.1
PR:		271789
commit hash: 1d61daa912396e4f5d31d130fe9600540ba6644b commit hash: 1d61daa912396e4f5d31d130fe9600540ba6644b commit hash: 1d61daa912396e4f5d31d130fe9600540ba6644b commit hash: 1d61daa912396e4f5d31d130fe9600540ba6644b  Sanity Test Failure
Tuesday, 30 May 2023
08:34 Yuri Victorovich (yuri) search for other commits by this committer
misc/py-lightning-utilities: New port: PyTorch Lightning sample project
commit hash: 887237b23c3275da9ed34dc79a44b9b84cb3e51e commit hash: 887237b23c3275da9ed34dc79a44b9b84cb3e51e commit hash: 887237b23c3275da9ed34dc79a44b9b84cb3e51e commit hash: 887237b23c3275da9ed34dc79a44b9b84cb3e51e  Sanity Test Failure
Thursday, 18 May 2023
19:48 Vladimir Druzenko (vvd) search for other commits by this committer
Thursday, 4 May 2023
22:19 Dan Langille (dvl) search for other commits by this committer Author: Andreas Motl
sysutils/py-mqttwarn: Rename option REISPUB to REDISPUB

The REISPUB option was spelled wrong. Let's rename it.

While here, add an UPDATING entry to let the users know it changed.
commit hash: 35c70b0431781b47c33d8b977e020e18b5480558 commit hash: 35c70b0431781b47c33d8b977e020e18b5480558 commit hash: 35c70b0431781b47c33d8b977e020e18b5480558 commit hash: 35c70b0431781b47c33d8b977e020e18b5480558  Sanity Test Failure
Saturday, 22 Apr 2023
15:21 Bjoern A. Zeeb (bz) search for other commits by this committer
  • net/wifi-firmware-ath10k-kmod 20230310 Firmware modules for ath10k WiFi NIC
    • net/wifi-firmware-ath11k-kmod 20230310 Firmware modules for ath11k WiFi NIC
      • net/wifi-firmware-base Firmware modules for base WiFi NIC Deleted Ignore
        • net/wifi-firmware-mt76-kmod 20230310 Firmware modules for mt76 WiFi NIC
          • net/wifi-firmware-rtw88-kmod 20230310 Firmware modules for rtw88 WiFi NIC
          • net/wifi-firmware-*: add framework and firmware for various WiFi chipsets
            
            Add a "base port framework" to fetch (WiFi) firmware and license files
            from the linux-firmware.git repository and an accompanying FreeBSD
            build kmod framework tarball (for now; we might do without that in
            the future).
            Add child ports for Realtek rtw88 and rtw89, Mediatek mt76, and
            Atheros ath10k and ath11k firmware as a start.
            
            This is a beginning in order to stop bloating src.git and the
            installed kernels with lots of MB of firmware files whereas usually
            only one vebdor/chipset/flavor is needed.  Before fully switching
            more infrastructure needs to be in place but this is the first and
            most important step.
            
            PR:		270742
            Reviewed by:	lwhsu
            Approved by:	lwhsu (ports)
            Differential Revision: https://reviews.freebsd.org/D39487
            commit hash: 3082cab3f868c1f7538d5221080703d891a2d0a6 commit hash: 3082cab3f868c1f7538d5221080703d891a2d0a6 commit hash: 3082cab3f868c1f7538d5221080703d891a2d0a6 commit hash: 3082cab3f868c1f7538d5221080703d891a2d0a6  Sanity Test Failure
Wednesday, 12 Apr 2023
05:39 Muhammad Moinur Rahman (bofh) search for other commits by this committer Author: Dima Panov
  • lang/php81 8.1.17 PHP Scripting Language (8.1.X branch) Deprecated Expiration Date
    • lang/php82 8.2.4 PHP Scripting Language (8.2.X branch)
    lang/php8[12]: Fix build on aarch64 with ZTS
    
    - Refresh patches
    
    PR:		266175
    Reported by:	thresh@nginx.com
    Sponsored by:	Bounce Experts
    commit hash: c89b6f2799891129e89d1b4fedf8e25865241060 commit hash: c89b6f2799891129e89d1b4fedf8e25865241060 commit hash: c89b6f2799891129e89d1b4fedf8e25865241060 commit hash: c89b6f2799891129e89d1b4fedf8e25865241060  Sanity Test Failure
Saturday, 8 Apr 2023
18:24 Matthias Fechner (mfechner) search for other commits by this committer
Wednesday, 5 Apr 2023
20:19 Diane Bruce (db) search for other commits by this committer
devel/zpu-gcc: Obsolete port no longer needed

This port was originally needed for the uhd port.
Obsolete port and no longer used.
commit hash: 458e9135c145f9b5ef78948c2df15cb0cb35dbfb commit hash: 458e9135c145f9b5ef78948c2df15cb0cb35dbfb commit hash: 458e9135c145f9b5ef78948c2df15cb0cb35dbfb commit hash: 458e9135c145f9b5ef78948c2df15cb0cb35dbfb  Sanity Test Failure
Monday, 13 Feb 2023
09:26 Alex Dupre (ale) search for other commits by this committer
lang/solidity: try to fix build on -CURRENT
commit hash: 4cc8205e2faada337e0e7cd2bc7e8c621fdef9f3 commit hash: 4cc8205e2faada337e0e7cd2bc7e8c621fdef9f3 commit hash: 4cc8205e2faada337e0e7cd2bc7e8c621fdef9f3 commit hash: 4cc8205e2faada337e0e7cd2bc7e8c621fdef9f3  Sanity Test Failure
Sunday, 12 Feb 2023
18:06 Piotr Kubaj (pkubaj) search for other commits by this committer
graphics/bgfx: Revert "fix build on powerpc64* and probably riscv64"

Wrong cherry-pick, this port doesn't exist in 2023Q1.

Reported by:	Freshports

This reverts commit 85f7d7a34bad0da5785708b8c7932375dc3cf060.
commit hash: b9b118c5d292b7030dea9f70ed7e7c16e8751f04 commit hash: b9b118c5d292b7030dea9f70ed7e7c16e8751f04 commit hash: b9b118c5d292b7030dea9f70ed7e7c16e8751f04 commit hash: b9b118c5d292b7030dea9f70ed7e7c16e8751f04  Sanity Test Failure
17:57 Piotr Kubaj (pkubaj) search for other commits by this committer
graphics/bgfx: fix build on powerpc64* and probably riscv64

/wrkdirs/usr/ports/graphics/bgfx/work/bgfx.cmake-1.118.8398-370/bimg/3rdparty/nvtt/nvcore/debug.h:173:10:
error: cast from pointer to smaller type 'uint32' (aka 'unsigned int') loses
information
            if (reinterpret_cast<uint32>(ptr) == 0xcccccccc) return false;
                ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/wrkdirs/usr/ports/graphics/bgfx/work/bgfx.cmake-1.118.8398-370/bimg/3rdparty/nvtt/nvcore/debug.h:174:10:
error: cast from pointer to smaller type 'uint32' (aka 'unsigned int') loses
information
            if (reinterpret_cast<uint32>(ptr) == 0xcdcdcdcd) return false;
                ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/wrkdirs/usr/ports/graphics/bgfx/work/bgfx.cmake-1.118.8398-370/bimg/3rdparty/nvtt/nvcore/debug.h:175:10:
error: cast from pointer to smaller type 'uint32' (aka 'unsigned int') loses
information
            if (reinterpret_cast<uint32>(ptr) == 0xdddddddd) return false;
                ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/wrkdirs/usr/ports/graphics/bgfx/work/bgfx.cmake-1.118.8398-370/bimg/3rdparty/nvtt/nvcore/debug.h:176:10:
error: cast from pointer to smaller type 'uint32' (aka 'unsigned int') loses
information
            if (reinterpret_cast<uint32>(ptr) == 0xffffffff) return false;
                ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~

(cherry picked from commit 32cf9412c58d339066e091ad088126e1236b52dd)
commit hash: 85f7d7a34bad0da5785708b8c7932375dc3cf060 commit hash: 85f7d7a34bad0da5785708b8c7932375dc3cf060 commit hash: 85f7d7a34bad0da5785708b8c7932375dc3cf060 commit hash: 85f7d7a34bad0da5785708b8c7932375dc3cf060  Sanity Test Failure
Thursday, 22 Dec 2022
12:00 Loïc Bartoletti (lbartoletti) search for other commits by this committer
graphics/comical: mark deprecated
commit hash: 3f4e6b46bfe0c690d5ac8d9545d1605f71e5d92c commit hash: 3f4e6b46bfe0c690d5ac8d9545d1605f71e5d92c commit hash: 3f4e6b46bfe0c690d5ac8d9545d1605f71e5d92c commit hash: 3f4e6b46bfe0c690d5ac8d9545d1605f71e5d92c  Sanity Test Failure
12:00 Loïc Bartoletti (lbartoletti) search for other commits by this committer
  • math/graphthing Tool that allows you to create, manipulate, and study graphs Deleted Refresh
math/graphthing: mark deprecated
commit hash: 35e5bbdcef93e75765f08e438b92c41fab1dc468 commit hash: 35e5bbdcef93e75765f08e438b92c41fab1dc468 commit hash: 35e5bbdcef93e75765f08e438b92c41fab1dc468 commit hash: 35e5bbdcef93e75765f08e438b92c41fab1dc468  Sanity Test Failure
12:00 Loïc Bartoletti (lbartoletti) search for other commits by this committer
  • net/opennx Open source drop in replacement for NoMachine's NX client Deleted Refresh
net/opennx: mark deprecated
commit hash: 791a137fcdb44b6841a1c23a25aeedf48a34a645 commit hash: 791a137fcdb44b6841a1c23a25aeedf48a34a645 commit hash: 791a137fcdb44b6841a1c23a25aeedf48a34a645 commit hash: 791a137fcdb44b6841a1c23a25aeedf48a34a645  Sanity Test Failure
12:00 Loïc Bartoletti (lbartoletti) search for other commits by this committer
net-p2p/amule-devel: mark deprecated
commit hash: 9174a18b9e5b13f0b571fc514d3c972a787762a0 commit hash: 9174a18b9e5b13f0b571fc514d3c972a787762a0 commit hash: 9174a18b9e5b13f0b571fc514d3c972a787762a0 commit hash: 9174a18b9e5b13f0b571fc514d3c972a787762a0  Sanity Test Failure
12:00 Loïc Bartoletti (lbartoletti) search for other commits by this committer
deskutils/xchm: mark deprecated
commit hash: 845606f080d436093df94abcc90aa51c103550fc commit hash: 845606f080d436093df94abcc90aa51c103550fc commit hash: 845606f080d436093df94abcc90aa51c103550fc commit hash: 845606f080d436093df94abcc90aa51c103550fc  Sanity Test Failure
12:00 Loïc Bartoletti (lbartoletti) search for other commits by this committer
editors/madedit: mark deprecated
commit hash: f43424c55b82dd1b4424688948c670690e424db1 commit hash: f43424c55b82dd1b4424688948c670690e424db1 commit hash: f43424c55b82dd1b4424688948c670690e424db1 commit hash: f43424c55b82dd1b4424688948c670690e424db1  Sanity Test Failure
12:00 Loïc Bartoletti (lbartoletti) search for other commits by this committer
emulators/lisaem: mark deprecated
commit hash: 5fd997ddc4bcccccc5def87546167f47142f8e4f commit hash: 5fd997ddc4bcccccc5def87546167f47142f8e4f commit hash: 5fd997ddc4bcccccc5def87546167f47142f8e4f commit hash: 5fd997ddc4bcccccc5def87546167f47142f8e4f  Sanity Test Failure
12:00 Loïc Bartoletti (lbartoletti) search for other commits by this committer
games/scorched3d: mark deprecated
commit hash: e26bf9a85fa482f31e114a084e866b22548b2588 commit hash: e26bf9a85fa482f31e114a084e866b22548b2588 commit hash: e26bf9a85fa482f31e114a084e866b22548b2588 commit hash: e26bf9a85fa482f31e114a084e866b22548b2588  Sanity Test Failure
12:00 Loïc Bartoletti (lbartoletti) search for other commits by this committer
  • cad/basicdsp Program for experimenting with simple audio DSP algorithms Deleted Refresh
cad/basicdsp: mark deprecated
commit hash: d9186c898e096ecba7bdf4416bc6e380c86e10d7 commit hash: d9186c898e096ecba7bdf4416bc6e380c86e10d7 commit hash: d9186c898e096ecba7bdf4416bc6e380c86e10d7 commit hash: d9186c898e096ecba7bdf4416bc6e380c86e10d7  Sanity Test Failure
12:00 Loïc Bartoletti (lbartoletti) search for other commits by this committer
comms/ebook2cwgui: mark deprecated
commit hash: 212897e4557f4065699dc81d7d1cb4cac5b8e29c commit hash: 212897e4557f4065699dc81d7d1cb4cac5b8e29c commit hash: 212897e4557f4065699dc81d7d1cb4cac5b8e29c commit hash: 212897e4557f4065699dc81d7d1cb4cac5b8e29c  Sanity Test Failure
Friday, 16 Dec 2022
03:32 Sergey A. Osokin (osa) search for other commits by this committer
devel/libnjs: add NGINX JavaScript static library
commit hash: 65e729092681ede8724a0d8768db4517d0d18ec5 commit hash: 65e729092681ede8724a0d8768db4517d0d18ec5 commit hash: 65e729092681ede8724a0d8768db4517d0d18ec5 commit hash: 65e729092681ede8724a0d8768db4517d0d18ec5  Sanity Test Failure
Sunday, 11 Dec 2022
19:16 Yuri Victorovich (yuri) search for other commits by this committer
  • cad/nvc VHDL compiler and simulator Refresh
cad/nvc: Disable LTO on i386

Otherwise LTO fails, see bug#268319
commit hash: 02542ea91df19ec0d3637301c3c5cbc997f6d606 commit hash: 02542ea91df19ec0d3637301c3c5cbc997f6d606 commit hash: 02542ea91df19ec0d3637301c3c5cbc997f6d606 commit hash: 02542ea91df19ec0d3637301c3c5cbc997f6d606  Sanity Test Failure
Thursday, 1 Dec 2022
22:58 Piotr Kubaj (pkubaj) search for other commits by this committer
  • biology/metaeuk Gene discovery and annotation for large-scale eukaryotic metagenomics Refresh
biology/metaeuk: fix build without libomp and disable -m{arch,cpu}=native
commit hash: 1a0bbb896a78bf4abe39f3e5770a36639eff0eb7 commit hash: 1a0bbb896a78bf4abe39f3e5770a36639eff0eb7 commit hash: 1a0bbb896a78bf4abe39f3e5770a36639eff0eb7 commit hash: 1a0bbb896a78bf4abe39f3e5770a36639eff0eb7  Sanity Test Failure
Monday, 28 Nov 2022
10:59 Dima Panov (fluffy) search for other commits by this committer
graphics/inkscape: fix spellchecking related depends (+)

Inkscape does not use libgtkspell, libaspell or libenchant in any way,
these dependencies were incorrect and need to be removed.
It does optionally use libgspell, so add corresponding option and dependency [1]

While here, add runntime dependency on py-cachecontrol, py-requests and
py-filelock [2]

PR:	267967 [1], 267754 [2]
commit hash: 3c5671ce73aea8479f77c03c20f218007a512242 commit hash: 3c5671ce73aea8479f77c03c20f218007a512242 commit hash: 3c5671ce73aea8479f77c03c20f218007a512242 commit hash: 3c5671ce73aea8479f77c03c20f218007a512242  Sanity Test Failure
Friday, 21 Oct 2022
19:21 Yuri Victorovich (yuri) search for other commits by this committer
  • cad/appcsxcad 0.2.2.9_3 Minimal GUI Application using the QCSXCAD library
    • cad/csxcad 0.6.2.109_3 C++ library to describe geometrical objects
      • cad/opencascade 7.6.0_9 Open CASCADE Technology, 3D modeling & numerical simulation
        • cad/qcsxcad 0.6.2.9_2 Qt-GUI for CSXCAD
          • deskutils/just 1.6.0 Just a command runner: handy way to save/run project-specific commands
            • devel/py-spyder Scientific PYthon Development EnviRonment, an alternative to IDLE Deleted Refresh
              • graphics/cloudcompare 2.12.4_2 3D point cloud processing software
                • graphics/f3d 1.3.1_2 Fast and minimalist 3D viewer
                  • graphics/mirtk 2.0.0.178_3 Medical Image Registration ToolKit (MIRTK)
                    • graphics/opencv 4.6.0_3 Open Source Computer Vision library
                                    (Only the first 10 of 18 items in this commit are shown above. View all ports for this commit)
                                    deskutils/just: Update 1.5.0 -> 1.6.0
                                    
                                    Reported by:	portscout
                                    commit hash: 9f02903fc610e0ee6355d351d75c201b213e0abe commit hash: 9f02903fc610e0ee6355d351d75c201b213e0abe commit hash: 9f02903fc610e0ee6355d351d75c201b213e0abe commit hash: 9f02903fc610e0ee6355d351d75c201b213e0abe  Sanity Test Failure
Saturday, 15 Oct 2022
20:46 Jan Beich (jbeich) search for other commits by this committer
Thursday, 13 Oct 2022
17:25 Yuri Victorovich (yuri) search for other commits by this committer
  • cad/appcsxcad 0.2.2.9_3 Minimal GUI Application using the QCSXCAD library
    • cad/csxcad 0.6.2.109_3 C++ library to describe geometrical objects
      • cad/opencascade 7.6.0_9 Open CASCADE Technology, 3D modeling & numerical simulation
        • cad/qcsxcad 0.6.2.9_2 Qt-GUI for CSXCAD
          • devel/py-spyder Scientific PYthon Development EnviRonment, an alternative to IDLE Deleted Refresh
            • graphics/cloudcompare 2.12.4_2 3D point cloud processing software
              • graphics/f3d 1.3.1_2 Fast and minimalist 3D viewer
                • graphics/mirtk 2.0.0.178_3 Medical Image Registration ToolKit (MIRTK)
                  • graphics/opencv 4.6.0_3 Open Source Computer Vision library
                    • graphics/pcl-pointclouds 1.12.1_5 Point Cloud Library
                                      (Only the first 10 of 19 items in this commit are shown above. View all ports for this commit)
                                      textproc/py-python-lsp-black: New port: Black plugin for the Python LSP Server
                                      commit hash: 0c041ad4a2d2ade16fb3a91a5e651f018e33455f commit hash: 0c041ad4a2d2ade16fb3a91a5e651f018e33455f commit hash: 0c041ad4a2d2ade16fb3a91a5e651f018e33455f commit hash: 0c041ad4a2d2ade16fb3a91a5e651f018e33455f  Sanity Test Failure
Friday, 16 Sep 2022
21:02 Piotr Kubaj (pkubaj) search for other commits by this committer
devel/py-orjson: fix build on powerpc64*

Similar to www/py-adblock.
commit hash: 80fa80f5a52c245257e33ff078f5b109f1fbb2b7 commit hash: 80fa80f5a52c245257e33ff078f5b109f1fbb2b7 commit hash: 80fa80f5a52c245257e33ff078f5b109f1fbb2b7 commit hash: 80fa80f5a52c245257e33ff078f5b109f1fbb2b7  Sanity Test Failure
Wednesday, 7 Sep 2022
09:55 Emmanuel Vadot (manu) search for other commits by this committer
graphics/drm-54-kmod: Remove port

All version of FreeBSD starting from 13.1 can and should use
drm-510-kmod.

Sponsored by:	Beckhoff Automation GmbH & Co. KG
MFH:		2022Q3

(cherry picked from commit a707d16a2d1eab39ea706e33efa0dc0e26929dcb)
commit hash: 1351c57c879afcaf57c22d90f86b2e1839a00669 commit hash: 1351c57c879afcaf57c22d90f86b2e1839a00669 commit hash: 1351c57c879afcaf57c22d90f86b2e1839a00669 commit hash: 1351c57c879afcaf57c22d90f86b2e1839a00669  Sanity Test Failure
09:55 Emmanuel Vadot (manu) search for other commits by this committer
graphics/drm-fbsd13-kmod: Remove port

Remove the specific 13.X version of drm-kmod. There is no need for it
now that we have ports that directly tracks Linux numbering scheme.

Sponsored by:	Beckhoff Automation GmbH & Co. KG
MFH:		2022Q3

(cherry picked from commit 70d3745d257f377df27431a8c18b5acfa3f973b5)
commit hash: 5b603131a3eb4c62e9abdafaf7bdd32ed2aedf0a commit hash: 5b603131a3eb4c62e9abdafaf7bdd32ed2aedf0a commit hash: 5b603131a3eb4c62e9abdafaf7bdd32ed2aedf0a commit hash: 5b603131a3eb4c62e9abdafaf7bdd32ed2aedf0a  Sanity Test Failure
Monday, 5 Sep 2022
19:06 Dima Panov (fluffy) search for other commits by this committer
www/kf5-kdewebkit: pet stage-qa
commit hash: 83ee9ab7ff629b3905e29bca5ed865ccc4b55d2d commit hash: 83ee9ab7ff629b3905e29bca5ed865ccc4b55d2d commit hash: 83ee9ab7ff629b3905e29bca5ed865ccc4b55d2d commit hash: 83ee9ab7ff629b3905e29bca5ed865ccc4b55d2d  Sanity Test Failure
Saturday, 23 Jul 2022
20:26 Yuri Victorovich (yuri) search for other commits by this committer
science/kplib: Remove -march=native to fix build on some architectures

Reported by:	fallout

(cherry picked from commit 9da256a46aa0dd84a5605dcc4defcbbe4b855548)
commit hash: 7c6753bb87e10384f87a36b9a59820ba519bdafd commit hash: 7c6753bb87e10384f87a36b9a59820ba519bdafd commit hash: 7c6753bb87e10384f87a36b9a59820ba519bdafd commit hash: 7c6753bb87e10384f87a36b9a59820ba519bdafd  Sanity Test Failure
Thursday, 21 Jul 2022
22:41 Yuri Victorovich (yuri) search for other commits by this committer
science/kplib: Remove -march=native to fix build on some architectures

Reported by:	fallout

(cherry picked from commit d5465238b2e5d217a614d348d8ad37e2c0b4eac7)
commit hash: 5d5af2d3df6974680062029173b8e54884420f0c commit hash: 5d5af2d3df6974680062029173b8e54884420f0c commit hash: 5d5af2d3df6974680062029173b8e54884420f0c commit hash: 5d5af2d3df6974680062029173b8e54884420f0c  Sanity Test Failure
Tuesday, 19 Jul 2022
08:30 Yuri Victorovich (yuri) search for other commits by this committer
misc/ngraph: Discontinue

ngraph was developed by Nervana Systems.
Intel bount it and discontinued all Nervana development 2+ years ago.
The company is now defunct, and so are all its projects.

(cherry picked from commit 229eb3336f3fbc614f5d36e0d32ca6cb6aeb1fea)
commit hash: 144e572cda906edccdaf58946a89bb4b4271f7c2 commit hash: 144e572cda906edccdaf58946a89bb4b4271f7c2 commit hash: 144e572cda906edccdaf58946a89bb4b4271f7c2 commit hash: 144e572cda906edccdaf58946a89bb4b4271f7c2  Sanity Test Failure
Thursday, 30 Jun 2022
19:37 Rene Ladan (rene) search for other commits by this committer
  • databases/mysql55-client 5.5.62_3 Multithreaded SQL database (client) Deleted Deprecated Expired
    • databases/mysql55-server 5.5.62_3 Multithreaded SQL database (server) Deleted Deprecated Expired  This port version is marked as vulnerable. 
      • databases/percona56-client 5.6.51.91.0 Multithreaded SQL database (client) Deleted
      • cleanup: Remove expired ports:
        
        2022-06-30 databases/percona56-server: EOL since February 2021
        2022-06-30 databases/percona56-client: EOL since February 2021
        2022-06-30 databases/mysql55-server: Upstream support ended on December 2018
        2022-06-30 databases/mysql55-client: Upstream support ended on December 2018
        commit hash: 6fcb7301e2a5cc0c3586a5f826e5a82613de7822 commit hash: 6fcb7301e2a5cc0c3586a5f826e5a82613de7822 commit hash: 6fcb7301e2a5cc0c3586a5f826e5a82613de7822 commit hash: 6fcb7301e2a5cc0c3586a5f826e5a82613de7822  Sanity Test Failure
Wednesday, 29 Jun 2022
13:56 Eugene Grosbein (eugen) search for other commits by this committer
games/vt100-art-and-animations: unbreak

Unbreak and undeprecate the port providing several
live distfile sources.
commit hash: fc716c0168b50cd84af2d14640420983c2b73d14 commit hash: fc716c0168b50cd84af2d14640420983c2b73d14 commit hash: fc716c0168b50cd84af2d14640420983c2b73d14 commit hash: fc716c0168b50cd84af2d14640420983c2b73d14  Sanity Test Failure
Monday, 27 Jun 2022
11:36 Rene Ladan (rene) search for other commits by this committer
  • devel/qbs 1.21.0_1 Qbs Build Suite Deleted Broken Deprecated Expired Ignore
    • lang/cmucl 21.b CMU implementation of Common Lisp Deleted Broken Deprecated Expired Ignore
      • lang/cmucl-extra 21.b Optional extras for the CMU implementation of Common Lisp Deleted Broken Deprecated Expired Ignore
        • net-mgmt/zabbix54-frontend 5.4.12 Enterprise-class open source distributed monitoring (frontend-php74) Deleted Deprecated Expired
          • net-mgmt/zabbix54-server 5.4.12 Enterprise-class open source distributed monitoring (server) Deleted Deprecated Expired
            • security/modsecurity3-apache 0.0.9.b1.20 Intrusion detection and prevention engine / Apache Wrapper Deleted Deprecated Expired
              • security/protonvpn-cli 1.1.2_1 ProtonVPN Command line tool Deleted Deprecated Expired
              • cleanup: Remove expired ports:
                
                2022-06-25 lang/cmucl: Not supported upstream since 2017 and broken since
                FreeBSD 12.1
                2022-06-25 devel/qbs: Abandoned and not working with modern clang
                2022-06-25 lang/cmucl-extra: lang/cmucl is not supported upstream since 2017 and
                broken since FreeBSD 12.1
                2022-06-25 security/protonvpn-cli: This version is deprecated and unsupported
                upstream. The port needs an update, which would require a fair amount of effort.
                Use OpenVPN or Wireguard with configuration files provided by ProtonVPN instead.
                2022-06-27 sysutils/firstboot-growfs: A better version is available on all
                FreeBSD version
                2022-06-27 security/modsecurity3-apache: The project was not developed further
                2022-06-29 net-mgmt/zabbix54-frontend: Unsupported by upstream
                2022-06-29 net-mgmt/zabbix54-server: Unsupported by upstream
                commit hash: 2fb224a12bba79baeabc41519ab19ab876baec32 commit hash: 2fb224a12bba79baeabc41519ab19ab876baec32 commit hash: 2fb224a12bba79baeabc41519ab19ab876baec32 commit hash: 2fb224a12bba79baeabc41519ab19ab876baec32  Sanity Test Failure
Wednesday, 8 Jun 2022
14:06 Baptiste Daroussin (bapt) search for other commits by this committer
  • net-im/finch 2.14.9_1 Finch multi-protocol messaging client (Console UI)
    • net-im/libpurple 2.14.9_1 Backend library for the Pidgin multi-protocol messaging client
    • pidgin: drop gconf references entirely
      
      Given how the port evolved USE_GNOME=gconf2 was never set anyway,
      just remove it entirely, and add the configure argument to ensure
      it will never come back even by accident
      commit hash: 00f1472c6af6516e19438c32226a49525860bda2 commit hash: 00f1472c6af6516e19438c32226a49525860bda2 commit hash: 00f1472c6af6516e19438c32226a49525860bda2 commit hash: 00f1472c6af6516e19438c32226a49525860bda2  Sanity Test Failure
Tuesday, 19 Apr 2022
12:09 Piotr Kubaj (pkubaj) search for other commits by this committer
benchmarks/libcelero: remove -mabi=elfv2 since the base compiler is used, which
defaults to elfv2

Also remove USE_GCC=yes, since there is already appriopriate USES=compiler.
commit hash: dc669f8d68757e894614a7d8ac9eaddc1545d619 commit hash: dc669f8d68757e894614a7d8ac9eaddc1545d619 commit hash: dc669f8d68757e894614a7d8ac9eaddc1545d619 commit hash: dc669f8d68757e894614a7d8ac9eaddc1545d619  Sanity Test Failure
Sunday, 20 Feb 2022
15:49 Jan Beich (jbeich) search for other commits by this committer
multimedia/emby-server-devel: remove after 7bd8fb0a8c61

1132f2bb1d88 is missing on 2022Q1 branch, so drop a patch for
non-existent port.
commit hash: 6cdc201667ed247d03767c119d46c7fe9cce2f98 commit hash: 6cdc201667ed247d03767c119d46c7fe9cce2f98 commit hash: 6cdc201667ed247d03767c119d46c7fe9cce2f98 commit hash: 6cdc201667ed247d03767c119d46c7fe9cce2f98  Sanity Test Failure
15:22 Jan Beich (jbeich) search for other commits by this committer
  • branches/2022Q1/multimedia/emby-server 4.6.7.0 Media server to organize, play & stream audio/video to various devices This port version is marked as vulnerable. 
  • multimedia/emby-server: unbreak with dav1d 1.0.0
    
    libavcodec/libdav1d.c:137:7: error: no member named 'n_tile_threads' in 'struct
    Dav1dSettings'
        s.n_tile_threads = dav1d->tile_threads
        ~ ^
    libavcodec/libdav1d.c:144:14: error: no member named 'n_frame_threads' in
    'struct Dav1dSettings'
               s.n_frame_threads, s.n_tile_threads);
               ~ ^
    
    (cherry picked from commit 1133c44239e4d97453dadd9a16f2c1b768a3d95c)
    commit hash: 7bd8fb0a8c61caa3b9cc5ee050202e2fd867de5d commit hash: 7bd8fb0a8c61caa3b9cc5ee050202e2fd867de5d commit hash: 7bd8fb0a8c61caa3b9cc5ee050202e2fd867de5d commit hash: 7bd8fb0a8c61caa3b9cc5ee050202e2fd867de5d  Sanity Test Failure
Wednesday, 16 Feb 2022
09:18 Cy Schubert (cy) search for other commits by this committer
Thursday, 27 Jan 2022
23:55 Matthias Andree (mandree) search for other commits by this committer
  • branches/2022Q1/devel/e2fsprogs-libss Deleted
    • branches/2022Q1/sysutils/e2fsprogs 1.46.4_2 Utilities & library to manipulate ext2/3/4 filesystems This port version is marked as vulnerable. 
      • branches/2022Q1/sysutils/e2tools 0.1.0_2 Utilities to manipulate files in an ext2/ext3 filesystem
        • branches/2022Q1/sysutils/fusefs-ext2 0.0.10_3 FUSE module to mount ext2, ext3 and ext4 with read write support
          • branches/2022Q1/sysutils/unetbootin 702_1 Bootable Live USB creator for various Linux distributions
          • devel/e2fsprogs-libss: merge to sysutils/e2fsprogs
            
            This is to break dependency cycles between e2fsprogs-libss and
            e2fsprogs (see 254751 comment #18 for details), and to avoid creating
            yet another split-out port, then for e2fsprogs's libcom_err.
            
            Bump PORTREVISION of the four e2fsprogs consumers to flush out
            their e2fsprogs-libss dependency records.
            
            PR:		254751
            Reported by:	Felix Palmen
            PR:		261217
            Reported by:	tech-lists@zyxst.net
            Fixes:		8e6ae60 devel/e2fsprogs-libss: use local compile_et...
            
            Approved by:	prior maintainer timeout (Ben Kaduk, 7 months) on 254751
            
            (cherry picked from commit 29b349b2dba2a188140cb73fe451a9b9793178d4)
            commit hash: 69d35222fd84c30922c302fb08873d371cea333e commit hash: 69d35222fd84c30922c302fb08873d371cea333e commit hash: 69d35222fd84c30922c302fb08873d371cea333e commit hash: 69d35222fd84c30922c302fb08873d371cea333e  Sanity Test Failure
Saturday, 22 Jan 2022
00:59 Jan Beich (jbeich) search for other commits by this committer
  • branches/2022Q1/emulators/yuzu s20220119_1 Nintendo Switch emulator/debugger
  • emulators/yuzu: merge -qt5 port as QT5 option
    
    yuzu package provided "yuzu-cmd" executable but it's very buggy and
    hard to use. yuzu-qt5 package provided stable "yuzu" executable.
    The split was inspired by citra{,-qt5} but in yuzu confused new users.
    
    (cherry picked from commit 57c6f7e1cbc6667455b50a022c9388e10ca83646)
    commit hash: 41944891b2a0af2d90a9104712f07722937e5be4 commit hash: 41944891b2a0af2d90a9104712f07722937e5be4 commit hash: 41944891b2a0af2d90a9104712f07722937e5be4 commit hash: 41944891b2a0af2d90a9104712f07722937e5be4  Sanity Test Failure
Friday, 26 Nov 2021
14:27 Michael Reifenberger (mr) search for other commits by this committer
finance/nextcloud-cospend: Add nextcloud app cospend

Add Nextcloud Cospend 💰

Nextcloud Cospend is a group/shared budget manager.
It was inspired by the great IHateMoney.

You can use it when you share a house, when you go on vacation with friends,
whenever you share money with others.

It lets you create projects with members and bills.
Each member has a balance computed from the project bills.
This way you can see who owes the group and who the group owes.
Ultimately you can ask for a settlement plan telling you which payments
to make to reset members balances.

Project members are independent from Nextcloud users.
Projects can be accessed and modified by people without a Nextcloud account.
Each project has an ID and a password for guest access.

MoneyBuster Android client is available in F-Droid and on the Play store.

PayForMe iOS client is currently being developped!
commit hash: f7f7bba9fdc1158e527515b70c147e87ee369149 commit hash: f7f7bba9fdc1158e527515b70c147e87ee369149 commit hash: f7f7bba9fdc1158e527515b70c147e87ee369149 commit hash: f7f7bba9fdc1158e527515b70c147e87ee369149  Sanity Test Failure
Wednesday, 24 Nov 2021
11:20 Ashish SHUKLA (ashish) search for other commits by this committer Author: Goran Mekic
Tuesday, 16 Nov 2021
01:57 Bryan Drewery (bdrewery) search for other commits by this committer
devel/rbtools: Add some missing dependencies
commit hash: 3c8e68a28d3db4875da73f426c08a255e74b9b48 commit hash: 3c8e68a28d3db4875da73f426c08a255e74b9b48 commit hash: 3c8e68a28d3db4875da73f426c08a255e74b9b48 commit hash: 3c8e68a28d3db4875da73f426c08a255e74b9b48  Sanity Test Failure
Friday, 5 Nov 2021
19:14 Po-Chuan Hsieh (sunpoet) search for other commits by this committer
  • www/npm 6.14.8 Node package manager (meta port)
www/npm: Add NODE16 option

- Update CONFLICTS_INSTALL
commit hash: b5e1c5e21682bf5e152d42e2ecaea35b7c6f156b commit hash: b5e1c5e21682bf5e152d42e2ecaea35b7c6f156b commit hash: b5e1c5e21682bf5e152d42e2ecaea35b7c6f156b commit hash: b5e1c5e21682bf5e152d42e2ecaea35b7c6f156b  Sanity Test Failure
Thursday, 23 Sep 2021
16:22 Baptiste Daroussin (bapt) search for other commits by this committer
  • audio/cam 1.02 Cpu's Audio Mixer [curses based]
    • audio/cmp3 2.0.p6_2 Ncurses based frontend to mpg123 Deleted Deprecated Expired
      • audio/funktrackergold 1.5.2_8 Curses MOD/FNK music tracker
        • audio/juke 0.7 Simple (n)curses based juke box program
          • audio/mp3c 0.31_2 CD to mp3c converter with a console frontend Deleted Deprecated Expired
            • audio/mp3info 0.8.5a MP3 technical info viewer and ID3 1.x tag editor Deleted Deprecated Expired
              • audio/playmidi 2.5_1 MIDI player
                • audio/rexima 1.4 ncurses-based console mixer
                  • audio/siren 0.9_4 Text-based audio player
                    • audio/stymulator 0.21.a_3 Command-line Yamaha YM2149 (.ym) chiptune player
                                                                  (Only the first 10 of 33 items in this commit are shown above. View all ports for this commit)
                                                                  ncurses: fix build with futur base and ports ncurses
                                                                  
                                                                  in preparation for the split in base of libtinfo and libncurses, clearly
                                                                  specify when the packages should link against.
                                                                  
                                                                  Note this also fixes the build with ports ncurses
                                                                  commit hash: 266130ce71ef2f1cd944a70789bf003da3254c29 commit hash: 266130ce71ef2f1cd944a70789bf003da3254c29 commit hash: 266130ce71ef2f1cd944a70789bf003da3254c29 commit hash: 266130ce71ef2f1cd944a70789bf003da3254c29  Sanity Test Failure
Thursday, 9 Sep 2021
19:13 Dmitry Marakasov (amdmi3) search for other commits by this committer
  • x11/sdwmbar Simple statusbar for the dwm window manager Refresh
x11/sdwmbar: add port: Simple statusbar for the dwm window manager

A simple statusbar for x11-wm/dwm

Shows load averages, date-time and battery life.

WWW: https://github.com/sakhmatd/sdwmbar
commit hash: 65614cb11873f57c90adb2bd14b1d815d1181446 commit hash: 65614cb11873f57c90adb2bd14b1d815d1181446 commit hash: 65614cb11873f57c90adb2bd14b1d815d1181446 commit hash: 65614cb11873f57c90adb2bd14b1d815d1181446  Sanity Test Failure
Wednesday, 1 Sep 2021
22:58 Neel Chauhan (nc) search for other commits by this committer Author: Dmitry Wagin
www/hs-postgrest: Update to 8.0.0

Changes: https://postgrest.org/en/v8.0/releases/v8.0.0.html

PR:	258184
commit hash: 6238bf3d5e56d614e09caff6a00ea4e8b44be5b1 commit hash: 6238bf3d5e56d614e09caff6a00ea4e8b44be5b1 commit hash: 6238bf3d5e56d614e09caff6a00ea4e8b44be5b1 commit hash: 6238bf3d5e56d614e09caff6a00ea4e8b44be5b1  Sanity Test Failure
Saturday, 7 Aug 2021
10:23 Vanilla I. Shu (vanilla) search for other commits by this committer
  • www/grafana8 Dashboard and graph editor for multiple data stores Deleted Refresh Deprecated Expired
www/grafana8: Update to 8.1.0

Changelog:
https://grafana.com/docs/grafana/latest/whatsnew/whats-new-in-v8-1/

Also small port refactoring:
- Excluded GH_TUPLE to dedicated Makefile.modules file.
- Removed config sample file grafana.ini.in, refactored to
  auto-generation via Makefile (it prevents unnecessary file patching
while update).

PR:		257655
Reported by:	maintainer
commit hash: 2df908509325f2ea45a5aed34fe4188a302abe34 commit hash: 2df908509325f2ea45a5aed34fe4188a302abe34 commit hash: 2df908509325f2ea45a5aed34fe4188a302abe34 commit hash: 2df908509325f2ea45a5aed34fe4188a302abe34  Sanity Test Failure
Thursday, 22 Jul 2021
21:57 Joseph Mingrone (jrm) search for other commits by this committer
  • devel/bear Tool that generates a compilation database for clang tooling Refresh
devel/bear: Fix build on 11.4

To use dprintf from cstdio on FreeBSD versions prior to 12, #define
_WITH_DPRINTF is required.

Credit to ashish for discovering this.
commit hash: 0826576597499645e573e70f6b79875bbff58214 commit hash: 0826576597499645e573e70f6b79875bbff58214 commit hash: 0826576597499645e573e70f6b79875bbff58214 commit hash: 0826576597499645e573e70f6b79875bbff58214  Sanity Test Failure
Sunday, 18 Jul 2021
12:53 Emmanuel Vadot (manu) search for other commits by this committer
sysutils/u-boot-qemu-*: Mark broken on 11.4

Base openssl is too old for u-boot-qemu, mark both port as broken.

Reported by:	pkg-fallout
commit hash: ebfb1beaef02df53e8e317f500eb1967e12bc5aa commit hash: ebfb1beaef02df53e8e317f500eb1967e12bc5aa commit hash: ebfb1beaef02df53e8e317f500eb1967e12bc5aa commit hash: ebfb1beaef02df53e8e317f500eb1967e12bc5aa  Sanity Test Failure
Thursday, 8 Jul 2021
20:18 Bernhard Froehlich (decke) search for other commits by this committer
sysutils/u-boot-master: Add https mirror to MASTER_SITES

PR:		257046
Approved by:	manu@

(cherry picked from commit bf089b31aaf7c53237fc8ee1a8c988fb10be5767)
commit hash: 134d2a4cd2fb7c14d235e81552428ac711f1bcb3 commit hash: 134d2a4cd2fb7c14d235e81552428ac711f1bcb3 commit hash: 134d2a4cd2fb7c14d235e81552428ac711f1bcb3 commit hash: 134d2a4cd2fb7c14d235e81552428ac711f1bcb3  Sanity Test Failure
Sunday, 20 Jun 2021
09:06 Alexander Leidinger (netchild) search for other commits by this committer
  • misc/openhab Vendor and technology agnostic open source smart-home software Refresh
  • misc/openhab: new v3 based upon copy from openhab2
    
    - copy openhab2* to openhab (follow upstream)
    - update to 3.0.2
    - remove update script (no auto migration from v2, scrip may come back
      later, if needed)
    - use openhab instead openhabvX directories (follow upstream)
    - use openjdk 11 (new requirement)
    - add UPDATING entry for users which may want to switch to v3
    commit hash: 207827e2a8e65c4b0933edd15c0b21233c7cfa67 commit hash: 207827e2a8e65c4b0933edd15c0b21233c7cfa67 commit hash: 207827e2a8e65c4b0933edd15c0b21233c7cfa67 commit hash: 207827e2a8e65c4b0933edd15c0b21233c7cfa67  Sanity Test Failure
Friday, 18 Jun 2021
15:29 John Baldwin (jhb) search for other commits by this committer
Tuesday, 25 May 2021
13:55 Dmitry Marakasov (amdmi3) search for other commits by this committer
  • databases/py-gdbm 3.8.10_6 Python bindings to the GNU dbm library (Python 3.9)
    • databases/py-sqlite3 3.8.10_7 Standard Python binding to the SQLite3 library (Python 3.9)
      • lang/pypy 7.3.0_1 Fast, compliant implementation of the Python language Deleted Deprecated Expired
        • lang/python-doc-html Documentation for the Python programming language Refresh
          • lang/python-tools 3.8.10_1 Supplementary tools for the Python language
            • lang/python27 2.7.18_1 Interpreted object-oriented programming language Deprecated Expired
              • lang/python36 3.6.13 Interpreted object-oriented programming language Deleted Deprecated Expired
                • lang/python37 3.7.10_1 Interpreted object-oriented programming language Deleted Deprecated Expired
                  • lang/python38 3.8.10 Interpreted object-oriented programming language Deprecated Expiration Date
                    • lang/python39 3.9.5 Interpreted object-oriented programming language
                        (Only the first 10 of 12 items in this commit are shown above. View all ports for this commit)
                        Mk: switch from PYTHON_PORTVERSION to PYTHON_DISTVERSION
                        
                        This brings python framework in consistense with handbook recommendations
                        to prefer DISTVERSION and simplifies adding prerelease versions of
                        python
                        
                        PR:		255013
                        Differential Revision:	https://reviews.freebsd.org/D29418
                        Exp-run by:	antoine
                        Approved by:	wen@, no objection from python@ or portmgr@
                        commit hash: 5f69415313f894338dca54e21b5c3981e5e5f58f commit hash: 5f69415313f894338dca54e21b5c3981e5e5f58f commit hash: 5f69415313f894338dca54e21b5c3981e5e5f58f commit hash: 5f69415313f894338dca54e21b5c3981e5e5f58f  Sanity Test Failure
Thursday, 20 May 2021
06:58 Roger Pau Monné (royger) search for other commits by this committer
  • sysutils/edk2 g202102 EDK2 Firmware for macchiatobin
  • sysutils/xen-tools: fix build on FreeBSD 12
    
    QEMU Inter-VM shared memory device (ivshmem) depends on eventfd and
    will only be built on FreeBSD versions > 12.
    
    The fix is picked up from the QEMU port.
    
    Approved by: bapt (implicit)
    commit hash: 97632df2b3f820f6cbd8a09602aa96af6aaec0f5 commit hash: 97632df2b3f820f6cbd8a09602aa96af6aaec0f5 commit hash: 97632df2b3f820f6cbd8a09602aa96af6aaec0f5 commit hash: 97632df2b3f820f6cbd8a09602aa96af6aaec0f5  Sanity Test Failure
Monday, 10 May 2021
17:13 Yuri Victorovich (yuri) search for other commits by this committer
security/tor: Update 0.4.5.7 -> 0.4.5.8

Changelog: https://blog.torproject.org/node/2031

Reported by:	upstream notification
commit hash: 24d7b3d06d2ca635a5193730a11da9ba634be51f commit hash: 24d7b3d06d2ca635a5193730a11da9ba634be51f commit hash: 24d7b3d06d2ca635a5193730a11da9ba634be51f commit hash: 24d7b3d06d2ca635a5193730a11da9ba634be51f  Sanity Test Failure
17:13 Yuri Victorovich (yuri) search for other commits by this committer
security/tor-devel: Update 0.4.6.2-alpha -> 0.4.6.3-rc

o Major bugfixes (onion service, control port):
  - Make the ADD_ONION command properly configure client authorization.
    Before this fix, the created onion failed to add the client(s).
    Fixes bug 40378; bugfix on 0.4.6.1-alpha.

o Minor features (compatibility, Linux seccomp sandbox):
  - Add a workaround to enable the Linux sandbox to work correctly
    with Glibc 2.33. This version of Glibc has started using the
    fstatat() system call, which previously our sandbox did not allow.
    Closes ticket 40382; see the ticket for a discussion of trade-offs.

etc.

Reported by:	Upstream notification
commit hash: e0dfc470f5be1b6bee64050675dc14202023b30a commit hash: e0dfc470f5be1b6bee64050675dc14202023b30a commit hash: e0dfc470f5be1b6bee64050675dc14202023b30a commit hash: e0dfc470f5be1b6bee64050675dc14202023b30a  Sanity Test Failure
17:13 Yuri Victorovich (yuri) search for other commits by this committer
  • net/mvfst Implementation of the QUIC transport protocol Refresh
net/mvfst: Update g20201119 -> g20210508
commit hash: 23ccdfccede7310692cca038612debf841dd7e90 commit hash: 23ccdfccede7310692cca038612debf841dd7e90 commit hash: 23ccdfccede7310692cca038612debf841dd7e90 commit hash: 23ccdfccede7310692cca038612debf841dd7e90  Sanity Test Failure
17:13 Yuri Victorovich (yuri) search for other commits by this committer
  • www/proxygen Collection of C++ HTTP libraries including easy way to use HTTP server Refresh
www/proxygen: Update 2021.04.26.00 -> 2021.05.10.00
commit hash: aa1a9ff21fa2495207ddf926ef80186fd4c27371 commit hash: aa1a9ff21fa2495207ddf926ef80186fd4c27371 commit hash: aa1a9ff21fa2495207ddf926ef80186fd4c27371 commit hash: aa1a9ff21fa2495207ddf926ef80186fd4c27371  Sanity Test Failure
17:13 Yuri Victorovich (yuri) search for other commits by this committer
  • net/fbzmq Framework for writing services in C++ while leveraging libzmq Refresh
net/fbzmq: Update 2021.04.26.00 -> 2021.05.10.00
commit hash: c69203e5398b978d16938c47a87c6931ba54f70e commit hash: c69203e5398b978d16938c47a87c6931ba54f70e commit hash: c69203e5398b978d16938c47a87c6931ba54f70e commit hash: c69203e5398b978d16938c47a87c6931ba54f70e  Sanity Test Failure
17:13 Yuri Victorovich (yuri) search for other commits by this committer
net/rsocket-cpp: Update 2021.04.26.00 -> 2021.05.10.00
commit hash: 8410cfcdd17dee494f87760d79102cfdaa6ef279 commit hash: 8410cfcdd17dee494f87760d79102cfdaa6ef279 commit hash: 8410cfcdd17dee494f87760d79102cfdaa6ef279 commit hash: 8410cfcdd17dee494f87760d79102cfdaa6ef279  Sanity Test Failure
17:13 Yuri Victorovich (yuri) search for other commits by this committer
  • devel/fbthrift Facebook's branch of Apache Thrift, including a new C++ server Refresh
devel/fbthrift: Update 2021.04.26.00 -> 2021.05.10.00
commit hash: ab0246a3a397dd3830618b218277966bba606526 commit hash: ab0246a3a397dd3830618b218277966bba606526 commit hash: ab0246a3a397dd3830618b218277966bba606526 commit hash: ab0246a3a397dd3830618b218277966bba606526  Sanity Test Failure
17:13 Yuri Victorovich (yuri) search for other commits by this committer
  • net/wangle Framework for building services in a consistent/modular/composable way Refresh
net/wangle: Update 2021.04.26.00 -> 2021.05.10.00
commit hash: 5f05127e7d1d1b67dfe57fa072eeb7dc96be0a95 commit hash: 5f05127e7d1d1b67dfe57fa072eeb7dc96be0a95 commit hash: 5f05127e7d1d1b67dfe57fa072eeb7dc96be0a95 commit hash: 5f05127e7d1d1b67dfe57fa072eeb7dc96be0a95  Sanity Test Failure
17:13 Yuri Victorovich (yuri) search for other commits by this committer
  • devel/folly C++ library developed and used at Facebook Refresh
devel/folly: Update 2021.04.26.00 -> 2021.05.10.00
commit hash: 0a65c42063b486491b37c14b3f91d0c7e0fc4800 commit hash: 0a65c42063b486491b37c14b3f91d0c7e0fc4800 commit hash: 0a65c42063b486491b37c14b3f91d0c7e0fc4800 commit hash: 0a65c42063b486491b37c14b3f91d0c7e0fc4800  Sanity Test Failure
17:13 Yuri Victorovich (yuri) search for other commits by this committer
security/fizz: Update 2021.04.26.00 -> 2021.05.10.00
commit hash: 0a0df77fefdae8570bb1018054fd670a19532d9f commit hash: 0a0df77fefdae8570bb1018054fd670a19532d9f commit hash: 0a0df77fefdae8570bb1018054fd670a19532d9f commit hash: 0a0df77fefdae8570bb1018054fd670a19532d9f  Sanity Test Failure
16:54 Li-Wen Hsu (lwhsu) search for other commits by this committer
multimedia/libxine: Remove GNOMEVFS2 option

GNOME=gnomevfs2 was removed in
8e6f2eb82e5edec98737d1f9c12361343def00c7

PR:		255574
Reported by:	Jack <xxjack12xx@gmail.com>
commit hash: 24c35addb4584b1323b14899f8a5d7469363a07c commit hash: 24c35addb4584b1323b14899f8a5d7469363a07c commit hash: 24c35addb4584b1323b14899f8a5d7469363a07c commit hash: 24c35addb4584b1323b14899f8a5d7469363a07c  Sanity Test Failure
16:51 Neel Chauhan (nc) search for other commits by this committer
  • net/cloudquery Transform cloud infrastructure into queryable SQL tables Refresh
net/cloudquery: Update to 0.12.2

Changes: https://github.com/cloudquery/cloudquery/releases/tag/v0.12.2
commit hash: d85c697dbe887735e60e427beb76a70326983f9f commit hash: d85c697dbe887735e60e427beb76a70326983f9f commit hash: d85c697dbe887735e60e427beb76a70326983f9f commit hash: d85c697dbe887735e60e427beb76a70326983f9f  Sanity Test Failure
Monday, 29 Mar 2021
08:47 dch search for other commits by this committer
  • lang/gleam ML-flavoured type-safe language using Erlang's BEAM runtime Refresh
lang/gleam: update to 0.14.4

upstream has fixed port fallout reported in rust 1.51.0

Reported by:	tobik
Sponsored by:	SkunkWerks, GmbH
Original commitRevision:569439  Sanity Test Failure
Tuesday, 16 Mar 2021
16:35 jbeich search for other commits by this committer
  • x11/rofi 1.6.1 Window switcher, run dialog and dmenu replacement
x11/rofi: convert to USES=meson

PR:		253043
Approved by:	nomoo@nomoo.ru (maintainer)
Original commitRevision:568581  Sanity Test Failure
Sunday, 14 Mar 2021
13:50 cy search for other commits by this committer
Add x11/mxascii: Similar to xascii but using X11/Motif widgets

Add x11/mxascii to ports. mxascii is a X/Motif program to display
ASCII character set (0-127) in decimal, hexadecimal, or octal.
mxascii is similar to xascii but uses Motif widgets instead of Xaw
widgets.
Original commitRevision:568389  Sanity Test Failure
Sunday, 7 Mar 2021
22:09 sunpoet search for other commits by this committer
Add py-urbanaccess 0.2.2

UrbanAccess is tool for creating multi-modal graph networks for use in
multi-scale (e.g. address level to the metropolitan level) transit accessibility
analyses with the network analysis tool Pandana. UrbanAccess uses open data from
General Transit Feed Specification (GTFS) data to represent disparate
operational schedule transit networks and pedestrian OpenStreetMap (OSM) data to
represent the pedestrian network. UrbanAccess provides a generalized,
computationally efficient, and unified accessibility calculation framework by
linking tools for: 1) network data acquisition, validation, and processing; 2)
computing an integrated pedestrian and transit weighted network graph; and 3)
network analysis using Pandana.

WWW: https://github.com/UDST/urbanaccess
Original commitRevision:567606  Sanity Test Failure
Saturday, 6 Mar 2021
17:55 jwb search for other commits by this committer
  • archivers/py-xopen 1.1.0 Open compressed files transparently
  • py-cutadapt: Update to 3.3
    
    Numerous small bug fixes and enhancements, code refactoring
    
    py-xopen: Update to 1.1.0
    
    Required by cutadapt 3.3
    Drop python 3.5 support
    Add isal support (not yet utilized in FreeBSD port)
    Original commitRevision:567503  Sanity Test Failure
Wednesday, 3 Mar 2021
18:06 sunpoet search for other commits by this committer
Add py-opencensus 0.7.12

OpenCensus provides a framework to measure a server's resource usage and collect
performance stats.

WWW: https://github.com/census-instrumentation/opencensus-python
Original commitRevision:567107  Sanity Test Failure
Saturday, 27 Feb 2021
00:06 swills search for other commits by this committer
net/p5-Net-Connection-Sort: create port

This sorts a array of Net::Connection objects.

Currently the methods below are supported.

 * host_f - Host foreign
 * host_fl - Host, foreign then local
 * host_l - Host, local
 * host_lf - Host, local then foreign
 * pid - Process ID
 * port_f - Port, foreign, numeric
 * port_fa - Port, foreign, alpha
 * port_l - Port, local, numeric
 * port_la - Port, local, alpha
 * proto - Network connection protocol
 * ptr_f - PTR, foreign
 * ptr_l - PTR, local
 * state - Connection
 * uid - User ID
 * user - Username

WWW: https://metacpan.org/release/Net-Connection-Sort

PR:		253409
Submitted by:	Zane C. Bowers-Hadley <vvelox@vvelox.net>
Original commitRevision:566646  Sanity Test Failure
00:06 swills search for other commits by this committer
net/p5-Net-Connection-Match: create port

Provides a easy to use method for checking if a Net::Connection
object mathes a series of checks.

Currently can do matching based off of the following.

 * CIDR
 * Command
 * PctCPU
 * PctMem
 * Ports
 * Protocol
 * State
 * RegexPTR
 * PTR
 * UID
 * Username
 * WChan

WWW: https://metacpan.org/release/Net-Connection-Match

PR:		253408
Submitted by:	Zane C. Bowers-Hadley <vvelox@vvelox.net>
Original commitRevision:566645  Sanity Test Failure
Wednesday, 24 Feb 2021
10:46 Marc Fonvieille (blackend) search for other commits by this committer
Wednesday, 17 Feb 2021
17:51 sunpoet search for other commits by this committer
Add rubygem-cucumber-html-formatter9 9.0.0 (copied from
rubygem-cucumber-html-formatter)

- Change RUN_DEPENDS from rubygem-cucumber-messages to
rubygem-cucumber-messages13
- Add PORTSCOUT
Original commitRevision:565540  Sanity Test Failure
Tuesday, 9 Feb 2021
13:10 Renato Botelho (garga) search for other commits by this committer
MFH: r564784

devel/git: Update to 2.30.1

PR:		253365
Submitted by:	Yasuhiro Kimura <yasu@utahime.org>
Sponsored by:	Rubicon Communications, LLC ("Netgate")
commit hash: e5dfc7582c2ee7f6493894d1273c47c2b66b4caa commit hash: e5dfc7582c2ee7f6493894d1273c47c2b66b4caa commit hash: e5dfc7582c2ee7f6493894d1273c47c2b66b4caa commit hash: e5dfc7582c2ee7f6493894d1273c47c2b66b4caa  Sanity Test Failure
Saturday, 6 Feb 2021
20:46 sunpoet search for other commits by this committer
  • devel/py-tabulator 1.53.1_1 Consistent interface for stream reading and writing tabular data (csv/xls/json/etc)
Add missing dependency

- Bump PORTREVISION for dependency change
Original commitRevision:564280  Sanity Test Failure
20:43 sunpoet search for other commits by this committer
Add rubygem-google-cloud-translate 3.0.3

API Client library for the Cloud Translation API

Cloud Translation can dynamically translate text between thousands of language
pairs. Translation lets websites and programs programmatically integrate with
the translation service.

Actual client classes for the various versions of this API are defined in
versioned client gems, with names of the form google-cloud-translate-v*. The gem
google-cloud-translate is the main client library that brings the verisoned gems
in as dependencies, and provides high-level methods for constructing clients.

WWW: https://github.com/googleapis/google-cloud-ruby
WWW:
https://github.com/googleapis/google-cloud-ruby/tree/master/google-cloud-translate
Original commitRevision:564247  Sanity Test Failure
Tuesday, 2 Feb 2021
17:24 yuri search for other commits by this committer
www/cpp-httplib: Update 0.8.2 -> 0.8.3

Reported by:	portscout
Original commitRevision:563832  Sanity Test Failure
Monday, 1 Feb 2021
19:20 sunpoet search for other commits by this committer
Add p5-Data-Dmp 0.240

Data::Dmp is a Perl dumper like Data::Dumper. It's compact (only about 200 lines
of code long), starts fast and does not use any non-core modules except
Regexp::Stringify when dumping regexes. It produces compact single-line output
(similar to Data::Dumper::Concise). It roughly has the same speed as
Data::Dumper (usually a bit faster for smaller structures) and faster than
Data::Dump, but does not offer the various formatting options. It supports
dumping objects, regexes, circular structures, coderefs. Its code is first based
on Data::Dump: I removed all the parts that I don't need, particularly the
pretty formatting stuffs) and added some features that I need like proper regex
dumping and coderef deparsing.

WWW: https://metacpan.org/release/Data-Dmp
Original commitRevision:563611  Sanity Test Failure
Saturday, 30 Jan 2021
17:39 jwb search for other commits by this committer
biology/bowtie2: Switch to devel/onetbb

PR:             252683
Submitted by:   martymac
Original commitRevision:563427  Sanity Test Failure
Tuesday, 26 Jan 2021
17:20 sunpoet search for other commits by this committer
Add rubygem-google-apis-iamcredentials_v1 0.1.0

This is a simple client library for version V1 of the IAM Service Account
Credentials API. It provides:
- A client object that connects to the HTTP/JSON REST endpoint for the service.
- Ruby objects for data structures related to the service.
- Integration with the googleauth gem for authentication using OAuth, API keys,
  and service accounts.
- Control of retry, pagination, and timeouts.

WWW: https://github.com/googleapis/google-api-ruby-client
WWW:
https://github.com/googleapis/google-api-ruby-client/tree/master/generated/google-apis-iamcredentials_v1
Original commitRevision:562726  Sanity Test Failure
17:20 sunpoet search for other commits by this committer
Add rubygem-google-apis-generator 0.1.2

This library includes common base classes and dependencies used by legacy REST
clients for Google APIs.

WWW: https://github.com/googleapis/google-api-ruby-client
WWW:
https://github.com/googleapis/google-api-ruby-client/tree/master/google-apis-generator
Original commitRevision:562725  Sanity Test Failure
17:19 sunpoet search for other commits by this committer
Add rubygem-google-apis-discovery_v1 0.1.0

This is a simple client library for version V1 of the API Discovery Service. It
provides:
- A client object that connects to the HTTP/JSON REST endpoint for the service.
- Ruby objects for data structures related to the service.
- Integration with the googleauth gem for authentication using OAuth, API keys,
  and service accounts.
- Control of retry, pagination, and timeouts.

WWW: https://github.com/googleapis/google-api-ruby-client
WWW:
https://github.com/googleapis/google-api-ruby-client/tree/master/generated/google-apis-discovery_v1
Original commitRevision:562724  Sanity Test Failure
Monday, 25 Jan 2021
23:55 yuri search for other commits by this committer
www/cpp-httplib: Update 0.8.1 -> 0.8.2

Reported by:	portscout
Original commitRevision:562623  Sanity Test Failure
Sunday, 24 Jan 2021
14:38 mr search for other commits by this committer
  • comms/hackrf 2017.02.1 Low cost open source hardware software radio platform
  • Copy hackrf to hackrf-devel and update to a current snapshot of hackrf
    Original commitRevision:562478  Sanity Test Failure
Thursday, 21 Jan 2021
19:34 yuri search for other commits by this committer
www/cpp-httplib: Fix build on 11 by removing the SSL option there

The project requires a higher SSL verion than 11 has.

Reported by:	fallout
Original commitRevision:562236  Sanity Test Failure
Sunday, 10 Jan 2021
14:26 pi search for other commits by this committer
New port: www/rubygem-nanoc-deploying

Provides deploying functionality for Nanoc.

WWW: https://nanoc.ws/

PR:		252137
Submitted by:	Stephane D'Alu <sdalu@sdalu.com>
Original commitRevision:561073  Sanity Test Failure
08:51 sunpoet search for other commits by this committer
Add rubygem-sass-rails-rails61 6.1.0 (copied from rubygem-sass-rails-rails60)
Original commitRevision:561045  Sanity Test Failure
08:51 sunpoet search for other commits by this committer
Add rubygem-rails61 6.1.0 (copied from rubygem-rails60)
Original commitRevision:561037  Sanity Test Failure
08:51 sunpoet search for other commits by this committer
Add rubygem-actionpack61 6.1.0 (copied from rubygem-actionpack60)
Original commitRevision:561036  Sanity Test Failure
08:50 sunpoet search for other commits by this committer
Add rubygem-actioncable61 6.1.0 (copied from rubygem-actioncable60)
Original commitRevision:561035  Sanity Test Failure
08:50 sunpoet search for other commits by this committer
Add rubygem-actionmailer61 6.1.0 (copied from rubygem-actionmailer60)
Original commitRevision:561032  Sanity Test Failure
08:50 sunpoet search for other commits by this committer
Add rubygem-actionmailbox61 6.1.0 (copied from rubygem-actionmailbox60)
Original commitRevision:561031  Sanity Test Failure
08:50 sunpoet search for other commits by this committer
Add rubygem-activejob61 6.1.0 (copied from rubygem-activejob60)
Original commitRevision:561029  Sanity Test Failure
08:50 sunpoet search for other commits by this committer
Add rubygem-actionview61 6.1.0 (copied from rubygem-actionview60)
Original commitRevision:561028  Sanity Test Failure
08:50 sunpoet search for other commits by this committer
Add rubygem-activerecord61 6.1.0 (copied from rubygem-activerecord60)
Original commitRevision:561027  Sanity Test Failure
08:50 sunpoet search for other commits by this committer
Add rubygem-activemodel61 6.1.0 (copied from rubygem-activemodel60)
Original commitRevision:561026  Sanity Test Failure
Wednesday, 6 Jan 2021
10:47 dch search for other commits by this committer
databases/foundationdb-devel: update to 20201228 snapshot

Sponsored by:	SkunkWerks, GmbH
Original commitRevision:560493  Sanity Test Failure
Sunday, 3 Jan 2021
20:02 sunpoet search for other commits by this committer
Add rubygem-net-imap 0.1.1

Net::IMAP implements Internet Message Access Protocol (IMAP) client
functionality.

WWW: https://github.com/ruby/net-imap
Original commitRevision:560082  Sanity Test Failure
20:02 sunpoet search for other commits by this committer
Add rubygem-net-ftp 0.1.1

Net::FTP implements the File Transfer Protocol. If you have used a command-line
FTP program, and are familiar with the commands, you will be able to use this
class easily. Some extra features are included to take advantage of Ruby's style
and strengths.

WWW: https://github.com/ruby/net-ftp
Original commitRevision:560081  Sanity Test Failure
20:02 sunpoet search for other commits by this committer
Add rubygem-resolv-replace 0.1.0

resolv-replace.rb replaces Socket DNS with Resolv.

WWW: https://github.com/ruby/resolv-replace
Original commitRevision:560080  Sanity Test Failure
19:57 sunpoet search for other commits by this committer
  • math/py-spvcm 0.3.0 Fit spatial multilevel models and diagnose convergence
Add py-spvcm 0.3.0

Gibbs sampling for spatially-correlated variance-components

This is a package to estimate spatially-correlated variance components
models/varying intercept models. In addition to a general toolkit to conduct
Gibbs sampling in Python, the package also provides an interface to PyMC3 and
CODA.

WWW: https://github.com/pysal/spvcm
Original commitRevision:560049  Sanity Test Failure
19:57 sunpoet search for other commits by this committer
Add py-spreg 1.1.2.post1

Spatial Regression Models (spreg)

spreg, short for "spatial regression", is a python package to estimate
simultaneous autoregressive spatial regression models. These models are useful
when modeling processes where observations interact with one another.

WWW: https://spreg.readthedocs.io/en/latest/
WWW: https://github.com/pysal/spreg
Original commitRevision:560048  Sanity Test Failure
19:57 sunpoet search for other commits by this committer
  • math/py-splot 1.1.3 Visual analytics for spatial analysis with PySAL
Add py-splot 1.1.3

splot provides PySAL users with a lightweight visualization interface to explore
their data and quickly iterate through static and dynamic visualisations.

splot connects spatial analysis done in PySAL to different popular visualization
toolkits like matplotlib. The splot package allows you to create both static
plots ready for publication and interactive visualizations for quick iteration
and spatial data exploration. The primary goal of splot is to enable you to
visualize popular PySAL objects and gives you different views on your spatial
analysis workflow.

WWW: https://splot.readthedocs.io/en/latest/
WWW: https://github.com/pysal/splot
Original commitRevision:560047  Sanity Test Failure
19:57 sunpoet search for other commits by this committer
Add py-spint 1.0.7

Spatial Interaction Modeling Package

The Spatial Interaction Modeling (SpInt) module seeks to provide a collection of
tools to study spatial interaction processes and analyze spatial interaction
data.

The module currently supports the calibration of the 'family' of spatial
interaction models (Wilson, 1971) which are derived using an entropy maximizing
(EM) framework or the equivalent information minimizing (IM) framework. As such,
it is able to derive parameters for the following Poisson count models:
- unconstrained gravity model
- production-constrained model (origin-constrained)
- attraction-constrained model (destination-constrained)
- doubly-constrained model

WWW: https://github.com/pysal/spint
Original commitRevision:560046  Sanity Test Failure
19:57 sunpoet search for other commits by this committer
Add py-spglm 1.0.8

This module is an adaptation of a portion of GLM functionality from the
Statsmodels package, this it has been simplified and customized for the purposes
of serving as the base for several other PySAL modules, namely SpInt and GWR.
Currently, it supports the estimation of Gaussian, Poisson, and Logistic
regression using only iteratively weighted least squares estimation (IWLS). One
of the large differences this module and the functions avaialble in the
Statsmodels package is that the custom IWLS routine is fully sparse compatible,
which was necesary for the very sparse design matrices that arise in constrained
spatial interaction models. The somewhat limited functionality and computation
of only a subset of GLM diagnostics also decreases the computational overhead.
Another difference is that this module also supports the estimation of
QuasiPoisson models. One caveat is that this custom IWLS routine currently
generates estimates by directly solves the least squares normal equations rather
than using a more robust method like the pseudo inverse. For more robust
estimation of ill conditioned data and a fuller GLM framework we suggest using
the original GLM functionality from Statsmodels.

WWW: https://github.com/pysal/spglm
Original commitRevision:560045  Sanity Test Failure
19:57 sunpoet search for other commits by this committer
Add py-pointpats 2.2.0

Point Pattern Analysis (pointpats)

pointpats is an open-source python library for the statistical analysis of
planar point patterns. It is a subpackage of PySAL (Python Spatial Analysis
Library) and is under active development for the inclusion of many newly
proposed analytics for point patterns.

WWW: https://pointpats.readthedocs.io/en/latest/
WWW: https://github.com/pysal/pointpats
Original commitRevision:560043  Sanity Test Failure
19:57 sunpoet search for other commits by this committer
Add py-mgwr 2.1.2

Multiscale Geographically Weighted Regression (MGWR)

mgwr is a Python implementation of multiscale geographically weighted regression
for investigating process spatial heterogeneity and scale. It incorporates the
widely used approach to modeling process spatial heterogeneity - Geographically
Weighted Regression (GWR) as well as the newly proposed approach - Multiscale
GWR (MGWR) which relaxes the assumption that all of the processes being modeled
operate at the same spatial scale. Inferences are available for both approaches.

WWW: https://mgwr.readthedocs.io/en/latest/
WWW: https://github.com/pysal/mgwr
Original commitRevision:560042  Sanity Test Failure
19:57 sunpoet search for other commits by this committer
Add py-giddy 2.3.3

GeospatIal Distribution DYnamics (GIDDY)

Giddy is an open-source python library for the analysis of dynamics of
longitudinal spatial data. Originating from the spatial dynamics module in PySAL
(Python Spatial Analysis Library), it is under active development for the
inclusion of many newly proposed analytics that consider the role of space in
the evolution of distributions over time and has several new features including
inter- and intra-regional decomposition of mobility association and local
measures of exchange mobility in addition to space-time LISA and spatial markov
methods.

WWW: https://pysal.org/giddy/
WWW: https://github.com/pysal/giddy
Original commitRevision:560041  Sanity Test Failure
Saturday, 2 Jan 2021
16:36 madpilot search for other commits by this committer
  • archivers/thunar-archive-plugin 0.4.0_1 Archive plugin for the Thunar File Manager
    • audio/thunar-media-tags-plugin 0.3.0_1 Media tags plugin
      • audio/xfce4-pulseaudio-plugin 0.4.3_1 Panel plugin for controlling PulseAudio mixer
        • deskutils/orage 4.12.1_10 Calendar application for the Xfce Desktop
          • deskutils/xfce4-generic-slider 0.0.20171223_1 Slider plugin to adjust and/or monitor any numeric variable
            • deskutils/xfce4-notes-plugin 1.8.1_2 Notes plugin for the Xfce panel
              • deskutils/xfce4-notifyd 0.6.2_2 Visually-appealing notification daemon for Xfce
                • deskutils/xfce4-tumbler 4.16.0 Thumbnail service for Xfce desktop
                  • deskutils/xfce4-volumed 0.1.13_4 Volume management daemon for the Xfce desktop Deleted Broken Deprecated Expired Ignore
                    • deskutils/xfce4-volumed-pulse 0.2.3_4 Volume management daemon for Xfce using PulseAudio
                                                                                                                                    (Only the first 10 of 66 items in this commit are shown above. View all ports for this commit)
                                                                                                                                    Welcome XFCE 4.16 to the FreeBSD ports tree!
                                                                                                                                    
                                                                                                                                    Upstream announce: https://xfce.org/about/news/?post=1608595200
                                                                                                                                    
                                                                                                                                    This XFCE release dropped support for GTK2 plugins and also dropped
                                                                                                                                    GTK2 from all components.
                                                                                                                                    
                                                                                                                                    WARNING: please check UPDATING before upgrading your packages. In
                                                                                                                                    case of problems also read the libexo pkg-message.
                                                                                                                                    
                                                                                                                                    Due to this some panel plugins and libraries will be removed since
                                                                                                                                    they cannot compile anymore:
                                                                                                                                    
                                                                                                                                    - print/xfce4-print
                                                                                                                                    - x11/xfce4-quicklauncher-plugin
                                                                                                                                    - x11/xfce4-wmdock-plugin
                                                                                                                                    - x11-toolkits/libxfce4gui
                                                                                                                                    
                                                                                                                                    These further components also fail to build or work and are being
                                                                                                                                    marked BROKEN, deprecated and marked for removal:
                                                                                                                                    
                                                                                                                                    - science/xfce4-equake-plugin
                                                                                                                                    - x11/xfce4-embed-plugin
                                                                                                                                    - deskutils/orage
                                                                                                                                    - deskutils/xfce4-volumed [1]
                                                                                                                                    
                                                                                                                                    deskutils/xfce4-notes-plugin will be also marked BROKEN, but there
                                                                                                                                    is active development in it's upstream repository and a fixed release
                                                                                                                                    is expected soon.
                                                                                                                                    
                                                                                                                                    deskutils/xfce4-generic-slider will also be marked broken, since
                                                                                                                                    it fails to compile. [2]
                                                                                                                                    
                                                                                                                                    Thanks also to riggs, Olivier Duchateau <duchateau.olivier@gmail.com>
                                                                                                                                    and the people in Approved and Reviewed lines below for help and
                                                                                                                                    contributions.
                                                                                                                                    
                                                                                                                                    Reviewed by:		woodsb02
                                                                                                                                    Approved by:		sergey.dyatko@gmail.com (maintainer) [1],
                                                                                                                                    			ehaupt [2]
                                                                                                                                    Differential Revision:	https://reviews.freebsd.org/D27846
                                                                                                                                    Original commitRevision:559953  Sanity Test Failure
Thursday, 31 Dec 2020
22:35 db search for other commits by this committer
cura is just a front-end, and heavily depends on its dependencies.
without updating depended libraries, new version will not provide what
the release note says. this is especially true in this PR, as the reporter
needs fixes in cura engine, the slicer.

Submitter was not clear with the bugs present. In any case I have corrected
a few missing dependancies and am committing two of the dependencies
for cura-engine.

PR:		ports/251236
Reported by:	trombik1973@gmail.com
Original commitRevision:559782  Sanity Test Failure
Sunday, 27 Dec 2020
17:40 acm search for other commits by this committer
- Copy bareos-* to bareos19-* preparing for update bareos to 20.0.0
- Clean port [1]

PR:		250440
Submitted by:	brad  at  facefault.org [1]
Original commitRevision:559386  Sanity Test Failure
Monday, 21 Dec 2020
14:16 jbeich search for other commits by this committer
x11/xdg-desktop-portal-wlr: add new port

xdg-desktop-portal backend for wlroots

https://github.com/emersion/xdg-desktop-portal-wlr
Original commitRevision:558828  Sanity Test Failure
Saturday, 19 Dec 2020
20:04 sunpoet search for other commits by this committer
Add py-markdown-it-py 0.6.0

markdown-it-py is a Python port of markdown-it, and some of its associated
plugins.
- Follows the CommonMark spec for baseline parsing
- Configurable syntax: you can add new rules and even replace existing ones.
- Pluggable: Adds syntax extensions to extend the parser (see the plugin list).
- High speed (see our benchmarking tests)
- Safe by default

WWW: https://github.com/executablebooks/markdown-it-py
Original commitRevision:558478  Sanity Test Failure
20:03 sunpoet search for other commits by this committer
Add py-nbclient 0.5.1

NBClient, a client library for programmatic notebook execution, is a tool for
running Jupyter Notebooks in different execution contexts. NBClient was spun out
of nbconvert's former ExecutePreprocessor.

WWW: https://github.com/jupyter/nbclient
Original commitRevision:558473  Sanity Test Failure
Tuesday, 1 Dec 2020
13:21 thierry search for other commits by this committer
Adding Mathics, a general-purpose computer algebra system (CAS).
Original commitRevision:556732  Sanity Test Failure
04:06 jrm search for other commits by this committer
www/chromium: Update to version 87.0.4280.66

Submitted by:	Matthias Wolf, cem, rene
Obtained from:	Some patches from OpenBSD port (robert@openbsd.org)
Original commitRevision:556709  Sanity Test Failure
Thursday, 26 Nov 2020
23:22 dvl search for other commits by this committer
Sunday, 15 Nov 2020
17:56 sunpoet search for other commits by this committer
Add py-aioquic 0.9.7

aioquic is a library for the QUIC network protocol in Python. It features a
minimal TLS 1.3 implementation, a QUIC stack and an HTTP/3 stack.

WWW: https://github.com/aiortc/aioquic
Original commitRevision:555253  Sanity Test Failure
Saturday, 14 Nov 2020
10:57 pi search for other commits by this committer
multimedia/lives: update 2.10.2 -> 3.2.0

- major update
- submitter becomes maintainer

PR:		246491
Submitted by:	vvd@unislabs.com
Relnotes:	http://lives-video.com/releases/CHANGELOG-3.2.0
Original commitRevision:555106  Sanity Test Failure
Thursday, 12 Nov 2020
10:19 danfe search for other commits by this committer
Allow to build on FreeBSD pre-12.x and i386 by stealing some patches
from the `databases/mysql80-server' port.

Suggested by:	fluffy
Original commitRevision:554946  Sanity Test Failure
Monday, 9 Nov 2020
17:35 sunpoet search for other commits by this committer
Update to 0.4.2.post2

Changes:	https://github.com/facebookresearch/nevergrad/releases
		https://github.com/facebookresearch/nevergrad/blob/master/CHANGELOG.md
Original commitRevision:554747  Sanity Test Failure
Sunday, 8 Nov 2020
17:10 sunpoet search for other commits by this committer
Add py-smbprotocol 1.2.0

SMB is a network file sharing protocol and has numerous iterations over the
years. This library implements the SMBv2 and SMBv3 protocol based on the MS-SMB2
document.

Features:
- Negotiation of the SMB 2.0.2 protocol to SMB 3.1.1 (Windows 10/Server 2016)
- Authentication with both NTLM and Kerberos
- Message signing
- Message encryption (SMB 3.x.x+)
- Connect to a Tree/Share
- Opening of files, pipes and directories
- Set create contexts when opening files
- Read and writing of files and pipes
- Sending IOCTL commands
- Sending of multiple messages in one packet (compounding)
- Experimental support for both standalone and DFS server shares

WWW: https://github.com/jborean93/smbprotocol
Original commitRevision:554479  Sanity Test Failure
Friday, 6 Nov 2020
11:11 sunpoet search for other commits by this committer
Add py-filedepot 0.8.0

DEPOT is a framework for easily storing and serving files in web applications.

DEPOT supports storing files in multiple backends, like:
- Local Disk
- In Memory (for tests)
- On GridFS
- On Amazon S3 (or compatible services)
and integrates with database by providing files attached to your SQLAlchemy or
Ming/MongoDB models with respect to transactions behaviours (files are rolled
back too).

WWW: https://github.com/amol-/depot
Original commitRevision:554182  Sanity Test Failure
09:19 0mp search for other commits by this committer
Use -fuse-lld=lld to avoid link errors using old ld(1) on 11.x

PR:		249974
Submitted by:	John Hein <jcfyecrayz__liamekaens_com>
Approved by:	portmgr blanket
MFH:		2020Q4
Original commitRevision:554175  Sanity Test Failure
Wednesday, 21 Oct 2020
20:19 rene search for other commits by this committer
graphics/dspdfviewer: simplify logic for -Wno-error=extra-semi-stmt

I first bogusly added OSVERSION < 1300000 at the end, but in hindsight
and from looking at svnweb the version logic after 11.3 EOL is
v >= 1300014 || (v in 1104000 .. 1200000) || v >= 1201000
==
(v in 1104000 .. 1200000) || v >= 1201000
==
(v >= 1200000 && v < 1201000)

So the port should not relax the check on (early) 12.0, which we can as
well leave out.

While here, add a note about upstream #191 still being open.

Phabricator:	D26646
Original commitRevision:552891  Sanity Test Failure
Tuesday, 13 Oct 2020
18:41 sunpoet search for other commits by this committer
Add py-behave 1.2.6

Behave is behavior-driven development in Python style.

Behavior-driven development (or BDD) is an agile software development technique
that encourages collaboration between developers, QA and non-technical or
business participants in a software project.

behave uses tests written in a natural language style, backed up by Python code.

WWW: https://github.com/behave/behave
Original commitRevision:552246  Sanity Test Failure
Monday, 12 Oct 2020
10:45 krion search for other commits by this committer
  • devel/py-pop 14 Plugin Oriented Programming interface for Python
Add devel/py-pop

Plugin Oriented Programming interface for Python

https://pop.readthedocs.io
Original commitRevision:552120  Sanity Test Failure
Friday, 9 Oct 2020
19:02 sunpoet search for other commits by this committer
Change RUN_DEPENDS from py-prettytable to py-prettytable0

- Bump PORTREVISION for dependency change
Original commitRevision:551797  Sanity Test Failure
Monday, 5 Oct 2020
17:24 sunpoet search for other commits by this committer
Update to 0.601

Changes:	https://metacpan.org/changes/distribution/Text-ANSITable
Original commitRevision:551513  Sanity Test Failure
Sunday, 4 Oct 2020
11:00 pi search for other commits by this committer
  • dns/knot3 3.0.0 High performance authoritative-only DNS server
dns/knot3: remove for repo-copy

PR:		249363
Reported by:	danfe
Original commitRevision:551378  Sanity Test Failure
Wednesday, 23 Sep 2020
19:18 sunpoet search for other commits by this committer
Change RUN_DEPENDS from py-httpx to py-httpx013

- Bump PORTREVISION for dependency change

Kai checked the test suite and 1 test fails with httpx 0.14.0.
Therefore, I change this port to use repocopied httpx 0.13.3 for now.

Approved by:	kai (maintainer, implicit, via private mail)
Original commitRevision:549829  Sanity Test Failure
Saturday, 19 Sep 2020
12:41 sunpoet search for other commits by this committer
Add rubygem-minima 2.5.1

Minima is a one-size-fits-all Jekyll theme for writers. It's Jekyll's default
(and first) theme. It's what you get when you run jekyll new.

WWW: https://github.com/jekyll/minima
Original commitRevision:548974  Sanity Test Failure
Monday, 14 Sep 2020
17:45 sunpoet search for other commits by this committer
Add p5-Module-Load-Util 0.003

Module::Load::Util provides some utility routines related to module loading.

WWW: https://metacpan.org/release/Module-Load-Util
Original commitRevision:548637  Sanity Test Failure
Sunday, 13 Sep 2020
05:56 jbeich search for other commits by this committer
  • graphics/dssim 1.3.3.15 Image similarity comparison simulating human perception
graphics/dssim: add new port

This tool computes (dis)similarity between two or more PNG images
using an algorithm approximating human vision.

Comparison is done in L*a*b* color space (D65 white point, sRGB gamma)
using a multi-scale variant of the SSIM algorithm.

Features:
- Supports alpha channel
- Supports gamma correction
- No OpenCV or MATLAB needed:
   - DSSIM version 1.x uses C (C99) and libpng or Cocoa on macOS.
   - DSSIM version 2.x is easy to build with Rust

https://kornel.ski/dssim
Original commitRevision:548452  Sanity Test Failure
Saturday, 12 Sep 2020
12:07 sunpoet search for other commits by this committer
Add rubygem-async-websocket 0.16.0

Async::WebSocket is an asynchronous websocket client/server implementation for
HTTP/1 and HTTP/2.

WWW: https://github.com/socketry/async-websocket
Original commitRevision:548315  Sanity Test Failure
12:07 sunpoet search for other commits by this committer
Add py-h3 3.6.4

H3 is a geospatial indexing system using a hexagonal grid that can be
(approximately) subdivided into finer and finer hexagonal grids, combining the
benefits of a hexagonal grid with S2's hierarchical subdivisions.

This port is the Python binding for H3 core library.

WWW: https://github.com/uber/h3-py
Original commitRevision:548312  Sanity Test Failure
Sunday, 30 Aug 2020
20:21 sunpoet search for other commits by this committer
Change RUN_DEPENDS from py-pip-tools to py-pip-tools4

- Bump PORTREVISION for dependency change
Original commitRevision:547096  Sanity Test Failure
07:12 sunpoet search for other commits by this committer
Add py-python-binary-memcached 0.30.0

bmemcached is a pure python module (thread safe) to access memcached via it's
binary with SASL auth support.

The main purpose of this module it to be able to communicate with memcached
using binary protocol and support authentication, so it can work with Heroku for
example.

WWW: https://github.com/jaysonsantos/python-binary-memcached
Original commitRevision:546973  Sanity Test Failure
Saturday, 22 Aug 2020
11:04 Matthias Andree (mandree) search for other commits by this committer
MFH: r545759

net/chrony: security update to 3.5.1

This upstream update essentially contains one Git commit:
https://git.tuxfamily.org/chrony/chrony.git/commit/?h=3.5-stable&id=f00fed20092b6a42283f29c6ee1f58244d74b545

It is to fix a symlink vulnerability when writing the pidfile.

Changelog:
https://listengine.tuxfamily.org/chrony.tuxfamily.org/chrony-announce/2020/08/msg00000.html

Security:	CVE-2020-14367
Security:	719f06af-e45e-11ea-95a1-c3b8167b8026

Approved by:	ports-secteam (blanket, upstream update contains only security fix)
commit hash: 911f67192bde9731260f4f74d72abb4b80b42fa7 commit hash: 911f67192bde9731260f4f74d72abb4b80b42fa7 commit hash: 911f67192bde9731260f4f74d72abb4b80b42fa7 commit hash: 911f67192bde9731260f4f74d72abb4b80b42fa7  Sanity Test Failure
Sunday, 16 Aug 2020
09:51 Matthias Andree (mandree) search for other commits by this committer
Sunday, 9 Aug 2020
08:53 tcberner search for other commits by this committer
Saturday, 8 Aug 2020
14:38 Danilo G. Baio (dbaio) search for other commits by this committer
  • branches/2020Q3/mail/notmuch 0.29.1_1 Thread-based email index, search and tagging application
  • MFH: r544270 r544271 r544289
    
    mail/notmuch: reset maintainership
    
    Maintainer stops using FreeBSD.
    
    PR:	248492
    Submitted by:	seschwar@gmail.com (maintainer)
    
    mail/py-afew: reset maintainership
    
    Maintainer stops using FreeBSD.
    
    PR:	248491
    Submitted by:   seschwar@gmail.com (maintainer)
    
    mail/py-afew, mail/notmuch: Take MAINTAINER'ship
    
    Approved by:	ports-secteam (blanket: consistent port/package metadata)
    Reported by:	koobs
    commit hash: f254641c37df8c9681762d216f6ba7ded2af24d0 commit hash: f254641c37df8c9681762d216f6ba7ded2af24d0 commit hash: f254641c37df8c9681762d216f6ba7ded2af24d0 commit hash: f254641c37df8c9681762d216f6ba7ded2af24d0  Sanity Test Failure
10:19 sunpoet search for other commits by this committer
Update to 2.0.0

Changes:	https://github.com/googleapis/python-iam/releases
Original commitRevision:544410  Sanity Test Failure
Thursday, 30 Jul 2020
09:47 sunpoet search for other commits by this committer
Add rubygem-train 3.3.6

Train lets you talk to your local or remote operating systems and APIs with a
unified interface.

It allows you to:
- execute commands via run_command
- interact with files via file
- identify the target operating system via os
- authenticate to API-based services and treat them like a platform

Train supports:
- Local execution
- SSH
- WinRM
- Docker
- Mock (for testing and debugging)
- AWS as an API
- Azure as an API
- VMware via PowerCLI
- Habitat

WWW: https://github.com/inspec/train
Original commitRevision:543733  Sanity Test Failure
Friday, 24 Jul 2020
10:06 mikael search for other commits by this committer
www/p5-Web-Machine: create port

Web::Machine provides a RESTful web framework modeled as a state machine.
You define one or more resource classes. Each resource represents a single
RESTful URI end point, such as a user, an email, etc. The resource class can
also be the target for POST requests to create a new user, email, etc.

Each resource is a state machine, and each request for a resource is handled by
running the request through that state machine.

Web::Machine is built on top of Plack, but it handles the full request and
response cycle.

PR:		248041
Original commitRevision:543237  Sanity Test Failure
07:08 sunpoet search for other commits by this committer
Add rubygem-bio-executables 1.0.0

bio-executables is a collection of miscellaneous utilities for bioinformatics
that were formerly part of the BioRuby core ("bio" gem). Because of reducing
complexity, they were moved to this gem.

This code has historically been part of the BioRuby gem, but has been split into
its own gem as part of an effort to modularize BioRuby. bio-executables and many
more plugins are available at biogems.info.

WWW: https://github.com/bioruby/bioruby-executables
Original commitRevision:543010  Sanity Test Failure
Saturday, 18 Jul 2020
09:31 Matthias Andree (mandree) search for other commits by this committer
Friday, 17 Jul 2020
22:35 Jan Beich (jbeich) search for other commits by this committer
MFH: r542454

x11/swaylock: limit root to authenticating child process

Taken from initialize_pw_backend in shadow.c.

PR:		248053
Approved by:	ports-secteam blanket
commit hash: 6550b772fb63ad972cf9416e5832e60ddea31c73 commit hash: 6550b772fb63ad972cf9416e5832e60ddea31c73 commit hash: 6550b772fb63ad972cf9416e5832e60ddea31c73 commit hash: 6550b772fb63ad972cf9416e5832e60ddea31c73  Sanity Test Failure
22:14 Jan Beich (jbeich) search for other commits by this committer
MFH: r542450

x11/swaylock: unbreak PAM locking

Since 1.5 it includes "login" service which doesn't ask for password
from user running Wayland session. Before pam_authenticate(3) failed
with PAM_AUTH_ERR due to missing permissions password database.

PR:		248053
Reported by:	many
Submitted by:	andrew|_|tao11.riddles.org.uk, jbeich
Tested by:	ashish
Approved by:	ports-secteam blanket
commit hash: 033f2cc92a3c923f2db55b46ade60459ba9ac149 commit hash: 033f2cc92a3c923f2db55b46ade60459ba9ac149 commit hash: 033f2cc92a3c923f2db55b46ade60459ba9ac149 commit hash: 033f2cc92a3c923f2db55b46ade60459ba9ac149  Sanity Test Failure
Thursday, 9 Jul 2020
18:08 sunpoet search for other commits by this committer
  • math/py-jax 0.1.72 Differentiate, compile, and transform Numpy code
Add py-jax 0.1.72

JAX is Autograd and XLA, brought together for high-performance machine learning
research.

With its updated version of Autograd, JAX can automatically differentiate native
Python and NumPy functions. It can differentiate through loops, branches,
recursion, and closures, and it can take derivatives of derivatives of
derivatives. It supports reverse-mode differentiation (a.k.a. backpropagation)
via grad as well as forward-mode differentiation, and the two can be composed
arbitrarily to any order.

What's new is that JAX uses XLA to compile and run your NumPy programs on GPUs
and TPUs. Compilation happens under the hood by default, with library calls
getting just-in-time compiled and executed. But JAX also lets you just-in-time
compile your own Python functions into XLA-optimized kernels using a
one-function API, jit. Compilation and automatic differentiation can be composed
arbitrarily, so you can express sophisticated algorithms and get maximal
performance without leaving Python. You can even program multiple GPUs or TPU
cores at once using pmap, and differentiate through the whole thing.

Dig a little deeper, and you'll see that JAX is really an extensible system for
composable function transformations. Both grad and jit are instances of such
transformations. Others are vmap for automatic vectorization and pmap for
single-program multiple-data (SPMD) parallel programming of multiple
accelerators, with more to come.

WWW: https://github.com/google/jax
Original commitRevision:541767  Sanity Test Failure
Monday, 29 Jun 2020
16:14 sunpoet search for other commits by this committer
Add rubygem-flipper-active_record017 0.17.2 (copied from
rubygem-flipper-active_record)

- Add PORTSCOUT
Original commitRevision:540784  Sanity Test Failure
Saturday, 27 Jun 2020
23:25 jbeich search for other commits by this committer
MFH: r540655

emulators/ppsspp: unbreak OLDJOY after r512863

SDL/SDLJoystick.cpp:24:13: error: no member named 'bPS3Controller' in 'Config'
                        g_Config.bPS3Controller = true;
                        ~~~~~~~~ ^
SDL/SDLJoystick.cpp:27:22: error: no member named 'bPS3Controller' in 'Config'
        if (g_Config.bPS3Controller)
            ~~~~~~~~ ^

Approved by:	ports-secteam blanket
Original commitRevision:540657  Sanity Test Failure
23:25 Jan Beich (jbeich) search for other commits by this committer
MFH: r540655

emulators/ppsspp: unbreak OLDJOY after r512863

SDL/SDLJoystick.cpp:24:13: error: no member named 'bPS3Controller' in 'Config'
                        g_Config.bPS3Controller = true;
                        ~~~~~~~~ ^
SDL/SDLJoystick.cpp:27:22: error: no member named 'bPS3Controller' in 'Config'
        if (g_Config.bPS3Controller)
            ~~~~~~~~ ^

Approved by:	ports-secteam blanket
commit hash: d4781f3ddbd51541d2027a5f892a30092461feb1 commit hash: d4781f3ddbd51541d2027a5f892a30092461feb1 commit hash: d4781f3ddbd51541d2027a5f892a30092461feb1 commit hash: d4781f3ddbd51541d2027a5f892a30092461feb1  Sanity Test Failure
18:10 Jan Beich (jbeich) search for other commits by this committer
Friday, 19 Jun 2020
20:07 mi search for other commits by this committer
Add Linux version of libxslt, as might be required by future
application ports.
Original commitRevision:539676  Sanity Test Failure
Monday, 15 Jun 2020
18:39 sunpoet search for other commits by this committer
Add p5-Term-App-Util-Color 0.001

Term::App::Util::Color tries to determine the suitable color depth to use.

WWW: https://metacpan.org/release/Term-App-Util-Color
Original commitRevision:538928  Sanity Test Failure
Saturday, 6 Jun 2020
23:10 Jan Beich (jbeich) search for other commits by this committer
MFH: r538136

emulators/ppsspp: unbreak Vulkan on Wayland after r512863

Regressed by https://github.com/hrydgard/ppsspp/commit/3e4faea6adcb

$ SDL_VIDEODRIVER=wayland LD_PRELOAD=libGLEW-wayland.so ppsspp
[...]
I: VulkanLoader.cpp:451: VulkanLoad: Found library 'libvulkan.so'
W: VulkanLoader.cpp:472: VulkanLoad: Base functions loaded.
W: VulkanLoader.cpp:548: Vulkan instance functions loaded.
I: VulkanContext.cpp:502: Chose physical device 0: 0x8056427c0
I: VulkanContext.cpp:538: Memory Types (1):
I: VulkanContext.cpp:547:   0: Heap 0; Flags: DEVICE_LOCAL HOST_VISIBLE
HOST_CACHED HOST_COHERENT
W: VulkanLoader.cpp:555: Vulkan device functions loaded.
I: VulkanLoader.cpp:571: Missing (device):
vkGetPhysicalDeviceSparseImageFormatProperties
I: VulkanContext.cpp:659: Device created.

Vulkan subsystem 6 not supported

Approved by:	ports-secteam blanket
commit hash: 870d6c9c1aded5ae2a5fa0605ca450578b9df995 commit hash: 870d6c9c1aded5ae2a5fa0605ca450578b9df995 commit hash: 870d6c9c1aded5ae2a5fa0605ca450578b9df995 commit hash: 870d6c9c1aded5ae2a5fa0605ca450578b9df995  Sanity Test Failure
Saturday, 16 May 2020
15:45 mikael search for other commits by this committer
irc/komanda-cli: add new port

Sister app of komanda.io, an IRC
client for developers built in go.

WWW: https://github.com/mephux/komanda-cli

PR:		246504
Submitted by:	Lewis Cook <vulcan@wired.sh>
Original commitRevision:535473  Sanity Test Failure
09:22 Matthias Andree (mandree) search for other commits by this committer
MFH: r535367

mail/mailman: cherry-pick regression fix from upstream

https://bazaar.launchpad.net/~mailman-coders/mailman/2.1/revision/1850#NEWS
https://launchpad.net/bugs/1878458

Obtained from:	Mark Sapiro

Approved by:	ports-secteam@ (blanket approval for reliability fix backport)
commit hash: ce801f8bd15bc2a38728f86b8f542fddf15252f8 commit hash: ce801f8bd15bc2a38728f86b8f542fddf15252f8 commit hash: ce801f8bd15bc2a38728f86b8f542fddf15252f8 commit hash: ce801f8bd15bc2a38728f86b8f542fddf15252f8  Sanity Test Failure
Wednesday, 13 May 2020
17:30 acm search for other commits by this committer
17:30 acm search for other commits by this committer
17:29 acm search for other commits by this committer
Friday, 8 May 2020
20:46 sunpoet search for other commits by this committer
Add py-rasterio 1.1.4

Rasterio reads and writes geospatial raster data.

Geographic information systems use GeoTIFF and other formats to organize and
store gridded, or raster, datasets. Rasterio reads and writes these formats and
provides a Python API based on N-D arrays.

WWW: https://github.com/mapbox/rasterio
Original commitRevision:534419  Sanity Test Failure
Thursday, 7 May 2020
19:56 Matthias Andree (mandree) search for other commits by this committer
mail/mailman: fix another content injection vuln via private archive login

This led up to mailman 2.1.33 today.
https://bugs.launchpad.net/mailman/+bug/1877379
https://launchpadlibrarian.net/478684932/private.diff
https://mail.python.org/archives/list/mailman-developers@python.org/thread/SYBIZ3MNSQZLKN6PVKO7ZKR7QMOBMS45/

Approved by:    ports-secteam@ (blanket for security fixes)
Security:       88760f4d-8ef7-11ea-a66d-4b2ef158be83
commit hash: 256087e126eb204ceb01408435c728dfd8510c80 commit hash: 256087e126eb204ceb01408435c728dfd8510c80 commit hash: 256087e126eb204ceb01408435c728dfd8510c80 commit hash: 256087e126eb204ceb01408435c728dfd8510c80  Sanity Test Failure
01:45 emaste search for other commits by this committer
devel/arm-none-eabi-gcc492: add objdump binutils dependency

/usr/bin/objdump has been removed from the base system for FreeBSD 13.0.

PR:		212319 [exp-run]
Sponsored by:	The FreeBSD Foundation
Original commitRevision:534230  Sanity Test Failure
Tuesday, 5 May 2020
22:57 Matthias Andree (mandree) search for other commits by this committer
2020Q2 specific mail/mailman minimal security fix

Backporting 2.1.31 needs more consideration and more than just MFH r534101,
so forgo that and for the nonce, plug this information leak quickly with the
one-line fix by upstream, and hack additional translations to match into the
.po files with REINPLACE_CMD.

Approved by:	ports-secteam@ (blanket, trivial security fix)
Security:	88760f4d-8ef7-11ea-a66d-4b2ef158be83
commit hash: 9e0d62bd3f0ceeab16cef6119cba8f9a5a5fa7d4 commit hash: 9e0d62bd3f0ceeab16cef6119cba8f9a5a5fa7d4 commit hash: 9e0d62bd3f0ceeab16cef6119cba8f9a5a5fa7d4 commit hash: 9e0d62bd3f0ceeab16cef6119cba8f9a5a5fa7d4  Sanity Test Failure
Sunday, 3 May 2020
20:46 sunpoet search for other commits by this committer
Add py-pytest-benchmark 3.2.3

pytest-benchmark is a pytest fixture for benchmarking code. It will group the
tests into rounds that are calibrated to the chosen timer.

WWW: https://github.com/ionelmc/pytest-benchmark
Original commitRevision:533811  Sanity Test Failure
Friday, 24 Apr 2020
18:00 sunpoet search for other commits by this committer
Add p5-Keyword-Declare 0.001017

Keyword::Declare implements a new Perl keyword: keyword, which you can use to
specify other new keywords.

Normally, to define new keywords in Perl, you either have to write them in XS
(shiver!) or use a module like Keyword::Simple or Keyword::API. Using any of
these approaches requires you to grab all the source code after the keyword,
manually parse out the components of the keyword's syntax, construct the
replacement source code, and then substitute it for the original source code you
just parsed.

Using Keyword::Declare, you define a new keyword by specifying its name and a
parameter list corresponding to the syntactic components that must follow the
keyword. You then use those parameters to construct and return the replacement
source code. The module takes care of setting up the keyword, and of the
associated syntax parsing, and of inserting the replacement source code in the
correct place.

WWW: https://metacpan.org/release/Keyword-Declare
Original commitRevision:532811  Sanity Test Failure
18:00 sunpoet search for other commits by this committer
Add p5-Data-Object-Types 0.04

Data::Object::Types provides type constraints for Data::Object.

WWW: https://metacpan.org/release/Data-Object-Types
Original commitRevision:532809  Sanity Test Failure
18:00 sunpoet search for other commits by this committer
Add p5-Data-Object-Try 2.02

Data::Object::Try provides an object-oriented interface for performing complex
try/catch operations.

WWW: https://metacpan.org/release/Data-Object-Role-Tryable
Original commitRevision:532808  Sanity Test Failure
18:00 sunpoet search for other commits by this committer
Add p5-Data-Object-Struct 2.00

Data::Object::Struct provides a class that creates struct-like objects which
bundle attributes together, is immutable, and provides accessors, without having
to write an explicit class.

WWW: https://metacpan.org/release/Data-Object-Struct
Original commitRevision:532807  Sanity Test Failure
18:00 sunpoet search for other commits by this committer
Add p5-Data-Object-State 2.00

Data::Object::State provides an abstract base class for creating singleton
classes. This package is derived from Moo and makes consumers Moo classes (with
all that that entails). This package also injects a BUILD method which is
responsible for hooking into the build process and returning the appropriate
state.

WWW: https://metacpan.org/release/Data-Object-State
Original commitRevision:532806  Sanity Test Failure
18:00 sunpoet search for other commits by this committer
Add p5-Data-Object-Space 2.01

Data::Object::Space provides methods for parsing and manipulating package
namespaces.

WWW: https://metacpan.org/release/Data-Object-Space
Original commitRevision:532805  Sanity Test Failure
18:00 sunpoet search for other commits by this committer
Add p5-Data-Object-RoleHas 2.01

Data::Object::RoleHas provides options for defining class attributes.

WWW: https://metacpan.org/release/Data-Object-RoleHas
Original commitRevision:532804  Sanity Test Failure
18:00 sunpoet search for other commits by this committer
Add p5-Data-Object-Role-Tryable 2.00

Data::Object::Role::Tryable provides a wrapper around the Data::Object::Try
class which provides an object-oriented interface for performing complex
try/catch operations.

WWW: https://metacpan.org/release/Data-Object-Role-Tryable
Original commitRevision:532803  Sanity Test Failure
18:00 sunpoet search for other commits by this committer
Add p5-Data-Object-Role-Throwable 2.01

Data::Object::Role::Throwable provides mechanisms for throwing the object as an
exception.

WWW: https://metacpan.org/release/Data-Object-Role-Throwable
Original commitRevision:532802  Sanity Test Failure
17:59 sunpoet search for other commits by this committer
Add p5-Data-Object-Role-Stashable 2.01

Data::Object::Role::Stashable provides methods for stashing data within the
object.

WWW: https://metacpan.org/release/Data-Object-Role-Stashable
Original commitRevision:532801  Sanity Test Failure
17:59 sunpoet search for other commits by this committer
Add p5-Data-Object-Role-Proxyable 2.03

Data::Object::Role::Proxyable provides a wrapper around the AUTOLOAD routine
which processes calls to routines which don't exist. Adding a build_proxy method
to the consuming class acts as a hook into routine dispatching, which processes
calls to routines which don't exist. The build_proxy routine is called as a
method and receives $self, $package, $method, and any arguments passed to the
method as a list of arguments, e.g. @args. The build_proxy method must return a
routine (i.e. a callback) or the undefined value which results in a "method
missing" error.

WWW: https://metacpan.org/release/Data-Object-Role-Proxyable
Original commitRevision:532800  Sanity Test Failure
17:59 sunpoet search for other commits by this committer
Add p5-Data-Object-Role-Pluggable 0.01

Data::Object::Role::Pluggable provides a mechanism for dispatching to plugin
classes.

WWW: https://metacpan.org/release/Data-Object-Role-Pluggable
Original commitRevision:532799  Sanity Test Failure
17:48 sunpoet search for other commits by this committer
Add p5-Data-Object-Role-Immutable 2.01

Data::Object::Role::Immutable provides a mechanism for making any derived object
immutable.

WWW: https://metacpan.org/release/Data-Object-Role-Immutable
Original commitRevision:532797  Sanity Test Failure
17:48 sunpoet search for other commits by this committer
Add p5-Data-Object-Role-Formulatable 0.01

Data::Object::Role::Formulatable provides a mechanism for automatically
inflating objects from constructor arguments.

WWW: https://metacpan.org/release/Data-Object-Role-Formulatable
Original commitRevision:532796  Sanity Test Failure
17:48 sunpoet search for other commits by this committer
Add p5-Data-Object-Role-Errable 0.01

Data::Object::Role::Errable provides a mechanism for handling errors
(exceptions). It's a more structured approach to being "throwable". The idea is
that any object that consumes this role can set an error which automatically
throws an exception which if trapped includes the state (object as thrown) in
the exception context.

WWW: https://metacpan.org/release/Data-Object-Role-Errable
Original commitRevision:532795  Sanity Test Failure
17:48 sunpoet search for other commits by this committer
Add p5-Data-Object-Role-Dumpable 2.01

Data::Object::Role::Dumpable provides methods for dumping the object and
underlying value.

WWW: https://metacpan.org/release/Data-Object-Role-Dumpable
Original commitRevision:532794  Sanity Test Failure
17:48 sunpoet search for other commits by this committer
Add p5-Data-Object-Role-Buildable 0.03

Data::Object::Role::Buildable provides methods for hooking into object
construction of the consuming class, e.g. handling single-arg object
construction.

WWW: https://metacpan.org/release/Data-Object-Role-Buildable
Original commitRevision:532793  Sanity Test Failure
17:48 sunpoet search for other commits by this committer
Add p5-Data-Object-Role-Arguable 0.01

Data::Object::Role::Arguable provides a mechanism for unpacking an argument list
and creating a data structure suitable for passing to the consumer constructor.
The argslist routine should return a list of attribute names in the order to be
parsed. An attribute name maybe prefixed with "@" to denote that all remaining
items should be assigned to an arrayref, e.g. @options, or "%" to denote that
all remaining items should be assigned to a hashref, e.g. %options.

WWW: https://metacpan.org/release/Data-Object-Role-Arguable
Original commitRevision:532792  Sanity Test Failure
17:47 sunpoet search for other commits by this committer
Add p5-Data-Object-Role 2.01

Data::Object::Role modifies the consuming package making it a role.

WWW: https://metacpan.org/release/Data-Object-Role
Original commitRevision:532791  Sanity Test Failure
17:47 sunpoet search for other commits by this committer
Add p5-Data-Object-Plugin 0.01

Data::Object::Plugin provides an abstract base class for defining plugin
classes.

WWW: https://metacpan.org/release/Data-Object-Plugin
Original commitRevision:532790  Sanity Test Failure
17:47 sunpoet search for other commits by this committer
Add p5-Data-Object-Opts 2.00

Data::Object::Opts provides methods for accessing command-line arguments.

WWW: https://metacpan.org/release/Data-Object-Opts
Original commitRevision:532789  Sanity Test Failure
17:47 sunpoet search for other commits by this committer
Add p5-Data-Object-Name 2.01

Data::Object::Name provides methods for converting "name" strings.

WWW: https://metacpan.org/release/Data-Object-Name
Original commitRevision:532788  Sanity Test Failure
17:47 sunpoet search for other commits by this committer
Add p5-Data-Object-Kind 0.01

Data::Object::Kind provides methods common across all Data::Object value
classes.

WWW: https://metacpan.org/release/Data-Object-Kind
Original commitRevision:532787  Sanity Test Failure
17:47 sunpoet search for other commits by this committer
Add p5-Data-Object-Exception 2.02

Data::Object::Exception provides functionality for creating, throwing, and
introspecting exception objects.

WWW: https://metacpan.org/release/Data-Object-Exception
Original commitRevision:532786  Sanity Test Failure
17:47 sunpoet search for other commits by this committer
Add p5-Data-Object-Data 2.01

Data::Object::Data provides methods for parsing and extracting pod-like sections
from any file or package. The pod-like syntax allows for using these sections
anywhere in the source code and having Perl properly ignoring them.

WWW: https://metacpan.org/release/Data-Object-Data
Original commitRevision:532785  Sanity Test Failure
17:47 sunpoet search for other commits by this committer
Add p5-Data-Object-ClassHas 2.01

Data::Object::ClassHas provides options for defining class attributes.

WWW: https://metacpan.org/release/Data-Object-ClassHas
Original commitRevision:532784  Sanity Test Failure
17:47 sunpoet search for other commits by this committer
Add p5-Data-Object-Class 2.02

Data::Object::Class modifies the consuming package making it a class.

WWW https://metacpan.org/release/Data-Object-Class
Original commitRevision:532783  Sanity Test Failure
17:46 sunpoet search for other commits by this committer
Add p5-Data-Object-Cast 0.01

Data::Object::Cast provides functions for casting native data types to objects
and the reverse.

WWW: https://metacpan.org/release/Data-Object-Cast
Original commitRevision:532782  Sanity Test Failure
17:46 sunpoet search for other commits by this committer
Add p5-Data-Object-Attributes 0.06

Data::Object::Attributes provides options for defining class attributes.
Specifically, this package wraps the has attribute keyword and adds shortcuts
and enhancements. If no directives are specified, the attribute is declared as
read-write and optional.

WWW: https://metacpan.org/release/Data-Object-Attributes
Original commitRevision:532781  Sanity Test Failure
17:46 sunpoet search for other commits by this committer
Add p5-Data-Object-Args 2.00

Data::Object::Args provides methods for accessing @ARGS items.

WWW: https://metacpan.org/release/Data-Object-Args
Original commitRevision:532780  Sanity Test Failure
Wednesday, 22 Apr 2020
12:40 Renato Botelho (garga) search for other commits by this committer
MFH: r532234

devel/git: Update to 2.26.2

Security:	CVE-2020-11008
Sponsored by:	Rubicon Communications, LLC (Netgate)
Approved by:	ports-secteam (joneum)
commit hash: 54e2c9990c64c5d1253c581e733268ff28e3c6e3 commit hash: 54e2c9990c64c5d1253c581e733268ff28e3c6e3 commit hash: 54e2c9990c64c5d1253c581e733268ff28e3c6e3 commit hash: 54e2c9990c64c5d1253c581e733268ff28e3c6e3  Sanity Test Failure
Friday, 17 Apr 2020
22:59 Matthias Andree (mandree) search for other commits by this committer
MFH: r531727

mail/mailman: update to 2.1.30 - bug fix (incl. data loss)

* upstream changelog:
https://bazaar.launchpad.net/~mailman-coders/mailman/2.1/view/head:/NEWS#L6

Note that upstream means 2.1.30 to be the final 2.x release,
because it relies on Python 2.x which is EOL upstream.

! MAJOR DATA LOSS FIX, rename all templates/* files to .sample,
! and list them as a @sample in pkg-plist, because they can be edited
! through the web server, and an upgrade should not stomp over edited files.

* rearrange makefile a bit (portlint, portfmt)
* update and upload new htdig patch
* expose NLS port option to pkg-install script to avoid failure
* patch upstream bin/check_perms script to not complain about tightened-
  up messages/ and mailmanprefix (${PREFIX}/mailman) permissions that we
  set to 0755 instead of 02775. Mailman should not need to write outside
  designated directories or create new top-level directories in its install.
* fix a typo in the German (mailman.po) translation
* tweak pkg-install to:
  - leave ${PREFIX}/mailman permissions alone and not set them to 02775
  - fix up non-moved .sample files if pkg-install is run with -I
  - create a copy of mm_cfg.py from mm_cfg.py.dist if missing (-I)
  - create a newsyslog.conf.d/mailman.conf if missing, from
    examples/mailman.newsyslog.sample if installed (-I)
  - not attempt to fix messages/ (translations) permissions if the NLS
    port option is disabled
* tweak pkg-plist so that the proper permissions and groups are set
  by default already
* clean up pkg-message, thanks to bapt@ for pointing out that a missing
  type: means "install or upgrade".

Approved by:	ports-secteam@ (joneum@)
commit hash: f8d71bff7e75749ea7e2dac857902fd5b01b476b commit hash: f8d71bff7e75749ea7e2dac857902fd5b01b476b commit hash: f8d71bff7e75749ea7e2dac857902fd5b01b476b commit hash: f8d71bff7e75749ea7e2dac857902fd5b01b476b  Sanity Test Failure
Wednesday, 15 Apr 2020
14:21 Renato Botelho (garga) search for other commits by this committer
MFH: r531622 r531627 r531715

devel/git: Update to 2.26.0

Sponsored by:	Rubicon Communications, LLC (Netgate)

devel/git: Fix build

I've committed the wrong changes in r531622 breaking git build.  Fix it now.

Reported by:	mandree and jbeich
Sponsored by:	Rubicon Communications, LLC (Netgate)

devel/git: Update to 2.26.1

Security:	CVE-2020-5260
Sponsored by:	Rubicon Communications, LLC (Netgate)

Approved by:	ports-secteam (joneum)
commit hash: 31eb82bf11eb786157c51482fbe30aca06796890 commit hash: 31eb82bf11eb786157c51482fbe30aca06796890 commit hash: 31eb82bf11eb786157c51482fbe30aca06796890 commit hash: 31eb82bf11eb786157c51482fbe30aca06796890  Sanity Test Failure
Sunday, 12 Apr 2020
02:43 Matthias Andree (mandree) search for other commits by this committer
  • branches/2020Q2/dns/dnsmasq 2.80_5,1 Lightweight DNS forwarder, DHCP, and TFTP server This port version is marked as vulnerable. 
    • branches/2020Q2/dns/dnsmasq-devel 2.81.r4,3 Lightweight DNS forwarder, DHCP, and TFTP server This port version is marked as vulnerable. 
      • branches/2020Q2/graphics/rawtherapee 5.8_2 Powerful RAW image processing application
        • branches/2020Q2/mail/mailman 2.1.29_7 Mailing list manager with user-friendly web front-end This port version is marked as vulnerable. 
        • MFH: r531475 r531476 r531477 r531478
          
          dns/dnsmasq: repair damage from UNAUTHORIZED UCL conversion of pkg-message
          
          The pkg-message contains a security note that is necessary on
          new installs and on updates alike.
          
          Since per the porter's handbook, the UCL does not support enumeration
          of types, and this is not relevant on removal, the UCL change must be
          reverted.  While here, remove formatting.
          
          Failure inducing commit:
          |------------------------------------------------------------------------
          |r508835 | mat | 2019-08-13 18:01:59 +0200 (Tue, 13 Aug 2019) | 2 lines
          |
          |Convert to UCL & cleanup pkg-message (categories d)
          |
          |------------------------------------------------------------------------
          
          NOTE: The UCL conversion of files/pkg-message.in was not authorized
          and damaging and no heads-up was sent to the maintainer.
          
          portmgr@ MUST act more carefully with sweeping changes and hand them out
          for review first.
          
          dns/dnsmasq-devel: synch non-UCL pkg-message.in
          
          e2fsprogs, rawtherapee: Repair more UCL pkg-message conversion errors.
          
          Both pkg-message texts are relevant for updates.
          
          Reverting this part of UNAUTHORIZED commits, and bump PORTREVISION.
          Clean up pkg-message.
          
          Failure-inducing commits:
          
          ------------------------------------------------------------------------
          r508837 | mat | 2019-08-13 18:03:11 +0200 (Tue, 13 Aug 2019) | 2 lines
          
          Convert to UCL & cleanup pkg-message (categories e-g)
          
          ------------------------------------------------------------------------
          r508909 | mat | 2019-08-14 14:16:12 +0200 (Wed, 14 Aug 2019) | 2 lines
          
          Convert to UCL & cleanup pkg-message (categories s)
          
          ------------------------------------------------------------------------
          
          mail/mailman: repair incomplete UCL conversion of pkg-message.in
          
          There are parts of the install message that are also relevant on
          updates, but were missed. Add them, and bump PORTREVISION.
          
          Failure-inducing commit:
          
          ------------------------------------------------------------------------
          r508882 | mat | 2019-08-14 00:29:42 +0200 (Wed, 14 Aug 2019) | 2 lines
          
          onvert to UCL & cleanup pkg-message (categories l-m)
          
          ------------------------------------------------------------------------
          
          Approved by:	ports-secteam@ (blanket, only changing pkg-message[.in])
          commit hash: 3a61ee38290ca77b8c46debef0bb53eb83d5bf05 commit hash: 3a61ee38290ca77b8c46debef0bb53eb83d5bf05 commit hash: 3a61ee38290ca77b8c46debef0bb53eb83d5bf05 commit hash: 3a61ee38290ca77b8c46debef0bb53eb83d5bf05  Sanity Test Failure
Tuesday, 7 Apr 2020
21:49 jbeich search for other commits by this committer
Sunday, 5 Apr 2020
14:46 cy search for other commits by this committer
  • deskutils/xrolo 2.6_2 Electronic Rolodex Deleted Deprecated Expired
    • games/xvmahjongg 2.1_2 Mahjongg for XView with multicolored tiles Deleted Deprecated Expired
      • games/xvmines 1.0_2 Simple minesweeper game for X Window System Deleted Deprecated Expired
        • math/calctool 2.4.13_5 Multi-GUI (terminal, X, XView) calculator program Deleted Deprecated Expired
          • sysutils/disktool XView sysadmin tool for monitoring diskfull situations Deleted Refresh Deprecated Expired
          • Chase r530745.
            
            Openlook and Xview have been scheduledfor deorbit for their lack of
            64-bit support. This commit also deprecates and expires ports that
            depend on Xview.
            
            Reported by:	antoine
            Thanked by:	mcl
            Original commitRevision:530791  Sanity Test Failure
Saturday, 4 Apr 2020
20:51 antoine search for other commits by this committer
Thursday, 2 Apr 2020
13:08 db search for other commits by this committer
- Removed zombie dependancy on clang since system clang now works
- Now uses python3 by default remove python2 dependancy
- split the VOLK project into separate port

Change log from upstream follows
## [3.8.1.0-rc1] - 2020-02-16

### Changed

#### Project Scope

- clang-tidy improvements
  - Throw exceptions by value, catch by reference
  - `emplace_back` where applicable
  - `empty()` instead of `vector::size() == 0`

### Fixed

#### Project scope

- FindQwt paths
- floatAlmostEqual unittest assert function wrongly passing on sequence types
- Only require boost unittest when testing is enabled
- FindLOG4CPP typo

#### gnuradio-runtime

- block gateway shadowed system port
- Flaky message passing unit test contained timeout (not the test's job)
- ctrlport/`rpcaggregator` & Co: removed storage of references to scope-lifetime
objects
- Sine table generation python was wrong
- `get_tags_in_range` for delay < (end-start)
- premature tag pruning

#### gr_modtool

- wrong use of `input` -> `raw_input`
- allow empty argument list
- testing
- check for and deny TSB under Python
- QA addition bugs

#### gr-analog

- clipping in FM receiver: remove superfluous gain
- C++ generation for multiple blocks

#### gr-audio

- portaudio source: lock acquisition

#### gr-blocks

- broken `rotator` workaround

#### gr-digital

- `map_bb` buffer overflow
- `map_bb` thread safety
- `additive_scrambler `count based reset

#### gr-fec

- heap corruption in `async_decoder`
- `cc_encoder` was broken for constraint lengths > 8

#### gr-fft

- restore Boost 1.53 compat

#### gr-qtgui

- no longer requiring unnecessary key in `edit_box_msg`

#### gr-uhd

- fixed examples under Py3
- multichannel objects not populating channels

#### GRC

- several issues with YAML files
- nested objects now properly populate namespaces
- comments now included in block bounds calculation
- Wiki documentation link removed from OOT blocks' docs tab
- Dragging connections to auto-hide ports works now

### Added

#### Project Scope

- Codec2 development branch / future compat
- Boost 1.71 compat
- CI now checks for formatting

#### gnuradio-runtime

- dot graphs now contain message edges

#### gr-uhd

- UHD Filter API

#### GRC

- block affinity, buffer sizes available as advanced options for blocks
- testing
Original commitRevision:530370  Sanity Test Failure
Tuesday, 31 Mar 2020
17:44 fluffy search for other commits by this committer
  • mail/opensmtpd Security- and simplicity-focused SMTP server from OpenBSD Refresh
mail/opensmtpd: We not need to care about OpenBSD here

Make configure args for mbox path unconditional

Noted by:	mat
Original commitRevision:529996  Sanity Test Failure
Sunday, 29 Mar 2020
18:09 amdmi3 search for other commits by this committer
Switch to graphics/py-pyglet150
Original commitRevision:529822  Sanity Test Failure
Saturday, 28 Mar 2020
09:10 mfechner search for other commits by this committer
Update to 12.9.1.
Changelog:
https://about.gitlab.com/releases/2020/03/22/gitlab-12-9-released/
Original commitRevision:529323  Sanity Test Failure
Wednesday, 25 Mar 2020
12:49 db search for other commits by this committer
Chase renamed py-python-fcl name
Original commitRevision:529099  Sanity Test Failure
01:10 db search for other commits by this committer
Trimesh is a pure Python (2.7-3.4+) library for loading and using triangular
meshes with an emphasis on watertight surfaces. The goal of the library
is to provide a full featured and well tested Trimesh object which allows
for easy manipulation and analysis, in the style of the Polygon object in
the Shapely library.

The API is mostly stable, but this should not be relied on and is not
guaranteed: install a specific version if you plan on deploying something
using trimesh.

WWW: https://pypi.org/project/trimesh/#description
Original commitRevision:529070  Sanity Test Failure
Wednesday, 18 Mar 2020
01:58 Kyle Evans (kevans) search for other commits by this committer
  • branches/2020Q1/sysutils/u-boot-master 2019.10 Cross-build das u-boot for model NONE Ignore
    • branches/2020Q1/sysutils/u-boot-rpi3 2019.10_1 Cross-build das u-boot for model rpi3
    • MFH: r528547
      
      sysutils/u-boot-rpi{3,4}: Add patch to fix PSCI stub reservation
      
      For the traditional spin table setup, only the lowest page needs
      to be reserved.  However, our PSCI stubs are slightly bigger and occupy
      a little over one page.  These patches, already sent upstream, allow a
      variable number of initial pages to be reserved for the SMP stubs.  We
      then set the values for these in our fragment to '2' to reserve the first
      and second page.
      
      Approved by:	koobs (mentor)
      Approved by:	manu (uboot, maintainer)
      Differential Revision:	https://reviews.freebsd.org/D24085
      
      Approved by:	ports-secteam (joneum)
      commit hash: 68e0c8c52a98b8b3837cf34aa9986176ddddcf79 commit hash: 68e0c8c52a98b8b3837cf34aa9986176ddddcf79 commit hash: 68e0c8c52a98b8b3837cf34aa9986176ddddcf79 commit hash: 68e0c8c52a98b8b3837cf34aa9986176ddddcf79  Sanity Test Failure
Saturday, 7 Mar 2020
09:34 Jochen Neumeister (joneum) search for other commits by this committer
MFH: r527924

hand over Maintainership to Chris (portmaster@BSDforge.com)

Sponsored by:	Netzkommune GmbH

Approved by:	ports-secteam (joneum)
commit hash: a88e27fda87206cb65bf551f9853e9ea9ca68f52 commit hash: a88e27fda87206cb65bf551f9853e9ea9ca68f52 commit hash: a88e27fda87206cb65bf551f9853e9ea9ca68f52 commit hash: a88e27fda87206cb65bf551f9853e9ea9ca68f52  Sanity Test Failure
Sunday, 1 Mar 2020
06:28 sunpoet search for other commits by this committer
Add py-flit 2.2.0

Flit is a simple way to put Python packages and modules on PyPI. It tries to
require less thought about packaging and help you avoid common mistakes.

WWW: https://github.com/takluyver/flit
Original commitRevision:527494  Sanity Test Failure
Sunday, 23 Feb 2020
08:07 sunpoet search for other commits by this committer
Update LIB_DEPENDS after splitting gsasl library into libgsasl

- Bump PORTREVISION for dependency change
Original commitRevision:526898  Sanity Test Failure
08:07 sunpoet search for other commits by this committer
Update LIB_DEPENDS after splitting gsasl library into libgsasl

- Bump PORTREVISION for dependency change
Original commitRevision:526894  Sanity Test Failure
08:07 sunpoet search for other commits by this committer
Update LIB_DEPENDS after splitting gsasl library into libgsasl

- Bump PORTREVISION for dependency change
Original commitRevision:526893  Sanity Test Failure
08:07 sunpoet search for other commits by this committer
Split GSASL into gsasl (command-line utility) and libgsasl (library)

GNU SASL has been split into 2 ports:
- security/gsasl: the command-line utility
- security/libgsasl: the library

It was based on hrs@ patch.

Thanks to:	hrs
Original commitRevision:526892  Sanity Test Failure
Wednesday, 5 Feb 2020
18:42 sunpoet search for other commits by this committer
Add rubygem-sass-rails-rails60 6.0.0 (copied from rubygem-sass-rails-rails52)
Original commitRevision:525334  Sanity Test Failure
18:41 sunpoet search for other commits by this committer
Add rubygem-devise-rails60 4.7.1 (copied from rubygem-devise-rails52)
Original commitRevision:525329  Sanity Test Failure
18:41 sunpoet search for other commits by this committer
Add rubygem-rails60 6.0.2.1 (copied from rubygem-rails52)
Original commitRevision:525326  Sanity Test Failure
18:40 sunpoet search for other commits by this committer
Add rubygem-actionpack60 6.0.2.1 (copied from rubygem-actionpack52)
Original commitRevision:525325  Sanity Test Failure
18:40 sunpoet search for other commits by this committer
Add rubygem-actioncable60 6.0.2.1 (copied from rubygem-actioncable52)
Original commitRevision:525324  Sanity Test Failure
18:40 sunpoet search for other commits by this committer
Add rubygem-actiontext60 6.0.2.1

Action Text brings rich text content and editing to Rails. It includes the Trix
editor that handles everything from formatting to links to quotes to lists to
embedded images and galleries. The rich text content generated by the Trix
editor is saved in its own RichText model that's associated with any existing
Active Record model in the application. Any embedded images (or other
attachments) are automatically stored using Active Storage and associated with
the included RichText model.

WWW: https://rubyonrails.org/
WWW: https://github.com/rails/rails/tree/master/actiontext
Original commitRevision:525323  Sanity Test Failure
18:40 sunpoet search for other commits by this committer
Add rubygem-activestorage60 6.0.2.1 (copied from rubygem-activestorage52)
Original commitRevision:525322  Sanity Test Failure
18:40 sunpoet search for other commits by this committer
Add rubygem-actionmailer60 6.0.2.1 (copied from rubygem-actionmailer52)
Original commitRevision:525321  Sanity Test Failure
18:40 sunpoet search for other commits by this committer
Add rubygem-actionmailbox60 6.0.2.1

Action Mailbox routes incoming emails to controller-like mailboxes for
processing in Rails. It ships with ingresses for Mailgun, Mandrill, Postmark,
and SendGrid. You can also handle inbound mails directly via the built-in Exim,
Postfix, and Qmail ingresses.

The inbound emails are turned into InboundEmail records using Active Record and
feature lifecycle tracking, storage of the original email on cloud storage via
Active Storage, and responsible data handling with on-by-default incineration.

These inbound emails are routed asynchronously using Active Job to one or
several dedicated mailboxes, which are capable of interacting directly with the
rest of your domain model.

WWW: https://rubyonrails.org/
WWW: https://github.com/rails/rails/tree/master/actionmailbox
Original commitRevision:525320  Sanity Test Failure
18:40 sunpoet search for other commits by this committer
Add rubygem-activejob60 6.0.2.1 (copied from rubygem-activejob52)
Original commitRevision:525318  Sanity Test Failure
18:40 sunpoet search for other commits by this committer
Add rubygem-actionview60 6.0.2.1 (copied from rubygem-actionview52)
Original commitRevision:525317  Sanity Test Failure
18:40 sunpoet search for other commits by this committer
Add rubygem-activerecord60 6.0.2.1 (copied from rubygem-activerecord52)
Original commitRevision:525316  Sanity Test Failure
18:39 sunpoet search for other commits by this committer
Add rubygem-activemodel60 6.0.2.1 (copied from rubygem-activemodel52)
Original commitRevision:525315  Sanity Test Failure
Tuesday, 4 Feb 2020
23:03 osa search for other commits by this committer
  • www/jwt-cli Super fast CLI tool to decode and encode JWTs Refresh
Update from 2.5.1 to 2.5.2.

<ChangeLog>

- Prevent an invalid JWT token from causing a panic during `decode` #51

</ChangeLog>
Original commitRevision:525243  Sanity Test Failure
Sunday, 2 Feb 2020
10:55 sunpoet search for other commits by this committer
Add rubygem-image_processing 1.10.3

ImageProcessing provides higher-level image processing helpers that are commonly
needed when handling image uploads.

This gem can process images with either ImageMagick/GraphicsMagick or libvips
libraries. ImageMagick is a good default choice, especially if you are migrating
from another gem or library that uses ImageMagick. Libvips is a newer library
that can process images very rapidly (often multiple times faster than
ImageMagick).

WWW: https://github.com/janko/image_processing
Original commitRevision:524848  Sanity Test Failure
10:54 sunpoet search for other commits by this committer
Add rubygem-r18n-rails 4.0.0

R18n-rails is a gem to add out-of-box R18n support to Rails I18n.

It is a wrapper for R18n Rails API and R18n core libraries. See R18n core
documentation for more information.

WWW: https://github.com/r18n/r18n/tree/master/r18n-rails
Original commitRevision:524845  Sanity Test Failure
10:54 sunpoet search for other commits by this committer
Add py-distributed 2.10.0

Dask.distributed is a lightweight library for distributed computing in Python.
It extends both the concurrent.futures and dask APIs to moderate sized clusters.

WWW: https://github.com/dask/distributed
Original commitRevision:524841  Sanity Test Failure
Tuesday, 28 Jan 2020
17:20 bapt search for other commits by this committer
Monday, 27 Jan 2020
19:37 sunpoet search for other commits by this committer
Add rubygem-azure_sdk 0.51.1

Microsoft Azure SDK - Azure Client Library for Ruby.

This project provides a Ruby package for Azure Resource Management (ARM).

WWW: https://github.com/Azure/azure-sdk-for-ruby
Original commitRevision:524407  Sanity Test Failure
19:20 sunpoet search for other commits by this committer
Add rubygem-azure-storage-blob 1.1.0

Microsoft Azure Storage Blob Client Library for Ruby.

WWW: https://github.com/Azure/azure-storage-ruby
WWW: https://github.com/Azure/azure-storage-ruby/tree/master/blob
Original commitRevision:524271  Sanity Test Failure
Saturday, 25 Jan 2020
18:18 sunpoet search for other commits by this committer
Add py-fontbakery 0.7.17

Font Bakery is a command-line tool for checking the quality of font projects.

WWW: https://github.com/googlefonts/fontbakery
Original commitRevision:524058  Sanity Test Failure
Saturday, 18 Jan 2020
18:22 sunpoet search for other commits by this committer
Add py-monkeytype 19.11.2

MonkeyType collects runtime types of function arguments and return values, and
can automatically generate stub files or even add draft type annotations
directly to your Python code based on the types collected at runtime.

WWW: https://github.com/Instagram/MonkeyType
Original commitRevision:523433  Sanity Test Failure
03:00 romain search for other commits by this committer
Update to 3.4.0

With hat:	puppet
Original commitRevision:523395  Sanity Test Failure
Sunday, 12 Jan 2020
16:04 sunpoet search for other commits by this committer
Add rubygem-dry-configurable 0.9.0

dry-configurable is a simple mixin to make Ruby classes configurable.

WWW: https://github.com/dry-rb/dry-configurable
Original commitRevision:522795  Sanity Test Failure
Sunday, 5 Jan 2020
04:06 sunpoet search for other commits by this committer
  • devel/py-pipx 0.14.0.0 Install and Run Python Applications in Isolated Environments
Add py-pipx 0.14.0.0

pipx is a tool to help you install and run end-user applications written in
Python. pipx is not a tool for development or publishing of your code -- it's
only for consuming already published packages.

Python and PyPI allow developers to distribute code with "console script entry
points". These scripts let users call into Python code from the command line,
effectively acting like standalone applications. pipx is a tool to install and
run any of these thousands of Python applications available on PyPI in a safe,
convenient, and reliable way. In a way, it turns Python Package Index (PyPI)
into a big app store for Python applications. Not all Python packages have entry
points, but many do.

pipx enables you to:
- Safely install packages to isolated environments, while globally exposing
  their CLI entry points so you can run them from anywhere (see the install
  command). This guarantees no dependency conflicts and clean uninstalls!
- Easily list, upgrade, and uninstall packages that were installed with pipx
- Run the latest version of a Python application in a temporary environment (see
  the run command)

Best of all, pipx runs with regular user permissions.

WWW: https://github.com/pipxproject/pipx
Original commitRevision:522085  Sanity Test Failure
04:06 sunpoet search for other commits by this committer
Add py-libcst 0.2.6

LibCST is a Concrete Syntax Tree (CST) parser and serializer library for Python.

LibCST parses Python source code as a CST tree that keeps all formatting details
(comments, whitespaces, parentheses, etc). It's useful for building automated
refactoring (codemod) applications and linters.

LibCST creates a compromise between an Abstract Syntax Tree (AST) and a
traditional Concrete Syntax Tree (CST). By carefully reorganizing and naming
node types and fields, we've created a lossless CST that looks and feels like an
AST.

WWW: https://github.com/Instagram/LibCST
Original commitRevision:522084  Sanity Test Failure
Wednesday, 1 Jan 2020
09:18 sunpoet search for other commits by this committer
Change RUN_DEPENDS from py-graphql-relay to py-graphql-relay2

- Bump PORTREVISION for dependency change
Original commitRevision:521687  Sanity Test Failure
Sunday, 29 Dec 2019
17:31 sunpoet search for other commits by this committer
  • devel/py-clikit 0.4.1 Utilities to build beautiful and testable command line interfaces
Add py-clikit 0.4.1

CliKit is a group of utilities to build beautiful and testable command line
interfaces.

WWW: https://github.com/sdispater/clikit
Original commitRevision:521367  Sanity Test Failure
17:31 sunpoet search for other commits by this committer
  • devel/py-cleo 0.7.6 Create beautiful and testable command-line interfaces
Add py-cleo 0.7.6

Cleo creates beautiful and testable command-line interfaces. Cleo is mostly a
higher level wrapper for CliKit, so a lot of the components and utilities comes
from it.

WWW: https://github.com/sdispater/cleo
Original commitRevision:521366  Sanity Test Failure
12:47 sunpoet search for other commits by this committer
Add rubygem-ms_rest 0.7.5

MsRest is a library which supports the clients (SDKs) generated with Autorest
tool. It contains core logic and helper classes for error handling and
authentication. Usually it is not supposed to be used as a standalone gem but
only as a dependency for generated client gems.

WWW: https://github.com/Azure/azure-sdk-for-ruby
WWW: https://github.com/Azure/azure-sdk-for-ruby/tree/master/runtime/ms_rest
Original commitRevision:521291  Sanity Test Failure
Friday, 13 Dec 2019
06:40 sunpoet search for other commits by this committer
Add py-cssselect2 0.2.2

cssselect2 is a straightforward implementation of CSS3 Selectors for markup
documents (HTML, XML, etc.) that can be read by ElementTree-like parsers
(including cElementTree, lxml, html5lib, etc.)

Unlike cssselect, it does not translate selectors to XPath and therefore does
not have all the correctness corner cases that are hard or impossible to fix in
cssselect.

WWW: https://github.com/Kozea/cssselect2
Original commitRevision:519972  Sanity Test Failure
06:40 sunpoet search for other commits by this committer
Add py-cairosvg 2.4.2

CairoSVG is a SVG converter based on Cairo. It can export SVG files to PDF,
PostScript and PNG files.

WWW: https://cairosvg.org/
WWW: https://github.com/Kozea/CairoSVG
Original commitRevision:519971  Sanity Test Failure
Saturday, 7 Dec 2019
11:52 Mark Linimon (linimon) search for other commits by this committer
MFH: r519199

Once again, mark the freebsd-doc-* ports broken on powerc64.  They have been
consistently failing to build for quite some time.

Approved by:	portmgr (tier-2 blanket)
commit hash: 7e13e7bc17d1a866f8fd136045f111e39e511195 commit hash: 7e13e7bc17d1a866f8fd136045f111e39e511195 commit hash: 7e13e7bc17d1a866f8fd136045f111e39e511195 commit hash: 7e13e7bc17d1a866f8fd136045f111e39e511195  Sanity Test Failure
Tuesday, 3 Dec 2019
22:53 romain search for other commits by this committer
New port: textproc/rubygem-puppet-strings

Puppet Strings generates HTML documentation for Puppet extensions written in
Puppet and Ruby.

WWW: https://github.com/puppetlabs/puppet-strings

With hat:	puppet
Original commitRevision:518971  Sanity Test Failure
Friday, 22 Nov 2019
21:03 Cy Schubert (cy) search for other commits by this committer
MFH: r518051 r518052 r518101

Add rc.d support, stealing the rc.d file from base.

Make the installation of the rc script conditional to avoid conflict
with base.

Rather than an option, automatically detect if the target system
has an amd rc script. Eventually when amd is removed from base
packages will automatically include the rc script.

Adjust the location of the amd binary in the supplied rc script.

Approved by:	portmgr (joneum)
commit hash: 5e5428d86a6dcc1e8688b879650950d8012aba43 commit hash: 5e5428d86a6dcc1e8688b879650950d8012aba43 commit hash: 5e5428d86a6dcc1e8688b879650950d8012aba43 commit hash: 5e5428d86a6dcc1e8688b879650950d8012aba43  Sanity Test Failure
21:03 cy search for other commits by this committer
MFH: r518051 r518052 r518101

Add rc.d support, stealing the rc.d file from base.

Make the installation of the rc script conditional to avoid conflict
with base.

Rather than an option, automatically detect if the target system
has an amd rc script. Eventually when amd is removed from base
packages will automatically include the rc script.

Adjust the location of the amd binary in the supplied rc script.

Approved by:	portmgr (joneum)
Original commitRevision:518165  Sanity Test Failure
Friday, 15 Nov 2019
10:09 bapt search for other commits by this committer
Monday, 11 Nov 2019
16:06 jbeich search for other commits by this committer
MFH: r513636 r514012 r514204 r514305 r514636 r514867 r515317 r515737 r516118
r516277 r516759 r517212

multimedia/rav1e: update to 0.1.0

Changes:	https://github.com/xiph/rav1e/compare/4245f89e...0.1.0
Approved by:	ports-secteam (miwi)
Original commitRevision:517267  Sanity Test Failure
16:06 Jan Beich (jbeich) search for other commits by this committer
MFH: r513636 r514012 r514204 r514305 r514636 r514867 r515317 r515737 r516118
r516277 r516759 r517212

multimedia/rav1e: update to 0.1.0

Changes:	https://github.com/xiph/rav1e/compare/4245f89e...0.1.0
Approved by:	ports-secteam (miwi)
commit hash: 2384df3cf31d25fbdff226692631d47a49d810ea commit hash: 2384df3cf31d25fbdff226692631d47a49d810ea commit hash: 2384df3cf31d25fbdff226692631d47a49d810ea commit hash: 2384df3cf31d25fbdff226692631d47a49d810ea  Sanity Test Failure
Thursday, 7 Nov 2019
20:20 zeising search for other commits by this committer
  • audio/csound 6.12.2.83_8 Sound synthesizer
    • audio/mp3blaster 3.2.6_2 MP3 console ncurses-based player
      • audio/ocp 0.1.21_5,1 Legendary Open Cubic Player
        • biology/emboss 6.6.0_3 Collection of open source tools for genetic sequence analysis
          • cad/jspice3 2.5.110615 Adaptation of the Berkeley Spice3f4 with superconductivity Deleted Deprecated Expired Ignore
            • cad/spice 3f5.2_12 General-purpose circuit simulation program
              • comms/gnokii 0.6.31_12,1 Tools to talk to GSM cellular phones
                • comms/morse 2.5 Morse Code Trainer
                  • comms/multimon-ng 1.1.0 Digital transmission decoder
                    • deskutils/cairo-dock 3.4.1_4 Lightweight and eye-candy dock (program launcher)
                                                                                                                                            (Only the first 10 of 70 items in this commit are shown above. View all ports for this commit)
                                                                                                                                            Sprinkle more USES=xorg
                                                                                                                                            Original commitRevision:517008  Sanity Test Failure
Wednesday, 6 Nov 2019
14:00 antoine search for other commits by this committer
  • mail/akpop3d 0.7.7 POP3 daemon aimed to be small and secure
    • mail/chk4mail 2.28 Quickly check multiple folders for new email Deleted Broken Deprecated Expired Ignore
      • mail/cyrus-imapd23 2.3.20_2 Cyrus mail server, supporting POP3 and IMAP4 protocols Deleted Deprecated Expired  This port version is marked as vulnerable. 
        • mail/dbmail 3.2.3_6 SQL database-based mail system (POP3 and IMAP)
          • mail/fetchmailconf 6.4.1_1 Python-based GUI to configure fetchmail
            • mail/librfc822 1.2 Complete parser for RFC822 addresses Deleted Broken Deprecated Expired Ignore
              • mail/mailmgr 1.2.3 Sendmail Analysis Report Generator Deleted Broken Deprecated Expired Ignore
                • mail/milter-skem 1.0.2_2 Cache earlier sendmail's verdicts for the relays
                  • mail/mreport 0.9 Sendmail logfile summary tool Deleted Broken Deprecated Expired Ignore
                    • mail/msgconvert 20060330_1 Convert .MSG files to multipart MIME messages (mbox) Deleted Broken Deprecated Expired Ignore
                                                                                                                                                                                                                                                                                                                                                                                (Only the first 10 of 184 items in this commit are shown above. View all ports for this commit)
                                                                                                                                                                                                                                                                                                                                                                                Mark a few ports BROKEN (unfetchable)
                                                                                                                                                                                                                                                                                                                                                                                Original commitRevision:516887  Sanity Test Failure
12:48 antoine search for other commits by this committer
Tuesday, 5 Nov 2019
15:48 zeising search for other commits by this committer
  • editors/calligra KDE office suite Refresh
    • editors/calligraplan 3.1.0_5 KDE Calligra project management application
      • editors/cooledit 3.17.28_3 CoolEdit Programmers Code Editor
        • editors/cudatext 1.84.2_1 Cross-platform text editor, written in Lazarus
          • editors/featherpad 0.10.0_1 Lightweight Qt5 plain-text editor
            • editors/fte 20110708 Full-featured text editor for X11 Deleted Deprecated Expired
              • editors/gedit 3.28.1_2 Small but powerful text editor for the GNOME Desktop Environment
                • editors/jedit 5.5.0,1 Powerful programmer's text editor written in Java
                  • editors/lazarus 2.0.4_1 Portable Delphi-like IDE for the FreePascal compiler (GTK2)
                    • editors/madedit 0.2.9_23 Open-source and cross-platform text/hex editor Deleted
                                                                                                                                                  (Only the first 10 of 73 items in this commit are shown above. View all ports for this commit)
                                                                                                                                                  Add USES=xorg USES=gl, ports categories e
                                                                                                                                                  
                                                                                                                                                  Add USES=xorg, USES=gl and in a few cases USES=gnome to ports in categories
                                                                                                                                                  starting with 'e'.
                                                                                                                                                  Original commitRevision:516802  Sanity Test Failure
Monday, 4 Nov 2019
15:59 sunpoet search for other commits by this committer
Update CONFLICTS_INSTALL and OPTIONS_EXCLUDE
Original commitRevision:516666  Sanity Test Failure
15:59 sunpoet search for other commits by this committer
  • www/npm 6.12.1 Node package manager (meta port)
Add NODE12 option
Original commitRevision:516664  Sanity Test Failure
Sunday, 27 Oct 2019
11:30 sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-tzinfo to rubygem-tzinfo1

- Bump PORTREVISION for dependency change
Original commitRevision:515787  Sanity Test Failure
11:30 sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-tzinfo to rubygem-tzinfo1

- Bump PORTREVISION for dependency change
Original commitRevision:515786  Sanity Test Failure
Saturday, 26 Oct 2019
14:30 sunpoet search for other commits by this committer
Update to 1.8.1

Changes:	https://github.com/googleapis/gax-ruby/releases
		https://github.com/googleapis/gax-ruby/blob/master/CHANGELOG.md
Original commitRevision:515695  Sanity Test Failure
Thursday, 17 Oct 2019
00:32 Jan Beich (jbeich) search for other commits by this committer
MFH: r514632

emulators/ppsspp: update to 1.9.4

Changes:	https://github.com/hrydgard/ppsspp/compare/v1.9.3...v1.9.4
Approved by:	ports-secteam blanket
commit hash: 1e9ae84c29f3c5347a58c1d5ea3f1bd18d7b3f28 commit hash: 1e9ae84c29f3c5347a58c1d5ea3f1bd18d7b3f28 commit hash: 1e9ae84c29f3c5347a58c1d5ea3f1bd18d7b3f28 commit hash: 1e9ae84c29f3c5347a58c1d5ea3f1bd18d7b3f28  Sanity Test Failure
Wednesday, 9 Oct 2019
17:41 brooks search for other commits by this committer
ttempt to work around a problem with binutils not liking the armv6 code
generated by LLVM 7.

PR:		235282
Requested by:	jbeich
Original commitRevision:514175  Sanity Test Failure
16:45 Marc Fonvieille (blackend) search for other commits by this committer
Tuesday, 8 Oct 2019
00:50 Jan Beich (jbeich) search for other commits by this committer
MFH: r514007

emulators/ppsspp: update to 1.9.3

Changes:	https://github.com/hrydgard/ppsspp/compare/v1.9.2...v1.9.3
Approved by:	ports-secteam blanket (regression and crash fixes)
commit hash: c513aa61d41b7d6f1bd7d1ac7fea938857b67306 commit hash: c513aa61d41b7d6f1bd7d1ac7fea938857b67306 commit hash: c513aa61d41b7d6f1bd7d1ac7fea938857b67306 commit hash: c513aa61d41b7d6f1bd7d1ac7fea938857b67306  Sanity Test Failure
Tuesday, 10 Sep 2019
19:37 tijl search for other commits by this committer
Create USE_LINUX sdlttf keyword and use it in games/linux-dwarffortress.
Original commitRevision:511773  Sanity Test Failure
06:33 Rene Ladan (rene) search for other commits by this committer
MFH: r511598 r511599

multimedia/lives: fix build and some pkg-plist issues

PR:		237320
Submitted by:	Hiroo Ono

multimedia/lives: set missing SVN keywords.

Approved by:	ports-secteam (joneum)
commit hash: c3568679f002e9fc368160d4db6f302efcf47b5c commit hash: c3568679f002e9fc368160d4db6f302efcf47b5c commit hash: c3568679f002e9fc368160d4db6f302efcf47b5c commit hash: c3568679f002e9fc368160d4db6f302efcf47b5c  Sanity Test Failure
Thursday, 5 Sep 2019
04:40 acm search for other commits by this committer
- Fix build on i386

PR:		234858
Reported by:	emaste
Original commitRevision:511154  Sanity Test Failure
Wednesday, 4 Sep 2019
11:17 dvl search for other commits by this committer
* add python as a secondary virtual category
* set LICENSE_FILE
Original commitRevision:511082  Sanity Test Failure
Monday, 26 Aug 2019
07:16 mfechner search for other commits by this committer
Add rubygem-redis-rails-rails52 5.0.2 (copied from rubygem-redis-rails-rails5).
Original commitRevision:509869  Sanity Test Failure
07:13 mfechner search for other commits by this committer
Add rubygem-kaminari-rails52 1.1.1 (copied from rubygem-kaminari-rails5).
Original commitRevision:509868  Sanity Test Failure
Sunday, 25 Aug 2019
11:02 tijl search for other commits by this committer
Add archivers/linux-c7-lz4, required by upcoming linux-c7-systemd-libs.
Original commitRevision:509788  Sanity Test Failure
Tuesday, 13 Aug 2019
16:01 mat search for other commits by this committer
Monday, 12 Aug 2019
04:44 cy search for other commits by this committer
  • shells/ksh93 AT&T KornShell ksh93u+ 2012-08-01 (stable) version Refresh
Mark broken when USE_GCC=9. Upstream git commit
63e9edcb6084d4b164439065e2d71f3e900ec3c7 resolves this issue.
Unfortunately it does not apply, requiring this port to be upated to
ksh93 well into ksh93-devel. Bringing ksh93 up to the ksh93-devel or
shy of it would negate the justification for ksh93's existence. It is
therefore recommended that people use ksh93-devel on architectures that
use GCC 9 or use GCC 8.

PR:		239644
Reported by:	pkubaj@
Original commitRevision:508705  Sanity Test Failure
Tuesday, 16 Jul 2019
15:42 antoine search for other commits by this committer
Deprecate: no longer maintained
Original commitRevision:506746  Sanity Test Failure
Sunday, 7 Jul 2019
09:35 mfechner search for other commits by this committer
Monday, 1 Jul 2019
07:02 Kubilay Kocak (koobs) search for other commits by this committer
MFH: r502940 r503843

www/npm: Fix the python executable name

PR:		238204
Reported by:	run failure
Approved by:	portmgr (blanket: ports/framework (python) compliance)

Compile and install .pyc files for node-gyp

- Bump PORTREVISION for package change

PR:		238243
Submitted by:	Hiroki Tagato <tagattie@yandex.com>

Approved by:	ports-secteam (blanket(s): run/packaging fix, ports (python)
compliance)
commit hash: 24a93a5bd86d37e8c8ef88c64232b55a61cb6e73 commit hash: 24a93a5bd86d37e8c8ef88c64232b55a61cb6e73 commit hash: 24a93a5bd86d37e8c8ef88c64232b55a61cb6e73 commit hash: 24a93a5bd86d37e8c8ef88c64232b55a61cb6e73  Sanity Test Failure
Thursday, 13 Jun 2019
16:17 Marc Fonvieille (blackend) search for other commits by this committer
Wednesday, 5 Jun 2019
09:07 pkubaj search for other commits by this committer
databases/percona55-server: fix build

Requires C11 features:
/wrkdirs/usr/ports/databases/percona55-server/work/percona-server-5.5.61-38.13/storage/innobase/include/os0sync.h:386:4:
error: #error "Unsupported platform"

Approved by:	mentors (implicit approval)
Original commitRevision:503501  Sanity Test Failure
Friday, 31 May 2019
16:13 fernape search for other commits by this committer
  • math/cminpack Solving nonlinear equations and nonlinear least squares problems Refresh
math/cminpack: build as a shared library

This change makes math/openturns able to find cminpack.

Also add dependency on openblas

PR:	238154
Submitted by:	yuri@
Original commitRevision:503180  Sanity Test Failure
Saturday, 18 May 2019
09:43 sunpoet search for other commits by this committer
Add RUBY option

- Bump PORTREVISION for dependency change
Original commitRevision:501926  Sanity Test Failure
Friday, 17 May 2019
12:48 lme search for other commits by this committer
Add net-mgmt/icingaweb2-module-reporting:

Icinga Reporting is the central component for reporting related functionality
in the monitoring web frontend and framework Icinga Web 2. The engine allows
you to create reports over a specified time period for ad-hoc and scheduled
generation of reports. Other modules use the provided functionality in order to
provide concrete reports.

WWW: https://github.com/Icinga/icingaweb2-module-reporting
Original commitRevision:501867  Sanity Test Failure
Wednesday, 15 May 2019
21:11 jrm search for other commits by this committer
02:42 stephen search for other commits by this committer
  • cad/netgen Automatic 3D tetrahedral mesh generator Refresh
- Mark broken for recent versions of FreeBSD.

Reported by:	pkg-fallout@
Original commitRevision:501675  Sanity Test Failure
Tuesday, 14 May 2019
12:41 koobs search for other commits by this committer
devel/py-pytest-xdist: Update to 1.28.0

Changelog:

  https://github.com/pytest-dev/pytest-xdist/blob/v1.28.0/CHANGELOG.rst
Original commitRevision:501653  Sanity Test Failure
Saturday, 11 May 2019
17:33 ericbsd search for other commits by this committer
Thursday, 9 May 2019
18:30 acm search for other commits by this committer
18:17 acm search for other commits by this committer
Wednesday, 1 May 2019
19:10 jrm search for other commits by this committer
  • math/R Language for statistical computing and graphics Refresh
math/R: Upgrade to version 3.6.0

Upstream changes: See 'CHANGES IN R 3.6.0' from
https://cran.r-project.org/doc/manuals/r-devel/NEWS.html
Original commitRevision:500605  Sanity Test Failure
Tuesday, 30 Apr 2019
19:05 sunpoet search for other commits by this committer
Add rubygem-elasticsearch6 6.3.0 (copied from rubygem-elasticsearch)

- Update RUN_DEPENDS
- Add PORTSCOUT
Original commitRevision:500523  Sanity Test Failure
Wednesday, 17 Apr 2019
18:50 sunpoet search for other commits by this committer
Change RUN_DEPENDS from py-more-itertools to py-more-itertools5

- While I'm here, add NO_ARCH
- Bump PORTREVISION for dependency change
Original commitRevision:499202  Sanity Test Failure
Monday, 15 Apr 2019
21:15 sunpoet search for other commits by this committer
Add py-tableschema 1.4.0

Table Schema is a simple language- and implementation-agnostic way to declare a
schema for tabular data. Table Schema is well suited for use cases around
handling and validating tabular data in text formats such as CSV, but its
utility extends well beyond this core usage, towards a range of applications
where data benefits from a portable schema format.

Features:
- Table to work with data tables described by Table Schema
- Schema representing Table Schema
- Field representing Table Schema field
- validate to validate Table Schema
- infer to infer Table Schema from data
- built-in command-line interface to validate and infer schemas
- storage/plugins system to connect tables to different storage backends like
  SQL Database

WWW: https://github.com/frictionlessdata/tableschema-py
Original commitRevision:499050  Sanity Test Failure
Wednesday, 3 Apr 2019
11:06 Antoine Brodin (antoine) search for other commits by this committer
MFH: r497706

Mark BROKEN on FreeBSD 12 and 13

Reported by:	pkg-fallout
commit hash: 6ad1be11c4226ef01a0af93e297d813374cae6c9 commit hash: 6ad1be11c4226ef01a0af93e297d813374cae6c9 commit hash: 6ad1be11c4226ef01a0af93e297d813374cae6c9 commit hash: 6ad1be11c4226ef01a0af93e297d813374cae6c9  Sanity Test Failure
Sunday, 31 Mar 2019
08:24 yuri search for other commits by this committer
New port: science/py-qcengine: Quantum chemistry program executor and IO
standardizer (QCSchema)
Original commitRevision:497392  Sanity Test Failure
08:12 yuri search for other commits by this committer
New port: science/py-qcelemental: Essentials for quantum chemistry
Original commitRevision:497391  Sanity Test Failure
Monday, 25 Mar 2019
10:40 adridg search for other commits by this committer
  • net-im/mtxclient 0.2.0 Client API library for the Matrix protocol
    • security/olm 3.0.0 Double Ratchet cryptographic ratchet in C++
    New ports security/olm and net-im/mtxclient
    
    These are support libraries for Matrix clients; Nheko in particular.
    Until I wrap-up Nheko, they aren't used by anything.
    Original commitRevision:496814  Sanity Test Failure
Sunday, 24 Mar 2019
14:32 sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-fast_gettext to rubygem-fast_gettext1

- Bump PORTREVISION for dependency change
Original commitRevision:496735  Sanity Test Failure
Wednesday, 20 Mar 2019
13:01 antoine search for other commits by this committer
Fix DEPENDS
Original commitRevision:496341  Sanity Test Failure
Thursday, 14 Mar 2019
22:43 Jan Beich (jbeich) search for other commits by this committer
MFH: r495739

emulators/ppsspp: don't try to build on big-endian

In file included from Core/Dialog/PSPMsgDialog.cpp:18:
Core/Dialog/PSPMsgDialog.cpp: In member function 'virtual int
PSPMsgDialog::Init(unsigned int)':
Core/Dialog/PSPMsgDialog.h:37:57: warning: ISO C++ says that these are
ambiguous, even though the worst conversion for the first is better than the
worst conversion for the second:
 #define SCE_UTILITY_MSGDIALOG_OPTION_SUPPORTED          0x000001B3 // OR of all
options coded to display warning
                                                         ^~~~~~~~~~
Core/Dialog/PSPMsgDialog.cpp:62:49: note: in expansion of macro
'SCE_UTILITY_MSGDIALOG_OPTION_SUPPORTED'
  int optionsNotCoded = messageDialog.options &
~SCE_UTILITY_MSGDIALOG_OPTION_SUPPORTED;
                                                
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.h:22,
                 from Core/Dialog/PSPMsgDialog.cpp:18:
Common/Swap.h:473:3: note: candidate 1: 'S operator&(const swap_struct_t<T, F>&,
const S&) [with S = int; T = unsigned int; F = swap_32_t<unsigned int>]'
 S operator&(const swap_struct_t<T, F>& v, const S &i) {
   ^~~~~~~~
Common/Swap.h:308:12: note: candidate 2: 'swap_struct_t<T, F>::swapped_t
swap_struct_t<T, F>::operator&(const S&) const [with S = int; T = unsigned int;
F = swap_32_t<unsigned int>; swap_struct_t<T, F>::swapped_t =
swap_struct_t<unsigned int, swap_32_t<unsigned int> >]'
  swapped_t operator &(const S &b) const {
            ^~~~~~~~
Core/Dialog/PSPMsgDialog.cpp:71:59: warning: ISO C++ says that these are
ambiguous, even though the worst conversion for the first is better than the
worst conversion for the second:
  if(messageDialog.type == 0 && !(messageDialog.errorNum & 0x80000000))
                                                           ^~~~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.h:22,
                 from Core/Dialog/PSPMsgDialog.cpp:18:
Common/Swap.h:473:3: note: candidate 1: 'S operator&(const swap_struct_t<T, F>&,
const S&) [with S = unsigned int; T = unsigned int; F = swap_32_t<unsigned
int>]'
 S operator&(const swap_struct_t<T, F>& v, const S &i) {
   ^~~~~~~~
Common/Swap.h:308:12: note: candidate 2: 'swap_struct_t<T, F>::swapped_t
swap_struct_t<T, F>::operator&(const S&) const [with S = unsigned int; T =
unsigned int; F = swap_32_t<unsigned int>; swap_struct_t<T, F>::swapped_t =
swap_struct_t<unsigned int, swap_32_t<unsigned int> >]'
  swapped_t operator &(const S &b) const {
            ^~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.cpp:18:
Core/Dialog/PSPMsgDialog.h:31:57: warning: ISO C++ says that these are
ambiguous, even though the worst conversion for the first is better than the
worst conversion for the second:
 #define SCE_UTILITY_MSGDIALOG_OPTION_DEFAULT_NO         0x00000100
                                                         ^~~~~~~~~~
Core/Dialog/PSPMsgDialog.cpp:89:31: note: in expansion of macro
'SCE_UTILITY_MSGDIALOG_OPTION_DEFAULT_NO'
   if((messageDialog.options & SCE_UTILITY_MSGDIALOG_OPTION_DEFAULT_NO) &&
                               ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.h:22,
                 from Core/Dialog/PSPMsgDialog.cpp:18:
Common/Swap.h:473:3: note: candidate 1: 'S operator&(const swap_struct_t<T, F>&,
const S&) [with S = int; T = unsigned int; F = swap_32_t<unsigned int>]'
 S operator&(const swap_struct_t<T, F>& v, const S &i) {
   ^~~~~~~~
Common/Swap.h:308:12: note: candidate 2: 'swap_struct_t<T, F>::swapped_t
swap_struct_t<T, F>::operator&(const S&) const [with S = int; T = unsigned int;
F = swap_32_t<unsigned int>; swap_struct_t<T, F>::swapped_t =
swap_struct_t<unsigned int, swap_32_t<unsigned int> >]'
  swapped_t operator &(const S &b) const {
            ^~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.cpp:18:
Core/Dialog/PSPMsgDialog.h:28:57: warning: ISO C++ says that these are
ambiguous, even though the worst conversion for the first is better than the
worst conversion for the second:
 #define SCE_UTILITY_MSGDIALOG_OPTION_YESNO              0x00000010
                                                         ^~~~~~~~~~
Core/Dialog/PSPMsgDialog.cpp:90:31: note: in expansion of macro
'SCE_UTILITY_MSGDIALOG_OPTION_YESNO'
     !(messageDialog.options & SCE_UTILITY_MSGDIALOG_OPTION_YESNO))
                               ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.h:22,
                 from Core/Dialog/PSPMsgDialog.cpp:18:
Common/Swap.h:473:3: note: candidate 1: 'S operator&(const swap_struct_t<T, F>&,
const S&) [with S = int; T = unsigned int; F = swap_32_t<unsigned int>]'
 S operator&(const swap_struct_t<T, F>& v, const S &i) {
   ^~~~~~~~
Common/Swap.h:308:12: note: candidate 2: 'swap_struct_t<T, F>::swapped_t
swap_struct_t<T, F>::operator&(const S&) const [with S = int; T = unsigned int;
F = swap_32_t<unsigned int>; swap_struct_t<T, F>::swapped_t =
swap_struct_t<unsigned int, swap_32_t<unsigned int> >]'
  swapped_t operator &(const S &b) const {
            ^~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.cpp:18:
Core/Dialog/PSPMsgDialog.h:37:57: warning: ISO C++ says that these are
ambiguous, even though the worst conversion for the first is better than the
worst conversion for the second:
 #define SCE_UTILITY_MSGDIALOG_OPTION_SUPPORTED          0x000001B3 // OR of all
options coded to display warning
                                                         ^~~~~~~~~~
Core/Dialog/PSPMsgDialog.cpp:95:32: note: in expansion of macro
'SCE_UTILITY_MSGDIALOG_OPTION_SUPPORTED'
   if (messageDialog.options & ~SCE_UTILITY_MSGDIALOG_OPTION_SUPPORTED)
                                ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.h:22,
                 from Core/Dialog/PSPMsgDialog.cpp:18:
Common/Swap.h:473:3: note: candidate 1: 'S operator&(const swap_struct_t<T, F>&,
const S&) [with S = int; T = unsigned int; F = swap_32_t<unsigned int>]'
 S operator&(const swap_struct_t<T, F>& v, const S &i) {
   ^~~~~~~~
Common/Swap.h:308:12: note: candidate 2: 'swap_struct_t<T, F>::swapped_t
swap_struct_t<T, F>::operator&(const S&) const [with S = int; T = unsigned int;
F = swap_32_t<unsigned int>; swap_struct_t<T, F>::swapped_t =
swap_struct_t<unsigned int, swap_32_t<unsigned int> >]'
  swapped_t operator &(const S &b) const {
            ^~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.cpp:18:
Core/Dialog/PSPMsgDialog.h:28:57: warning: ISO C++ says that these are
ambiguous, even though the worst conversion for the first is better than the
worst conversion for the second:
 #define SCE_UTILITY_MSGDIALOG_OPTION_YESNO              0x00000010
                                                         ^~~~~~~~~~
Core/Dialog/PSPMsgDialog.cpp:109:31: note: in expansion of macro
'SCE_UTILITY_MSGDIALOG_OPTION_YESNO'
   if((messageDialog.options & SCE_UTILITY_MSGDIALOG_OPTION_YESNO) &&
                               ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.h:22,
                 from Core/Dialog/PSPMsgDialog.cpp:18:
Common/Swap.h:473:3: note: candidate 1: 'S operator&(const swap_struct_t<T, F>&,
const S&) [with S = int; T = unsigned int; F = swap_32_t<unsigned int>]'
 S operator&(const swap_struct_t<T, F>& v, const S &i) {
   ^~~~~~~~
Common/Swap.h:308:12: note: candidate 2: 'swap_struct_t<T, F>::swapped_t
swap_struct_t<T, F>::operator&(const S&) const [with S = int; T = unsigned int;
F = swap_32_t<unsigned int>; swap_struct_t<T, F>::swapped_t =
swap_struct_t<unsigned int, swap_32_t<unsigned int> >]'
  swapped_t operator &(const S &b) const {
            ^~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.cpp:18:
Core/Dialog/PSPMsgDialog.h:31:57: warning: ISO C++ says that these are
ambiguous, even though the worst conversion for the first is better than the
worst conversion for the second:
 #define SCE_UTILITY_MSGDIALOG_OPTION_DEFAULT_NO         0x00000100
                                                         ^~~~~~~~~~
Core/Dialog/PSPMsgDialog.cpp:113:30: note: in expansion of macro
'SCE_UTILITY_MSGDIALOG_OPTION_DEFAULT_NO'
   if(messageDialog.options & SCE_UTILITY_MSGDIALOG_OPTION_DEFAULT_NO)
                              ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.h:22,
                 from Core/Dialog/PSPMsgDialog.cpp:18:
Common/Swap.h:473:3: note: candidate 1: 'S operator&(const swap_struct_t<T, F>&,
const S&) [with S = int; T = unsigned int; F = swap_32_t<unsigned int>]'
 S operator&(const swap_struct_t<T, F>& v, const S &i) {
   ^~~~~~~~
Common/Swap.h:308:12: note: candidate 2: 'swap_struct_t<T, F>::swapped_t
swap_struct_t<T, F>::operator&(const S&) const [with S = int; T = unsigned int;
F = swap_32_t<unsigned int>; swap_struct_t<T, F>::swapped_t =
swap_struct_t<unsigned int, swap_32_t<unsigned int> >]'
  swapped_t operator &(const S &b) const {
            ^~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.cpp:18:
Core/Dialog/PSPMsgDialog.h:29:57: warning: ISO C++ says that these are
ambiguous, even though the worst conversion for the first is better than the
worst conversion for the second:
 #define SCE_UTILITY_MSGDIALOG_OPTION_OK                 0x00000020
                                                         ^~~~~~~~~~
Core/Dialog/PSPMsgDialog.cpp:118:31: note: in expansion of macro
'SCE_UTILITY_MSGDIALOG_OPTION_OK'
   if((messageDialog.options & SCE_UTILITY_MSGDIALOG_OPTION_OK) && (size ==
SCE_UTILITY_MSGDIALOG_SIZE_V3))
                               ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.h:22,
                 from Core/Dialog/PSPMsgDialog.cpp:18:
Common/Swap.h:473:3: note: candidate 1: 'S operator&(const swap_struct_t<T, F>&,
const S&) [with S = int; T = unsigned int; F = swap_32_t<unsigned int>]'
 S operator&(const swap_struct_t<T, F>& v, const S &i) {
   ^~~~~~~~
Common/Swap.h:308:12: note: candidate 2: 'swap_struct_t<T, F>::swapped_t
swap_struct_t<T, F>::operator&(const S&) const [with S = int; T = unsigned int;
F = swap_32_t<unsigned int>; swap_struct_t<T, F>::swapped_t =
swap_struct_t<unsigned int, swap_32_t<unsigned int> >]'
  swapped_t operator &(const S &b) const {
            ^~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.cpp:18:
Core/Dialog/PSPMsgDialog.h:30:57: warning: ISO C++ says that these are
ambiguous, even though the worst conversion for the first is better than the
worst conversion for the second:
 #define SCE_UTILITY_MSGDIALOG_OPTION_NOCANCEL           0x00000080
                                                         ^~~~~~~~~~
Core/Dialog/PSPMsgDialog.cpp:125:33: note: in expansion of macro
'SCE_UTILITY_MSGDIALOG_OPTION_NOCANCEL'
   if(!((messageDialog.options & SCE_UTILITY_MSGDIALOG_OPTION_NOCANCEL)  &&
(size == SCE_UTILITY_MSGDIALOG_SIZE_V3)))
                                 ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.h:22,
                 from Core/Dialog/PSPMsgDialog.cpp:18:
Common/Swap.h:473:3: note: candidate 1: 'S operator&(const swap_struct_t<T, F>&,
const S&) [with S = int; T = unsigned int; F = swap_32_t<unsigned int>]'
 S operator&(const swap_struct_t<T, F>& v, const S &i) {
   ^~~~~~~~
Common/Swap.h:308:12: note: candidate 2: 'swap_struct_t<T, F>::swapped_t
swap_struct_t<T, F>::operator&(const S&) const [with S = int; T = unsigned int;
F = swap_32_t<unsigned int>; swap_struct_t<T, F>::swapped_t =
swap_struct_t<unsigned int, swap_32_t<unsigned int> >]'
  swapped_t operator &(const S &b) const {
            ^~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.cpp:18:
Core/Dialog/PSPMsgDialog.h:27:57: warning: ISO C++ says that these are
ambiguous, even though the worst conversion for the first is better than the
worst conversion for the second:
 #define SCE_UTILITY_MSGDIALOG_OPTION_NOSOUND            0x00000002
                                                         ^~~~~~~~~~
Core/Dialog/PSPMsgDialog.cpp:127:30: note: in expansion of macro
'SCE_UTILITY_MSGDIALOG_OPTION_NOSOUND'
   if(messageDialog.options & SCE_UTILITY_MSGDIALOG_OPTION_NOSOUND)
                              ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.h:22,
                 from Core/Dialog/PSPMsgDialog.cpp:18:
Common/Swap.h:473:3: note: candidate 1: 'S operator&(const swap_struct_t<T, F>&,
const S&) [with S = int; T = unsigned int; F = swap_32_t<unsigned int>]'
 S operator&(const swap_struct_t<T, F>& v, const S &i) {
   ^~~~~~~~
Common/Swap.h:308:12: note: candidate 2: 'swap_struct_t<T, F>::swapped_t
swap_struct_t<T, F>::operator&(const S&) const [with S = int; T = unsigned int;
F = swap_32_t<unsigned int>; swap_struct_t<T, F>::swapped_t =
swap_struct_t<unsigned int, swap_32_t<unsigned int> >]'
  swapped_t operator &(const S &b) const {
            ^~~~~~~~
In file included from Core/Dialog/PSPMsgDialog.cpp:23:
Common/ChunkFile.h: In instantiation of 'void PointerWrap::DoClass(T&) [with T =
pspMessageDialog]':
Common/ChunkFile.h:96:4:   required from 'static void PointerWrap::DoHelper<T,
isPOD, isPointer>::Do(PointerWrap*, T&) [with T = pspMessageDialog; bool isPOD =
false; bool isPointer = false]'
Common/ChunkFile.h:496:18:   required from 'void PointerWrap::Do(T&) [with T =
pspMessageDialog]'
Core/Dialog/PSPMsgDialog.cpp:321:20:   required from here
Common/ChunkFile.h:475:5: error: 'struct pspMessageDialog' has no member named
'DoState'
   x.DoState(*this);
   ~~^~~~~~~

Reported by:	pkg-fallout
Approved by:	ports-secteam blanket
commit hash: e4ab1472a0b9079c3f9166dd40f24b0ae8d7f11e commit hash: e4ab1472a0b9079c3f9166dd40f24b0ae8d7f11e commit hash: e4ab1472a0b9079c3f9166dd40f24b0ae8d7f11e commit hash: e4ab1472a0b9079c3f9166dd40f24b0ae8d7f11e  Sanity Test Failure
Sunday, 10 Mar 2019
18:22 pi search for other commits by this committer
New port: devel/py-launchpadlib

launchpadlib is an open-source Python library that lets you treat the
HTTP resources published by Launchpad's web service as Python objects
responding to a standard set of commands. With launchpadlib you can
integrate your applications into Launchpad without knowing a lot about
HTTP client programming.

WWW: https://help.launchpad.net/API/launchpadlib

PR:		236434
Submitted by:	fullermd@over-yonder.net
Original commitRevision:495312  Sanity Test Failure
18:14 pi search for other commits by this committer
New port: devel/py-lazr.restfulclient

A programmable client library that takes advantage of the commonalities
among lazr.restful web services to provide added functionality on top of
wadllib.

This project is also part of https://launchpad.net/lazr

WWW: https://launchpad.net/lazr.uri

PR:		236433
Submitted by:	fullermd@over-yonder.net
Original commitRevision:495311  Sanity Test Failure
Saturday, 9 Mar 2019
09:06 tcberner search for other commits by this committer
Mark graphics/py-exiv2 deprecated by end of march.

py-exiv2 has been been last released on 2011-10-23.
The projects upstream is dead, and the last release is
not compatible with exiv2-0.27, which will land soon.

People who need python bindings to exiv2 should switch to:
https://wiki.gnome.org/Projects/gexiv2
Original commitRevision:495110  Sanity Test Failure
07:34 tcberner search for other commits by this committer
New port: x11/py-caffeine-ng.

Caffeine is a little daemon that sits in your systray, and prevents
the screensaver from showing up, or the system from going to sleep. It
does so when an application is fullscreened (eg: youtube), or when you
click on the systray icon (which you can do, when, eg: reading).

WWW: https://github.com/caffeine-ng/caffeine-ng

PR:		235639
Submitted by: 	Hiroki Tagato <tagattie@yandex.com>
Original commitRevision:495101  Sanity Test Failure
Saturday, 2 Mar 2019
18:01 sunpoet search for other commits by this committer
  • www/redmine 3.4.9_1 Flexible project management web application Deleted Deprecated Expired
Change RUN_DEPENDS from rubygem-nokogiri to rubygem-nokogiri18

- Bump PORTREVISION for dependency change
Original commitRevision:494443  Sanity Test Failure
Monday, 25 Feb 2019
23:35 sunpoet search for other commits by this committer
Update to 0.201

Changes:	https://metacpan.org/changes/distribution/Module-Version
Original commitRevision:493909  Sanity Test Failure
12:47 bapt search for other commits by this committer
  • astro/opencpn 4.4.0_7 Concise ChartPlotter/Navigator
    • audio/audacity 2.3.0_4 GUI editor for digital audio waveforms
      • audio/mbox 0.7.2_15 Program intended to help with organizing your music files Deleted Broken Deprecated Expired Ignore
        • audio/py-karaoke 0.7.5_18 Python karaoke application (Plays CD+G, MP3+G, OGG+G files) Deleted Deprecated Expired
          • audio/spek 0.8.2_14 Acoustic spectrum analyser
            • audio/wxguitar 1.01_11 Simple guitar tuning assistant
              • cad/gspiceui 1.1.00_4 GUI for ngspice and gnucap circuit simulators
                • cad/kicad 5.0.2_3,2 Schematic and PCB editing software
                  • cad/kicad-devel r20190206192034_7 Schematic and PCB editing software
                    • comms/cwstudio 0.9.6_1 Multichannel portable Morse code signals generator
                                                                                                                                (Only the first 10 of 64 items in this commit are shown above. View all ports for this commit)
                                                                                                                                wxGTK3.0: switch to gtk3 and webkit2
                                                                                                                                
                                                                                                                                Discussed with:	portmgr
                                                                                                                                Original commitRevision:493853  Sanity Test Failure
Sunday, 17 Feb 2019
19:41 sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-sshkey to rubygem-sshkey1

- Bump PORTREVISION for dependency change
Original commitRevision:493215  Sanity Test Failure
19:36 sunpoet search for other commits by this committer
Add p5-Term-TablePrint 0.108

Term::TablePrint shows a table and lets the user interactively browse it. It
provides a cursor which highlights the row on which it is located. The user can
scroll through the table with the different cursor keys.

If the table has more rows than the terminal, the table is divided up on as many
pages as needed automatically. If the cursor reaches the end of a page, the next
page is shown automatically until the last page is reached. Also if the cursor
reaches the topmost line, the previous page is shown automatically if it is not
already the first one.

If the terminal is too narrow to print the table, the columns are adjusted to
the available width automatically.

If the option table_expand is enabled and a row is selected with Return, each
column of that row is output in its own line preceded by the column name. This
might be useful if the columns were cut due to the too low terminal width.

WWW: https://metacpan.org/release/Term-TablePrint
Original commitRevision:493185  Sanity Test Failure
19:36 sunpoet search for other commits by this committer
Add p5-Term-Choose-Util 0.070

Term::Choose::Util provides some CLI related functions required by
App::DBBrowser, App::YTDL and Term::TablePrint.

WWW: https://metacpan.org/release/Term-Choose-Util
Original commitRevision:493184  Sanity Test Failure
Friday, 8 Feb 2019
12:00 Jochen Neumeister (joneum) search for other commits by this committer
MFH: r492403

Security update www/unit from 1.7.0 to 1.7.1.

<ChangeLog>

Everybody is strongly advised to update to a new version.

*) Security: a heap memory buffer overflow might have been caused in the
   router process by a specially crafted request, potentially resulting
   in a segmentation fault or other unspecified behavior
   (CVE-2019-7401).

*) Bugfix: install of Go module failed without prior building of Unit
   daemon; the bug had appeared in 1.7.

</ChangeLog>

Approved by:	ports-secteam (joneum)
Security:		95836a0-2b3b-11e9-9838-8c164567ca3c
commit hash: 83c5aa13f308797dc970c9d520c87ede6600ec0b commit hash: 83c5aa13f308797dc970c9d520c87ede6600ec0b commit hash: 83c5aa13f308797dc970c9d520c87ede6600ec0b commit hash: 83c5aa13f308797dc970c9d520c87ede6600ec0b  Sanity Test Failure
Tuesday, 5 Feb 2019
15:58 manu search for other commits by this committer
  • sysutils/u-boot-firefly-rk3399 2019.01 Cross-build das u-boot for model firefly-rk3399
  • u-boot-firefly-rk3399: Add a u-boot port for this board
    
    This is a ARM64 board with a RockChip RK3399 SoC.
    
    Add support for RK3399 to the u-boot-master port. No METADATA are created
    for now as this u-boot is split in two file and we don't support this scheme
    yet.
    Two patch are needed :
     - One to allow booting u-boot proper from the same source as the DTS (accepted
     and merge upstream)
     - One to have the BL31 (ATF binary) path in a environment variable instead of
     in the source directory (accepted upstream).
    Original commitRevision:492255  Sanity Test Failure
Friday, 1 Feb 2019
23:53 Jan Beich (jbeich) search for other commits by this committer
MFH: r491720

print/harfbuzz: update to 2.3.1

Changes:	https://github.com/harfbuzz/harfbuzz/blob/2.3.1/NEWS
ABI:		https://abi-laboratory.pro/tracker/timeline/harfbuzz/
Approved by:	ports-secteam blanket (required by Firefox 67)
commit hash: 92b60166733ad14282805d98023dcd6c7346af0d commit hash: 92b60166733ad14282805d98023dcd6c7346af0d commit hash: 92b60166733ad14282805d98023dcd6c7346af0d commit hash: 92b60166733ad14282805d98023dcd6c7346af0d  Sanity Test Failure
Thursday, 31 Jan 2019
11:17 Tobias Kortkamp (tobik) search for other commits by this committer
MFH: r491705

misc/mc: Do not override variables after bsd.port.pre.mk

At least the Python run dependency is not added on FreeBSD >= 12.0
because of it.

PR:		234587
Approved by:	woodsb02 (maintainer timeout, 4 weeks)

Approved by:	ports-secteam blanket
commit hash: b231273b9c3ae8fe0bce40882f69f6d6ebeda7a4 commit hash: b231273b9c3ae8fe0bce40882f69f6d6ebeda7a4 commit hash: b231273b9c3ae8fe0bce40882f69f6d6ebeda7a4 commit hash: b231273b9c3ae8fe0bce40882f69f6d6ebeda7a4  Sanity Test Failure
Sunday, 27 Jan 2019
15:57 swills search for other commits by this committer
devel/py-resource: create port

A Python library concentrated on the Resource layer
of RESTful APIs.

WWW: https://github.com/RussellLuo/resource

PR:		234897
Submitted by:	Antonio Huete Jimenez <tuxillo@quantumachine.net>
Original commitRevision:491362  Sanity Test Failure
Friday, 18 Jan 2019
17:59 Tijl Coosemans (tijl) search for other commits by this committer
Thursday, 10 Jan 2019
08:44 Jochen Neumeister (joneum) search for other commits by this committer
Sunday, 6 Jan 2019
12:18 arrowd search for other commits by this committer
  • archivers/hs-tar 0.5.1.0_3 Reading, writing, and manipulating ".tar" archive files Deleted Deprecated Expired
    • archivers/hs-zip-archive 0.4_1 Library for creating and modifying zip archives Deleted Deprecated Expired
      • archivers/hs-zlib 0.6.1.2_4 Compression and decompression in the gzip and zlib formats Deleted Deprecated Expired
        • archivers/hs-zlib-bindings 0.1.1.5_5 Low-level bindings to the zlib package Deleted Deprecated Expired
          • audio/hs-ALUT 2.4.0.2_4 Binding for the OpenAL Utility Toolkit Deleted Deprecated Expired
            • audio/hs-OpenAL 1.7.0.4_4 Binding to the OpenAL cross-platform 3D audio API Deleted Deprecated Expired
              • audio/hs-libmpd 0.9.0.9_1 MPD client library Deleted Deprecated Expired
                • benchmarks/hs-criterion 1.5.3.0_1 Robust, reliable performance measurement and analysis Deleted Deprecated Expired
                  • benchmarks/hs-criterion-measurement 0.1.1.0_1 Criterion measurement functionality and associated types Deleted Deprecated Expired
                    • converters/hs-aeson 1.3.1.0_2 Fast JSON parsing and encoding Deleted Deprecated Expired
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  (Only the first 10 of 553 items in this commit are shown above. View all ports for this commit)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  lang/ghc: Update to 8.6.3 and bump PORTREVISION's of all Haskell ports.
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  As usual, it is recommended to rebuild or reinstall all the
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  dependent ports and the lang/ghc port itself in one of the following
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  ways:
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  # portmaster -w -r ghc
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    or
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  # portupgrade -fr lang/ghc
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  In case of pkg(8), it is probably safer to remove all the GHC-dependent
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  packages along with GHC and reinstall everything from scratch.  For
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  example:
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  # pkg query "%ro" ghc > ghc-pkgs.txt
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  # pkg delete -y lang/ghc
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  # pkg install -y `cat ghc-pkgs.txt`
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  During update some hs-* ports got two PORTREVISION bumps in a row. Other ports
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  got a PORTVERSION update together with one PORTREVISION bump. This is caused
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  by bulk-bumping PORTREVISION of all hs-* ports. There are a lot of them updated,
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  so figuring out which ones require a bump and which are not is too tedious.
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  Approved by:	tcberner (mentor)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  Differential Revision:	https://reviews.freebsd.org/D18707
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  Original commitRevision:489474  Sanity Test Failure
Tuesday, 1 Jan 2019
20:34 sunpoet search for other commits by this committer
Update to 0.200

Changes:	https://metacpan.org/changes/distribution/Module-Version
Original commitRevision:488977  Sanity Test Failure
13:52 rene search for other commits by this committer
  • databases/pecl-memcache 3.0.8_1 Memcached extension
    • databases/pecl-memcached2 2.2.0_5 PHP extension for interfacing with memcached via libmemcached library Deleted Deprecated Expired
      • devel/pecl-APCu4 4.0.11_1 APC User Caching Deleted Deprecated Expired
        • devel/pecl-intl 3.0.0_17 PECL extension to support Internationalization(ICU) Deleted Deprecated Expired
          • lang/php56 5.6.39 PHP Scripting Language Deleted Deprecated Expired
            • math/pecl-bitset2 2.0.4 PECL extension for manipulating bitsets Deleted Deprecated Expired
              • multimedia/zoneminder-h264 1.30.20170222_8 Complete security camera solution, fully web based with image analysis, experimental h264 version Deleted Deprecated Expired
                • security/bitwarden-ruby 0.0.0.20180321 Ruby implementation of the BitWarden API Deleted Deprecated Expired
                  • security/pecl-ssh2-0 0.13 PECL extension to the libssh2 library Deleted Deprecated Expired
                    • textproc/pecl-xdiff 1.5.2_1 PECL extension to create/apply binary and text patches Deleted Deprecated Expired
                        (Only the first 10 of 12 items in this commit are shown above. View all ports for this commit)
                        Remove expired ports:
                        2018-12-30 textproc/pecl-xdiff: Works only with EOL php 5.6
                        2019-01-01 www/mod_http2-devel: Use the module that is shipped with Apache 2.4
                        2019-01-01 www/varnish5: Varnish 5 is Retired
                        2018-12-30 security/pecl-ssh2-0: Works only with EOL php 5.6
                        2019-01-01 security/bitwarden-ruby: Expects very specific rubygem versions for
                        new updates. Please follow instructions in git repo.
                        2018-12-30 devel/pecl-intl: Works only with EOL php 5.6
                        2018-12-30 devel/pecl-APCu4: Works only with EOL php 5.6
                        2018-12-30 databases/pecl-memcache: Works only with EOL php 5.6
                        2018-12-30 databases/pecl-memcached2: Works only with EOL php 5.6
                        2018-12-30 math/pecl-bitset2: Works only with EOL php 5.6
                        2019-01-01 multimedia/zoneminder-h264: h264 feature was commited to main branch,
                        please upgrade to www/zoneminder
                        2019-01-01 lang/php56: Security Support ends on 31 Dec 2018
                        Original commitRevision:488894  Sanity Test Failure
Monday, 31 Dec 2018
17:55 rene search for other commits by this committer
  • accessibility/jovie-kde4 4.14.3_3 KDE text-to-speech system Deleted Deprecated Expired
    • accessibility/kaccessible-kde4 4.14.3_3 Accessibility services for KDE Deleted Deprecated Expired
      • accessibility/kdeaccessibility-kde4 4.14.3_3 Accessibility applications for KDE 4 Deleted Deprecated Expired
        • accessibility/kmag-kde4 4.14.3_3 KDE Screen magnifier Deleted Deprecated Expired
          • accessibility/kmousetool-kde4 4.14.3_3 Automatic mouse click tool for KDE Deleted Deprecated Expired
            • accessibility/kmouth-kde4 4.14.3_3 Speech synthesizer frontend for KDE Deleted Deprecated Expired
              • arabic/kde4-l10n 4.14.3_3 Arabic messages and documentation for KDE SC 4 Deleted Deprecated Expired
                • archivers/ark-kde4 4.14.3_5 Archiving tool for KDE Deleted Deprecated Expired
                  • astro/kstars-kde4 4.14.3_13 KDE 4 desktop planetarium Deleted Deprecated Expired
                    • astro/libkgeomap-kde4 15.04.3_13 KDE4 library for browsing photos on a map Deleted Deprecated Expired
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  (Only the first 10 of 337 items in this commit are shown above. View all ports for this commit)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  Remove KDE4, part 5
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 korean/kde4-l10n: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net/kget-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net/kdenetwork-strigi-analyzers-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net/zeroconf-ioslave-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net/libkfbapi: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net/kdenetwork-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net/kwooty: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net/kdenetwork-filesharing-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net/libmediawiki-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net/kio-upnp-ms: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net/libkvkontakte-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net/krfb-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net/smb4k-kde4: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net/krdc-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 french/kde4-l10n: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 ukrainian/kde4-l10n: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 textproc/kompare-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 textproc/libkomparediff2-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/silence: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/kdepim-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/plasma-applet-serverstatuswidget: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/strigi: KDE4 is end-of-life
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/plasma-applet-qstardict: Qt4 has been EOL since december
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/homerun: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/plasma-applet-daisy: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/plasma-applet-teacooker: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/kdepim-runtime-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/plasma-applet-panelspacer: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/plasma-applet-cwp: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/plasma-applet-yawp: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/kruler-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/superkaramba-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/kcharselect-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/kdepimlibs-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/ksshaskpass: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/plasma-applet-simpleweatherforecast: Qt4 has been EOL since
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/kdeconnect-kde-kde4: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/plasma-applet-fancytasks: Qt4 has been EOL since december
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 deskutils/kdeplasma-addons-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 japanese/kiten-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 japanese/kde4-l10n: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/libkdcraw-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/skanlite-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/kamera-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/kphotoalbum-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/kdegraphics-strigi-analyzer-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/kiconedit: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/kdegraphics-thumbnailers-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/libkscreen: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/kcoloredit: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/libksane-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/ksnapshot-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/gwenview-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/kpovmodeler: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/ksaneplugin-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/digikam-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/kdegraphics-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/kdegraphics-svgpart-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/kcolorchooser-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/okular-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/kqtquickcharts-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/libkipi-kde4: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/libkexiv2-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/kolourpaint-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 graphics/kdegraphics-mobipocket-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 russian/kde4-l10n: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 mail/kshowmail: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 mail/kbiff: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 www/kpartsplugin: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 www/choqok-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 www/kdewebdev-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 www/kwebkitpart: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 www/rekonq: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 security/subversion-kwallet: KDE4 is end-of-life
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 security/kwalletmanager-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 security/kgpg-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/libkgapi-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/kapptemplate-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/py-krosspython-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/kcachegrind-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/smokegen-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/cervisia-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/kdevelop-php-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/py-pykdeuic4-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/okteta-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/kdevelop-pg-qt-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/ruby-korundum-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/py-pykde4-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/dolphin-plugins-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/kde-dev-utils-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/kdesvn-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/smokekde-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/p5-perlkde-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/kdevelop-php-docs-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/p5-perlqt-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/kdevelop-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/poxml-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/kde-dev-scripts-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/umbrello-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/kdebindings-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/kdesdk-strigi-analyzers-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/kdesdk-thumbnailers-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/kdesdk-kioslaves-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/kdevplatform-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/smokeqt-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/ruby-qtruby-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/kdesdk-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/lokalize-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/libkolab: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 devel/ruby-krossruby-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 arabic/kde4-l10n: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 databases/akonadi-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 ftp/plasma-applet-ftpmonitor: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 print/print-manager-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 print/kover: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net-p2p/libktorrent-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net-p2p/ktorrent-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 editors/kile-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 editors/klat4: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 editors/kate-plugin-pate-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 editors/kate-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kdeedu-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/krecipes-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde-thumbnailer-epub-kde4: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde-thumbnailer-fb2-kde4: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/libkdeedu-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-ia: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-nl: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-cs: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-fa: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kwordquiz-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-km: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-lt: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kdeutils-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-es: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-wa: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-en_GB: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-gl: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde-thumbnailer-chm-kde4: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-ug: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-ga: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-nb: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-hr: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-bs: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-et: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-pa: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-nds: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-bg: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-tr: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-sk: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kgeography-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-is: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-da: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-ca: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-it: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-ro: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-ca_valencia: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-kk: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/parley-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-sl: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-hi: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-sr: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/klettres-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-sv: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-fi: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-lv: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-eu: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/ktouch-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-id: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-mr: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-nn: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 misc/kde4-l10n-el: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 science/step-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 science/kalzium-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/palapeli-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kiriki-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kanagram-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/khangman-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kdiamond-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kigo-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kshisen-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/klickety-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kdegames-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kmines-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/ksquares-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/konquest-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/killbots-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kblocks-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/knavalbattle-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/blinken-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/picmi-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kjumpingcube-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/ksudoku-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/klines-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/bomber-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kajongg-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kbounce-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kreversi-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kmahjongg-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kfourinline-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kbreakout-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/bovo-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kubrick-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/ksirk-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/granatier-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/libkdegames-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/pairs-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kspaceduel-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/libkmahjongg-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/lskat-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/knetwalk-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/katomic-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kollision-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kgoldrunner-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kapman-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kpat-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kolf-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/kblackbox-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/ksnakeduel-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 games/ktuberling-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-clocks/kdetoys-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-clocks/plasma-applet-adjustableclock: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-clocks/amor-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-clocks/plasma-applet-geekclock: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-clocks/kteatime-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-clocks/ktux-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-clocks/ktimer-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 hebrew/kde4-l10n: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net-im/ktp-approver-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net-im/ktp-filetransfer-handler-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net-im/ktp-send-file-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net-im/ktp-contact-list-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net-im/ktp-desktop-applets-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net-im/ktp-contact-runner-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net-im/kopete-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net-im/ktp-accounts-kcm-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net-im/kmess-kde4: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net-im/plasma-applet-ktp-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net-im/ktp-kded-integration-module-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net-im/ktp-text-ui-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net-im/telepathy-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net-im/ktp-auth-handler-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 net-im/ktp-common-internals-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 audio/libkcompactdisc-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 audio/kmix-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 audio/audex: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 audio/kio-audiocd-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 audio/kid3-kde4: Qt4 and KDE4 EOL upstream. Use audio/kid3-qt5 or
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  audio/kid3-kf5 instead
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 audio/libkcddb-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 audio/kstreamripper: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 audio/juk-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 audio/kscd-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 audio/simon: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 math/analitza-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 math/kmplot-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 math/kcalc-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 math/kig-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 math/kbruch-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 math/cantor-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 math/abakus: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 math/kalgebra-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 math/rocs-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11/plasma-scriptengine-python-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11/kactivitymanagerd: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11/yakuake-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11/kdelibs-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11/libkonq-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11/kde4: KDE4 is end-of-life
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11/kgamma-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11/plasma-scriptengine-ruby-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11/kde-baseapps-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11/kactivities: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11/konsole-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11/kde-workspace-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11/kde-runtime-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 polish/kde4-l10n: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 chinese/kde4-l10n-zh_CN: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 chinese/kde4-l10n-zh_TW: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-fm/krusader2-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 archivers/ark-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 german/kde4-l10n: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 portuguese/kde4-l10n-pt_BR: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 portuguese/kde4-l10n: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 multimedia/dragon-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 multimedia/k9copy-kde4: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 multimedia/kdemultimedia-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 multimedia/kdemultimedia-ffmpegthumbs-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 multimedia/kdenlive-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 multimedia/kdemultimedia-mplayerthumbs-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 multimedia/subtitlecomposer-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 multimedia/kplayer-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 astro/marble-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 astro/libkgeomap-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 astro/kstars-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-themes/kde4-style-oxygen-transparent: Qt4 has been EOL since
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-themes/kde4-windeco-crystal: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-themes/gtk-qt4-engine: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-themes/kde-gtk-config: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-themes/kde4-style-skulpture: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-themes/kde-wallpapers-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-themes/kde4-style-bespin: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-themes/kde4-windeco-dekorator: Qt4 has been EOL since december
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-themes/kde-base-artwork-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-themes/kde4-style-polyester: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-themes/kdeartwork-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-themes/plasma5-breeze-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-themes/kde4-style-nitrogen: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 x11-themes/qtcurve-kde4: KDE4 is EOL
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 lang/kturtle-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 accessibility/kaccessible-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 accessibility/kmouth-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 accessibility/kmag-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 accessibility/jovie-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 accessibility/kdeaccessibility-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 accessibility/kmousetool-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 finance/kmymoney-kde4: KDE4 is EOL upstream. Use finance/kmymoney
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  instead
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 comms/kremotecontrol-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/kdf-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/kdeadmin-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/sweeper-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/kcron-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/nepomuk-core-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/kfilemetadata-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/ksystemlog-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/knutclient-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/baloo-widgets-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/filelight-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/baloo-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/polkit-kde: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/kuser-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/nepomuk-widgets-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/k3b-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/ksysguardd-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/kfloppy-kde4: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 sysutils/kcm-polkit-kde: Qt4 has been EOL since december 2015
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  2018-12-31 hungarian/kde4-l10n: KDE4 is EOL upstream
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  Original commitRevision:488807