notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
NOTE: There is a known problem on production with searching pkg-plist - it returns no results. This problem is not present on stage.freshports.org
Port details
rubygem-activerecord Object-relational mapping layer for Rails MVC Framework
3.2.22.2 databases Deleted on this many watch lists=12 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Upstream support ended
Expired This port expired on: 2017-01-07
Maintainer: ruby@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2005-07-20 13:54:49
Last Update: 2017-01-07 15:39:26
SVN Revision: 430809
People watching this port, also watch:: libiconv, rubygem-rake, expat, pcre
Also Listed In: rubygems
License: MIT
Description:
Homepage    cgit ¦ GitHub ¦ GitHub ¦ GitLab ¦ SVNWeb
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • rubygem-activerecord>0:databases/rubygem-activerecord
No installation instructions:
This port has been deleted.
PKGNAME: rubygem-activerecord
Flavors: there is no flavor information for this port.
distinfo:

Packages (timestamps in pop-ups are UTC):
rubygem-activerecord
ABIlatestquarterly
FreeBSD:11:aarch64pkg-falloutpkg-fallout
FreeBSD:11:amd64pkg-falloutpkg-fallout
FreeBSD:11:armv63.2.22.2pkg-fallout
FreeBSD:11:i386pkg-falloutpkg-fallout
FreeBSD:11:mipspkg-falloutpkg-fallout
FreeBSD:11:mips64pkg-falloutpkg-fallout
FreeBSD:12:aarch64pkg-falloutpkg-fallout
FreeBSD:12:amd64pkg-falloutpkg-fallout
FreeBSD:12:armv6pkg-falloutpkg-fallout
FreeBSD:12:armv7pkg-falloutpkg-fallout
FreeBSD:12:i386pkg-falloutpkg-fallout
FreeBSD:12:mipspkg-falloutpkg-fallout
FreeBSD:12:mips64pkg-falloutpkg-fallout
FreeBSD:12:powerpc64pkg-falloutpkg-fallout
FreeBSD:13:aarch64pkg-falloutpkg-fallout
FreeBSD:13:amd64pkg-falloutpkg-fallout
FreeBSD:13:armv6pkg-falloutpkg-fallout
FreeBSD:13:armv7pkg-falloutpkg-fallout
FreeBSD:13:i386pkg-falloutpkg-fallout
FreeBSD:13:mipspkg-falloutpkg-fallout
FreeBSD:13:mips64pkg-falloutpkg-fallout
FreeBSD:13:powerpc64pkg-falloutpkg-fallout
FreeBSD:13:riscv64pkg-falloutpkg-fallout
FreeBSD:14:aarch64pkg-falloutpkg-fallout
FreeBSD:14:amd64pkg-falloutpkg-fallout
FreeBSD:14:armv6pkg-falloutpkg-fallout
FreeBSD:14:armv7pkg-falloutpkg-fallout
FreeBSD:14:i386pkg-falloutpkg-fallout
FreeBSD:14:mipspkg-falloutpkg-fallout
FreeBSD:14:mips64pkg-falloutpkg-fallout
FreeBSD:14:powerpc64pkg-falloutpkg-fallout
FreeBSD:14:riscv64pkg-falloutpkg-fallout
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. ruby22 : lang/ruby22
  2. gem22 : devel/ruby-gems
Runtime dependencies:
  1. rubygem-activemodel>=3.2.22.2 : databases/rubygem-activemodel
  2. rubygem-activesupport>=3.2.22.2 : devel/rubygem-activesupport
  3. rubygem-arel3>=3.0.3 : databases/rubygem-arel3
  4. rubygem-tzinfo03>=0.3.29 : devel/rubygem-tzinfo03
  5. ruby22 : lang/ruby22
  6. gem22 : devel/ruby-gems
Patch dependencies:
  1. ruby22 : lang/ruby22
  2. gem22 : devel/ruby-gems
Extract dependencies:
  1. ruby22 : lang/ruby22
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Build

Deleted ports which required this port:

Expand this list of 1 deleted port
  1. databases/rubygem-rubyrep*
  2. Collapse this list of deleted ports.
for Run

Deleted ports which required this port:

Expand this list of 4 deleted ports
  1. databases/rubygem-activerecord-mysql-adapter*
  2. databases/rubygem-rubyrep*
  3. devel/rubygem-acts-as-taggable-on*
  4. www/rubygem-rails*
  5. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message

Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://rubygems.global.ssl.fastly.net/gems/
Collapse this list.
Port Moves
  • port deleted on 2017-01-07
    REASON: Has expired: Upstream support ended

Number of commits found: 74

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
CommitCreditsLog message
3.2.22.2
07 Jan 2017 15:39:26
Revision:430809Original commit files touched by this commit
rene search for other commits by this committer
Remove expired ports:
2017-01-07 databases/rubygem-dm-rails: Depends on deprecated
www/rubygem-actionpack
2017-01-07 databases/rubygem-activerecord: Upstream support ended
2017-01-07 devel/rubygem-activesupport: Upstream support ended
2017-01-07 devel/rubygem-tzinfo03: Use devel/rubygem-tzinfo instead
2017-01-07 devel/rubygem-sprockets22: Use devel/rubygem-sprockets or
devel/rubygem-sprockets3 instead
2017-01-07 devel/rubygem-prototype-rails: Depends on deprecated
www/rubygem-rails
2017-01-07 devel/rubygem-rubigen: Depends on deprecated
devel/rubygem-activesupport
2017-01-07 devel/rubygem-coffee-rails: Depends on deprecated
www/rubygem-railties
2017-01-07 japanese/rubygem-jpmobile: Depends on deprecated rubygem-rails
2017-01-07 mail/rubygem-actionmailer: Upstream support ended
2017-01-07 mail/rubygem-mail25: Use mail/rubygem-mail instead
2017-01-07 security/dradis: Depends on deprecated www/rubygem-rails
2017-01-07 textproc/rubygem-sass-rails: Depends on deprecated
www/rubygem-railties
2017-01-07 www/rubygem-rails: Upstream support ended
2017-01-07 www/rubygem-activeresource: Upstream support ended
2017-01-07 www/rubygem-responders-rails3: Depends on deprecated
www/rubygem-railties
2017-01-07 www/rubygem-jquery-ui-rails: Depends on deprecated
www/rubygem-railties
2017-01-07 www/rubygem-haml-rails: Depends on deprecated www/rubygem-actionpack
2017-01-07 www/rubygem-jquery-rails: Depends on deprecated www/rubygem-railties
2017-01-07 www/rubygem-railties: Upstream support ended
2017-01-07 www/rubygem-actionpack: Upstream support ended
2017-01-07 databases/rubygem-rubyrep: Depends on deprecated
databases/rubygem-activerecord
2017-01-07 databases/rubygem-activerecord-mysql-adapter: Depends on deprecated
databases/rubygem-activerecord
2017-01-07 databases/rubygem-dm-active_model: Depends on deprecated
databases/rubygem-activemodel
3.2.22.2
04 Jan 2017 15:33:34
Revision:430569Original commit files touched by this commit
sunpoet search for other commits by this committer
Update WWW: http://www.rubyonrails.org/ redirects to http://rubyonrails.org/
3.2.22.2
23 Dec 2016 10:57:39
Revision:429247Original commit files touched by this commit
tz search for other commits by this committer
databases/rubygem-activerecord: Fix optional RUN_DEPENDS for MYSQL option

Fix a build problem when MYSQL option is used. Since the option is
not default there is no PORTREVISION bump.

PR:           214667
Submitted by: Gerrit Beine <mail+freebsd@gerritbeine.de>
Approved by:  mentors (implicit)
3.2.22.2
06 Dec 2016 23:10:05
Revision:428010Original commit files touched by this commit
swills search for other commits by this committer
Deprecate rails 3.x since upstream support has ended

See also: http://guides.rubyonrails.org/maintenance_policy.html

With hat:	ruby@
3.2.22.2
27 Apr 2016 21:57:32
Revision:414136Original commit files touched by this commit
swills search for other commits by this committer
Convert USES=gem:autoplist to USES=gem since autoplist is default
3.2.22.2
27 Apr 2016 16:36:42
Revision:414118Original commit files touched by this commit
swills search for other commits by this committer
create USES=gem and update rubygem- ports to use it

Note that for now ports still have to have USE_RUBY=yes to use USES=gem

PR:		209041
Differential Revision:	https://reviews.freebsd.org/D6070
3.2.22.2
01 Apr 2016 14:00:57
Revision:412346Original commit files touched by this commit
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.

With hat:	portmgr
Sponsored by:	Absolight
3.2.22.2
06 Mar 2016 06:39:09
Revision:410441Original commit files touched by this commit
sunpoet search for other commits by this committer
- Update to 3.2.22.2

Changes:	https://github.com/rails/rails/blob/3-2-stable/activerecord/CHANGELOG.md
		https://github.com/rails/rails/compare/v3.2.22.1...v3.2.22.2
Security:	5a016dd0-8aa8-490e-a596-55f4cc17e4ef
MFH:		2016Q1
3.2.22.1
02 Feb 2016 22:46:25
Revision:407881Original commit files touched by this commit
sunpoet search for other commits by this committer
- Update to 3.2.22.1

Changes:	https://github.com/rails/rails/blob/3-2-stable/activerecord/CHANGELOG.md
		https://github.com/rails/rails/compare/v3.2.22...v3.2.22.1
Security:	bb0ef21d-0e1b-461b-bc3d-9cba39948888
MFH:		2016Q1
3.2.22
04 Oct 2015 18:01:22
Revision:398608Original commit files touched by this commit This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Add LICENSE_FILE
3.2.22
17 Aug 2015 14:20:41
Revision:394508Original commit files touched by this commit This port version is marked as vulnerable.
mat search for other commits by this committer
Remove UNIQUENAME and LATEST_LINK.

UNIQUENAME was never unique, it was only used by USE_LDCONFIG and now,
we won't have conflicts there.

Use PKGBASE instead of LATEST_LINK in PKGLATESTFILE, the *only* consumer
is pkg-devel, and it works just fine without LATEST_LINK as pkg-devel
has the correct PKGNAME anyway.

Now that UNIQUENAME is gone, OPTIONSFILE is too. (it's been called
OPTIONS_FILE now.)

Reviewed by:	antoine, bapt
Exp-run by:	antoine
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D3336
3.2.22
02 Jul 2015 16:01:08
Revision:391169Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
Set NO_ARCH for remaining rubygem-* ports with no arch dependent files

Obtained from:  DEVELOPER_MODE
With Hat:       ruby@

Sponsored by:   RideCharge Inc / Curb
3.2.22
17 Jun 2015 17:26:22
Revision:389971Original commit files touched by this commit This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Update to 3.2.22

Changes:	https://github.com/rails/rails/blob/3-2-stable/activerecord/CHANGELOG.md
3.2.21
02 Apr 2015 19:59:00
Revision:383060Original commit files touched by this commit Sanity Test Failure This port version is marked as vulnerable.
swills search for other commits by this committer
www/rubygem-rails: update rubygem-rails and friends to 3.2.21
3.2.19_1
06 Sep 2014 20:51:04
Revision:367472Original commit files touched by this commit This port version is marked as vulnerable.
swills search for other commits by this committer
devel/rubygem-tzinfo: update to 1.2.2

While here, create a port for the older 0.3 version for the ports that need it,
hook it up to the build, set those ports to use the older version and bump
portrev on those ports.
3.2.19
02 Jul 2014 23:26:38
Revision:360311Original commit files touched by this commit This port version is marked as vulnerable.
swills search for other commits by this committer
- Update rails and friend to 3.2.19

Security:	CVE-2014-3482
Security:	CVE-2014-3483
3.2.17
19 Feb 2014 03:23:25
Revision:344989Original commit files touched by this commit This port version is marked as vulnerable.
swills search for other commits by this committer
- Update rails to 3.2.17 [1]
- Update polyglot to 0.3.4 since rails wants the newer version
- Update redmine to use new rails

Security:	CVE-2014-0080 [1]
Security:	CVE-2014-0081 [1]
Security:	CVE-2014-0082 [1]
MFH:		2014Q1
3.2.16_1
18 Feb 2014 21:31:22
Revision:344969Original commit files touched by this commit This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Fix RUN_DEPENDS
3.2.16_1
02 Feb 2014 03:11:49
Revision:342240Original commit files touched by this commit This port version is marked as vulnerable.
swills search for other commits by this committer
- Update dependencies
3.2.16
05 Dec 2013 20:27:39
Revision:335702Original commit files touched by this commit This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Update to 3.2.16
- Sort RUN_DEPENDS

Changes:	https://github.com/rails/rails/blob/v3.2.16/activerecord/CHANGELOG.md
3.2.15
02 Dec 2013 18:36:22
Revision:335530Original commit files touched by this commit This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Add LICENSE
- Convert to new options helper
3.2.15
30 Oct 2013 02:20:20
Revision:332031Original commit files touched by this commit This port version is marked as vulnerable.
swills search for other commits by this committer
- Add stage support
3.2.15
24 Oct 2013 01:45:28
Revision:331450Original commit files touched by this commit This port version is marked as vulnerable.
swills search for other commits by this committer
- Update rails and friends to 3.2.15
- Update rubygem-i18n to 0.6.5
3.2.13
20 Sep 2013 16:13:49
Revision:327717Original commit files touched by this commit This port version is marked as vulnerable.
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
databases)
3.2.13
11 Apr 2013 11:30:01
Revision:315783Original commit files touched by this commit This port version is marked as vulnerable.
bdrewery search for other commits by this committer
- Update to 3.2.13 to fix security vulnerabilities
- Update rubygem-mail to 2.5.3 as rubygem-actionmailer-3.2.13 requires it

PR:		ports/177709
Submitted by:	Geoffroy Desvernay <dgeo@centrale-marseille.fr>
With hat:	ruby
Approved by:	portmgr (implicit)
Reviewed by:	miwi
Security:	db0c4b00-a24c-11e2-9601-000d601460a4
3.2.12
16 Feb 2013 20:54:38
Revision:312384Original commit files touched by this commit This port version is marked as vulnerable.
swills search for other commits by this committer
- Update rails to 3.2.12
- Update dependent ports, including:
- Update rack to 1.4.5 to resolve CVE-2013-0263 and CVE-2013-0262
- Update activemodel to 3.2.12 to resolve CVE-2013-0276

Security:	forthcoming
3.2.11
11 Jan 2013 22:05:13
Revision:310250Original commit files touched by this commit This port version is marked as vulnerable.
jgh search for other commits by this committer
- update remaining ruby@ maintained ports to new options framework
- trim historical header where applicable

Reviewed by:	swills@ (ruby@)
3.2.11
09 Jan 2013 03:53:16
Revision:310121Original commit files touched by this commit This port version is marked as vulnerable.
swills search for other commits by this committer
- Update rubygem-rails to 3.2.11
- Update ports require by rubygem-rails
- Add vuxml entry for rails security issues

Security:	ca5d3272-59e3-11e2-853b-00262d5ed8ee
Security:	b4051b52-58fa-11e2-853b-00262d5ed8ee
3.2.8
10 Aug 2012 02:50:54
Original commit files touched by this commit This port version is marked as vulnerable.
swills search for other commits by this committer
- Update rails and friends to 3.2.8
- Document security issue in 3.2.7 [1]

Submitted by:	bdrewery [1]
Reviewed by:	swills [1]
Security:	31db9a18-e289-11e1-a57d-080027a27dbf
3.2.7
27 Jul 2012 03:09:19
Original commit files touched by this commit This port version is marked as vulnerable.
swills search for other commits by this committer
- Update Rails and friends to 3.2.7
- Add vuxml entry for Rails 3.2.6 [1]

Reviewed by:	zi [1]
3.2.6
24 Jul 2012 00:41:43
Original commit files touched by this commit This port version is marked as vulnerable.
swills search for other commits by this committer
- Update rails to 3.2.6 and accompanying dependency updates
3.2.1
12 Feb 2012 02:08:20
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- Update to 3.2.1

With Hat:       ruby@
Sponsored by:   RideCharge Inc. / TaxiMagic
3.2.0
08 Feb 2012 02:51:13
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- Fix gem version requirements

With Hat:   ruby@
3.2.0
08 Feb 2012 02:04:52
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- Update to 3.2.0

With Hat:       ruby@
Sponsored by:   RideCharge Inc. / TaxiMagic
3.1.3
28 Nov 2011 04:30:40
Original commit files touched by this commit This port version is marked as vulnerable.
swills search for other commits by this committer
- Update to 3.1.3

Feature safe:   yes
3.1.1
27 Oct 2011 03:02:52
Original commit files touched by this commit This port version is marked as vulnerable.
swills search for other commits by this committer
- Update Rails to 3.1.1 and associated changes

With hat:       ruby@
3.0.10
19 Aug 2011 23:28:41
Original commit files touched by this commit This port version is marked as vulnerable.
delphij search for other commits by this committer
Update Rails to 3.0.10.

Submitted by:   Alexander Kriventsov <avk vl.ru>
PR:             ports/159906
Security:       be77eff6-ca91-11e0-aea3-00215c6a37bb
3.0.9
23 Jun 2011 19:34:14
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- guess thats enough for the 1st day back
- add files supposed to have been in previous commit for rails update to 3.0.9
3.0.9
23 Jun 2011 19:32:59
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- Update rails to 3.0.9 (current)
  bump required dependencie

With Hat:       ruby@
Sponsored by:   RideCharge Inc. / TaxiMagic
3.0.6
23 Jun 2011 17:35:27
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- Update rails to 3.0.6
  and its dependency requirements

With Hat:       ruby@
Sponsored by:   RideCharge Inc. / TaxiMagic
3.0.5
04 Mar 2011 02:52:24
Original commit files touched by this commit This port version is marked as vulnerable.
wen search for other commits by this committer
- Update to 3.0.5
- Update RUN_DEPENDS
3.0.3
23 Nov 2010 07:18:56
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- Update to 3.0.3

With Hat:       ruby@
Sponsored by:   RideCharge Inc. / TaxiMagic
3.0.2
16 Nov 2010 06:53:30
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- Update to 3.0.2

With Hat:       ruby@
Sponsored by:   RideCharge Inc. / TaxiMagic
3.0.1
20 Oct 2010 01:35:47
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- Mass fixup of WWW: lines pkg-descr based on rubygems.org Homepage meta info

Prompted by:    distilator
With Hat:       ruby@
Sponsored by:   RideCharge Inc. / TaxiMagic
3.0.1
19 Oct 2010 06:54:02
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- Update to 3.0.1

With Hat:       ruby@
Sponsored by:   RideCharge Inc. / TaxiMagic
3.0.0
02 Sep 2010 02:43:28
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
                    Presenting Rails 3.0

    http://weblog.rubyonrails.org/2010/8/29/rails-3-0-it-s-done

N.B.:
  lang/ruby19 does not work with rails3 until the upgrade to 1.9.2
  by stas@ happens.

- Update www/rubygem-rails to 3.0.0

Sponsored by:       RideCharge Inc. / Taximagic
2.3.8
06 Jun 2010 19:25:10
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- GEMS are always RUN_DEPENDS of other GEMS
- Bump PORTREVISION when something other then BUILD_DEPENDS changes
- Some minor verticle whitespace in some ports for consistency with the rest

PR:             ports/147551
Submitted by:   pgollucci@ (myself)
Reviewed by:    portmgr (pav)
With Hat:       ruby
2.3.8
26 May 2010 06:00:54
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- Update www/rubygem-rack to 1.1.0
  See [ports/147047 which fixes www/rubygem-innate]
- Set rails deps to *exactly* rack 1.1.0
- Pass www/rubygem-activeresource to ruby@
  [approved by clsung@ (maintainer) long time ago]
- Convert rails & railities from RF -> RG

            *** Update rails aka www/rubygem-rails to 2.3.8 ***
               *** note 3.0 has been beta for 3+ months ***

PR:                 ports/146938
Special thanks to:  Eric Freeman <freebsdports@chillibear.com> for the
Mk/bsd.sites.mk RG patch
Sponsored by:       RideCharge Inc. / Taxi Magic
Tested by:          P6 TB rubygems- run and RC TB rubygems- run
With Hat:           ruby@
2.3.4_1
27 Apr 2010 22:55:23
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- Re-assign all my rubygem-* ports to ruby@
  this gives us more eyes and brings us inline with perl@

  Current ruby@ members (stas, dinoex, pgollucci)
  http://wiki.freebsd.org/Ruby

Discussed with: stas on #bsdports
2.3.4_1
15 Jan 2010 00:49:35
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- Convert from rubygem-postgres to reubygem-pg to fix ruby 1.9.x issues

PR:             ports/142461
Reported by:    Aaron Gifford <astounding@gmail.com>
With help from: dinoex
2.3.4
10 Sep 2009 17:12:20
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- Update to rails 2.3.4
2.3.3
24 Jul 2009 22:43:51
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- Update to Rails 2.3.3

  *** Be sure to read the Changes ***

Sponsored by:   RideCharge Inc.
2.3.2
28 May 2009 22:04:27
Original commit files touched by this commit This port version is marked as vulnerable.
linimon search for other commits by this committer
Reassign these ports to the committer who has been most active in updating
them.

Approved by:    old maintainer
2.3.2
24 Apr 2009 02:45:08
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- Update to rails 2.3.2
  www/rubygem-rails [2]
     devel/rubygem-activesupport [5]
     databases/rubygem-activerecord
     mail/rubygem-actionmailer [4]
     www/rubygem-actionpack [3]
     www/rubygem-activeresource [1]

PRs:               ports/133523 [1], ports/133525 [2], ports/133522 [3]
                   ports/133518 [4], ports/133516 [5], ports/133504 [6]
Approved by:       maintainer timeout (2 weeks 1 day) [1-6]
Submitted by:      me [1-6]
Tested by: RidCharge Inc. Tinderbox

Sponsored by:   RideCharge Inc.
2.2.2
09 Apr 2009 00:11:47
Original commit files touched by this commit This port version is marked as vulnerable.
pgollucci search for other commits by this committer
- convert to RUBYGEM_AUTOPLIST
  remove x-generate-plist and friends
- use RF macro and remove SUBDIR where possible
- remove some uneeded GEM_NAME=${DISTNAME}
  (this c/should be handled better in bsd.*.mk)

other deltas specific to individual ports:
  audio/rubygem-mp3info     - unbreak, fix packaging, bump PORTREVISION
  devel/rubygem-rapt        - adopt
  devel/rubygem-rspec       - remove BUILD_DEPENDS=RUN_DEPENDS -- neither set
  devel/rubygem-ruby2ruby   - add #' for vim highlight
  graphics/rubygem-extifr   - drop PORTREVISION=0
  graphics/rubygem-gd2      - add #' for vim highlight
  www/rubygem-rubyfulsoup   - swap GEM_NAME / DISTNAME for constistency

Sponsored by:   RideCharge Inc.
Tested on:      RideCharge's Tinderbox
Reviewed by:    stas
2.2.2
13 Feb 2009 23:32:15
Original commit files touched by this commit This port version is marked as vulnerable.
stas search for other commits by this committer
- Fix plist after ruby plist by generating it dynamically.
2.2.2
12 Feb 2009 02:59:04
Original commit files touched by this commit This port version is marked as vulnerable.
clsung search for other commits by this committer
- Update to 2.2.2

PR:             ports/131279
Submitted by:   clsung
Approved by:    maintainer (Jonathan Weiss)
1.15.6
06 Apr 2008 08:58:21
Original commit files touched by this commit This port version is marked as vulnerable.
stas search for other commits by this committer
- Add ruby 1.9 support
- Implement new knobs for gems and rake (these are included in
  ruby 1.9 distribution already). Also move gem bits from
  ruby-gems/Makefile.common to bsd.ruby.mk[1]. Now to depend
  on gems or rake you should define USE_RUBYGEMS/USE_RAKE
  accordingly. Also RAKE_BIN variable is provided for
  pointing to the right rake executable.
- Rewrite RUBY_SCHEBANG in awk to eliminate build dependency
  on ruby.

Discussed with: Jonathan Weiss <jw@innerewut.de> [1] (gems maintainer)
Tested by:      ports@
1.15.6
18 Mar 2008 10:03:17
Original commit files touched by this commit This port version is marked as vulnerable.
dinoex search for other commits by this committer
- Fix depends after update of rubygem-postgres
1.15.6
03 Dec 2007 23:26:41
Original commit files touched by this commit This port version is marked as vulnerable.
miwi search for other commits by this committer
- Update to 1.15.6 (needed for a security update)

PR:             117668
Submitted by:   Alexander Logvinov <ports@logvinov.com>
Approved by:    portmgr (linimon), maintainer timeout
1.15.3
03 Aug 2007 16:51:34
Original commit files touched by this commit This port version is marked as vulnerable.
clsung search for other commits by this committer
- Update RUN_DEPENDS according to the repo of rubygem-postgres

Noted by:   Dmitry Morozovsky <marck_AT_rinet dot ru>
1.15.3
04 Apr 2007 01:30:45
Original commit files touched by this commit This port version is marked as vulnerable.
clsung search for other commits by this committer
- Update to 1.15.3

PR:             ports/110659
Submitted by:   Alexander Logvinov <ports_AT_logvinov dot com>
Approved by:    maintainer (Jonathan Weiss)
1.15.2
09 Mar 2007 02:52:26
Original commit files touched by this commit This port version is marked as vulnerable.
clsung search for other commits by this committer
- Update to 1.15.2

PR:             109540
Submitted by:   Alexander Logvinov <ports_AT_logvinov dot com>
Approved by:    maintainer (Jonathan Weiss)
1.15.1
14 Feb 2007 02:35:55
Original commit files touched by this commit This port version is marked as vulnerable.
clsung search for other commits by this committer
- fix dependency path of rubygem-sqlite3(ruby-sqlite3, previous)

PR:             ports/109067
Submitted by:   clsung
Approved by:    maintainer (Jonathan Weiss)
1.15.1
27 Jan 2007 23:46:00
Original commit files touched by this commit This port version is marked as vulnerable.
miwi search for other commits by this committer
- Update to 1.2.1

PR:             108336
Submitted by:   Jonathan Weiss<jw@innerewut.de> (maintainer)
1.14.4
23 Aug 2006 02:30:46
Original commit files touched by this commit This port version is marked as vulnerable.
clsung search for other commits by this committer
* Update rails and its related ports to match rails 1.1.6:
        activesupport    = 1.3.1
        activerecord     = 1.14.4
        actionpack       = 1.12.5
        actionmailer     = 1.2.5
        actionwebservice = 1.1.6
        rails            = 1.1.6
    This update is needed to fix a serious bug in rails
* Add a x-generate-plist target to easy the creation of pkg-plist
* Add an "WWW" entry on pkg-descr that points to the correspoding
  project on rubyforge.

PR:             ports/101973
Submitted by:   Rui Lopes <rgl_AT_ruilopes dot com>
Approved by:    maintainer (Jonathan Weiss)
Security:      
http://weblog.rubyonrails.org/2006/8/10/rails-1-1-6-backports-and-full-disclosure
Security:      
http://www.vuxml.org/freebsd/90064567-28b1-11db-844d-000c6ec775d9.html
1.14.2
08 Aug 2006 11:35:27
Original commit files touched by this commit This port version is marked as vulnerable.
jmelo search for other commits by this committer
- Change to use MASTER_SITE_RUBYFORGE macro to fix fetch problem.

Approved by:    portmgr (erwin)
1.14.2
25 Apr 2006 20:35:52
Original commit files touched by this commit This port version is marked as vulnerable.
pav search for other commits by this committer
- Update the ruby on rails suite to 1.1.2

PR:             ports/95688
Submitted by:   Jonathan Weiss <jw@innerewut.de> (maintainer)
1.13.2_2
23 Jan 2006 16:40:28
Original commit files touched by this commit This port version is marked as vulnerable.
vd search for other commits by this committer
Add database options

PR:             ports/92072
Submitted by:   Roderick van Domburg <roderick@developer.nedforce.nl>, Jonathan
Weiss <jw@innerewut.de>
Approved by:    Jonathan Weiss <jw@innerewut.de> (maintainer), garga (mentor)
1.13.2_1
21 Jan 2006 20:25:07
Original commit files touched by this commit This port version is marked as vulnerable.
pav search for other commits by this committer
- Populate newly created rubygems category
1.13.2_1
16 Jan 2006 02:43:25
Original commit files touched by this commit This port version is marked as vulnerable.
pav search for other commits by this committer
- Update plist for ruby 1.8.4 rdoc

Reported by:    krismail
1.13.2
19 Dec 2005 14:30:31
Original commit files touched by this commit This port version is marked as vulnerable.
lawrance search for other commits by this committer
Update to 1.13.2.

PR:             ports/90635
Submitted by:   Jonathan Weiss <jw@innerewut.de> (maintainer)
1.11.1
20 Jul 2005 23:31:17
Original commit files touched by this commit This port version is marked as vulnerable.
pav search for other commits by this committer
- Update to 1.11.1
- Fix maintainer's email address

Submitted by:   Jonathan Weiss <jw@innerewut.de> (maintainer)
1.10.1
20 Jul 2005 13:53:52
Original commit files touched by this commit This port version is marked as vulnerable.
pav search for other commits by this committer
Action Record

In Rails, the model is handled by what's called a object-relational
mapping layer entitled Active Record. This layer allows you to present
the data from database rows as objects and embellish these data objects
with business logic methods

PR:             ports/82397
Submitted by:   Jonathan Weiss <jw@innerewut.de>

Number of commits found: 74