notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
NOTE: There is a known problem on production with searching pkg-plist - it returns no results. This problem is not present on stage.freshports.org
Port details
postgresql91-server The most advanced open-source database available anywhere
9.1.23_1 databases Deleted on this many watch lists=10 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: End-of-life is near
Expired This port expired on: 2016-10-01
Maintainer: pgsql@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2011-04-28 07:47:27
Last Update: 2016-10-03 18:19:04
SVN Revision: 423218
People watching this port, also watch:: clamav
License: not specified in port
Description:
Homepage    cgit ¦ GitHub ¦ GitHub ¦ GitLab ¦ SVNWeb
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • postgresql91-server>0:databases/postgresql91-server
No installation instructions:
This port has been deleted.
PKGNAME: postgresql91-server
Flavors: there is no flavor information for this port.
distinfo:

Packages (timestamps in pop-ups are UTC):
postgresql91-server
ABIlatestquarterly
FreeBSD:11:aarch64pkg-falloutpkg-fallout
FreeBSD:11:amd64pkg-falloutpkg-fallout
FreeBSD:11:armv69.1.22pkg-fallout
FreeBSD:11:i386pkg-falloutpkg-fallout
FreeBSD:11:mipspkg-falloutpkg-fallout
FreeBSD:11:mips649.1.22_2pkg-fallout
FreeBSD:12:aarch64pkg-falloutpkg-fallout
FreeBSD:12:amd64pkg-falloutpkg-fallout
FreeBSD:12:armv6pkg-falloutpkg-fallout
FreeBSD:12:armv7pkg-falloutpkg-fallout
FreeBSD:12:i386pkg-falloutpkg-fallout
FreeBSD:12:mipspkg-falloutpkg-fallout
FreeBSD:12:mips64pkg-falloutpkg-fallout
FreeBSD:12:powerpc64pkg-falloutpkg-fallout
FreeBSD:13:aarch64pkg-falloutpkg-fallout
FreeBSD:13:amd64pkg-falloutpkg-fallout
FreeBSD:13:armv6pkg-falloutpkg-fallout
FreeBSD:13:armv7pkg-falloutpkg-fallout
FreeBSD:13:i386pkg-falloutpkg-fallout
FreeBSD:13:mipspkg-falloutpkg-fallout
FreeBSD:13:mips64pkg-falloutpkg-fallout
FreeBSD:13:powerpc64pkg-falloutpkg-fallout
FreeBSD:13:riscv64pkg-falloutpkg-fallout
FreeBSD:14:aarch64pkg-falloutpkg-fallout
FreeBSD:14:amd64pkg-falloutpkg-fallout
FreeBSD:14:armv6pkg-falloutpkg-fallout
FreeBSD:14:armv7pkg-falloutpkg-fallout
FreeBSD:14:i386pkg-falloutpkg-fallout
FreeBSD:14:mipspkg-falloutpkg-fallout
FreeBSD:14:mips64pkg-falloutpkg-fallout
FreeBSD:14:powerpc64pkg-falloutpkg-fallout
FreeBSD:14:riscv64pkg-falloutpkg-fallout
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. gmake : devel/gmake
  2. msgfmt : devel/gettext-tools
Library dependencies:
  1. libpq.so.5 : databases/postgresql91-client
  2. libintl.so : devel/gettext-runtime
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Build

Deleted ports which required this port:

Expand this list of 2 deleted ports
  1. databases/postgresql91-plpython*
  2. databases/postgresql91-pltcl*
  3. Collapse this list of deleted ports.
for Run

Deleted ports which required this port:

Expand this list of 3 deleted ports
  1. databases/postgresql91-plperl*
  2. databases/postgresql91-plpython*
  3. databases/postgresql91-pltcl*
  4. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message

Master Sites:
Expand this list (3 items)
Collapse this list.
  1. ftp://ftp.postgresql.org/pub/source/v9.1.23/
  2. http://ftp.postgresql.org/pub/source/v9.1.23/
  3. https://ftp.postgresql.org/pub/source/v9.1.23/
Collapse this list.
Port Moves
  • port deleted on 2016-10-03
    REASON: Has expired: End-of-life is near

Number of commits found: 120 (showing only 100 on this page)

1 | 2  »  

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
CommitCreditsLog message
9.1.23_1
03 Oct 2016 18:19:04
Revision:423218Original commit files touched by this commit
rene search for other commits by this committer
Remove expired/expiring ports:
2016-10-01 databases/postgresql91-client: End-of-life is near
2016-10-08 databases/postgresql91-pgtcl: Depends on expired PostgreSQL 9.1
2016-10-01 databases/postgresql91-server: End-of-life is near
2016-10-08 databases/postgresql-pllua: Depends on expired PostgreSQL 9.1
9.1.23_1
24 Sep 2016 11:06:57
Revision:422711Original commit files touched by this commit
tijl search for other commits by this committer
- Update devel/icu to 57.1.
- Clean up the Makefile.
- Follow some upstream recommendations (--with-data-packaging=archive,
  --disable-renaming, -DICU_NO_USER_DATA_OVERRIDE).
- Patch makefiles to install static libraries with INSTALL_DATA so they
  aren't stripped.
- Patch config/mh-bsd-gcc to sync with config/mh-linux-gcc.
- Fix endianness detection in ICU.  The code wanted to use BYTE_ORDER
  defined in machine/endian.h, but this isn't visible because ICU is
  compiled with _XOPEN_SOURCE.  Patch the code to use _BYTE_ORDER instead.
- Compile ICU with C++11 compiler to enable move constructors.
- Patch ICU to fix a problem with atomics in the case of a C++11 compiler
  without C++11 header <atomic> (like Clang on FreeBSD 9).
- Bump all ports that depend on it due to library version change.
- Add USES=compiler:c++0x to some ports that pick up -std=c++0x from ICU
  pkgconfig files.
- Add USES=compiler:c++11-lib to graphics/libcdr01 because it also needs
  a C++11 runtime library now.  Add this to all ports that depend on it
  so their executables load the right libstdc++.so on FreeBSD 9.

PR:		205120
Exp-run by:	antoine
Approved by:	portmgr (antoine)
9.1.23
11 Aug 2016 18:35:31
Revision:420093Original commit files touched by this commit
ohauer search for other commits by this committer
- fix sizes
- s/USE_OPENSSL/USES=ssl/

assumed OK for commit ~1h after first notify about wrong sizes in distinfo
9.1.23
11 Aug 2016 16:39:40
Revision:420089Original commit files touched by this commit
girgen search for other commits by this committer
The PostgreSQL Global Development Group has released an update to all supported
versions of our database system, including 9.5.4, 9.4.9, 9.3.14, 9.2.18 and
9.1.23. This release fixes two security issues. It also patches a number of
other bugs reported over the last three months. Users who rely on security
isolation between database users should update as soon as possible. Other users
should plan to update at the next convenient downtime.

If you are using the ICU patch, please consult UPDATING.

Improve periodic cleanup, suggested by claudius (at) ambtec.de. [1]

PR:		210941 [1]
Security:	CVE-2016-5423, CVE-2016-5424
9.1.22_2
06 Jul 2016 22:10:14
Revision:418153Original commit files touched by this commit This port version is marked as vulnerable.
mat search for other commits by this committer
Bump PORTREVISION for the icu revert.

This time not bumping lang/php70, but devel/php70-intl which is the one
really depending on icu.

PR:		205120
With hat:	portmgr
Sponsored by:	Absolight
9.1.22_1
06 Jul 2016 07:34:13
Revision:418119Original commit files touched by this commit This port version is marked as vulnerable.
gahr search for other commits by this committer
devel/icu: bump PORTREVISION on dependent ports
9.1.22
17 Jun 2016 23:28:05
Revision:417041Original commit files touched by this commit This port version is marked as vulnerable.
mat search for other commits by this committer
Rename all files containing a : in their filename.

While there, run make makepatch on affected ports, and rename patches
accordingly.

Sponsored by:	Absolight
9.1.22
19 May 2016 11:09:14
Revision:415503Original commit files touched by this commit This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Fix trailing whitespace in pkg-messages

Approved by:	portmgr blanket
9.1.22
12 May 2016 22:36:10
Revision:415091Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL to latest versions

URL:	http://www.postgresql.org/docs/9.5/static/release-9-5-3.html
9.1.21
01 Apr 2016 14:00:57
Revision:412346Original commit files touched by this commit This port version is marked as vulnerable.
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.

With hat:	portmgr
Sponsored by:	Absolight
9.1.21
31 Mar 2016 14:49:02
Revision:412227Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL 9.1, 9.2 9.3 and 9.4 to latest versions.

URL:	http://www.postgresql.org/about/news/1656/
9.1.20
13 Feb 2016 22:42:04
Revision:408835Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL to latest versions.

Security Fixes for Regular Expressions, PL/Java

This release closes security hole CVE-2016-0773, an issue with regular
expression (regex) parsing. Prior code allowed users to pass in expressions
which included out-of-range Unicode characters, triggering a backend crash.
This issue is critical for PostgreSQL systems with untrusted users or which
generate regexes based on user input.

The update also fixes CVE-2016-0766, a privilege escalation issue for users of
PL/Java.  Certain custom configuration settings (GUCS) for PL/Java will now be
modifiable only by the database superuser

URL:		http://www.postgresql.org/about/news/1644/
Security:	CVE-2016-0773, CVE-2016-0766
9.1.19
13 Jan 2016 10:36:22
Revision:406034Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Some binaries where moved from contrib to base in 9.5, like pgbench and
pg_upgrade. Other where added in 9.5, but the port failed to install them.
Make sure they are properly installed by the correct port (-client or -server)
[1]

Remove unused and hence confusing OSSP_UUID parameters from Makefile [2]

Add options to allow user to be set for the backup script in periodic.
Add this option only to 9.5 for now. It will be updated to other servers at
next regular patch release. [3]

The path to perl in hard coded into pgxs/src/Makefile.global which is
then installed. Hence, we must depend on perl when that file is installed.

Noticed by:	Paul Guyot [1]
PR:		192387 [2]
PR:		172110 [3]
PR:		206046 [4]
9.1.19
15 Oct 2015 14:55:14
Revision:399346Original commit files touched by this commit Sanity Test Failure This port version is marked as vulnerable.
mat search for other commits by this committer
Drop 8 support.

With hat:	portmgr
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D3694
9.1.19
08 Oct 2015 21:25:01
Revision:398895Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL port to latest version.

Two security issues have been fixed in this release which affect users
of specific PostgreSQL features:

CVE-2015-5289: json or jsonb input values constructed from arbitrary
user input can crash the PostgreSQL server and cause a denial of
service.

CVE-2015-5288: The crypt( function included with the optional pgCrypto
extension could be exploited to read a few additional bytes of memory.
No working exploit for this issue has been developed.

This update will also disable SSL renegotiation by default;
previously, it was enabled by default.   SSL renegotiation will be
removed entirely in PostgreSQL versions 9.5 and later.

URL:		http://www.postgresql.org/about/news/1615/
Security:	CVE-2015-5288 CVE-2015-5289
9.1.18_1
24 Jul 2015 06:05:23
Revision:392771Original commit files touched by this commit This port version is marked as vulnerable.
bapt search for other commits by this committer
Really fix ldap option
9.1.18_1
22 Jul 2015 23:20:03
Revision:392703Original commit files touched by this commit This port version is marked as vulnerable.
bapt search for other commits by this committer
Fix ldap option
9.1.18_1
22 Jul 2015 23:10:40
Revision:392702Original commit files touched by this commit This port version is marked as vulnerable.
bapt search for other commits by this committer
Only defined options marked as server only for the servers
Remove (server) from the description
9.1.18_1
22 Jul 2015 22:56:56
Revision:392701Original commit files touched by this commit This port version is marked as vulnerable.
bapt search for other commits by this committer
UNIQUENAME is not used anymore for long to save options
9.1.18_1
22 Jul 2015 22:45:36
Revision:392699Original commit files touched by this commit This port version is marked as vulnerable.
bapt search for other commits by this committer
Simplify a bit the Makefiles

Use OPTIONS_SUB to automatically PLIST_SUB
Use OPTIONS helpers
9.1.18_1
22 Jul 2015 21:46:28
Revision:392696Original commit files touched by this commit This port version is marked as vulnerable.
bapt search for other commits by this committer
Cleanup plist and avoid useless @exec
9.1.18
12 Jun 2015 13:00:50
Revision:389267Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL to latest versions.

Earlier update releases attempted to fix an issue in PostgreSQL 9.3 and 9.4
with "multixact wraparound", but failed to account for issues doing multixact
cleanup during crash recovery. This could cause servers to be unable to restart
after a crash. As such, all users of 9.3 and 9.4 should apply this update as
soon as possible.

URL:	http://www.postgresql.org/about/news/1592/
9.1.17
05 Jun 2015 14:57:29
Revision:388585Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL to latest versions.
The update is mostly to fix the file persmission problem described
in the URL below. You might want to wait until next upgrade, depending
on you local configuration.
URL:	http://www.postgresql.org/about/news/1590/
9.1.16
22 May 2015 23:22:20
Revision:387089Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL ports to latest version.

Data Corruption Fix

For users of PostgreSQL versions 9.3 or 9.4, this release fixes a problem where
the database will fail to protect against "multixact wraparound", resulting in
data corruption or loss. Users with a high transaction rate (1 million or more
per hour) in a database with many foreign keys are especially vulnerable. We
strongly urge all users of 9.4 and 9.3 to update their installations in the
next few days.

Users of versions 9.2 and earlier are not affected by this issue.

Security:	fc38cd83-00b3-11e5-8ebd-0026551a22dc
9.1.15_1
14 May 2015 10:15:09
Revision:386312Original commit files touched by this commit This port version is marked as vulnerable.
mat search for other commits by this committer
MASTER_SITES cleanup.

- Replace ${MASTER_SITE_FOO} with FOO.
- Merge MASTER_SITE_SUBDIR into MASTER_SITES when possible. (This means 99.9%
  of the time.)
- Remove occurrences of MASTER_SITE_LOCAL when no subdirectory was present and
  no hint of what it should be was present.
- Fix some logic.
- And generally, make things more simple and easy to understand.

While there, add magic values to the FESTIVAL, GENTOO, GIMP, GNUPG, QT and
SAMBA macros.

Also, replace some EXTRACT_SUFX occurences with USES=tar:*.

Checked by:	make fetch-urlall-list
With hat:	portmgr
Sponsored by:	Absolight
9.1.15_1
19 Apr 2015 11:12:22
Revision:384279Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Commit the missing part of last commit: Chase upcoming update of ICU to 5.5.
9.1.15_1
18 Apr 2015 12:37:23
Revision:384223Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Chase upcoming update of ICU to 5.5.
9.1.15
05 Apr 2015 09:00:59
Revision:383272Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
remove redundant cpe markers on the slave ports
9.1.15
25 Mar 2015 09:33:53
Revision:382201Original commit files touched by this commit This port version is marked as vulnerable.
marino search for other commits by this committer
databases category: Remove $PTHREAD_LIBS

Note: virtuoso did not pass check-plist from before, so it was fixed.

approved by:	PTHREAD blanket
9.1.15
20 Mar 2015 08:42:19
Revision:381720Original commit files touched by this commit This port version is marked as vulnerable.
robak search for other commits by this committer
databases/postgresql91-server: add CPE information

- Maintainer's timeout (pgsql@FreeBSD.org)

PR:		197486
Submitted by:	Shun <shun.fbsd.pr@dropcut.net>
9.1.15
07 Feb 2015 17:05:08
Revision:378604Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Revert the change from readline to libedit, and instead make libedit optional.
PR:	ports/197362
9.1.15
05 Feb 2015 22:54:35
Revision:378500Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL-9.x to latests versions.

This update fixes multiple security issues reported in PostgreSQL over the past
few months. All of these issues require prior authentication, and some require
additional conditions, and as such are not considered generally urgent.
However, users should examine the list of security holes patched below in case
they are particularly vulnerable.

Security:	CVE-2015-0241,CVE-2015-0242,CVE-2015-0243,
		CVE-2015-0244,CVE-2014-8161
9.1.14_1
12 Nov 2014 09:53:42
Revision:372487Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Revert r247147.
We need -pthread in LDFLAGS for threaded extensions like plv8js to work.

PR:		175783
Submitted by:	Li-Wen Hsu <lwhsu@FreeBSD.org>
9.1.14
10 Sep 2014 13:34:54
Revision:367837Original commit files touched by this commit This port version is marked as vulnerable.
bapt search for other commits by this committer
Turn OPTIONS_SINGLE KRB5 into an OPTIONS_RADIO like it is supposed to be

PR:		193451
Submitted by:	dmitry2004@yandex.ru
9.1.14
25 Aug 2014 17:53:27
Revision:366114Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
Convert pgsql ports to use USES+=pgsql

Reviewed by:	bapt
9.1.14
02 Aug 2014 07:01:54
Revision:363792Original commit files touched by this commit This port version is marked as vulnerable.
mva search for other commits by this committer
- Unbreak builds after the lang/python27 update (r363790)

Exp-run:	192242, 192244
9.1.14
30 Jul 2014 18:21:47
Revision:363500Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
Update to the latest snapshots.

uuid-ossp patch has been outdated with irrelevant changes (for us),
so massage back in.

In head of postgresql, this is handled properly, so eventually the ossp patches
can go.
9.1.13_2
24 Jul 2014 18:34:16
Revision:362835Original commit files touched by this commit This port version is marked as vulnerable.
tijl search for other commits by this committer
net/openldap24-*:
- Convert to USES=libtool and bump dependent ports
- Avoid USE_AUTOTOOLS
- Don't use PTHREAD_LIBS
- Use MAKE_CMD

databases/glom:
- Drop :keepla
- Add INSTALL_TARGET=install-strip

databases/libgda4* databases/libgda5*:
- Convert to USES=libtool and bump dependent ports
- USES=tar:xz
- Use INSTALL_TARGET=install-strip
- Use @sample
(Only the first 15 lines of the commit message are shown above View all of this commit message)
9.1.13_1
16 Jul 2014 07:59:59
Revision:362047Original commit files touched by this commit This port version is marked as vulnerable.
bapt search for other commits by this committer
Fix non default LIB_DEPENDS

With hat:	portmgr
9.1.13_1
24 Jun 2014 22:34:28
Revision:359153Original commit files touched by this commit This port version is marked as vulnerable.
bapt search for other commits by this committer
Properly call MAKE_CMD
9.1.13_1
16 Jun 2014 16:52:46
Revision:358026Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Fix bad ICU_patchfile

PR:		191044
Submitted by:	melvyn
9.1.13_1
12 Jun 2014 12:46:52
Revision:357591Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
In preparation for upcoming ICU-5.3 upgrade, I failed to update distfile on
slave ports
9.1.13_1
16 Apr 2014 18:28:50
Revision:351411Original commit files touched by this commit This port version is marked as vulnerable.
zeising search for other commits by this committer
The FreeBSD x11@ and graphics team proudly presents
a zeising, kwm production, with help from dumbbell, bdrewery:

NEW XORG ON FREEBSD 9-STABLE AND 10-STABLE

This update switches over to use the new xorg stack by default on FreeBSD 9
and 10 stable, on osversions where vt(9) is available.
It is still possible to use the old stack by specifying WITHOUT_NEW_XORG in
/etc/make.conf .
FreeBSD 8-STABLE and released versions of FreeBSD still use
the old version.
A package repository with binary packages for new xorg will
be available soon.

This patch also contains updates of libxcb and related ports, pixman, as well
(Only the first 15 lines of the commit message are shown above View all of this commit message)
9.1.13
21 Mar 2014 08:15:26
Revision:348732Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Fix mistake with ossp-uuid: don't use --with-ossp-uuid, since it will need
the ossp library present, and then we never use it.
9.1.13
20 Mar 2014 13:43:16
Revision:348685Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
The PostgreSQL Global Development Group has released an update to all supported
version of the database system, including versions 9.3.4, 9.2.8, 9.1.13,
9.0.17, and 8.4.21. This minor release fixes a data corruption issue with
replication and crash recovery in version 9.3, as well as several other minor
issues in all versions.  All users of version 9.3 are urged to update their
installations at the next possible downtime.  Users of older versions should
update at their convenience.

The data corruption issue in PostgreSQL 9.3 affects binary replication
standbys, servers being recovered from point-in-time-recovery backup, and
standalone servers which recover from a system crash. The bug causes
unrecoverable index corruption during recovery due to incorrect replay of row
locking operations.  This can then cause query results to be inconsistent
depending on whether or not an index is used, and eventually lead to primary
key violations and similar issues.  For this reason, users are encouraged to
(Only the first 15 lines of the commit message are shown above View all of this commit message)
9.1.12
26 Feb 2014 17:24:36
Revision:346217Original commit files touched by this commit This port version is marked as vulnerable.
antoine search for other commits by this committer
Stage support

Reviewed by:	postgresql@
Tested by:	miwi and me
9.1.12
21 Feb 2014 20:42:21
Revision:345542Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
remove missing tzdata files
9.1.12
20 Feb 2014 18:11:38
Revision:345257Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
The PostgreSQL Global Development Group has released an important
update to all supported versions of the PostgreSQL database system,
which includes minor versions 9.3.3, 9.2.7, 9.1.12, 9.0.16, and
8.4.20. This update contains fixes for multiple security issues, as
well as several fixes for replication and data integrity issues.  All
users are urged to update their installations at the earliest
opportunity, especially those using binary replication or running a
high-security application.

This update fixes CVE-2014-0060, in which PostgreSQL did not properly
enforce the WITH ADMIN OPTION permission for ROLE management. Before
this fix, any member of a ROLE was able to grant others access to the
same ROLE regardless if the member was given the WITH ADMIN OPTION
permission. It also fixes multiple privilege escalation issues,
including: CVE-2014-0061, CVE-2014-0062, CVE-2014-0063, CVE-2014-0064,
CVE-2014-0065, and CVE-2014-0066. More information on these issues can
be found on our security page and the security issue detail wiki page.

Security:	CVE-2014-0060,CVE-2014-0061,CVE-2014-0062,CVE-2014-0063
		CVE-2014-0064,CVE-2014-0065,CVE-2014-0066,CVE-2014-0067
9.1.11_1
10 Feb 2014 23:46:46
Revision:343714Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
fix messed up file sizes for icu patch
9.1.11_1
10 Feb 2014 16:32:41
Revision:343650Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Chase ICU update
9.1.11_1
07 Feb 2014 11:44:09
Revision:343214Original commit files touched by this commit This port version is marked as vulnerable.
bapt search for other commits by this committer
Chase boost and icu bump
While here convert some LIB_DEPENDS
9.1.11
11 Dec 2013 18:08:53
Revision:336187Original commit files touched by this commit This port version is marked as vulnerable.
bapt search for other commits by this committer
In preparation for making libtool generate libraries with a sane name, fix all
LIB_DEPENDS in databases
9.1.11
05 Dec 2013 15:59:53
Revision:335673Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
The PostgreSQL Global Development Group has released a critical update
to all supported versions of the PostgreSQL database system, which
includes minor versions 9.3.2, 9.2.6, 9.1.11, 9.0.15, and 8.4.19. This
update fixes three serious data-loss bugs affecting replication and
database maintenance.  All users are urged to update their
installations at the earliest opportunity.

URL:	http://www.postgresql.org/about/news/1492/
9.1.10
28 Oct 2013 18:52:22
Revision:331888Original commit files touched by this commit This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Fix PLIST for python3

Submitted by:	sunpoet (myself)
Approved by:	crees (pgsql)
9.1.10
15 Oct 2013 17:17:06
Revision:330414Original commit files touched by this commit This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Remove DISTV: only used in PKGNAMESUFFIX and complained by portlint
- Convert to new LIB_DEPENDS format for postgresql*-contrib

Submitted by:	sunpoet (myself)
Reviewed by:	crees (pgsql)
Approved by:	jgh (pgsql)
9.1.10
12 Oct 2013 00:59:50
Revision:330109Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL ports to 9.3.1, 9.2.5, 9.1.10, 9.0.14, and 8.4.18.

Note that users of the hstore extension on version 9.3 must take an additional,
post upgrade step of running "ALTER EXTENSION hstore UPDATE" in each database
after update.

URL:	http://www.postgresql.org/about/news/1487/
9.1.9
10 Oct 2013 00:09:35
Revision:329946Original commit files touched by this commit This port version is marked as vulnerable.
jgh search for other commits by this committer
- Fix pkg name collision

Reviewed by: pgsql@
With hat: pgsql@
9.1.9
07 Oct 2013 20:03:38
Revision:329729Original commit files touched by this commit This port version is marked as vulnerable.
jgh search for other commits by this committer
- revert r329725

Reported by: qat@
With hat: pgsql@
9.1.9
07 Oct 2013 19:04:04
Revision:329725Original commit files touched by this commit This port version is marked as vulnerable.
jgh search for other commits by this committer
- Fix pkg name collision

Reviewed by: crees@
With hat: pgsql@
9.1.9
20 Sep 2013 16:13:49
Revision:327717Original commit files touched by this commit This port version is marked as vulnerable.
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
databases)
9.1.9
07 Jul 2013 00:15:47
Revision:322415Original commit files touched by this commit This port version is marked as vulnerable.
jgh search for other commits by this committer
- convert from USE_GMAKE to USES=gmake
- trim historical headers

With hat: pgsql@
9.1.9
06 May 2013 18:37:00
Revision:317540Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
Don't build client with ldap-- this is unnecessary and causes build breakage
for package building because of lack of LDAP installation.

PR:		ports/177381
Tested by:	Chris Dukes <chris.dukes.aix@gmail.com>
9.1.9
28 Apr 2013 18:15:06
Revision:316740Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
databases/postgresql-server ports: Unbreak NLS

Submitted by:	bapt
9.1.9
28 Apr 2013 14:00:03
Revision:316726Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
databases/postgresql{84,91,92}-server: Readd bsd.port.pre.mk; it is required for
checking existence of files in FILESDIR
9.1.9
26 Apr 2013 15:10:57
Revision:316620Original commit files touched by this commit This port version is marked as vulnerable.
bapt search for other commits by this committer
Convert USE_GETTEXT -> USES=gettext

While here:
- Trim headers
- Remove some useless pre.mk/post.mk
- Convert to optionsng
9.1.9
04 Apr 2013 13:21:23
Revision:315718Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
The PostgreSQL Global Development Group has released a security
update to all current versions of the PostgreSQL database system,
including versions 9.2.4, 9.1.9, 9.0.13, and 8.4.17. This update
fixes a high-exposure security vulnerability in versions 9.0 and
later. All users of the affected versions are strongly urged to apply
the update *immediately*.

A major security issue (for versions 9.x only) fixed in this release,
[CVE-2013-1899](http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-1899),
makes it possible for a connection request containing a database name
that begins with "-" to be crafted that can damage or destroy files
within a server's data directory. Anyone with access to the port the
PostgreSQL server listens on can initiate this request. This issue was
discovered by Mitsumasa Kondo and Kyotaro Horiguchi of NTT Open Source
Software Center.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
9.1.8
08 Feb 2013 07:54:10
Revision:311915Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
PostgreSQL 9.2.3, 9.1.8, 9.0.12, 8.4.16 and 8.3.23 released

This update fixes a denial-of-service (DOS) vulnerability.  All users
should update their PostgreSQL installations as soon as possible.

The security issue fixed in this release, CVE-2013-0255, allows a
previously authenticated user to crash the server by calling
an internal function with invalid arguments.

URL:	http://www.postgresql.org/about/news/1446/
Security: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-0255
9.1.7_1
22 Jan 2013 18:32:00
Revision:310833Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
Remove versioned PKGNAMESUFFIX from -plpython ports; the versions differ anyway

Submitted by:	sunpoet
9.1.7_1
22 Jan 2013 17:59:42
Revision:310832Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
Fix package build for -plpython

Although the plpython work was done by rm, this problem was actually my fault

Noticed by:	sunpoet
9.1.7_1
20 Jan 2013 10:17:45
Revision:310679Original commit files touched by this commit This port version is marked as vulnerable.
rm search for other commits by this committer
- add pkg-plist changes, forgotten in r310678
- fix portname in MOVED
- remove trailing whitespace in MOVED, while here
9.1.7_1
27 Dec 2012 21:11:42
Revision:309555Original commit files touched by this commit This port version is marked as vulnerable.
jgh search for other commits by this committer
- remove broken configurable non-default user/group for postgresql-server
- while here fix formatting of new header

With hat: pgsql@
9.1.7_1
19 Dec 2012 16:13:30
Revision:309247Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Chase ICU update properly and bump PORTREVISION
9.1.7
19 Dec 2012 16:03:59
Revision:309246Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Chase ICU update to 50
9.1.7
06 Dec 2012 16:40:36
Revision:308391Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
The PostgreSQL Global Development Group has released an update to all current
versions of the PostgreSQL database system, including versions 9.2.2, 9.1.7,
9.0.11, 8.4.15, and 8.3.22.  Users of PostgreSQL Hot Standby replication
should update at the next possible opportunity. Other users should update
at their next maintenance window.

Deprecate the 8.3.22 version, since it is near end-of-life.

URL:	http://www.postgresql.org/about/news/1430/

Feature safe: yes
9.1.6
16 Oct 2012 17:28:22
Revision:305983Original commit files touched by this commit This port version is marked as vulnerable.
jgh search for other commits by this committer
- adopt optionsNG

with hat pgsql@
Feature safe: yes
9.1.6
24 Sep 2012 22:03:11
Revision:304804Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
Update PostgreSQL to 9.2.1, 9.1.6, 9.0.10, 8.4.14 and 8.3.21 respectively.

This update fixes critical issues for major versions 9.1 and 9.2, and
users running those versions should apply it as soon as possible.

URL:	http://www.postgresql.org/about/news/1416/
9.1.5
19 Aug 2012 15:24:30
Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
Use pre-build instead of pre-everything for backupwarning-- stop making people
wait before fetching etc

Suggested by:	ohauer
Discussed with:	girgen

While here, fix package for postgresql92-server
9.1.5
17 Aug 2012 19:39:51
Original commit files touched by this commit This port version is marked as vulnerable.
jgh search for other commits by this committer
The PostgreSQL Global Development Group today released security updates for all
active branches
of the PostgreSQL database system, including versions 9.1.5, 9.0.9, 8.4.13 and
8.3.20. This
update patches security holes associated with libxml2 and libxslt, similar to
those affecting
other open source projects. All users are urged to update their installations at
the first
available opportunity.

This security release fixes a vulnerability in the built-in XML functionality,
and a vulnerability
in the XSLT functionality supplied by the optional XML2 extension. Both
vulnerabilities allow
reading of arbitrary files by any authenticated database user, and the XSLT
vulnerability
allows writing files as well. The fixes cause limited backwards compatibility
issues.
These issues correspond to the following two vulnerabilities:

CVE-2012-3488: PostgreSQL insecure use of libxslt
CVE-2012-3489: PostgreSQL insecure use of libxml2
This release also contains several fixes to version 9.1, and a smaller number of
fixes to older versions, including:
(Only the first 15 lines of the commit message are shown above View all of this commit message)
9.1.4
04 Jun 2012 11:00:52
Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
The PostgreSQL Global Development Group today released security updates for all
active branches of the PostgreSQL database system, including versions 9.1.4,
9.0.8, 8.4.12 and 8.3.19.

Users of the crypt(text, text) function with DES encryption in the optional
pg_crypto module should upgrade their installations immediately, if you have'nt
already updated since the port was patched on May 30.  All other database
administrators are urged to upgrade your version of PostgreSQL at the
next scheduled downtime.

URL:      http://www.postgresql.org/about/news/1398/

Security: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-2143
          Fix incorrect password transformation in contrib/pgcrypto’s DES
crypt() function
          This was fixed in a patch release for the FreeBSD ports on May 30.

Security: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-2655
          Ignore SECURITY DEFINER and SET attributes for a procedural
language’s call handle
9.1.3_1
30 May 2012 22:26:15
Original commit files touched by this commit This port version is marked as vulnerable.
jgh search for other commits by this committer
- Address postgresql*-servers for crypt vulnerability (CVE-2012-2143)

http://www.postgresql.org/about/news/1397/

With hat: pgsql
9.1.3
05 Mar 2012 21:18:50
Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
Break postgresql-pltcl up into versioned ports; now we will have packages

Fix plist for 9.1
9.1.3
05 Mar 2012 20:10:22
Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
Various tidiness patches:
 - Compact -plperl ports
 - Portlint for 90-plperl
 - Update version numbers in pkg-install-server
 - s/spaces/tabs/
 - Use ${} instead of $()
 - s/YES/yes/
 - Tidy IGNORE values

Submitted by:   sunpoet
9.1.3
04 Mar 2012 17:58:21
Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
Don't clobber do-build from slave ports

PR:             ports/165265
Submitted by:   Ben Morrow <ben@morrow.me.uk>
9.1.3
04 Mar 2012 17:19:59
Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
Over to new team, pgsql@FreeBSD.org
9.1.3
29 Feb 2012 19:42:37
Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
Fix plist.

Pointyhat:      pav --> girgen
9.1.3
27 Feb 2012 16:24:48
Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
The PostgreSQL Global Development Group today released security updates for all
active branches of the PostgreSQL object-relational database system, including
versions 9.1.3, 9.0.7, 8.4.11 and 8.3.18.

Users of pg_dump, users of SSL certificates for validation or users of triggers
using SECURITY DEFINER should upgrade their installations immediately. All
other database administrators are urged to upgrade your version of PostgreSQL
at the next scheduled downtime. More details on the security fixes here:

URL:    http://www.postgresql.org/about/news/1377/

Security: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0866
Security: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0867
Security: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0868
9.1.2_4
19 Feb 2012 19:35:02
Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
Remove p5- from postgresql*-plperl 's mention in pkg-message-client
9.1.2_4
19 Feb 2012 19:04:51
Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
Fix -plperl plist for 9.1
9.1.2_4
05 Feb 2012 15:32:49
Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
Install new pg_basebackup tool by default

Submitted by:   kuriyama
9.1.2_3
01 Feb 2012 19:31:58
Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
Minor changes for UNIQUENAME; remove excessive hyphens

Apologies for the noise here; I'm getting used to the consequences of
slaving ports like this-- postgresql has an unusual arrangement here.

Submitted by:   Neil Darlow (neil@darlow.co.uk)
9.1.2_3
31 Jan 2012 18:21:33
Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
- Stop clobbering postgresql-server/-client OPTIONS with -contrib OPTIONS
- Minor optimisation (stop testing for !SLAVE_ONLY twice)

PR:             ports/164662
9.1.2_3
30 Jan 2012 18:39:57
Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
Use DISTVERSION instead of PORTVERSION to generate UNIQUENAME; options
don't work correctly otherwise.

http://lists.freebsd.org/pipermail/freebsd-ports/2012-January/072756.html

Pointyhat:      crees
9.1.2_3
25 Jan 2012 21:12:33
Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
- To preserve my sanity, slave 82 and 83 to 84, and 90 to 91, resulting in
  three fewer Makefiles to maintain

- Switch patch master site

- Various cleanups
9.1.2_3
23 Jan 2012 20:36:58
Original commit files touched by this commit This port version is marked as vulnerable.
crees search for other commits by this committer
Add OPTION to postgresql9[10]-contrib for building without uuid-ossp

Requested by:   sunpoet
9.1.2_3
22 Jan 2012 06:59:27
Original commit files touched by this commit This port version is marked as vulnerable.
jgh search for other commits by this committer
- Add profile support for PostgreSQL servers
- re-assign LOCALBASE to PREFIX
- add PG_GROUP to SUB_PLIST for packaging fix
- fix permissions for package installations

PR:     ports/162776
Submitted by:   jgh, Phil Phillips < pphillips at experts-exchange.com >
Reviewed by: rene (mentor)
Approved by: crees (maintainer, mentor)
9.1.2_2
19 Jan 2012 19:06:00
Original commit files touched by this commit This port version is marked as vulnerable.
jgh search for other commits by this committer
fix typo %%PG_GROUP%% in pkg-plist-server

Spotted by: decke
Approved by:    crees, rene (mentors,implicit)
9.1.2_1
19 Jan 2012 03:35:49
Original commit files touched by this commit This port version is marked as vulnerable.
tabthorpe search for other commits by this committer
- Reset ports due to maintainer timeouts and lack of response to emails

With hat:       portmgr
9.1.2_1
18 Jan 2012 21:35:11
Original commit files touched by this commit This port version is marked as vulnerable.
jgh search for other commits by this committer
Fix plist to create directory with proper ownerships PostgreSQL database
may start.

PR:     ports/164273 (critical)
Submitted by: Alexander Yerenkow <yerenkow at gmail.com>
Approved by:    maintainer-timeout: girgen (1 day), portmgr (linimon)
9.1.2
14 Jan 2012 08:57:23
Original commit files touched by this commit This port version is marked as vulnerable.
dougb search for other commits by this committer
In the rc.d scripts, change assignments to rcvar to use the
literal name_enable wherever possible, and ${name}_enable
when it's not, to prepare for the demise of set_rcvar().

In cases where I had to hand-edit unusual instances also
modify formatting slightly to be more uniform (and in
some cases, correct). This includes adding some $FreeBSD$
tags, and most importantly moving rcvar= to right after
name= so it's clear that one is derived from the other.
9.1.2
05 Dec 2011 16:45:14
Original commit files touched by this commit This port version is marked as vulnerable.
girgen search for other commits by this committer
The PostgreSQL Global Development Group today released updates for all
active branches of the PostgreSQL object-relational database system,
including versions 9.1.2, 9.0.6, 8.4.10, 8.3.17 and 8.2.23.

This release contains 52 fixes to version 9.1, and a smaller number of
fixes to older versions, including:

- Fix bugs in information_schema.referential_constraints view**
- Correct collations for citext columns and indexes**
- Prevent possible crash when joining to a scalar function
- Prevent transitory data corruption of GIN indexes after a crash
- Prevent data corruption on TOAST columns when copying data
- Fix failures during hot standby startup
- Correct another "variable not found in subplan target list" bug
- Fix bug with sorting on aggregate expressions in windowing functions
(Only the first 15 lines of the commit message are shown above View all of this commit message)

Number of commits found: 120 (showing only 100 on this page)

1 | 2  »