notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
Some details on the 2023-01-16 website outage.
We just rebooted with several updates: * new HMTLify code * no port maintainer is now highly visible (e.g. https://freshports.org/security/sssd/) * fixed search logic error when using plain/ text details at https://github.com/FreshPorts/freshports/releases/tag/2.2.34
Port details
gwenhywfar-qt4 Gwenhywfar Qt4 support library
4.20.0 devel Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch. NOTE: Slave port - quarterly revision is most likely wrong.
Broken BROKEN: Not supported
Ignore IGNORE: is marked as broken: Not supported
Maintainer: jhale@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2012-09-01 17:06:05
Last Update: 2019-03-16 21:55:51
SVN Revision: 495967
Also Listed In: net security
License: LGPL21+
Description:
Homepage    cgit ¦ GitHub ¦ GitHub ¦ GitLab ¦ SVNWeb
pkg-plist: as obtained via: make generate-plist
Expand this list (12 items)
Collapse this list.
  1. /usr/local/share/licenses/gwenhywfar-qt4-4.20.0/catalog.mk
  2. /usr/local/share/licenses/gwenhywfar-qt4-4.20.0/LICENSE
  3. /usr/local/share/licenses/gwenhywfar-qt4-4.20.0/LGPL21+
  4. include/gwenhywfar4/gwen-gui-qt4/qt4_gui.hpp
  5. lib/cmake/gwengui-qt4-4.20/gwengui-qt4-config-version.cmake
  6. lib/cmake/gwengui-qt4-4.20/gwengui-qt4-config.cmake
  7. lib/libgwengui-qt4.so
  8. lib/libgwengui-qt4.so.0
  9. lib/libgwengui-qt4.so.0.0.0
  10. libdata/pkgconfig/gwengui-qt4.pc
  11. @postexec /usr/sbin/service ldconfig restart > /dev/null
  12. @postunexec /usr/sbin/service ldconfig restart > /dev/null
Collapse this list.
Dependency lines:
  • gwenhywfar-qt4>0:devel/gwenhywfar-qt4
No installation instructions:
This port has been deleted.
PKGNAME: gwenhywfar-qt4
Flavors: there is no flavor information for this port.
distinfo:

Packages (timestamps in pop-ups are UTC):
gwenhywfar-qt4
ABIlatestquarterly
FreeBSD:11:aarch644.20.0pkg-fallout
FreeBSD:11:amd64pkg-falloutpkg-fallout
FreeBSD:11:armv64.14.0pkg-fallout
FreeBSD:11:i386pkg-falloutpkg-fallout
FreeBSD:11:mipspkg-falloutpkg-fallout
FreeBSD:11:mips64pkg-falloutpkg-fallout
FreeBSD:12:aarch644.20.0pkg-fallout
FreeBSD:12:amd64pkg-falloutpkg-fallout
FreeBSD:12:armv64.20.0pkg-fallout
FreeBSD:12:armv74.20.0pkg-fallout
FreeBSD:12:i386pkg-falloutpkg-fallout
FreeBSD:12:mipspkg-falloutpkg-fallout
FreeBSD:12:mips64pkg-falloutpkg-fallout
FreeBSD:12:powerpc64pkg-falloutpkg-fallout
FreeBSD:13:aarch64pkg-falloutpkg-fallout
FreeBSD:13:amd64pkg-falloutpkg-fallout
FreeBSD:13:armv6pkg-falloutpkg-fallout
FreeBSD:13:armv7pkg-falloutpkg-fallout
FreeBSD:13:i386pkg-falloutpkg-fallout
FreeBSD:13:mipspkg-falloutpkg-fallout
FreeBSD:13:mips64pkg-falloutpkg-fallout
FreeBSD:13:powerpc64pkg-falloutpkg-fallout
FreeBSD:13:riscv64pkg-falloutpkg-fallout
FreeBSD:14:aarch64pkg-falloutpkg-fallout
FreeBSD:14:amd64pkg-falloutpkg-fallout
FreeBSD:14:armv6pkg-falloutpkg-fallout
FreeBSD:14:armv7pkg-falloutpkg-fallout
FreeBSD:14:i386pkg-falloutpkg-fallout
FreeBSD:14:mipspkg-falloutpkg-fallout
FreeBSD:14:mips64pkg-falloutpkg-fallout
FreeBSD:14:powerpc64pkg-falloutpkg-fallout
FreeBSD:14:riscv64pkg-falloutpkg-fallout
 

Master port: devel/gwenhywfar

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. msgfmt : devel/gettext-tools
  2. gmake : devel/gmake
  3. pkgconf>=1.3.0_1 : devel/pkgconf
Library dependencies:
  1. libgcrypt.so : security/libgcrypt
  2. libgnutls.so : security/gnutls
  3. libgpg-error.so : security/libgpg-error
  4. libgwenhywfar.so : devel/gwenhywfar
  5. libintl.so : devel/gettext-runtime
  6. libiconv.so : converters/libiconv
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Libraries

Deleted ports which required this port:

Expand this list of 1 deleted port
  1. finance/kmymoney-kde4*
  2. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message

Master Sites:
Expand this list (1 items)
Collapse this list.
  1. http://www.aquamaniac.de/sites/download/download.php?package=01&release=208&file=02&dummy=/
Collapse this list.
Port Moves
  • port deleted on 2019-03-16
    REASON: Has expired: Qt4 has been EOL since december 2015

Number of commits found: 13

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
This is a slave port. You may also want to view the commits to the master port: devel/gwenhywfar
CommitCreditsLog message
4.20.0
16 Mar 2019 21:55:51
Revision:495967Original commit files touched by this commit
tcberner search for other commits by this committer
Qt4 deprecation: Remove Qt4 and its consumes.

2019-03-15 accessibility/qt4-accessible: Qt4 has been EOL since december 2015
2019-03-15 astro/qlandkartegt: Qt4 has been EOL since december 2015
2019-03-15 astro/stellarium-qt4: Qt4 has been EOL since december 2015
2019-03-15 astro/xglobe: Qt4 has been EOL since december 2015
2019-03-15 audio/acoustid-fingerprinter: Qt4 has been EOL since december 2015
2019-03-15 audio/cueplayer: Qt4 has been EOL since december 2015
2019-03-15 audio/esperanza: Qt4 has been EOL since december 2015
2019-03-15 audio/lastfm-desktop: Qt4 has been EOL since december 2015
2019-03-15 audio/minitunes: Qt4 has been EOL since december 2015
2019-03-15 audio/mixxx20: Qt4 has been EOL since december 2015
2019-03-15 audio/mumble: Qt4 has been EOL since december 2015
2019-03-15 audio/murmur: Qt4 has been EOL since december 2015
2019-03-15 audio/puddletag: Qt4 has been EOL since december 2015
(Only the first 15 lines of the commit message are shown above View all of this commit message)
4.20.0
16 Mar 2019 21:41:17
Revision:495964Original commit files touched by this commit
tcberner search for other commits by this committer
devel/gwenhywfar: remove qt4 slave (Qt4 deprecation)

Approved by:	portmgr (implicit)
4.15.3
29 Oct 2016 11:38:35
Revision:424900Original commit files touched by this commit
jhale search for other commits by this committer
New port: devel/gwenhywfar-qt5, the Gwenhywfar Qt5 support library

While here:
- Clean up if statements in the master port
- Substitute the major.minor version in all gwenhywfar pkg-plists

devel/gwenhywfar/files/patch-configure had to be reworked, but the
changes only affect the new port and the other changes do not
affect the packages, so no PORTREVISON bump.
4.15.3
15 Oct 2016 12:30:02
Revision:424014Original commit files touched by this commit
jhale search for other commits by this committer
Update to 4.15.3
4.14.0
01 Jan 2016 05:14:55
Revision:404968Original commit files touched by this commit
jhale search for other commits by this committer
- Update devel/gwenhywfar* to 4.14.0
- Update finance/aqbanking to 5.5.1
4.3.3_2
22 Sep 2014 12:37:01
Revision:368895Original commit files touched by this commit
jhale search for other commits by this committer
- Trim @dirrm[try] from pkg-plist
4.3.3_2
23 Jul 2014 09:54:02
Revision:362645Original commit files touched by this commit
tijl search for other commits by this committer
- Replace security/gnutls with security/gnutls3 and update to 3.2.15
- Bump PORTREVISION on all ports that depend on security/gnutls and
  adjust all ports that depend on security/gnutls3
- Update mail/anubis to version 4.2 which supports gnutls 3.x
- Update mail/libvmime to a development snapshot (recommended by upstream
  developers)

PR:		191274
Exp-run by:	antoine
Approved by:	portmgr (antoine)
4.3.3_1
24 Jun 2014 11:46:45
Revision:359074Original commit files touched by this commit
amdmi3 search for other commits by this committer
- Switch devel/gwenhywfar* to USES=libtool, drop .la files
- Bump dependent ports as .so version has changed

Approved by:	portmgr blanket
4.3.3
10 Oct 2013 00:58:16
Revision:329953Original commit files touched by this commit
jhale search for other commits by this committer
- Support staging
- Use new LIB_DEPENDS syntax
- Use options helpers
4.3.3
20 Sep 2013 17:04:44
Revision:327723Original commit files touched by this commit
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
devel part 2)
4.3.3
13 Sep 2012 04:45:59
Revision:304177Original commit files touched by this commit
jhale search for other commits by this committer
- Update MAINTAINER to my new FreeBSD.org address

Approved by:	makc (mentor)
4.3.3
01 Sep 2012 17:36:04
Revision:303502Original commit files touched by this commit
rakuco search for other commits by this committer
Apply the rest of the changes that should have got in with r303495:
- svn rm some files which were just emptied in the previous commit.
- Adjust the new ports' Makefiles.

PR:		ports/170492
Submitted by:	Jason E. Hale <bsdkaffee@gmail.com> (maintainer)
4.3.3_1
01 Sep 2012 17:05:15
Revision:303495Original commit files touched by this commit
rakuco search for other commits by this committer
devel/gwenhywfar:
- Repocopy devel/gwenhywfar to devel/gwenhywfar-{fox16,gtk2,qt4}.
- devel/gwenhywfar is now a master port and new slave ports will allow the
  user to install the GUI libraries separately. This will make packaging
  easier for finance/gnucash and finance/kmymoney-kde4.

finance/aqbanking:
- finance/aqbanking has been updated to 5.0.25 and includes a shlib bump, so
  instead of making the user rebuild twice it is included here.
- Shlib bump aqbanking.33 -> aqbanking.34.
- Fix LICENSE.
- Convert to new OPTIONS framework.

finance/gnucash:
- Adjust LIB_DEPENDS for AQBANKING option so they are installed in the
(Only the first 15 lines of the commit message are shown above View all of this commit message)

Number of commits found: 13