notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
FreshPorts needs to find a new hosting provide willing to take a 2U chassis and host it free of charge. This is part of the FreshPorts project. Preferably in the Austin area. This is not a primary server, but it used for development.
Port details
libgcrypt General purpose cryptographic library based on the code from GnuPG
1.9.4_1 security on this many watch lists=268 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 1.9.4Version of this port present on the latest quarterly branch.
Maintainer: cy@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2002-10-14 12:39:38
Last Update: 2022-04-27 13:18:52
Commit Hash: 16aff2e
People watching this port, also watch:: libiconv, expat, libgpg-error, png, libxml2
License: GPLv2+ LGPL21+
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (20 items)
Collapse this list.
  1. @ldconfig
  2. /usr/local/share/licenses/libgcrypt-1.9.4_1/catalog.mk
  3. /usr/local/share/licenses/libgcrypt-1.9.4_1/LICENSE
  4. /usr/local/share/licenses/libgcrypt-1.9.4_1/GPLv2+
  5. /usr/local/share/licenses/libgcrypt-1.9.4_1/LGPL21+
  6. bin/mpicalc
  7. bin/dumpsexp
  8. bin/hmac256
  9. bin/libgcrypt-config
  10. include/gcrypt.h
  11. lib/libgcrypt.a
  12. lib/libgcrypt.so
  13. lib/libgcrypt.so.20
  14. lib/libgcrypt.so.20.3.4
  15. libdata/pkgconfig/libgcrypt.pc
  16. man/man1/hmac256.1.gz
  17. share/aclocal/libgcrypt.m4
  18. @owner
  19. @group
  20. @mode
Collapse this list.
Dependency lines:
  • For RUN/BUILD depends:
    • libgcrypt>0:security/libgcrypt
  • For LIB depends:
    • libgcrypt.so:security/libgcrypt
To install the port:
cd /usr/ports/security/libgcrypt/ && make install clean
To add the package, run one of these commands:
  • pkg install security/libgcrypt
  • pkg install libgcrypt
NOTE: If this package has multiple flavors (see below), then use one of them instead of the name specified above.
PKGNAME: libgcrypt
Flavors: there is no flavor information for this port.
distinfo:
Packages (timestamps in pop-ups are UTC):
libgcrypt
ABIlatestquarterly
FreeBSD:11:aarch641.8.31.8.5
FreeBSD:11:amd641.9.41.9.3
FreeBSD:11:armv61.7.11.8.5
FreeBSD:11:i3861.9.41.9.3
FreeBSD:11:mips--
FreeBSD:11:mips641.7.11.8.5
FreeBSD:12:aarch641.8.31.9.4
FreeBSD:12:amd641.9.4_11.9.4
FreeBSD:12:armv61.8.31.8.5
FreeBSD:12:armv71.8.31.8.5
FreeBSD:12:i3861.9.4_11.9.4
FreeBSD:12:mips--
FreeBSD:12:mips641.8.31.8.5
FreeBSD:12:powerpc64-1.9.2_1
FreeBSD:13:aarch641.9.4_11.9.4
FreeBSD:13:amd641.9.4_11.9.4
FreeBSD:13:armv61.8.71.9.4
FreeBSD:13:armv71.8.71.9.4
FreeBSD:13:i3861.9.4_11.9.4
FreeBSD:13:mips--
FreeBSD:13:mips641.8.71.8.7
FreeBSD:13:powerpc641.8.71.9.3
FreeBSD:14:aarch641.9.4_1-
FreeBSD:14:amd641.9.4_1-
FreeBSD:14:armv61.9.4_1-
FreeBSD:14:armv71.9.4_1-
FreeBSD:14:i3861.9.4_1-
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc641.9.2_1-
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. libgpg-error>=1.32 : security/libgpg-error
  2. makeinfo : print/texinfo
Runtime dependencies:
  1. libgpg-error>=1.32 : security/libgpg-error
  2. indexinfo : print/indexinfo
This port is required by:
for Build
  1. audio/libsidplayfp
  2. sysutils/rsyslog8

Deleted ports which required this port:

Expand this list of 5 deleted ports
  1. databases/drizzle*
  2. irc/irssi-otr*
  3. sysutils/rsyslog7*
  4. sysutils/rsyslog7-devel*
  5. sysutils/rsyslog8-devel*
  6. Collapse this list of deleted ports.
for Libraries
  1. archivers/rpm4
  2. audio/forked-daapd
  3. audio/libsidplayfp
  4. audio/pianobar
  5. audio/pianod2
  6. biology/ncbi-blast+
  7. comms/svxlink
Expand this list (191 items / 184 hidden - sorry, this count includes any deleted ports)
  1. Collapse this list).
  2. databases/freetds
  3. databases/libgda5-ui
  4. databases/recutils
  5. databases/xtrabackup
  6. databases/xtrabackup8
  7. devel/ccrtp
  8. devel/gvfs
  9. devel/gwenhywfar
  10. devel/gwenhywfar-fox16
  11. devel/gwenhywfar-gtk2
  12. devel/gwenhywfar-gtk3
  13. devel/gwenhywfar-qt5
  14. devel/libsoup
  15. devel/libvirt
  16. devel/libzrtpcpp
  17. devel/srecord
  18. emulators/fuse
  19. emulators/fuse-utils
  20. emulators/libspectrum
  21. ftp/filezilla
  22. games/libtmcg
  23. graphics/frogr
  24. graphics/swfmill
  25. graphics/telak
  26. irc/bitlbee
  27. irc/bitlbee-steam
  28. irc/weechat
  29. lang/gnustep-base
  30. mail/anubis
  31. mail/claws-mail
  32. mail/wmbiff
  33. misc/metalink-tools
  34. multimedia/libaacs
  35. multimedia/libbdplus
  36. multimedia/libmtp
  37. multimedia/libquvi09
  38. multimedia/totem-pl-parser
  39. multimedia/vlc
  40. multimedia/zoneminder
  41. net/freediameter
  42. net/grive2
  43. net/gtk-vnc
  44. net/kget
  45. net/libvncserver
  46. net/ndpi
  47. net/netatalk3
  48. net/ntopng
  49. net/remmina
  50. net/samba412
  51. net/samba413
  52. net/tigervnc-server
  53. net/tigervnc-viewer
  54. net/tshark
  55. net/tshark-lite
  56. net/vino
  57. net/wireshark
  58. net/wireshark-lite
  59. net-im/dino
  60. net-im/ktp-common-internals
  61. net-im/profanity
  62. net-im/telegram-purple
  63. net-mgmt/collectd5
  64. net-p2p/ktorrent
  65. net-p2p/libktorrent
  66. net-p2p/ncdc
  67. polish/kadu
  68. security/dirmngr
  69. security/fiked
  70. security/gcr
  71. security/gnome-keyring
  72. security/gnomint
  73. security/gnupg
  74. security/gnupg-pkcs11-scd
  75. security/gsad
  76. security/gvm-libs
  77. security/kdbxviewer
  78. security/keepass
  79. security/libgnome-keyring
  80. security/libgsasl
  81. security/libotr
  82. security/libotr3
  83. security/libsecret
  84. security/monkeysphere
  85. security/openvas
  86. security/openvpn-auth-radius
  87. security/p5-Crypt-GCrypt
  88. security/pam-pgsql
  89. security/pidgin-otr
  90. security/plasma5-kwallet-pam
  91. security/seccure
  92. security/shishi
  93. security/vpnc
  94. security/xmlsec1
  95. sysutils/amtc
  96. sysutils/bulk_extractor
  97. sysutils/freeipmi
  98. sysutils/fusefs-cryptofs
  99. sysutils/kf5-kwallet
  100. sysutils/libdnf
  101. sysutils/rsyslog8
  102. textproc/libxslt
  103. textproc/p5-XML-LibXSLT
  104. textproc/pdfgrep
  105. textproc/rubygem-nokogiri
  106. textproc/rubygem-nokogiri111
  107. www/chromium
  108. www/iridium
  109. www/webkit2-gtk3
  110. www/webkit2-gtk4
  111. x11/lightdm
  112. x11/yelp
  113. Collapse this list.

Deleted ports which required this port:

Expand this list of 73 deleted ports
  1. audio/libmtp*
  2. databases/freetds-msdblib*
  3. databases/libgda4*
  4. databases/libgda4-bdb*
  5. databases/libgda4-jdbc*
  6. databases/libgda4-ldap*
  7. databases/libgda4-mdb*
  8. databases/libgda4-mysql*
  9. databases/libgda4-postgresql*
  10. deskutils/chmsee*
  11. devel/gwenhywfar-qt4*
  12. devel/libsoup-gnome*
  13. devel/libsoup-reference*
  14. games/libggz*
  15. irc/irssi-otr*
  16. irc/weechat-devel*
  17. japanese/jd*
  18. japanese/jpilot*
  19. misc/tellico-kde4*
  20. multimedia/vlc-qt4*
  21. multimedia/vlc3*
  22. net/clamz*
  23. net/cyphesis*
  24. net/grive*
  25. net/librouteros*
  26. net/netatalk*
  27. net/quagga-re*
  28. net/remmina-plugin-vnc*
  29. net/samba4*
  30. net/samba41*
  31. net/samba410*
  32. net/samba411*
  33. net/tigervnc-devel*
  34. net/wireshark-qt5*
  35. net-p2p/gnunet*
  36. net-p2p/libktorrent-kde4*
  37. palm/jpilot*
  38. print/cups-base*
  39. print/cups-client*
  40. print/cups-image*
  41. security/gnupg20*
  42. security/gnupg22*
  43. security/greenbone-security-assistant*
  44. security/greenbone-security-assistant8*
  45. security/greenbone-security-assistant9*
  46. security/kdbx-viewer*
  47. security/keepassx-devel*
  48. security/keepassx2*
  49. security/libmatekeyring*
  50. security/mate-keyring*
  51. security/opencdk*
  52. security/openvas-libnasl*
  53. security/openvas-libraries*
  54. security/openvas-manager*
  55. security/openvas-scanner*
  56. security/openvas8-libraries*
  57. security/openvas8-manager*
  58. security/openvas8-scanner*
  59. security/openvas9-libraries*
  60. security/openvas9-manager*
  61. security/openvas9-scanner*
  62. security/pinentry-gtk*
  63. security/pinentry-qt*
  64. security/prelude-lml*
  65. security/prelude-manager*
  66. security/seahorse-plugins*
  67. sysutils/openhpi*
  68. sysutils/rsyslog5-gnutls*
  69. sysutils/rsyslog6-devel-gnutls*
  70. sysutils/rsyslog6-gnutls*
  71. textproc/rubygem-nokogiri18*
  72. x11/kde-runtime-kde4*
  73. x11/kde4-runtime*
  74. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (11 items)
Collapse this list.
  1. ftp://ftp.crysys.hu/pub/gnupg/libgcrypt/
  2. ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/libgcrypt/
  3. ftp://ftp.freenet.de/pub/ftp.gnupg.org/gcrypt/libgcrypt/
  4. ftp://ftp.gnupg.org/gcrypt/libgcrypt/
  5. ftp://mirror.switch.ch/mirror/gnupg/libgcrypt/
  6. http://mirror.tje.me.uk/pub/mirrors/ftp.gnupg.org/libgcrypt/
  7. https://artfiles.org/gnupg.org/libgcrypt/
  8. https://ftp.heanet.ie/mirrors/ftp.gnupg.org/gcrypt/libgcrypt/
  9. https://gnupg.org/ftp/gcrypt/libgcrypt/
  10. https://mirrors.dotsrc.org/gcrypt/libgcrypt/
  11. https://www.mirrorservice.org/sites/ftp.gnupg.org/gcrypt/libgcrypt/
Collapse this list.
Notes from UPDATING
These upgrade notes are taken from /usr/ports/UPDATING
  • 2013-05-03
    Affects: users of security/libgcrypt and any port that depends on it
    Author: ehaupt@FreeBSD.org
    Reason: 
      The libgcrypt port has been updated to 1.5.2 and all shared libraries
      versions have been bumped. So you need to rebuild all applications that
      depend on libgcrypt. Do something like:
    
      # portmaster -r libgcrypt
        or
      # portupgrade -rf libgcrypt
    
      Alternatively, you may install sysutils/bsdadminscripts, run pkg_libchk and
      rebuild all detected ports:
    
      # pkg_libchk | tee /tmp/rebuild
      # awk -F':' '/libgcrypt.so/ {print $1}' /tmp/rebuild | sort | uniq \
    	| xargs portmaster -D
    
    
Expand this list (3 items)
  • 2011-07-05
    Affects: users of security/libgcrypt and any port that depends on it
    Author: swills@FreeBSD.org
    Reason: 
      The libgcrypt port has been updated to 1.5.0 and all shared libraries
      versions have been bumped. So you need to rebuild all applications that
      depend on libgcrypt. Do something like:
    
      # portmaster -r libgcrypt
        or
      # portupgrade -rf libgcrypt
    
    
  • 2010-07-27
    Affects: users of security/libgcrypt
    Author: wxs@FreeBSD.org
    Reason: 
      libgcrypt has been upgraded to 1.4.6 which has a shared library version
      bump.  You need to reinstall all ports that depend on it.  Use something
      like this:
    
    	portupgrade -rf libgcrypt
    	portmaster -r libgcrypt
    
    
  • 2009-01-07
    Affects: users of security/libgcrypt
    Author: rafan@FreeBSD.org
    Reason: 
      libgcrypt has been upgraded to 1.4.3 which has a shared library version
      bump.  You need to reinstall all ports that depend on it.  Use something
      like this:
    
    	portupgrade -rf libgcrypt
    	portmaster -r libgcrypt
    
    
  • Collapse this list.

Number of commits found: 131 (showing only 100 on this page)

1 | 2  »  

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
27 Apr 2022 13:18:52
 files touched by this commit commit hash:16aff2e12fa1c4fe80447d9e457862c0b212577f  1.9.4_1
Piotr Kubaj (pkubaj) search for other commits by this committer
security/libgcrypt: enable asm on powerpc
27 Jan 2022 05:08:40
 files touched by this commit commit hash:fe14cd83dad652fbccffcdcaa81f73637f008c15  1.9.4
Cy Schubert (cy) search for other commits by this committer
Author: Greg V
security/libgcrypt: optionalize INFO

Allow the user to optionally exclude INFO files, allowing the space
conscious user the ability to install a minimual package. The default
remains to install INOF files as before.

PR:		259552
Reported by:	Greg V <greg@unrelenting.technology>
Submitted by:	Greg V <greg@unrelenting.technology>
23 Aug 2021 21:09:59
 files touched by this commit commit hash:8d78b2ea798690afa69d251bb26febd5213e4546  1.9.4
Cy Schubert (cy) search for other commits by this committer
security/libgcrypt: Update to 1.9.4
23 May 2021 03:41:32
 files touched by this commit commit hash:527821a60c9f2e706a0549ac23c8ddc6d8b778c3  1.9.3
Cy Schubert (cy) search for other commits by this committer
security/libgcrypt: Make static an option

Static linked binaries, due to the fact that they're statically linked,
can pose a security risk should a library be updated and depending
software not be recompiled and linked. This was a hot topic on BUGTRAQ
about 25 years ago.

The default is to build static libraries so as not to alter the package
avoiding a POLA violation.

PR:		255735
Submitted by:	Daniel Engberg <daniel.engberg.lists@pyret.net> (mostly)
Reported by:	Daniel Engberg <daniel.engberg.lists@pyret.net>
Reviewed by:	cy
Tested by:	cy
MFH:		2021Q2
23 May 2021 03:41:31
 files touched by this commit commit hash:865a2a94e8fd819d5598b3f2230db4e82ff7fc44  1.9.3
Cy Schubert (cy) search for other commits by this committer
security/libgcrypt: update to 1.9.3

PR:		255735
Submitted by:	Daniel Engberg <daniel.engberg.lists@pyret.net>
Reviewed by:	cy
Tested by:	cy
MFH:		2021Q2
07 Apr 2021 08:09:01
 files touched by this commit commit hash:cf118ccf875508b9a1c570044c93cfcc82bd455c  1.9.2_1
Mathieu Arnold (mat) search for other commits by this committer
One more small cleanup, forgotten yesterday.
Reported by:	lwhsu
06 Apr 2021 14:31:07
 files touched by this commit commit hash:305f148f482daf30dcf728039d03d019f88344eb  1.9.2_1
Mathieu Arnold (mat) search for other commits by this committer
Remove # $FreeBSD$ from Makefiles.
27 Mar 2021 02:55:45
Original commit files touched by this commit Revision:569290  1.9.2_1
cy search for other commits by this committer
security/libgcrypt: Fix armv7 build

Similar to armv6, armv7 fails to build jitterentropy-base.c without
optimization, falling flat on the #pragma GCC optimize statement.
Like armv6, avoid building jitterentropy-base.c altogether.

PR:		253698
17 Mar 2021 16:11:27
Original commit files touched by this commit Revision:568668  1.9.2_1
cy search for other commits by this committer
security/libgcrypt: Fix armv6 build

Armv6 fails to build jitterentropy-base.c without optimization,
even though #pragma GCC optimization and #pragma clang optimization
are specified. For now brute force disable building the jitter
entropy generator on armv6.

PR:		253698
Submitted by:	yani _ pi-greece.eu
Reported by:	yani _ pi-greece.eu
17 Mar 2021 16:10:21
Original commit files touched by this commit Revision:568667  1.9.2
cy search for other commits by this committer
security/libgcrypt: Fix FreeBSD 12 armv6 build.

MFH:		2021Q1
18 Feb 2021 14:41:18
Original commit files touched by this commit Revision:565939  1.9.2
cy search for other commits by this committer
security/libgcrypt: update 1.9.1 --> 1.9.2
03 Feb 2021 23:53:44
Original commit files touched by this commit Revision:563969  1.9.1
cy search for other commits by this committer
security/libgcrypt: Update 1.8.7 --> 1.9.1

Note: 1.8.7 nor 1.9.1 are vulnerable to CVE-2021-3345. Only 1.9.0 is.
24 Oct 2020 13:19:42
Original commit files touched by this commit Revision:553197  1.8.7
cy search for other commits by this committer
Update 1.8.6 --> 1.8.7
05 Oct 2020 17:55:00
Original commit files touched by this commit Revision:551532  1.8.6
cy search for other commits by this committer
Assume maintainership.
05 Oct 2020 17:54:56
Original commit files touched by this commit Revision:551531  1.8.6
cy search for other commits by this committer
Update 1.8.5 --> 1.8.6
05 Oct 2020 17:34:54
Original commit files touched by this commit Revision:551529  1.8.5
rene search for other commits by this committer
Return cpm@'s ports to the pool after safekeeping his commit bit.

With hat:	portmgr-secretary
31 Mar 2020 07:48:00
Original commit files touched by this commit Revision:529954  1.8.5
mikael search for other commits by this committer
security/libgcrypt: fix build on aarch64 with lld10

import upstream fix:
https://github.com/gpg/libgcrypt/commit/09c27280cc09798d15369b3a143036b7ab5ddd69

PR:		244848
Submitted by:	Charlie Li
Approved by:	cpm (maintainer timeout), manu (mentor, implicit)
02 Sep 2019 08:20:38
Original commit files touched by this commit Revision:510770  1.8.5
cpm search for other commits by this committer
security/libgcrypt: Update to 1.8.5

- Pet portlint

Noteworthy changes in version 1.8.5
===================================

* Bug fixes:

  - Add mitigation against an ECDSA timing attack.
    [T4626,CVE-2019-13627]

  - Improve ECDSA unblinding.

* Other features:

  - Provide a pkg-config file for libgcrypt.

Release-info: https://dev.gnupg.org/T4683

For further details, see
https://lists.gnupg.org/pipermail/gnupg-announce/2019q3/000440.html

MFH:		2019Q3
Security:	http://vuxml.freebsd.org/freebsd/c9c6c2f8-cd54-11e9-af89-080027ef1a23.html
10 Nov 2018 18:12:58
Original commit files touched by this commit Revision:484628  1.8.4_1 This port version is marked as vulnerable.
bapt search for other commits by this committer
Install texinfo files (GNU info) into ${PREFIX}/share/info

After a discussion on the mailing list on moving manpages to
${PREFIX}/share/man for consistency with base where it is
installed in usr/share/man, it appeared the same should happen
to GNU info files which were installed under share in base and
not in ports.

Now texinfo is not in base on any of the supported version of FreeBSD
it is possible to proceed to this move and it is easier to do than
the manpage change.

Other benefit than consistency are less patching: all build tools but
cmake are expecting info files to be under share/info and cmake (patched here)
was having an exception for BSD so the patch makes FreeBSD case less
specific for them

Bump revision of all impacted ports

PR:		232907
exp-run by:	antoine
Differential Revision:	https://reviews.freebsd.org/D17816
28 Oct 2018 21:15:27
Original commit files touched by this commit Revision:483355  1.8.4 This port version is marked as vulnerable.
cpm search for other commits by this committer
security/libgcrypt: Update to 1.8.4

- Update libgpg-error version required to 1.32

Changelog: https://lists.gnupg.org/pipermail/gnupg-announce/2018q4/000431.html
13 Jun 2018 18:59:05
Original commit files touched by this commit Revision:472337  1.8.3 This port version is marked as vulnerable.
cpm search for other commits by this committer
security/libgcrypt: Update to 1.8.3 (bugfix)

- Improve comment in Makefile
- Provide more elaborate port description and update WWW in pkg-descr

Noteworthy changes in version 1.8.3
===================================

   - Use blinding for ECDSA signing to mitigate a novel side-channel
     attack.  [#4011,CVE-2018-0495]

   - Fix incorrect counter overflow handling for GCM when using an IV
     size other than 96 bit.  [#3764]

   - Fix incorrect output of AES-keywrap mode for in-place encryption
(Only the first 15 lines of the commit message are shown above View all of this commit message)
22 Jan 2018 12:32:04
Original commit files touched by this commit Revision:459647  1.8.2 This port version is marked as vulnerable.
cpm search for other commits by this committer
security/libgcrypt: Fix build for powerpc/powerpcspe

- Add the missing check for powerpcspe- and powerpc- in mpi/config.links

Submitted by:	jhibbits
Approved by:	cpm (maintainer)
Differential Revision:	https://reviews.freebsd.org/D13854
15 Dec 2017 22:05:55
Original commit files touched by this commit Revision:456419  1.8.2 This port version is marked as vulnerable.
cpm search for other commits by this committer
security/libgcrypt: update to 1.8.2

- Update libgcrypt to 1.8.2
- Bump library version in pkg-plist

Changelog: https://abi-laboratory.pro/tracker/changelog/libgcrypt/1.8.2/log.html
Binary compatibility report:
https://abi-laboratory.pro/tracker/compat_report/libgcrypt/1.8.1/1.8.2/29a74/abi_compat_report.html

MFH:		2017Q4
30 Aug 2017 15:52:59
Original commit files touched by this commit Revision:448989  1.8.1 This port version is marked as vulnerable.
cpm search for other commits by this committer
security/libgcrypt: update to 1.8.1

- Update libgcrypt to 1.8.1
- Bump library version in pkg-plist

Noteworthy changes in version 1.8.1

 * Bug fixes:

   - Mitigate a local side-channel attack on Curve25519 dubbed "May
     the Fourth be With You".  [CVE-2017-0379] [also in 1.7.9]

   - Add more extra bytes to the pool after reading a seed file.

   - Add the OID SHA384WithECDSA from RFC-7427 to SHA-384.

   - Fix build problems with the Jitter RNG

   - Fix assembler code build problems on Rasbian (ARMv8/AArch32-CE).

Changes: https://abi-laboratory.pro/tracker/changelog/libgcrypt/1.8.1/log.html
Binary compatibility report:
https://abi-laboratory.pro/tracker/compat_report/libgcrypt/1.8.0/1.8.1/31172/abi_compat_report.html

MFH:		2017Q3
Security:	https://vuxml.freebsd.org/freebsd/22f28bb3-8d98-11e7-8c37-e8e0b747a45a.html
01 Aug 2017 12:10:13
Original commit files touched by this commit Revision:447018  1.8.0 This port version is marked as vulnerable.
cpm search for other commits by this committer
- Fix the command line munging for jitterbase

PR:		220937
Reported by:	O. Hartmann <ohartmann@walstatt.org>
Obtained from:	https://dev.gnupg.org/rCac39522ab08fcd2483edc223334c6ab9d19e91f3
MFH:		2017Q3 (blanket)
28 Jul 2017 21:45:20
Original commit files touched by this commit Revision:446854  1.8.0 This port version is marked as vulnerable.
jkim search for other commits by this committer
Set MAKEINFO to the full path of makeinfo when USES=makeinfo is set.

PR:		221027
Reviewed by:	mat
Approved by:	portmgr (antoine)
22 Jul 2017 01:05:15
Original commit files touched by this commit Revision:446350  1.8.0 This port version is marked as vulnerable.
cpm search for other commits by this committer
- Remove unnecessary extra-patch-aarch64 (applied upstream)

Reported by:	Shawn Webb <shawn.webb@hardenedbsd.org> via email
MFH:		2017Q3 (blanket)
21 Jul 2017 10:56:16
Original commit files touched by this commit Revision:446306  1.8.0 This port version is marked as vulnerable.
cpm search for other commits by this committer
security/libgcrypt: update to 1.8.0

- Update libgcrypt to 1.8.0
- Update libgpg-error version required to 1.25
- Bump library version in pkg-plist

Changes: https://lists.gnupg.org/pipermail/gnupg-announce/2017q3/000410.html
Binary compatibility report:
https://abi-laboratory.pro/tracker/compat_report/libgcrypt/1.7.8/1.8.0/d9ddd/abi_compat_report.html

PR:		220858
MFH:		2017Q3
Exp-run by:	antoine
04 Jul 2017 17:38:30
Original commit files touched by this commit Revision:445028  1.7.8 This port version is marked as vulnerable.
cpm search for other commits by this committer
security/libgcrypt: update to 1.7.8

- Update libgcrypt to 1.7.8
- Bump library version in pkg-plist

Noteworthy changes in version 1.7.8

 * Bug fixes:

   - Mitigate a flush+reload side-channel attack on RSA secret keys
     dubbed "Sliding right into disaster".  For details see
     <https://eprint.iacr.org/2017/627>.  [CVE-2017-7526]

Changes: https://lists.gnupg.org/pipermail/gnupg-announce/2017q2/000408.html
Binary compatibility report:
https://abi-laboratory.pro/tracker/compat_report/libgcrypt/1.7.7/1.7.8/95cc7/abi_compat_report.html

PR:		220382
MFH:		2017Q3
Exp-run by:	antoine
Security:	https://www.vuxml.org/freebsd/ed3bf433-5d92-11e7-aa14-e8e0b747a45a.html
07 Jun 2017 11:35:51
Original commit files touched by this commit Revision:442829  1.7.7 This port version is marked as vulnerable.
cpm search for other commits by this committer
security/libgcrypt: update to 1.7.7

- Update libgcrypt to 1.7.7
- Silence all explicitly called commands
- Update WWW in pkg-descr: use https://
- Bump library version in pkg-plist

Noteworthy changes in version 1.7.7

* Bug fixes:

  - Fix possible timing attack on EdDSA session key.
  - Fix long standing bug in secure memory implementation which could
     lead to a segv on free. [bug#3027].

PR:		219747
MFH:		2017Q2
Exp-run by:	antoine
09 Mar 2017 00:15:57
Original commit files touched by this commit Revision:435736  1.7.6 This port version is marked as vulnerable.
cpm search for other commits by this committer
- Patch only applies to aarch64. Remove armv6 check.

Reported by:	jbeich
MFH:		2017Q1 (blanket)
28 Feb 2017 12:21:13
Original commit files touched by this commit Revision:435049  1.7.6 This port version is marked as vulnerable.
cpm search for other commits by this committer
security/libgcrypt: fix build on aarch64

libtool: compile:  cc -DHAVE_CONFIG_H -I. -I.. -I../src -I../src
-Wa,--noexecstack -O2 -pipe -fno-strict-aliasing -std=gnu89 -MT
cipher-gcm-armv8-aarch64-ce.lo -MD -MP -MF .deps/cipher-gcm-armv8-aarch64-ce.Tpo
-c cipher-gcm-armv8-aarch64-ce.S  -fPIC -DPIC -o
.libs/cipher-gcm-armv8-aarch64-ce.o
cipher-gcm-armv8-aarch64-ce.S:190:3: error: instruction requires: neon
eor v31.16b, v31.16b, v31.16b
  ^

PR:		217271
Submitted by:	krion
Reported by:	Simon Rozman <simon@rozman.si>
MFH:		2017Q1 (blanket)
23 Jan 2017 12:12:13
Original commit files touched by this commit Revision:432213  1.7.6 This port version is marked as vulnerable.
cpm search for other commits by this committer
security/libgcrypt: update to 1.7.6

Noteworthy changes in version 1.7.6

* Bug fixes:

  - Fix AES CTR self-check detected failure in the SSSE3 based
     implementation.
  - Remove gratuitous select before the getrandom syscall.

PR:		216305
MFH:		2017Q1
Exp-run by:	antoine
23 Dec 2016 15:45:00
Original commit files touched by this commit Revision:429273  1.7.5 This port version is marked as vulnerable.
cpm search for other commits by this committer
security/libgcrypt: Update to 1.7.5

- Update to 1.7.5
- Remove files useless to install from DOCS
- Remove patch since sparc v8 is not supported on FreeBSD
- Bump library version in pkg-plist

Changelog:
  https://lists.gnupg.org/pipermail/gnupg-announce/2016q4/000399.html

PR:		215236
Approved by:	amdmi3 (mentor)
MFH:		2016Q4
Exp-run by:	antoine
21 Oct 2016 12:51:41
Original commit files touched by this commit Revision:424411  1.7.3  Sanity Test Failure This port version is marked as vulnerable.
mat search for other commits by this committer
${RM} already has -f.

PR:		213570
Submitted by:	mat
Exp-run by:	antoine
Sponsored by:	Absolight
18 Aug 2016 11:24:48
Original commit files touched by this commit Revision:420399  1.7.3 This port version is marked as vulnerable.
cpm search for other commits by this committer
- Update to 1.7.3 (security fixes)
- Bump library version in pkg-plist

ref: https://lists.gnupg.org/pipermail/gnupg-announce/2016q3/000395.html

Reviewed by:	amdmi3 (mentor)
Approved by:	amdmi3 (mentor)
MFH:	2016Q3
Differential Revision:	D7558
20 Jul 2016 09:09:44
Original commit files touched by this commit Revision:418828  1.7.2 This port version is marked as vulnerable.
cpm search for other commits by this committer
- Update to 1.7.2
- Bump library version in pkg-plist

Changelog:
  https://lists.gnupg.org/pipermail/gnupg-announce/2016q3/000392.html

PR:	211153
Reviewed by:	junovitch (mentor)
Approved by:	junovitch (mentor)
MFH:		2016Q3
Exp-run:	antoine
Differential Revision:	D7221
17 Jun 2016 23:00:27
Original commit files touched by this commit Revision:417040  1.7.1 This port version is marked as vulnerable.
cpm search for other commits by this committer
- Update to 1.7.1
- Remove unneeded patch (applied upstream)
- Convert to new test framework

  https://lists.gnupg.org/pipermail/gnupg-announce/2016q2/000389.html

PR:		210328
Reviewed by:	amdmi3, junovitch (mentors)
Approved by:	amdmi3, junovitch (mentors)
MFH:		2016Q2
Exp-run:	antoine
Differential Revision:	D6865
23 Apr 2016 10:01:20
Original commit files touched by this commit Revision:413860  1.7.0 This port version is marked as vulnerable.
cpm search for other commits by this committer
- Update to 1.7.0
- Remove unneeded patches (applied upstream)
- Fix inline assembler error on 9.x
- Fix pkg-plist

Changelog: https://lists.gnupg.org/pipermail/gnupg-announce/2016q2/000386.html

PR:		208907
Approved by:	junovitch (mentor)
Exp-run:	antoine
Differential Revision:	D5989
01 Apr 2016 14:25:18
Original commit files touched by this commit Revision:412349  1.6.5_1 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories r, s, t, and u.

With hat:	portmgr
Sponsored by:	Absolight
28 Mar 2016 23:41:45
Original commit files touched by this commit Revision:412077  1.6.5_1 This port version is marked as vulnerable.
cpm search for other commits by this committer
- cipher/salsa20.c (selftest): Ensure 16-byte alignment for salsa20
context structure.

- mpi/longlong.h: Fix build on sparc.

PR:		206919
Approved by:	junovitch (mentor)
16 Feb 2016 02:52:56
Original commit files touched by this commit Revision:408972  1.6.5 This port version is marked as vulnerable.
cpm search for other commits by this committer
- Update libgcrypt to 1.6.5
- Change LICENSE since support has been added for "or later" variants of GNU
licenses.
- Remove needless patch-cipher_salsa20.c

Changes:
  https://lists.gnupg.org/pipermail/gnupg-announce/2016q1/000384.html

PR:		207107
Approved by:	junovitch (mentor)
08 Feb 2016 20:54:10
Original commit files touched by this commit Revision:408514  1.6.4_4 This port version is marked as vulnerable.
cpm search for other commits by this committer
This patch fixes alignment of self-test context in salsa20 required
for amd64 implementation.

Other changes:
   - Regenerate patches to make portlint(1) happy
   - Update MAINTAINER to my @FreeBSD.org address
   - Bump PORTREVISION

PR:		206919
Approved by:	junovitch (mentor)
18 Dec 2015 12:25:01
Original commit files touched by this commit Revision:403961  1.6.4_3 This port version is marked as vulnerable.
rakuco search for other commits by this committer
Add upstream commit to fix build errors with -pedantic.

This fixes at least devel/ccrtp's build on 9.3, which is currently broken:

  In file included from ccrtp/crypto/gcrypt/gcrypthmac.cpp:23:
  /usr/local/include/gcrypt.h:509: error: comma at end of enumerator list
  /usr/local/include/gcrypt.h:1346: error: comma at end of enumerator list
  Makefile:571: recipe for target 'gcrypthmac.lo' failed

MFH'ing this is not necessary, this bug is only present in libgcrypt 1.6.4.

PR:		205000
Approved by:	maintainer timeout (15 days)
22 Nov 2015 17:33:05
Original commit files touched by this commit Revision:402237  1.6.4_2 This port version is marked as vulnerable.
pi search for other commits by this committer
security/libgcrypt: Re-add missing patch

- This patch was removed when updating to 1.6.4, so the patch needs
  to be put back in order to solve the bug 204399.

PR:		204600
Submitted by:	Carlos J. Puga Medina <cpm@fbsd.es> (maintainer)
29 Oct 2015 14:30:24
Original commit files touched by this commit Revision:400464  1.6.4_1 This port version is marked as vulnerable.
sbruno search for other commits by this committer
Enable the building and installation of the .a version of the library
for static linking.  This affects emulators/qemu-user-static primarily
but will help anyone trying to statically link their applications.

Reviewed by:	tijl cpm@fbsd.es (Maintainer)
27 Oct 2015 15:54:54
Original commit files touched by this commit Revision:400319  1.6.4 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Update to 1.8.4

Changes:	http://lists.gnupg.org/pipermail/gnupg-announce/2015q3/000375.html
PR:		204003
Submitted by:	Carlos J Puga Medina <cpm@fbsd.es> (maintainer)
20 Sep 2015 19:22:28
Original commit files touched by this commit Revision:397388  1.6.3 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Drop 8.x support
- Switch to options helpers

Approved by:	portmgr blanket
14 May 2015 10:15:09
Original commit files touched by this commit Revision:386312  1.6.3 This port version is marked as vulnerable.
mat search for other commits by this committer
MASTER_SITES cleanup.

- Replace ${MASTER_SITE_FOO} with FOO.
- Merge MASTER_SITE_SUBDIR into MASTER_SITES when possible. (This means 99.9%
  of the time.)
- Remove occurrences of MASTER_SITE_LOCAL when no subdirectory was present and
  no hint of what it should be was present.
- Fix some logic.
- And generally, make things more simple and easy to understand.

While there, add magic values to the FESTIVAL, GENTOO, GIMP, GNUPG, QT and
SAMBA macros.

Also, replace some EXTRACT_SUFX occurences with USES=tar:*.

Checked by:	make fetch-urlall-list
With hat:	portmgr
Sponsored by:	Absolight
28 Mar 2015 12:42:09
Original commit files touched by this commit Revision:382480  1.6.3 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Add CPE information

PR:		198985
Submitted by:	Carlos Jacobo Puga Medina <cpm@fbsd.es> (maintainer)
02 Mar 2015 23:42:00
Original commit files touched by this commit Revision:380309  1.6.3 This port version is marked as vulnerable.
bapt search for other commits by this committer
Remove Author from pkg-descr and white space fixes
28 Feb 2015 21:11:54
Original commit files touched by this commit Revision:380161  1.6.3 This port version is marked as vulnerable.
pi search for other commits by this committer
security/libgcrypt: 1.6.2 -> 1.6.3

Changes:
http://lists.gnupg.org/pipermail/gnupg-announce/2015q1/000364.html

PR:		198109
Submitted by:	Carlos Jacobo Puga Medina <cpm@fbsd.es> (maintainer)
07 Feb 2015 07:25:22
Original commit files touched by this commit Revision:378572  1.6.2_1 This port version is marked as vulnerable.
pi search for other commits by this committer
security/libgcrypt: fix some issues

- Fix crash at cipher/salsa20.c module on amd64.
- Fix strip shared object.
- Bump PORTREVISION.

PR:		197146
Submitted by:	cpm@fbsd.es (maintainer)
02 Jan 2015 18:46:34
Original commit files touched by this commit Revision:376062  1.6.2 This port version is marked as vulnerable.
pi search for other commits by this committer
security/libgcrypt: 1.6.1 -> 1.6.2, bump depends

Changes:
- src/sexp.c (do_vsexp_sscan): Return error for invalid args.
- cipher/md.c (_gcry_md_info): Fix a segv in case of calling
  with wrong parameters.
- cipher/primegen.c (_gcry_generate_elg_prime): Change to return an
  error code, possible NULL deref in call to prime generator.
- cipher/dsa.c (generate): Take care of new return code.
- cipher/elgamal.c (generate): Change to return an error code.  Take
	care of _gcry_generate_elg_prime return code.
- ecc: Support the non-standard 0x40 compression flag for EdDSA.
- mpi: Extend the internal mpi_get_buffer.
- mpi: Fix regression for powerpc-apple-darwin detection.
- Fix bug inhibiting the use of the sentinel attribute in src/gcrypt.h.in
(Only the first 15 lines of the commit message are shown above View all of this commit message)
04 Sep 2014 17:28:35
Original commit files touched by this commit Revision:367293  1.6.1_5 This port version is marked as vulnerable.
pi search for other commits by this committer
security/libgcrypt: fix build with GCC on 8.x/amd64, 2nd attempt

Thanks to tijl@ for spotting the Makefile bug.

PR:		192555
Submitted by:	Carlos Jacobo Puga Medina <cpm@fbsd.es>
Approved by:	maintainer (timeout)
02 Sep 2014 20:47:44
Original commit files touched by this commit Revision:367081  1.6.1_4 This port version is marked as vulnerable.
pi search for other commits by this committer
security/libgcrypt: fix build without assembler on 8.x/amd64

PR:		192555
Submitted by:	Carlos Jacobo Puga Medina <cpm@fbsd.es>
Approved by:	maintainer (timeout)
05 Aug 2014 22:13:29
Original commit files touched by this commit Revision:364143  1.6.1_3 This port version is marked as vulnerable.
tijl search for other commits by this committer
Bump PORTREVISION on more ports that depend on libgcrypt after the update
in r363436 and remove the UPDATING entry because it did not guarantee
that all ports were updated nor that they were updated in the right order.
Also remove libgcrypt.la again.

PR:		192342
Approved by:	portmgr (implicit, bump unstaged ports)
02 Aug 2014 21:57:14
Original commit files touched by this commit Revision:363841  1.6.1_2 This port version is marked as vulnerable.
pi search for other commits by this committer
devel/security: re-add .la file

- py-gnome-extras (and others) depend on it

PR:		192342
Submitted by:	freebsd@johnlevine.com
31 Jul 2014 18:30:51
Original commit files touched by this commit Revision:363648  1.6.1_1 This port version is marked as vulnerable.
pi search for other commits by this committer
security/libgcrypt: avoid non-portable use of assembler instruction on amd64

PR:		191256
Submitted by:	arcade@b1t.name
30 Jul 2014 03:57:24
Original commit files touched by this commit Revision:363436  1.6.1 This port version is marked as vulnerable.
pi search for other commits by this committer
security/libgcrypt: 1.5.3_3 -> 1.6.1

- Update to 1.6.1
- Remove some unneeded patches
- Fix pkg-plist
- report configure bug upstream
  https://bugs.g10code.com/gnupg/issue1668
- report API breakage downstream and find that MacPorts had the same issue
  https://rt.cpan.org/Ticket/Display.html?id=97201
- bump PORTREVISION for dependent ports (approx. 100 ports)
- Thanks to exp-run by antoine@ to find ports that break
- patch ports that would otherwise break
  security/shishi with PR 192164 is already committed
  [1] devel/ccrtp
  [2] editors/abiword
  [3] security/p5-Crypt-GCrypt

PR:		191256, 192162 [1], 192163 [2], 192166 [3]
Submitted by:	Carlos Jacobo Puga Medina <cjpugmed@gmail.com>
Approved by:	maintainer timeout, antoine (exp-run), portmgr (implicit)
15 Jul 2014 16:57:39
Original commit files touched by this commit Revision:361977  1.5.3_3 This port version is marked as vulnerable.
adamw search for other commits by this committer
Add DOCS to OPTIONS_DEFINE to ports that check for PORT_OPTIONS:MDOCS.
05 Jul 2014 23:19:06
Original commit files touched by this commit Revision:360837  1.5.3_3 This port version is marked as vulnerable.
sbruno search for other commits by this committer
Added needed ASM instructions for armv6 architecture support.

PR:	190848
Submitted by:	andrew@freebsd.org
Reviewed by:	mat@freebsd.org
25 Jun 2014 08:58:09
Original commit files touched by this commit Revision:359209  1.5.3_2 This port version is marked as vulnerable.
bapt search for other commits by this committer
Fix build on system built WITHOUT_INFO

With hat:	portmgr
23 Apr 2014 13:25:17
Original commit files touched by this commit Revision:351936  1.5.3_2 This port version is marked as vulnerable.
tijl search for other commits by this committer
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs
field) to the linker command line and store them in the dependency_libs
field of libA.la.  So everything that subsequently links with libA will also
link to these extra libraries.  This causes too much overlinking.

This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs
field in .la libraries during staging.  However, because .la libraries have
very limited use when dependency_libs is empty it makes sense to completely
remove them during staging.

So with this commit USES=libtool is modified to remove .la libraries and a
new form (USES=libtool:keepla) is introduced in case they need to be kept
(dependency_libs is still emptied).
(Only the first 15 lines of the commit message are shown above View all of this commit message)
01 Apr 2014 13:12:28
Original commit files touched by this commit Revision:349852  1.5.3_1 This port version is marked as vulnerable.
tijl search for other commits by this committer
- USES=libtool tar:bzip2.
- Enable asm on FreeBSD/i386 >= 10.0.
- Enable asm on FreeBSD/amd64. [1]
- Use MAKE_CMD instead of MAKE to run regression tests.

PR:		ports/187441
Submitted by:	Stoyan Dimov <pr.freebsd.org@registrations.systeem.com> [1]
Approved by:	maintainer timeout (2 weeks)
01 Mar 2014 21:23:14
Original commit files touched by this commit Revision:346721  1.5.3 This port version is marked as vulnerable.
gerald search for other commits by this committer
Replace USE_GCC=4.2+ by USE_GCC=any. [1]
And USE_GMAKE by USES=gmake where touching a port because of the above.

Approved by:	portmgr (bapt) [1]
14 Dec 2013 05:06:17
Original commit files touched by this commit Revision:336421  1.5.3 This port version is marked as vulnerable.
koobs search for other commits by this committer
security/libgcrypt: Remove BROKEN on powerpc

- Remove BROKEN on powerpc [1]
- Enable STAGE support

PR:		ports/183066
Submitted by:	jhibbits
Approved by:	maintainer timeout (1 month)
20 Sep 2013 22:55:26
Original commit files touched by this commit Revision:327769  1.5.3 This port version is marked as vulnerable.
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
security)
20 Aug 2013 05:31:34
Original commit files touched by this commit Revision:325029  1.5.3 This port version is marked as vulnerable.
rpaulo (src committer) search for other commits by this committer
Use GCC 4.2+ on armv6.

Reviewed by:	umq
Approved by:	umq
17 Aug 2013 07:56:12
Original commit files touched by this commit Revision:324830  1.5.3 This port version is marked as vulnerable.
bf search for other commits by this committer
Update security/libgcrypt to 1.5.3 [1], and document the latest gnupg
and libgcrypt vulnerability

PR:		181231
Submitted by:	Hirohisa Yamaguchi (maintainer) [1]
Security:	http://www.vuxml.org/freebsd/689c2bf7-0701-11e3-9a25-002590860428.html
03 May 2013 16:35:25
Original commit files touched by this commit Revision:317219  1.5.2 This port version is marked as vulnerable.
ehaupt search for other commits by this committer
Update to 1.5.2

Changelog:
http://lists.gnupg.org/pipermail/gnupg-announce/2013q1/000324.html (1.5.1)
http://lists.gnupg.org/pipermail/gnupg-announce/2013q2/000325.html (1.5.2)

PR:             177100
Submitted by:   Hirohisa Yamaguchi <umq@ueo.co.jp> (maintainer)
07 Sep 2012 19:42:03
Original commit files touched by this commit Revision:303822  1.5.0_1 This port version is marked as vulnerable.
linimon search for other commits by this committer
Mark as broken on powerpc only on -current.  This will unblock gnome,
kde, and other builds on 8 and 9.

Hat:		portmgr
25 Aug 2012 08:33:56
Original commit files touched by this commit   1.5.0_1 This port version is marked as vulnerable.
novel search for other commits by this committer
- Properly define deprecated functions to remove warnings in other
  ports
- Avoid installing multiple copies of the GPLv2 and LGPL21 licenses
- Bump PORTREVISION

PR:		170488
Submitted by:	Jason E. Hale <bsdkaffee@gmail.com>
Approved by:	Hirohisa Yamaguchi (maintainer)
24 Jul 2012 15:51:27
Original commit files touched by this commit   1.5.0 This port version is marked as vulnerable.
scheidell search for other commits by this committer
- Mark Broken for ppc
- Remove check for obsolete, unsupported OS version
- pet portlint (space/vs tab, like 41, 44 of Makefile)

PR:		ports/166388
Submitted by:	scheidell@ (me)
Reported by: 	glevand <geoffrey.levand@mail.ru>
Approved by:	maintainer (timeout, 21 days)
05 Nov 2011 17:26:19
Original commit files touched by this commit   1.5.0 This port version is marked as vulnerable.
miwi search for other commits by this committer
- Add a workaround to fix build on FreeBSD 10.0 i386
17 Sep 2011 21:56:22
Original commit files touched by this commit   1.5.0 This port version is marked as vulnerable.
pawel search for other commits by this committer
Require ligpg-error>=1.8 to build succesfully

PR:             ports/159873
Submitted by:   Michael Scheidell <scheidell@secnap.net>
Approved by:    maintainer, miwi, wen (mentors implicit)
26 Jul 2011 06:54:46
Original commit files touched by this commit   1.5.0 This port version is marked as vulnerable.
dim search for other commits by this committer
In the AES-NI inline assembly, change instances of 'cmpq' to 'cmpl'.  I
had erroneously assumed this would only be compiled on amd64, but even
then a 64 bit compare is wrong.  The variables referenced in the inline
assembly are all plain int, so 32 bit.

PR:     ports/159147
Pointy hat to:  dim
Requested by:   Hirohisa Yamaguchi <umq@ueo.co.jp> (maintainer)
21 Jul 2011 20:18:45
Original commit files touched by this commit   1.5.0 This port version is marked as vulnerable.
dim search for other commits by this committer
Building security/libgcrypt 1.5.0 with clang results in errors similar
to the following:

rijndael.c:846:46: error: ambiguous instructions require an explicit suffix
(could be 'cmpb', 'cmpw', 'cmpl', or 'cmpq')
"movdqa 0xa0(%%esi), %%xmm1\n\t"
^
<inline asm>:24:2: note: instantiated into assembly here
cmp $10, -80(%ebp)
^

This is because the 'cmp' instruction lacks a type suffix, and is thus
ambiguous.  Fix this by changing these to 'cmpq'.

PR:     ports/158994
Approved by:    Hirohisa Yamaguchi <umq@ueo.co.jp> (maintainer)
03 Jul 2011 11:39:40
Original commit files touched by this commit   1.5.0 This port version is marked as vulnerable.
swills search for other commits by this committer
- Update to 1.5.0

PR:             ports/158574
Submitted by:   Hirohisa Yamaguchi <umq@ueo.co.jp> (maintainer)
04 Dec 2010 07:34:27
Original commit files touched by this commit   1.4.6 This port version is marked as vulnerable.
ade search for other commits by this committer
Sync to new bsd.autotools.mk
02 Nov 2010 12:18:54
Original commit files touched by this commit   1.4.6 This port version is marked as vulnerable.
kwm search for other commits by this committer
Fix linking with clang, and give longlong.h a simular treatment like was
done in 9-current so clang can build it on i386.

Update LICENSE block, and remove md5 sum.

PR:             ports/151349
Submitted by:   myself
Approved by:    Yamaguchi Hirohisa <umq@ueo.co.jp> (maintainer)
27 Jul 2010 01:24:39
Original commit files touched by this commit   1.4.6 This port version is marked as vulnerable.
wxs search for other commits by this committer
Update to 1.4.6.

PR:             ports/148755
Submitted by:   Hirohisa Yamaguchi <umq@ueo.co.jp> (maintainer)
27 Jun 2010 12:57:34
Original commit files touched by this commit   1.4.5_1 This port version is marked as vulnerable.
stefan search for other commits by this committer
Bump PORTREVISION for latest gettext update. (I'm not sure anyone still needs
it, but it doesn't really hurt, either.)

PR:             147295
Submitted by:   Grzegorz Blach <magik@roorback.net>
Approved by:    maintainer timeout (>3 weeks)
Feature safe:   yes
13 Mar 2010 19:34:23
Original commit files touched by this commit   1.4.5 This port version is marked as vulnerable.
niels search for other commits by this committer
Upgrade to version 1.4.5

PR:     ports/144312
Submitted by:   Sunpoet Po-Chuan Hsieh <sunpoet at sunpoet.net>
Reviewed by:    Hirohisa Yamaguchi (maintainer)
Approved by:    itetcu (mentor)
02 Aug 2009 19:36:34
Original commit files touched by this commit   1.4.4 This port version is marked as vulnerable.
mezz search for other commits by this committer
-Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.
-Update libtool and libltdl to 2.2.6a.
-Remove devel/libtool15 and devel/libltdl15.
-Fix ports build with libtool22/libltdl22.
-Bump ports that depend on libltdl22 due to shared library version change.
-Explain what to do update in the UPDATING.

It has been tested with GNOME2, XFCE4, KDE3, KDE4 and other many wm/desktop
and applications in the runtime.

With help:      marcus and kwm
Pointyhat-exp:  a few times by pav
Tested by:      pgollucci, "Romain Tartière" <romain@blogreen.org>, and
                a few MarcusCom CVS users. Also, I might have missed a few.
Repocopy by:    marcus
Approved by:    portmgr
23 Jan 2009 15:52:58
Original commit files touched by this commit   1.4.4 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Update to 1.4.4

PR:             130914
Submitted by:   Hirohisa Yamaguchi <umq at ueo dot co dot jp> (maintainer)
06 Jan 2009 12:59:57
Original commit files touched by this commit   1.4.3 This port version is marked as vulnerable.
rafan search for other commits by this committer
- Update to 1.4.3
- Pass maintainership to submitter per PR 127224

PR:             ports/127478
Submitted by:   Hirohisa Yamaguchi <umq at ueo.co.jp>
Approved by:    arved (maintainer)
21 Aug 2008 06:18:49
Original commit files touched by this commit   1.4.1_1 This port version is marked as vulnerable.
rafan search for other commits by this committer
Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.
Specifically, newer autoconf (> 2.13) has different semantic of the
configure target. In short, one should use --build=CONFIGURE_TARGET
instead of CONFIGURE_TARGET directly. Otherwise, you will get a warning
and the old semantic may be removed in later autoconf releases.

To workaround this issue, many ports hack the CONFIGURE_TARGET variable
so that it contains the ``--build='' prefix.

To solve this issue, under the fact that some ports still have
configure script generated by the old autoconf, we use runtime detection
in the do-configure target so that the proper argument can be used.

Changes to Mk/*:
 - Add runtime detection magic in bsd.port.mk
(Only the first 15 lines of the commit message are shown above View all of this commit message)
06 Jun 2008 14:01:07
Original commit files touched by this commit   1.4.1_1 This port version is marked as vulnerable.
edwin search for other commits by this committer
Bump portrevision due to upgrade of devel/gettext.

The affected ports are the ones with gettext as a run-dependency
according to ports/INDEX-7 (5007 of them) and the ones with USE_GETTEXT
in Makefile (29 of them).

PR:             ports/124340
Submitted by:   edwin@
Approved by:    portmgr (pav)
03 May 2008 19:14:02
Original commit files touched by this commit   1.4.1 This port version is marked as vulnerable.
arved search for other commits by this committer
Update to 1.4.1

PR:             123099
Submitted by:   Hirohisa Yamaguchi
29 Feb 2008 09:32:39
Original commit files touched by this commit   1.4.0 This port version is marked as vulnerable.
arved search for other commits by this committer
Disable padlock-support on 6.x

PR:             121207
Submitted by:   ale, Mark Andrews
28 Feb 2008 21:44:49
Original commit files touched by this commit   1.4.0 This port version is marked as vulnerable.
arved search for other commits by this committer
Update to 1.4.0

PR:             118541
Submitted by:   Hirohisa Yamaguchi
24 Sep 2007 00:35:45
Original commit files touched by this commit   1.2.4_1 This port version is marked as vulnerable.
edwin search for other commits by this committer
security/libgcrypt portlint fixes

        1. remove quotes from COMMENT
        2. INSTALLS_SHLIB -> USE_LDCONFIG

PR:             ports/115286
Submitted by:   David Yeske <dyeske@gmail.com>
Approved by:    maintainer timeout
23 Jul 2007 09:36:52
Original commit files touched by this commit   1.2.4_1 This port version is marked as vulnerable.
rafan search for other commits by this committer
- Set --mandir and --infodir in CONFIGURE_ARGS if the configure script
  supports them.  This is determined by running ``configure --help'' in
  do-configure target and set the shell variable _LATE_CONFIGURE_ARGS
  which is then passed to CONFIGURE_ARGS.
- Remove --mandir and --infodir in ports' Makefile where applicable
  Few ports use REINPLACE_CMD to achieve the same effect, remove them too.
- Correct some manual pages location from PREFIX/man to MANPREFIX/man
- Define INFO_PATH where necessary
- Document that .info files are installed in a subdirectory relative to
  PREFIX/INFO_PATH and slightly change add-plist-info to use INFO_PATH and
  subdirectory detection.

PR:             ports/111470
Approved by:    portmgr
Discussed with: stas (Mk/*), gerald (info related stuffs)
Tested by:      pointyhat exp run
08 Mar 2007 14:12:08
Original commit files touched by this commit   1.2.4_1 This port version is marked as vulnerable.
jylefort search for other commits by this committer
Track libgpg-error shlib version change.
02 Feb 2007 14:25:54
Original commit files touched by this commit   1.2.4 This port version is marked as vulnerable.
arved search for other commits by this committer
Update to 1.2.4
28 Jan 2007 09:07:47
Original commit files touched by this commit   1.2.3_1 This port version is marked as vulnerable.
kris search for other commits by this committer
Use libtool port instead of included one to avoid objformat a.out botch
22 Sep 2006 07:10:31
Original commit files touched by this commit   1.2.3_1 This port version is marked as vulnerable.
sergei search for other commits by this committer
- Chase libgpg-error version bump [1]
- Add explicit version to libgpg-error dependency where missing [2]
- Bump PORTREVISION [1]

Approved by:    maintainers (arved, lofi, novel,
                ports at mcdermottroe dot com) [1]
Suggested by:   novel, lofi [2]
31 Aug 2006 21:20:52
Original commit files touched by this commit   1.2.3 This port version is marked as vulnerable.
arved search for other commits by this committer
Update to 1.2.3 (Minor bugfix release)
13 May 2006 04:15:53
Original commit files touched by this commit   1.2.2_1 This port version is marked as vulnerable.
edwin search for other commits by this committer
Remove USE_REINPLACE from all categories starting with S

Number of commits found: 131 (showing only 100 on this page)

1 | 2  »