notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
All times are UTC
non port: security/py-acme/files

Number of commits found: 4

Tue, 12 May 2020
[ 11:13 dbaio search for other commits by this committer ] Original commit   Revision:534987 (Only the first 10 of 27 ports in this commit are shown above. View all ports for this commit)
security/py-[acme|certbot]: Update to 1.4.0


Approved by:	koobs (python, maintainer)
Differential Revision:
Mon, 26 Jun 2017
[ 11:56 cpm search for other commits by this committer ] Original commit   Revision:444364
security/py-{acme,certbot}: fix missing dependency on py-mock


- Move py-mock requirement to dev_extras in

PR:		220274
Submitted by:	cpm
Reported by:	Randy Westlund <>
Approved by:	koobs (maintainer, py-certbot)
MFH:		2017Q2
Sat, 24 Jun 2017
[ 08:51 cpm search for other commits by this committer ] Original commit   Revision:444208
security/py-{acme,certbot}: update to 0.15.0


- Update PORTVERSION and distinfo checksum (0.15.0)
- Update RUN/TEST dependencies
- Remove unnecessary patches (applied upstream)


Reviewed by:	koobs
Approved by:	koobs (maintainer, py-certbot)
Differential Revision:
Sun, 30 Apr 2017
[ 14:26 cpm search for other commits by this committer ] Original commit   Revision:439825
security/py-{acme,certbot}: Make argparse a conditional dependency

Backport an upstream patch [1][2] to making argparse a conditional
dependency. Without this change, the following error is observed at run-time:

  pkg_resources.DistributionNotFound: The 'argparse' distribution was not found
and is required by certbot

This is due to the separate argparse distribution (via PyPI) no longer being
required for Python versions >= 2.7 and >= 3.2, as they contain the argparse
module in the standard library.

Since FreeBSD only supports Python versions with the argparse module built in,
*and* having removed the devel/py-argparse port, the install_requires=argparse
dependency cannot be satisfied, as install_requires is only relevant for non
standard library (PyPI) packages/dependencies.


PR:		218973
Reported by:	olgeni
Approved by:	koobs (py-certbot, maintainer)
Differential Revision:

Number of commits found: 4