notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
NOTE: There is a known problem on production with searching pkg-plist - it returns no results. This problem is not present on stage.freshports.org
Port details
qoauth Qt 4 support for OAuth-powered network services
2.0.0_3 net Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch.
Broken BROKEN: Missingd libqca.so:devel/qca@qt4
Deprecated DEPRECATED: Qt4 has been EOL since december 2015
Expired This port expired on: 2019-03-15
Ignore IGNORE: is marked as broken: Missingd libqca.so:devel/qca@qt4
Maintainer: kde@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2010-09-24 01:34:38
Last Update: 2019-03-16 21:55:51
SVN Revision: 495967
Also Listed In: devel security
License: LGPL21+
Description:
Homepage    cgit ¦ GitHub ¦ GitHub ¦ GitLab ¦ SVNWeb
pkg-plist: as obtained via: make generate-plist
Expand this list (16 items)
Collapse this list.
  1. /usr/local/share/licenses/qoauth-2.0.0_3/catalog.mk
  2. /usr/local/share/licenses/qoauth-2.0.0_3/LICENSE
  3. /usr/local/share/licenses/qoauth-2.0.0_3/LGPL21+
  4. include/QtOAuth/QtOAuth
  5. include/QtOAuth/interface.h
  6. include/QtOAuth/qoauth_global.h
  7. include/QtOAuth/qoauth_namespace.h
  8. lib/libqoauth.prl
  9. lib/libqoauth.so
  10. lib/libqoauth.so.1
  11. lib/libqoauth.so.1.0
  12. lib/libqoauth.so.1.0.1
  13. libdata/pkgconfig/qoauth.pc
  14. share/qt4/mkspecs/features/oauth.prf
  15. @postexec /usr/sbin/service ldconfig restart > /dev/null
  16. @postunexec /usr/sbin/service ldconfig restart > /dev/null
Collapse this list.
Dependency lines:
  • qoauth>0:net/qoauth
No installation instructions:
This port has been deleted.
PKGNAME: qoauth
Flavors: there is no flavor information for this port.
distinfo:

Packages (timestamps in pop-ups are UTC):
qoauth
ABIlatestquarterly
FreeBSD:11:aarch642.0.0_1pkg-fallout
FreeBSD:11:amd64pkg-falloutpkg-fallout
FreeBSD:11:armv61.0.1_1pkg-fallout
FreeBSD:11:i386pkg-falloutpkg-fallout
FreeBSD:11:mipspkg-falloutpkg-fallout
FreeBSD:11:mips64pkg-falloutpkg-fallout
FreeBSD:12:aarch642.0.0_1pkg-fallout
FreeBSD:12:amd64pkg-falloutpkg-fallout
FreeBSD:12:armv62.0.0_1pkg-fallout
FreeBSD:12:armv7pkg-falloutpkg-fallout
FreeBSD:12:i386pkg-falloutpkg-fallout
FreeBSD:12:mipspkg-falloutpkg-fallout
FreeBSD:12:mips64pkg-falloutpkg-fallout
FreeBSD:12:powerpc64pkg-falloutpkg-fallout
FreeBSD:13:aarch64pkg-falloutpkg-fallout
FreeBSD:13:amd64pkg-falloutpkg-fallout
FreeBSD:13:armv6pkg-falloutpkg-fallout
FreeBSD:13:armv7pkg-falloutpkg-fallout
FreeBSD:13:i386pkg-falloutpkg-fallout
FreeBSD:13:mipspkg-falloutpkg-fallout
FreeBSD:13:mips64pkg-falloutpkg-fallout
FreeBSD:13:powerpc64pkg-falloutpkg-fallout
FreeBSD:13:riscv64pkg-falloutpkg-fallout
FreeBSD:14:aarch64pkg-falloutpkg-fallout
FreeBSD:14:amd64pkg-falloutpkg-fallout
FreeBSD:14:armv6pkg-falloutpkg-fallout
FreeBSD:14:armv7pkg-falloutpkg-fallout
FreeBSD:14:i386pkg-falloutpkg-fallout
FreeBSD:14:mipspkg-falloutpkg-fallout
FreeBSD:14:mips64pkg-falloutpkg-fallout
FreeBSD:14:powerpc64pkg-falloutpkg-fallout
FreeBSD:14:riscv64pkg-falloutpkg-fallout
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. moc : devel/qt4-moc
  2. qmake : devel/qt4-qmake
Library dependencies:
  1. libQtCore.so : devel/qt4-corelib
  2. libQtNetwork.so : net/qt4-network
  3. libQtTest.so : devel/qt4-testlib
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Libraries

Deleted ports which required this port:

Expand this list of 3 deleted ports
  1. deskutils/kdeplasma-addons*
  2. deskutils/kdeplasma-addons-kde4*
  3. www/choqok-kde4*
  4. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message

Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://codeload.github.com/ayoy/qoauth/tar.gz/v2.0.0?dummy=/
Collapse this list.
Port Moves
  • port deleted on 2019-03-16
    REASON: Has expired: Qt4 has been EOL since december 2015

Number of commits found: 20

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
CommitCreditsLog message
2.0.0_3
16 Mar 2019 21:55:51
Revision:495967Original commit files touched by this commit
tcberner search for other commits by this committer
Qt4 deprecation: Remove Qt4 and its consumes.

2019-03-15 accessibility/qt4-accessible: Qt4 has been EOL since december 2015
2019-03-15 astro/qlandkartegt: Qt4 has been EOL since december 2015
2019-03-15 astro/stellarium-qt4: Qt4 has been EOL since december 2015
2019-03-15 astro/xglobe: Qt4 has been EOL since december 2015
2019-03-15 audio/acoustid-fingerprinter: Qt4 has been EOL since december 2015
2019-03-15 audio/cueplayer: Qt4 has been EOL since december 2015
2019-03-15 audio/esperanza: Qt4 has been EOL since december 2015
2019-03-15 audio/lastfm-desktop: Qt4 has been EOL since december 2015
2019-03-15 audio/minitunes: Qt4 has been EOL since december 2015
2019-03-15 audio/mixxx20: Qt4 has been EOL since december 2015
2019-03-15 audio/mumble: Qt4 has been EOL since december 2015
2019-03-15 audio/murmur: Qt4 has been EOL since december 2015
2019-03-15 audio/puddletag: Qt4 has been EOL since december 2015
(Only the first 15 lines of the commit message are shown above View all of this commit message)
2.0.0_3
16 Mar 2019 20:16:24
Revision:495954Original commit files touched by this commit
tcberner search for other commits by this committer
devel/qca: remove flavors (Qt4 deprecation)
2.0.0_2
16 Jan 2019 11:13:45
Revision:490472Original commit files touched by this commit
tijl search for other commits by this committer
Fix Qt5 symbol version scripts to put the catch-all clause first.  When
a symbol matches multiple clauses the last one takes precedence.  If the
catch-all is last it captures everything.  In the case of Qt5 libraries
this caused all symbols to have a Qt_5 label while some should have
Qt_5_PRIVATE_API.  This only affects lld because GNU ld always gives the
catch-all lowest priority.

Older versions of Qt5Webengine exported some memory allocation symbols from
the bundled Chromium.  Version 5.9 stopped exporting these [1] but the
symbols were kept as weak wrappers for the standard allocation functions to
maintain binary compatibility. [2][3]  The problem is that the call to the
standard function in these weak wrappers is only resolved to the standard
function if there's a call to this standard function in other parts of
Qt5Webengine, because only then is there a non-weak symbol that takes
precedence over the weak one.  If there's no such non-weak symbol the call
(Only the first 15 lines of the commit message are shown above View all of this commit message)
2.0.0_1
02 Dec 2018 15:41:48
Revision:486467Original commit files touched by this commit
rene search for other commits by this committer
Mark QT4 ports/functionality for removal on 2019-03-15

While here, chase some KDE4 ports and functionality, these are scheduled for
removal on 2018-12-31. Change the default option/flavor to QT5 where applicable
or use alternative toolkits like GTK.

Submitted by:	tcberner
Reviewed by:	adridg, jhale, rene, tcberner
Approved by:	portmgr (implicit, flavor hook)
Differential Revision:	https://reviews.freebsd.org/D17741
2.0.0_1
28 Jun 2018 17:39:55
Revision:473503Original commit files touched by this commit
tcberner search for other commits by this committer
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk

From now on, ports that depend on Qt4 will have to set
	USES=		qt:4
	USE_QT=		foo bar
ports depending on Qt5 will use
	USES=		qt:5
	USE_QT=		foo bar

PR:		229225
Exp-run by:	antoine
Reviewed by:	mat
Approved by:	portmgr (antoine)
Differential Revision:	-https://reviews.freebsd.org/D15540
2.0.0_1
14 Apr 2018 11:09:17
Revision:467306Original commit files touched by this commit
tcberner search for other commits by this committer
devel/qca, devel/qca-qt5 -- create flavors

Approved by:	portmgr (mat)
Differential Revision:	https://reviews.freebsd.org/D14651
2.0.0
28 Mar 2017 11:03:30
Revision:437118Original commit files touched by this commit
rakuco search for other commits by this committer
Update to 2.0.0.

Making qoauth-qt5 a slave port (or vice-versa) is currently left as an exercise
to the reader.
1.0.1_1
15 Mar 2017 14:45:31
Revision:436247Original commit files touched by this commit
mat search for other commits by this committer
Remove all USE_OPENSSL occurrences.

Sponsored by:	Absolight
1.0.1_1
02 Dec 2016 09:21:59
Revision:427548Original commit files touched by this commit
mat search for other commits by this committer
http://github.com redirects to https://github.com, spare everyone a redirect.

Sponsored by:	Absolight
1.0.1_1
23 May 2016 18:36:52
Revision:415738Original commit files touched by this commit
amdmi3 search for other commits by this committer
Convert tab after WWW: in pkg-descrs to single space as per PHB

Approved by:	portmgr blanket
1.0.1_1
01 Apr 2016 14:16:20
Revision:412348Original commit files touched by this commit
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories m, n, o, and p.

With hat:	portmgr
Sponsored by:	Absolight
1.0.1_1
12 Jan 2015 16:33:17
Revision:376838Original commit files touched by this commit
tijl search for other commits by this committer
- Update devel/qca to version 2.1.0
- Plugins are no longer available separately so remove security/qca-* and
  replace them with options in devel/qca
- Adjust all ports that depended on security/qca-*
- This also fixes the build of the OpenSSL plugin when OpenSSL doesn't
  support SSLv2

Approved by:	kde (rakuco)
1.0.1
22 Nov 2014 14:43:24
Revision:373063Original commit files touched by this commit
antoine search for other commits by this committer
Cleanup plist
1.0.1
29 Jul 2014 18:41:17
Revision:363371Original commit files touched by this commit Sanity Test Failure
adamw search for other commits by this committer
Convert a bunch of USE_BZIP2 to USES=tar:bzip2

Approved by:	portmgr (not really, but touches unstaged ports)
1.0.1
14 Jul 2014 18:42:04
Revision:361812Original commit files touched by this commit
bapt search for other commits by this committer
Modernize LIB_DEPENDS

With hat:	portmgr
1.0.1
22 Nov 2013 12:55:00
Revision:334586Original commit files touched by this commit
makc search for other commits by this committer
- Convert to USES=qmake (and other USES while I'm here)
- Add state support
- Convert LIB_DEPENDS to new style, adjust USE_QT4 components, etc.

Approved by:	portmgr (blanket approval)
1.0.1
20 Sep 2013 22:10:25
Revision:327755Original commit files touched by this commit
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
net)
1.0.1
06 Jun 2012 06:44:38
Original commit files touched by this commit
miwi search for other commits by this committer
- Convert USE_QT_VER=4 and QT_COMPONETS to USE_QT4

Review by:      bapt, David Naylor (kde team)
1.0.1
20 Mar 2011 12:54:45
Original commit files touched by this commit
miwi search for other commits by this committer
- Get Rid MD5 support
1.0.1
24 Sep 2010 01:34:07
Original commit files touched by this commit
swills search for other commits by this committer
QT support for OAuth-powered network services

WWW:    http://wiki.github.com/ayoy/qoauth/

Approved by:    pgollucci (mentor)

Number of commits found: 20