notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
Some details on the 2023-01-16 website outage.
We just rebooted with several updates: * new HMTLify code * no port maintainer is now highly visible (e.g. https://freshports.org/security/sssd/) * fixed search logic error when using plain/ text details at https://github.com/FreshPorts/freshports/releases/tag/2.2.34
Port details
qtchooser Qt tool wrapper
66_4 misc Deleted on this many watch lists=6 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch.
Maintainer: kde@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2017-02-18 19:48:20
Last Update: 2021-07-04 16:55:16
Commit Hash: be86c4f
People watching this port, also watch:: libraw, desktop-file-utils, font-misc-meltho, py39-pycparser, libinotify
License: GPLv3 LGPL21
Description:
Homepage    cgit ¦ Codeberg ¦ GitHub ¦ GitLab ¦ SVNWeb - no subversion history for this port
pkg-plist: as obtained via: make generate-plist
Expand this list (13 items)
Collapse this list.
  1. /usr/local/share/licenses/qtchooser-66_4/catalog.mk
  2. /usr/local/share/licenses/qtchooser-66_4/LICENSE
  3. /usr/local/share/licenses/qtchooser-66_4/GPLv3
  4. /usr/local/share/licenses/qtchooser-66_4/LGPL21
  5. bin/qtchooser
  6. bin/update-qtchooser-wrapper
  7. etc/xdg/qtchooser/default.conf
  8. etc/xdg/qtchooser/qt4.conf
  9. etc/xdg/qtchooser/qt5.conf
  10. man/man1/qtchooser.1.gz
  11. @owner
  12. @group
  13. @mode
Collapse this list.
Dependency lines:
  • qtchooser>0:misc/qtchooser
Conflicts:
CONFLICTS_INSTALL:
  • rubygem-github-linguist
  • rubygem-github-linguist47
  • rubygem-gitlab-linguist
Conflicts Matches:
There are no Conflicts Matches for this port. This is usually an error.
No installation instructions:
This port has been deleted.
PKGNAME: qtchooser
Flavors: there is no flavor information for this port.
distinfo:

Packages (timestamps in pop-ups are UTC):
qtchooser
ABIlatestquarterly
FreeBSD:11:aarch643966_2
FreeBSD:11:amd64pkg-fallout66_4
FreeBSD:11:armv6pkg-fallout66_2
FreeBSD:11:i386pkg-fallout66_4
FreeBSD:11:mipspkg-falloutpkg-fallout
FreeBSD:11:mips64pkg-fallout66_2
FreeBSD:12:aarch6439pkg-fallout
FreeBSD:12:amd64pkg-falloutpkg-fallout
FreeBSD:12:armv63966_4
FreeBSD:12:armv76666_4
FreeBSD:12:i386pkg-falloutpkg-fallout
FreeBSD:12:mipspkg-falloutpkg-fallout
FreeBSD:12:mips646666_2
FreeBSD:12:powerpc64pkg-fallout66_4
FreeBSD:13:aarch64pkg-falloutpkg-fallout
FreeBSD:13:amd64pkg-falloutpkg-fallout
FreeBSD:13:armv666_4pkg-fallout
FreeBSD:13:armv7pkg-falloutpkg-fallout
FreeBSD:13:i386pkg-falloutpkg-fallout
FreeBSD:13:mipspkg-falloutpkg-fallout
FreeBSD:13:mips6466_466_4
FreeBSD:13:powerpc6466_4pkg-fallout
FreeBSD:13:riscv64pkg-falloutpkg-fallout
FreeBSD:14:aarch64pkg-falloutpkg-fallout
FreeBSD:14:amd64pkg-falloutpkg-fallout
FreeBSD:14:armv6pkg-falloutpkg-fallout
FreeBSD:14:armv7pkg-falloutpkg-fallout
FreeBSD:14:i386pkg-falloutpkg-fallout
FreeBSD:14:mipspkg-falloutpkg-fallout
FreeBSD:14:mips64pkg-falloutpkg-fallout
FreeBSD:14:powerpc64pkg-falloutpkg-fallout
FreeBSD:14:riscv64pkg-falloutpkg-fallout
 
Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. gmake>=4.3 : devel/gmake
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Run

Deleted ports which required this port:

Expand this list of 59 deleted ports
  1. accessibility/qt4-accessible*
  2. chinese/qt4-codecs-cn*
  3. chinese/qt4-codecs-tw*
  4. databases/qt4-ibase-plugin*
  5. databases/qt4-mysql-plugin*
  6. databases/qt4-odbc-plugin*
  7. databases/qt4-pgsql-plugin*
  8. databases/qt4-sql*
  9. databases/qt4-sqlite-plugin*
  10. databases/qt4-sqlite3-plugin*
  11. devel/qt4-assistant*
  12. devel/qt4-corelib*
  13. devel/qt4-dbus*
  14. devel/qt4-designer*
  15. devel/qt4-help*
  16. devel/qt4-help-tools*
  17. devel/qt4-linguist*
  18. devel/qt4-linguisttools*
  19. devel/qt4-makeqpf*
  20. devel/qt4-moc*
  21. devel/qt4-porting*
  22. devel/qt4-qdbusviewer*
  23. devel/qt4-qdoc3*
  24. devel/qt4-qmake*
  25. devel/qt4-qmlviewer*
  26. devel/qt4-qt3support*
  27. devel/qt4-qvfb*
  28. devel/qt4-rcc*
  29. devel/qt4-script*
  30. devel/qt4-scripttools*
  31. devel/qt4-testlib*
  32. devel/qt4-uic*
  33. devel/qt4-uic3*
  34. graphics/qt4-iconengines*
  35. graphics/qt4-imageformats*
  36. graphics/qt4-opengl*
  37. graphics/qt4-pixeltool*
  38. graphics/qt4-svg*
  39. japanese/qt4-codecs-jp*
  40. korean/qt4-codecs-kr*
  41. lang/qt5-qml*
  42. misc/qt4-doc*
  43. misc/qt4-l10n*
  44. misc/qt4-qtconfig*
  45. misc/qt4-qtdemo*
  46. multimedia/qt4-multimedia*
  47. net/qt4-network*
  48. textproc/qt4-clucene*
  49. textproc/qt4-xml*
  50. textproc/qt4-xmlpatterns*
  51. textproc/qt4-xmlpatterns-tool*
  52. www/qt4-webkit*
  53. x11/qt4-graphicssystems-opengl*
  54. x11/qt4-inputmethods*
  55. x11-toolkits/qt4-declarative*
  56. x11-toolkits/qt4-gui*
  57. x11-toolkits/qt5-canvas3d*
  58. x11-toolkits/qt5-declarative-render2d*
  59. x11-toolkits/qt5-quick*
  60. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:
USES:
pkg-message:
For install:
WWW: https://github.com/qt/qtchooser
Master Sites:
Expand this list (6 items)
Collapse this list.
  1. http://master.qt.io/official_releases/qtchooser/
  2. http://qtmirror.ics.com/pub/qtproject/official_releases/qtchooser/
  3. http://www.nic.funet.fi/pub/mirrors/download.qt-project.org/official_releases/qtchooser/
  4. https://download.qt.io/official_releases/qtchooser/
  5. https://ftp.jaist.ac.jp/pub/qtproject/official_releases/qtchooser/
  6. https://www.mirrorservice.org/sites/download.qt-project.org/official_releases/qtchooser/
Collapse this list.
Notes from UPDATING
These upgrade notes are taken from /usr/ports/UPDATING
  • 2021-07-04
    Affects: users of misc/qtchooser
    Author: kde@FreeBSD.org
    Reason: 
      QtChooser allows you to select your version of Qt among those installed.
      However, this tool is no longer supported upstream and will not be
      available for Qt6.
    
      By default, our Qt installations are done in:
      ${LOCALBASE}/lib/qt${QT_VERSION} as recommended.
      We have added symbolic linking for the main binaries to
      ${LOCALBASE}/bin with the suffix -qt5.
    
    
Port Moves
  • port deleted on 2021-07-04
    REASON: No longer supported upstream

Number of commits found: 14

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
CommitCreditsLog message
66_4
04 Jul 2021 16:55:16
commit hash:be86c4fe23e089aeef1ed7467161c2ce321a8c81commit hash:be86c4fe23e089aeef1ed7467161c2ce321a8c81commit hash:be86c4fe23e089aeef1ed7467161c2ce321a8c81commit hash:be86c4fe23e089aeef1ed7467161c2ce321a8c81 files touched by this commit
Loïc Bartoletti (lbartoletti) search for other commits by this committer
misc/qtchooser: remove

QtChooser allows you to select your version of Qt among those installed.
However, this tool is no longer supported upstream and will not be
available for Qt6.
By default, our Qt installations are done in
${LOCALBASE}/lib/qt${QT_VERSION} as recommended.

We have added symbolic linking for the main binaries to
${LOCALBASE}/bin with the suffix -qt5.
66_4
07 Apr 2021 08:09:01
commit hash:cf118ccf875508b9a1c570044c93cfcc82bd455ccommit hash:cf118ccf875508b9a1c570044c93cfcc82bd455ccommit hash:cf118ccf875508b9a1c570044c93cfcc82bd455ccommit hash:cf118ccf875508b9a1c570044c93cfcc82bd455c files touched by this commit
Mathieu Arnold (mat) search for other commits by this committer
One more small cleanup, forgotten yesterday.
Reported by:	lwhsu
66_4
06 Apr 2021 14:31:13
commit hash:135fdeebb99c3569e42d8162b265e15d29bd937dcommit hash:135fdeebb99c3569e42d8162b265e15d29bd937dcommit hash:135fdeebb99c3569e42d8162b265e15d29bd937dcommit hash:135fdeebb99c3569e42d8162b265e15d29bd937d files touched by this commit
Mathieu Arnold (mat) search for other commits by this committer
all: Remove all other $FreeBSD keywords.
66_4
06 Apr 2021 14:31:07
commit hash:305f148f482daf30dcf728039d03d019f88344ebcommit hash:305f148f482daf30dcf728039d03d019f88344ebcommit hash:305f148f482daf30dcf728039d03d019f88344ebcommit hash:305f148f482daf30dcf728039d03d019f88344eb files touched by this commit
Mathieu Arnold (mat) search for other commits by this committer
Remove # $FreeBSD$ from Makefiles.
66_4
13 Sep 2020 04:01:28
Revision:548448Original commit files touched by this commit
danfe search for other commits by this committer
Ports Collection no longer offers Qt4 support, make the wording Qt version-
agnostic so it won't become inaccurate with every Qt(n+1) vs. Qt(n) cadence.
66_3
19 Jul 2020 21:37:57
Revision:542599Original commit files touched by this commit
adridg search for other commits by this committer
Massage misc/qtchooser

- expand documentation of the tool used to manage the links; while we
  have only Qt5 in the tree the whole thing is rather moot, it's good
  to tidy up before Qt6 shows up on the horizon.
- update the documentation in the Makefile to reflect the current
  state of Uses/qt.mk

I've bumped PORTREVISION because the package contents will change
with the updated script, but there's no functional change at all.

SVN hooks have forced me to remove svn:executable from the
script file, but this doesn't change the resulting permissions
on the installed executable and script.

PR:		242905
66_2
13 Apr 2020 12:35:59
Revision:531601Original commit files touched by this commit
tcberner search for other commits by this committer
Update Qt5 to 5.14.2

Very big thanks go again to kai@ who provided the www/qt5-webengine upgrade (to
5.14.0).
Notably, video capture support was re-enabled.

Announcement:
        https://www.qt.io/blog/qt-5.14-has-released

PR:		244964
Exp-run by:	antoine
66_2
14 Mar 2020 21:13:53
Revision:528447Original commit files touched by this commit
tcberner search for other commits by this committer
misc/qtchooser: remove verbosity of update script
66_1
25 Jan 2020 20:19:39
Revision:524129Original commit files touched by this commit
tcberner search for other commits by this committer
misc/qtchooser: do not create unnecessary wrappers

misc/qtchooser provides a wrapper binary bin/qtchooser, that when called with
name foo, will lauch the corresponding binary from
lib/qt${current_qt_version}/bin/foo.

Previously qtchooser would install a list of 30-ish symlinks to itself
automatically.
Now we switch this around.

qt-dist ports that define QT_BINARIES will now have a @postexec and @postunexec
entry added to their plist to run the shell-script update-qtchooser-wrapper
(installed by qtchooser).

update-qtchooser-wrapper removes all symlinks to bin/qtcreator that have no
corresponding binary in lib/qt*/bin, and readds links that are missing.

Exp-run by:	antoine
PR:		242905
PR:		243443
Reported by:	grarpamp@gmail.com
Reviewed by:	adridg
Differential Revision:	https://reviews.freebsd.org/D22991
66
13 Aug 2019 22:29:43
Revision:508882Original commit files touched by this commit
mat search for other commits by this committer
onvert to UCL & cleanup pkg-message (categories l-m)
66
08 Oct 2018 18:26:07
Revision:481555Original commit files touched by this commit
tcberner search for other commits by this committer
misc/qtchooser: update to 66.
39
17 Feb 2018 17:51:11
Revision:462177Original commit files touched by this commit
sunpoet search for other commits by this committer
Mark CONFLICTS_INSTALL with rubygem-github-linguist, rubygem-github-linguist47
and rubygem-gitlab-linguist
39
11 Jan 2018 16:53:45
Revision:458755Original commit files touched by this commit
danfe search for other commits by this committer
Remove superfluous linefeeds and fix some other minor whitespace bugs.
39
18 Feb 2017 19:48:05
Revision:434380Original commit files touched by this commit
tcberner search for other commits by this committer
Update Qt5 to 5.7.1, and unify the Qt4 and Qt5 ports some more

* Update Qt5 to 5.7.1
* Move Qt4 binaries to lib/qt4/bin
* Move Qt5 libraries to lib/qt5/lib
  By moving the libraries we should finally be able to get rid of the inplace
  upgrade bug (see ports bugs 194088, 195105 and 198720):  when Qt5's libraries
  were lying in /usr/local/lib, which would often get added by pkgconfig to the
  linker paths via dependencies, the already installed libraries were linked
  against, instead of the ones that were being built. This forced us to make
  sure, that -L${WRKSRC}/lib was always coming before -L/usr/local/lib in the
  linker flags. With this change this should no longer be the case.
* Rename some ports to match the rest (foo-qtX -> qtX-foo)
* Depend on new port misc/qtchooser [see UPDATING & CHANGES]

There are several new Qt5 ports which all have been created by Marie Loise
Nolden
<nolden@kde.org>. Thanks again.

PR:		216797
Exp-Run by:	antoine
Reviewed by:	rakuco, mat, groot_kde.org
Approved by:	rakuco (mentor)
Differential Revision:	https://reviews.freebsd.org/D9213

Number of commits found: 14