notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
Some details on the 2023-01-16 website outage.
We just rebooted with several updates: * new HMTLify code * no port maintainer is now highly visible (e.g. https://freshports.org/security/sssd/) * fixed search logic error when using plain/ text details at https://github.com/FreshPorts/freshports/releases/tag/2.2.34
Port details
ruby-poppler Ruby binding for Poppler
1.1.5_1 x11-toolkits Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch. NOTE: Slave port - quarterly revision is most likely wrong.
Deprecated DEPRECATED: Use rubygem-poppler instead
Expired This port expired on: 2014-03-23
Maintainer: ruby@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2010-11-27 03:33:44
Last Update: 2014-03-24 18:11:45
SVN Revision: 349046
Also Listed In: ruby
License: not specified in port
Description:
Homepage    cgit ¦ GitHub ¦ GitHub ¦ GitLab ¦ SVNWeb
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • ruby19-poppler>0:x11-toolkits/ruby-poppler
No installation instructions:
This port has been deleted.
PKGNAME: ruby19-poppler
Flavors: there is no flavor information for this port.
distinfo:
There is no distinfo for this port.

No package information for this port in our database
Sometimes this happens. Not all ports have packages. This is doubly so for new ports, like this one.
Master port: x11/ruby-gnome2
Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. rubygem-pkg-config>=1.0.7 : devel/rubygem-pkg-config
  2. ruby19 : lang/ruby19
Runtime dependencies:
  1. rubygem-pkg-config>=1.0.7 : devel/rubygem-pkg-config
  2. ruby19 : lang/ruby19
Library dependencies:
  1. libpoppler-glib.so : graphics/poppler-glib
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Run

Deleted ports which required this port:

Expand this list of 2 deleted ports
  1. misc/rabbit*
  2. x11/ruby-gnome2*
  3. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:
FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (2 items)
Collapse this list.
  1. ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/ruby/
  2. http://downloads.sourceforge.net/project/ruby-gnome2/ruby-gnome2/ruby-gnome2-1.1.5/
Collapse this list.
Port Moves
  • port deleted on 2014-03-24
    REASON: Has expired: Use rubygem-poppler instead

Number of commits found: 14

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
This is a slave port. You may also want to view the commits to the master port: x11/ruby-gnome2
CommitCreditsLog message
1.1.5_1
24 Mar 2014 18:11:45
Revision:349046Original commit files touched by this commit
swills search for other commits by this committer
2014-03-23 accessibility/ruby-atk: Use rubygem-atk instead
2014-03-23 devel/ruby-gio2: Use rubygem-gio2 instead
2014-03-23 devel/ruby-glib2: Use rubygem-glib2 instead
2014-03-23 graphics/ruby-cairo: Use rubygem-cairo instead
2014-03-23 graphics/ruby-gdk_pixbuf2: Use rubygem-gdk_pixbuf2 instead
2014-03-23 graphics/ruby-rsvg2: Use rubygem-rsvg2 instead
2014-03-23 x11-toolkits/ruby-goocanvas: No longer included upstream
2014-03-23 x11-toolkits/ruby-gstreamer: Use rubygem-gstreamer instead
2014-03-23 x11-toolkits/ruby-gtk2: Use rubygem-gtk2 instead
2014-03-23 x11-toolkits/ruby-gtksourceview2: Use rubygem-gtksourceview2 instead
2014-03-23 x11-toolkits/ruby-pango: Use rubygem-pango instead
2014-03-23 x11-toolkits/ruby-poppler: Use rubygem-poppler instead
2014-03-23 x11-toolkits/ruby-vte: Use rubygem-vte instead
2014-03-23 x11/ruby-gnome2: Use rubygem-gnome2 instead
1.1.5_1
22 Feb 2014 23:19:29
Revision:345679Original commit files touched by this commit
swills search for other commits by this committer
- Mark as broken with Ruby 2.0 and 2.1
- Mark deprecated in favor of rubygem- versions
1.1.5_1
27 Dec 2013 16:54:22
Revision:337749Original commit files touched by this commit
kwm search for other commits by this committer
Update poppler to 0.24.4.

Update comment.
Use new LIB_DEPENDS syntax, use USES=pathfix.
Stagify.

Bump portrevision of all affected ports, and Update poppler* LIB_DEPENDS to
new syntax.
1.1.5
20 Sep 2013 23:57:48
Revision:327785Original commit files touched by this commit
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
x11-toolkits)
1.1.5
06 Sep 2012 05:28:50
Revision:303740Original commit files touched by this commit
swills search for other commits by this committer
- Convert ruby-gnome ports to proper master/slave setup
Reviewed by:	gjb
1.1.4
24 Jul 2012 03:08:24
Original commit files touched by this commit
swills search for other commits by this committer
- Update ruby-gnome2 ports to 1.1.4
1.1.3_1
04 Jun 2012 21:02:59
Original commit files touched by this commit
swills search for other commits by this committer
- Update ruby-gnome ports to 1.1.3

PR:             ports/168435
Submitted by:   Makoto Kishimoto <ksmakoto@dd.iij4u.or.jp>
1.0.3_1
01 Jun 2012 05:26:28
Original commit files touched by this commit
dinoex search for other commits by this committer
- update png to 1.5.10
1.0.3
05 Dec 2011 22:54:11
Original commit files touched by this commit
swills search for other commits by this committer
- Update ruby-gnome2 to 1.0.3

PR:             ports/162139
Submitted by:   TAKATSU Tomonari <tota@freebsd.org> (based on)
Feature safe:   yes
0.90.5_2
31 Oct 2011 09:53:19
Original commit files touched by this commit
kwm search for other commits by this committer
Update poppler to 0.18.0.

The qt3 bindings are removed upstream.
The glib library lost the last gdk-pixbuf code. And rename it from
-gtk to -glib.

Thanks to:      pav for a exp-runs
                bapt for double checking the libreoffice ports
0.90.5_1
23 Aug 2011 18:36:21
Original commit files touched by this commit
kwm search for other commits by this committer
Chase poppler shlib bumps.
0.90.5
18 Mar 2011 19:47:39
Original commit files touched by this commit
swills search for other commits by this committer
- Fix PLIST issues with RUBY_VER == 1.9
0.90.5
20 Dec 2010 02:46:25
Original commit files touched by this commit
pgollucci search for other commits by this committer
Clean up ruby pkg-plists:
    %%RUBY_SITEARCHLIBDIR%%
    %%RUBY_SITELIBDIR%%
    lib/ruby/site_ruby
    %%RUBY_VENDORARCHLIBDIR%%
    %%RUBY_VENDORLIBDIR%%
    lib/ruby/vendor_ruby
    lib/ruby

Above directories are owned by lang/ruby1[89] ports.

PR:         ports/153041
Tested by:  2-exp runs by pav
With Hat:   ruby@
0.90.5
27 Nov 2010 03:32:41
Original commit files touched by this commit
swills search for other commits by this committer
- Update to 0.90.5
- create ports for vte, gstreamer, gtksourceview2, poppler and goocanvas modules
- sort depends in meta port
- remove patch to ruby-gtk2 that's merged upstream
- remove old gtksourceview module which seems broken

Submitted by:   swills (myself)
Approved by:    wxs (mentor)

Number of commits found: 14