notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
NOTE: the WWW: line in pkg-descr was relocated to a WWW= line in Makefile. Each port in FreshPorts has a homepage link. Look for it right after the Description: on each port's home page.

Do I know someone who can pick up a server from 7401 E. Ben White Blvd. Austin TX?

The emphasis is on know, or recommended by someone I know. This is the original FreshPorts server, way past useful: RAID, 8GB RAM, etc. The drives need to be wiped and everything recycled.
Port details
yarn-node12 Package manager for node, alternative to npm
1.22.10 www Deleted on this many watch lists=1 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch. NOTE: Slave port - quarterly revision is most likely wrong.
Deprecated DEPRECATED: Uses EOL Python 2.7 via www/node12
Expired This port expired on: 2021-06-23
Maintainer: pizzamig@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2019-11-20 17:27:33
Last Update: 2021-06-26 12:00:01
Commit Hash: 25e4567
People watching this port, also watch:: mariadb105-server, php80, php74
License: BSD2CLAUSE
Description:
HomepagecgitgithubgitlabSVNWeb
pkg-plist: as obtained via: make generate-plist
Expand this list (18 items)
Collapse this list.
  1. /usr/local/share/licenses/yarn-node12-1.22.10/catalog.mk
  2. /usr/local/share/licenses/yarn-node12-1.22.10/LICENSE
  3. /usr/local/share/licenses/yarn-node12-1.22.10/BSD2CLAUSE
  4. bin/yarn
  5. bin/yarn.js
  6. bin/yarnpkg
  7. lib/node_modules/yarn/LICENSE
  8. lib/node_modules/yarn/README.md
  9. @(,,755) lib/node_modules/yarn/bin/yarn
  10. @(,,755) lib/node_modules/yarn/bin/yarn.js
  11. @(,,755) lib/node_modules/yarn/bin/yarnpkg
  12. @(,,755) lib/node_modules/yarn/lib/cli.js
  13. lib/node_modules/yarn/lib/v8-compile-cache.js
  14. lib/node_modules/yarn/package.json
  15. lib/node_modules/yarn/preinstall.js
  16. @owner
  17. @group
  18. @mode
Collapse this list.
Dependency lines:
  • yarn-node12>0:www/yarn-node12
Conflicts:
CONFLICTS_INSTALL:
  • yarn
  • yarn-node10
  • yarn-node14
  • hadoop2*
Conflicts Matches:
There are no Conflicts Matches for this port. This is usually an error.
No installation instructions:
This port has been deleted.
PKGNAME: yarn-node12
Flavors: there is no flavor information for this port.
distinfo:

Packages (timestamps in pop-ups are UTC):
yarn-node12
ABIlatestquarterly
FreeBSD:11:aarch64pkg-fallout1.22.4_1
FreeBSD:11:amd64pkg-falloutpkg-fallout
FreeBSD:11:armv6pkg-falloutpkg-fallout
FreeBSD:11:i386pkg-falloutpkg-fallout
FreeBSD:11:mipspkg-falloutpkg-fallout
FreeBSD:11:mips64pkg-falloutpkg-fallout
FreeBSD:12:aarch64pkg-falloutpkg-fallout
FreeBSD:12:amd64pkg-falloutpkg-fallout
FreeBSD:12:armv6pkg-fallout1.22.4_1
FreeBSD:12:armv7pkg-fallout1.22.4_1
FreeBSD:12:i386pkg-falloutpkg-fallout
FreeBSD:12:mipspkg-falloutpkg-fallout
FreeBSD:12:mips64pkg-falloutpkg-fallout
FreeBSD:12:powerpc64pkg-fallout1.22.10
FreeBSD:13:aarch64pkg-falloutpkg-fallout
FreeBSD:13:amd64pkg-falloutpkg-fallout
FreeBSD:13:armv61.22.10pkg-fallout
FreeBSD:13:armv7pkg-falloutpkg-fallout
FreeBSD:13:i386pkg-falloutpkg-fallout
FreeBSD:13:mipspkg-falloutpkg-fallout
FreeBSD:13:mips64pkg-falloutpkg-fallout
FreeBSD:13:powerpc641.22.10pkg-fallout
FreeBSD:13:riscv64pkg-falloutpkg-fallout
FreeBSD:14:aarch64pkg-falloutpkg-fallout
FreeBSD:14:amd64pkg-falloutpkg-fallout
FreeBSD:14:armv6pkg-falloutpkg-fallout
FreeBSD:14:armv7pkg-falloutpkg-fallout
FreeBSD:14:i386pkg-falloutpkg-fallout
FreeBSD:14:mipspkg-falloutpkg-fallout
FreeBSD:14:mips64pkg-falloutpkg-fallout
FreeBSD:14:powerpc641.22.10pkg-fallout
FreeBSD:14:riscv64pkg-falloutpkg-fallout
 

Master port: www/yarn

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Runtime dependencies:
  1. node12>=12.0.0 : www/node12
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Fetch

Deleted ports which required this port:

Expand this list of 4 deleted ports
  1. devel/electron11*
  2. devel/electron6*
  3. devel/electron7*
  4. devel/electron9*
  5. Collapse this list of deleted ports.
for Patch

Deleted ports which required this port:

Expand this list of 4 deleted ports
  1. devel/electron11*
  2. devel/electron6*
  3. devel/electron7*
  4. devel/electron9*
  5. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:
FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://yarnpkg.com/downloads/1.22.10/
Collapse this list.
Port Moves
  • port deleted on 2021-06-26
    REASON: Has expired: Uses EOL Python 2.7 via www/node12

Number of commits found: 5

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
This is a slave port. You may also want to view the commits to the master port: www/yarn
CommitCreditsLog message
1.22.10
26 Jun 2021 12:00:01
commit hash:25e45674705f532893ef83e6a6334f53abbf085dcommit hash:25e45674705f532893ef83e6a6334f53abbf085dcommit hash:25e45674705f532893ef83e6a6334f53abbf085d files touched by this commit
Rene Ladan (rene) search for other commits by this committer
*/*: Remove expired ports:

2020-12-31 www/node12: Uses Python 2.7 which is EOLed upstream
www/npm-node12: uses www/node12
2021-06-23 www/yarn-node12: Uses EOL Python 2.7 via www/node12
1.22.10
06 Apr 2021 14:31:07
commit hash:305f148f482daf30dcf728039d03d019f88344ebcommit hash:305f148f482daf30dcf728039d03d019f88344ebcommit hash:305f148f482daf30dcf728039d03d019f88344eb files touched by this commit
Mathieu Arnold (mat) search for other commits by this committer
Remove # $FreeBSD$ from Makefiles.
1.22.10
24 Mar 2021 13:34:36
Revision:569118Original commit files touched by this commit
rene search for other commits by this committer
Mark ports recursively depending on Python 2.7 for expiration on June 23.

For ports optionally dependending on Python 2.7, just mark those options
as expired. Remove konquerer from the x11/kde-baseapps metaport and bump
its PORTREVISION.

Submitted by:	rene
Reviewed by:	portmgr, adridg, ehaupt, lme, madpilot, pizzamig, se, sunpoet, yuri
Approved by:	portmgr
Differential Revision:	https://reviews.freebsd.org/D28665
1.22.10
30 Dec 2020 17:20:12
Revision:559675Original commit files touched by this commit
pizzamig search for other commits by this committer
www/yarn-*: update to 1.22.10

Add support for Node 14
Fix CONFLICTS with an updated list of nodejs versions
Changelog: https://github.com/yarnpkg/yarn/blob/master/CHANGELOG.md

PR:		251967
Submitted by:	Jose Luis Duran <jlduran@gmail.com>
1.19.1
20 Nov 2019 17:27:26
Revision:518041Original commit files touched by this commit
pizzamig search for other commits by this committer
www/yarn-node12: Add new slave port

Add yarn-node12 slave port after the release of Node.js 12 as stable

Number of commits found: 5