notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
Some details on the 2023-01-16 website outage.
We just rebooted with several updates: * new HMTLify code * no port maintainer is now highly visible (e.g. https://freshports.org/security/sssd/) * fixed search logic error when using plain/ text details at https://github.com/FreshPorts/freshports/releases/tag/2.2.34
Port details
py-djblets Collection of useful classes and functions for Django
0.9.4 www Deleted on this many watch lists=1 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Does not build with py-django18 see pr: 216758
Expired This port expired on: 2017-04-19
Maintainer: python@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2011-02-26 14:56:17
Last Update: 2017-04-19 19:56:12
SVN Revision: 438908
People watching this port, also watch:: p5-Alien-wxWidgets, p5-Thread-Suspend, wipe, p5-threads-shared
Also Listed In: python
License: MIT
Description:
Homepage    cgit ¦ GitHub ¦ GitHub ¦ GitLab ¦ SVNWeb
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • ${PYTHON_PKGNAMEPREFIX}djblets>0:www/py-djblets@${PY_FLAVOR}
No installation instructions:
This port has been deleted.
PKGNAME: py27-djblets
Flavors: there is no flavor information for this port.
distinfo:

No package information for this port in our database
Sometimes this happens. Not all ports have packages. This is doubly so for new ports, like this one.

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. uglifyjs : www/uglifyjs
  2. msgfmt : devel/gettext-tools
  3. py27-setuptools>0 : devel/py27-setuptools
  4. python2.7 : lang/python27
Runtime dependencies:
  1. py27-django16>=1.6.11 : www/py-django16
  2. py27-django-pipeline13>=1.3.27 : www/py-django-pipeline13
  3. py27-feedparser>=5.1.2 : textproc/py-feedparser
  4. py27-pillow>0 : graphics/py-pillow
  5. py27-pytz>0 : devel/py-pytz
  6. py27-setuptools>0 : devel/py27-setuptools
  7. python2.7 : lang/python27
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Build

Deleted ports which required this port:

Expand this list of 1 deleted port
  1. www/reviewboard*
  2. Collapse this list of deleted ports.
for Run

Deleted ports which required this port:

Expand this list of 1 deleted port
  1. www/reviewboard*
  2. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message

Master Sites:
Expand this list (2 items)
Collapse this list.
  1. https://files.pythonhosted.org/packages/source/D/Djblets/
  2. https://pypi.python.org/packages/source/D/Djblets/
Collapse this list.
Port Moves
  • port deleted on 2017-04-19
    REASON: Has expired: Does not build with py-django18 see pr: 216758

Number of commits found: 38

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
CommitCreditsLog message
0.9.4
19 Apr 2017 19:56:12
Revision:438908Original commit files touched by this commit
rene search for other commits by this committer
Remove expired ports:
2015-10-01 www/py-django16: End of extended support: April 1, 2015
www/py-django16-tastypie: Uses expired Django version
2017-04-01 www/py-django-pipeline13: Depends on expired www/py-django16, and
expired upstream
2017-04-19 www/py-djblets: Does not build with py-django18 see pr: 216758
2017-04-19 security/py-crits: Does not build with py-django18 see pr: 216758
www/py-cactus: Depends on expired Django version
devel/py-django16-tastypie-mongoengine: Uses expired Django version
0.9.4
05 Apr 2017 15:37:20
Revision:437796Original commit files touched by this commit
miwi search for other commits by this committer
- Mark py-djblets deprecated and set expired date

Explanation:
- py-django16 is expired since April 2015 we don't need to keep it anymore.
- The django team have introduced in version 1.7 a new crontrib module called
  "the staticfile app" [1].
  This is required to be enabled manually after the installation and manual
  changes are needed in setting.py.
- py-djblets requires the staticfile module to be able get installed and to
  work [2]. Our framework doesn't support it, and there is no plan in a near
  future to support it.

  [1] https://docs.djangoproject.com/en/1.7/ref/contrib/staticfiles/
     
https://django-doc-test-kor.readthedocs.io/en/latest/howto/static-files/index.html
  [2]
https://github.com/djblets/djblets/blob/release-0.9.6/contrib/internal/build-media.py

PR:		    213269
            216758
0.9.4
20 Dec 2016 06:05:42
Revision:428977Original commit files touched by this commit
wen search for other commits by this committer
- Update to 0.9.4
0.9.3
01 Oct 2016 06:28:34
Revision:423034Original commit files touched by this commit
rm search for other commits by this committer
databases/py-djblets: update to 0.9.3

With hat:   python
0.9.2
01 Apr 2016 14:33:58
Revision:412351Original commit files touched by this commit
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories v, w, x, y, and z.

With hat:	portmgr
Sponsored by:	Absolight
0.9.2
05 Mar 2016 20:28:58
Revision:410209Original commit files touched by this commit
rm search for other commits by this committer
www/py-djblets: update to 0.9.2

Changelog [1]:

Fixed a Self-XSS vulnerability in the djblets.datagrid column headers.

A recently-discovered vulnerability in the datagrid templates allows an attacker
to generate a URL to any datagrid page containing malicious code in a column
sorting value. If the user visits that URL and then clicks that column, the code
will execute.

The cause of the vulnerability was due to a template not escaping user-provided
values.

This vulnerability was reported by Jose Carlos Exposito Bueno (0xlabs).

[1] https://www.reviewboard.org/docs/releasenotes/djblets/0.9.2/

With hat:		python
0.9.1
26 Feb 2016 19:23:28
Revision:409634Original commit files touched by this commit This port version is marked as vulnerable.
rm search for other commits by this committer
www/py-djblets: actually pass maintainership to python@
0.9.1
26 Feb 2016 19:22:30
Revision:409633Original commit files touched by this commit This port version is marked as vulnerable.
rm search for other commits by this committer
www/py-djblets: update to 0.9.1

- update to 0.9.1
- switch MASTER_SITES to PyPi (cdn)
- actualize dependencies
- add NO_ARCH, because there isn't platform-dependent code
- add more files to shebang changing list
- pass maintainership to python@

Since version 0.9.1 djblets supports Django 1.8, while it still depends upon
www/py-django-pipeline13 (that requires Django 1.6), so I keep this dependency
unchanged to prevent django versions clash.

In not yet released version 0.10 djblets now depends on django-pipeline 1.6.6,
so after release we can completely switch this port to using Django 1.8
0.9_1
25 Dec 2015 22:14:54
Revision:404481Original commit files touched by this commit This port version is marked as vulnerable.
cs search for other commits by this committer
Update WWW
0.9_1
08 Dec 2015 09:49:06
Revision:403259Original commit files touched by this commit This port version is marked as vulnerable.
vanilla search for other commits by this committer
1: required py-django-pipeline13, not py-django-pipeline14.
2: bump version.
0.9
30 Nov 2015 08:45:18
Revision:402655Original commit files touched by this commit This port version is marked as vulnerable.
marino search for other commits by this committer
www/py-djblets: Unbreak everywhere that uses clean environment

The port requires msgfmt.  After the last update, it would no longer
build in poudriere.
0.9
27 Nov 2015 06:36:24
Revision:402474Original commit files touched by this commit This port version is marked as vulnerable.
vanilla search for other commits by this committer
Upgrade to 0.9.
0.7.28_1
08 Nov 2015 09:18:52
Revision:401046Original commit files touched by this commit This port version is marked as vulnerable.
antoine search for other commits by this committer
Deprecate Django 1.4 ports
0.7.28_1
19 Oct 2015 14:50:52
Revision:399684Original commit files touched by this commit This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
Improve shebangfix framework

- Support multiple values in *_OLD_CMD, i.e. we can now fix both
"/usr/bin/python" and "/usr/bin/env python" at the same time
- Default *_OLD_CMD values are now always appended, so you don't need to specify
them in individual ports
- Add lua support (depends on USES=lua)
- Add more default values, such as "/usr/bin/env foo" for python, perl, bash,
ruby and lua
- Shebangfix now matches whole words, e.g. we will no longer (erroneously)
replace "/usr/bin/perl5.005" with "${perl_CMD}5.005" (but "/usr/bin/perl -tt" is
still (correctly) replaced with "${perl_CMD} -tt")

Note that *_OLD_CMD items containing spaces must now be quoted (e.g.
perl_OLD_CMD=/bin/perl /usr/bin/perl "/usr/bin/env perl")

Update shebangfix usage according to new rules in many ports:

- Remove *_OLD_CMD for patterns now replaced by default
- Quote custom *_OLD_CMD which contain spaces

Fix shebangfix usage in many ports (irrelevant to infrastructure change):

- Remove redundant SHEBANG_LANG (no need to duplicate default langs)
- Remove redundant *_CMD (such as
python_CMD=${LOCALBASE}/bin/python${PYTHON_VER} when USES=python is present)
- Never use *_OLD_CMD in REINPLACE_CMD matchers, these should always look for
exact string

Approved by:	portmgr (bapt)
Differential Revision:	D3756
0.7.28_1
29 Jul 2015 22:09:55
Revision:393196Original commit files touched by this commit This port version is marked as vulnerable.
antoine search for other commits by this committer
Switch default python_CMD used by shebangfix to ${PYTHON_CMD} for ports
using python

PR:		201077
Reviewed by:	mat
With hat:	portmgr
Differential Revision:	https://reviews.freebsd.org/D2955
0.7.28_1
26 Mar 2015 00:00:44
Revision:382280Original commit files touched by this commit This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Drop @dirrm* from plist
0.7.28_1
17 Oct 2014 10:23:35
Revision:371040Original commit files touched by this commit This port version is marked as vulnerable.
bapt search for other commits by this committer
Reset maintainership
0.7.28_1
07 Oct 2014 11:58:58
Revision:370304Original commit files touched by this commit This port version is marked as vulnerable.
wg search for other commits by this committer
www/py-djblets: switch from py-imaging to py-pillow

- USES python

With hat:	python
Approved by:	portmgr (bdrewery, implicit)
0.7.28
16 Jun 2014 17:38:41
Revision:358027Original commit files touched by this commit This port version is marked as vulnerable.
antoine search for other commits by this committer
Fix BUILD_DEPENDS
0.7.28
29 Mar 2014 23:43:56
Revision:349597Original commit files touched by this commit This port version is marked as vulnerable.
swills search for other commits by this committer
- Update to 0.7.28

PR:		ports/187450
Submitted by:	swills (mysels)
Approved by:	maintainer timeout (pclin, >2 weeks)
0.7.9_1
13 Jan 2014 21:00:04
Revision:339634Original commit files touched by this commit This port version is marked as vulnerable.
rene search for other commits by this committer
Python cleanup:
- USE_PYTHON* = 2.X -> USE_PYTHON* = 2
- USE_PYTHON* = 2.X+ -> USE_PYTHON* = yes
Reviewed by:	python (mva, rm)
Approved by:	portmgr-lurkers (mat)
0.7.9_1
14 Dec 2013 09:10:39
Revision:336425Original commit files touched by this commit This port version is marked as vulnerable.
mva search for other commits by this committer
- Fix BUILD_ and LIB_DEPENDS for py-django14

Reported by:	exp-run (PR 184591)
Approved by:	portmgr (blanket)
0.7.9_1
08 Dec 2013 13:36:11
Revision:335893Original commit files touched by this commit This port version is marked as vulnerable.
mva search for other commits by this committer
- Fix the usage of 'python' to get rid of the implicit lang/python
  dependency

Approved by:	portmgr (blanket)
0.7.9_1
20 Sep 2013 23:36:54
Revision:327776Original commit files touched by this commit This port version is marked as vulnerable.
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
www)
0.7.9_1
05 Mar 2013 18:09:08
Revision:313467Original commit files touched by this commit This port version is marked as vulnerable.
lwhsu search for other commits by this committer
- Update DEPENDS for the ports that explicitly claim need of Django 1.4
0.7.9
13 Feb 2013 09:37:50
Revision:312148Original commit files touched by this commit This port version is marked as vulnerable.
rm search for other commits by this committer
- update to 0.7.9

PR:		175754
Submitted by:	pclin (maintainer)
0.7.8
13 Feb 2013 06:04:09
Revision:312143Original commit files touched by this commit This port version is marked as vulnerable.
pclin search for other commits by this committer
- Update MAINTAINER email address for all my ports
- Convert Makefile header to new style if needed

Approved by:	swills (mentor)
0.7.8
07 Jan 2013 10:33:19
Revision:310033Original commit files touched by this commit This port version is marked as vulnerable.
rm search for other commits by this committer
- update to 0.7.8
- update dependencies list
- limit to python 2.x only

while here:
- remove indefinite article from COMMENT
- tab -> space change in pkg-descr:WWW

PR:		174681
Submitted by:	Po-Chien Lin <linpc@cs.nctu.edu.tw> (maintainer)
0.6.27
27 Nov 2012 13:13:47
Revision:307841Original commit files touched by this commit This port version is marked as vulnerable.
culot search for other commits by this committer
- Update to 0.6.27

PR:		ports/173919
Submitted by:	Po-Chien Lin <linpc@cs.nctu.edu.tw> (maintainer)
Feature safe:	yes
0.6.23
14 Oct 2012 11:24:38
Revision:305867Original commit files touched by this commit This port version is marked as vulnerable.
lwhsu search for other commits by this committer
- Update to 0.6.23
- Pass maintainership to submitter

PR:		ports/172578
Submitted by:	Po-Chien Lin <linpc@cs.nctu.edu.tw>
Feature safe:	yes
0.6.22
05 Aug 2012 08:15:14
Original commit files touched by this commit This port version is marked as vulnerable.
lwhsu search for other commits by this committer
- Update to 0.6.22

PR:		ports/170305
Submitted by:	Po-Chien Lin <linpc@cs.nctu.edu.tw>
0.6.19
28 Jun 2012 16:46:30
Original commit files touched by this commit This port version is marked as vulnerable.
lwhsu search for other commits by this committer
- Update to 0.6.19
0.6.18
28 Jun 2012 16:27:26
Original commit files touched by this commit This port version is marked as vulnerable.
lwhsu search for other commits by this committer
- Update to 0.6.18
- Change the Django dependency port to py-django13 because www/reviewboard
  depends on this version.

PR:             ports/168787
Submitted by:   Po-Chien Lin <linpc@cs.nctu.edu.tw>
0.6.17
30 Apr 2012 17:41:02
Original commit files touched by this commit This port version is marked as vulnerable.
lwhsu search for other commits by this committer
- Update to 0.6.17

PR:             ports/167458
Submitted by:   Po-Chien Lin <linpc@cs.nctu.edu.tw>
0.6.14
12 Nov 2011 14:42:19
Original commit files touched by this commit This port version is marked as vulnerable.
lwhsu search for other commits by this committer
- Update to 0.6.14

Feature safe:   yes
0.6.11
13 Sep 2011 22:15:22
Original commit files touched by this commit This port version is marked as vulnerable.
lwhsu search for other commits by this committer
- Update to 0.6.11
0.6.8
25 Jun 2011 07:30:31
Original commit files touched by this commit This port version is marked as vulnerable.
lwhsu search for other commits by this committer
- Update to 0.6.8

PR:             ports/158252
Submitted by:   Jin-Sih Lin <linpct@gmail.com>
0.6.7
26 Feb 2011 14:55:33
Original commit files touched by this commit This port version is marked as vulnerable.
lwhsu search for other commits by this committer
Add py-djblets 0.6.7, a collection of useful classes and functions for
Django.

Number of commits found: 38