notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
NOTE: There is a known problem on production with searching pkg-plist - it returns no results. This problem is not present on stage.freshports.org
Port details
py-dj21-django-debug-toolbar Configurable set of panels to display debug information
2.1 www Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Django 2.1 is now End-of-Life (Since December 2 2019) and no longer supported. Switch to Django 2.2+ versions of this port as soon as possible
Expired This port expired on: 2020-01-31
Maintainer: kai@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2019-02-11 12:03:08
Last Update: 2020-01-31 13:54:08
SVN Revision: 524704
Also Listed In: python
License: BSD3CLAUSE
Description:
Homepage    cgit ¦ GitHub ¦ GitHub ¦ GitLab ¦ SVNWeb
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • ${PYTHON_PKGNAMEPREFIX}dj21-django-debug-toolbar>0:www/py-dj21-django-debug-toolbar@${PY_FLAVOR}
Conflicts:
CONFLICTS_INSTALL:
  • py36-django-debug-toolbar
  • py36-dj22-django-debug-toolbar
Conflicts Matches:
There are no Conflicts Matches for this port. This is usually an error.
No installation instructions:
This port has been deleted.
PKGNAME: py36-dj21-django-debug-toolbar
Package flavors (<flavor>: <package>)
  • py36: py36-dj21-django-debug-toolbar
distinfo:

No package information for this port in our database
Sometimes this happens. Not all ports have packages.

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. py36-setuptools>0 : devel/py-setuptools@py36
  2. python3.6 : lang/python36
Runtime dependencies:
  1. py36-django21>=1.11 : www/py-django21@py36
  2. py36-sqlparse>=0.2.0 : databases/py-sqlparse@py36
  3. py36-setuptools>0 : devel/py-setuptools@py36
  4. python3.6 : lang/python36
There are no ports dependent upon this port

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message

Master Sites:
Expand this list (2 items)
Collapse this list.
  1. https://files.pythonhosted.org/packages/source/d/django-debug-toolbar/
  2. https://pypi.org/packages/source/d/django-debug-toolbar/
Collapse this list.
Port Moves
  • port moved to www/py-dj22-django-debug-toolbar on 2020-01-31
    REASON: Has expired: Django 2.1 is now End-of-Life (Since December 2 2019) and no longer supported. Switch to Django 2.2+ versions of this port as soon as possible

Number of commits found: 6

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
CommitCreditsLog message
2.1
31 Jan 2020 13:54:08
Revision:524704Original commit files touched by this commit
rene search for other commits by this committer
Remove expired ports:

2020-01-31 www/py-dj21-django-auth-ldap: Django 2.1 is now End-of-Life (Since
December 2 2019) and no longer supported. Switch to Django 2.2+ versions of this
port as soon as possible
2020-01-31 www/py-dj21-django-crispy-forms: Django 2.1 is now End-of-Life (Since
December 2 2019) and no longer supported. Switch to Django 2.2+ versions of this
port as soon as possible
2020-01-31 www/sogo3-activesync: Deprecated, replaced by www/sogo4
2020-01-31 devel/sope3: Deprecated, replaced by devel/sope4
2020-01-31 www/py-dj21-django-mptt: Django 2.1 is now End-of-Life (Since
December 2 2019) and no longer supported. Switch to Django 2.2+ versions of this
port as soon as possible
2020-01-31 graphics/py-willow11: Use graphics/py-willow instead
2020-01-31 www/py-dj21-django-tables2: Django 2.1 is now End-of-Life (Since
December 2 2019) and no longer supported. Switch to Django 2.2+ versions of this
port as soon as possible
2020-01-31 www/py-dj21-django-debug-toolbar: Django 2.1 is now End-of-Life
(Since December 2 2019) and no longer supported. Switch to Django 2.2+ versions
of this port as soon as possible
2020-01-31 security/krb5-115: EOL one year after the release of krb5 1.17
2020-01-31 www/py-dj21-django-taggit: Django 2.1 is now End-of-Life (Since
December 2 2019) and no longer supported. Switch to Django 2.2+ versions of this
port as soon as possible
2020-01-31 www/py-dj21-django-cors-headers: Django 2.1 is now End-of-Life (Since
December 2 2019) and no longer supported. Switch to Django 2.2+ versions of this
port as soon as possible
2020-01-31 graphics/py-imgurpython: No longer supported by upstream
2020-01-31 www/py-dj21-django-taggit-serializer: Django 2.1 is now End-of-Life
(Since December 2 2019) and no longer supported. Switch to Django 2.2+ versions
of this port as soon as possible
2020-01-31 www/py-dj21-django-filter: Django 2.1 is now End-of-Life (Since
December 2 2019) and no longer supported. Switch to Django 2.2+ versions of this
port as soon as possible
2020-01-31 www/py-dj21-django-timezone-field: Django 2.1 is now End-of-Life
(Since December 2 2019) and no longer supported. Switch to Django 2.2+ versions
of this port as soon as possible
2020-01-31 devel/py-xarray011: Use devel/py-xarray instead
2020-01-31 www/py-django-modelcluster4: Use www/py-django-modelcluster instead
2020-01-31 devel/py-semantic_version26: Use devel/py-semantic_version instead
2020-01-31 www/py-dj21-django-js-asset: Django 2.1 is now End-of-Life (Since
December 2 2019) and no longer supported. Switch to Django 2.2+ versions of this
port as soon as possible
2020-01-31 www/py-dj21-drf-yasg: Django 2.1 is now End-of-Life (Since December 2
2019) and no longer supported. Switch to Django 2.2+ versions of this port as
soon as possible
2.1
13 Dec 2019 10:14:27
Revision:520011Original commit files touched by this commit
kai search for other commits by this committer
www/py-{dj21,dj22}-django-debug-toolbar: Update to 2.1

Changelog:

https://github.com/jazzband/django-debug-toolbar/blob/2.1/docs/changes.rst
2.0
04 Dec 2019 12:02:32
Revision:519009Original commit files touched by this commit
kai search for other commits by this committer
www/py-django21 (and dj21 ports): Deprecate / set expiration date

Django 2.1 reached its End-of-Life (EoL) on 2nd December. Deprecate the port
and its consumers (= www/py-dj21-*) accordingly.

Set the expiration date to the end of January 2020 to give users enough time
to migrate to Django 2.2+ because the EoL is already onset and the
deprecation comes quite late.

Reviewed by:	koobs (python: maintainer)
Approved by:	koobs (python: maintainer)
Differential Revision:	https://reviews.freebsd.org/D22668
2.0
21 Jun 2019 08:09:55
Revision:504767Original commit files touched by this commit
kai search for other commits by this committer
www/py-{dj21,dj22}-django-debug-toolbar: Update to 2.0

Changelog:

https://github.com/jazzband/django-debug-toolbar/blob/2.0/docs/changes.rst
1.11
25 May 2019 10:10:01
Revision:502550Original commit files touched by this commit
kai search for other commits by this committer
net-mgmt/netbox: Update to 2.5.12 and switch to Django 2.2

Upstream decided to switch from Django 2.1 to the 2.2 LTS release to fix a
rather annoying bug that generated intermittent errors when objects were
deleted/manipulated.

Therefore the same procedure must be done in almost the same way as in
r492690 to make NetBox compatible with Django 2.2 in the ports tree.

That means to repocopy the required Django 1.11 ports, assign them to
Django 2.2, limit them to Python 3.5+ and update all related
CONFLICTS_INSTALL entries accordingly:

* www/py-dj22-django-cors-headers [1]
* www/py-dj22-django-debug-toolbar
(Only the first 15 lines of the commit message are shown above View all of this commit message)
1.11
11 Feb 2019 12:00:30
Revision:492690Original commit files touched by this commit
kai search for other commits by this committer
Create some ports that are assigned to Django 2.1 instead Django 1.11.

Django 1.11 is currently the "default" version in the ports tree due its
long term support until April 2020 thus ports that are assigned to that
version will exist until then.

The following packages are required to make the upgrade of net-mgmt/netbox
to 2.5.x possible because upstream has decided to switch from Django 1.11
to Django 2.1:

* www/py-dj21-django-cors-headers
* www/py-dj21-django-debug-toolbar
* www/py-dj21-django-filter
* www/py-dj21-django-js-asset
* www/py-dj21-django-mptt
(Only the first 15 lines of the commit message are shown above View all of this commit message)

Number of commits found: 6