notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
FreshPorts needs to find a new hosting provide willing to take a 2U chassis and host it free of charge. This is part of the FreshPorts project. Preferably in the Austin area. This is not a primary server, but it used for development.
Port details
linux-c6-flashplugin11 Adobe Flash Player NPAPI Plugin
11.2r202.644 www Deleted on this many watch lists=2 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch.
Restricted RESTRICTED: Redistribution not allowed
Maintainer: emulation@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2014-09-22 10:40:16
Last Update: 2016-12-13 17:51:14
SVN Revision: 428522
People watching this port, also watch:: xclock, screen, python, font-misc-meltho, font-bh-lucidatypewriter-100dpi
Also Listed In: linux multimedia
License: not specified in port
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • linux-c6-flashplugin>0:www/linux-c6-flashplugin11
No installation instructions:
This port has been deleted.
PKGNAME: linux-c6-flashplugin
Flavors: there is no flavor information for this port.
ONLY_FOR_ARCHS: amd64 i386
distinfo:
No package information for this port in our database
Sometimes this happens. Not all ports have packages.

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Runtime dependencies:
  1. linux-c6-curl>0 : ftp/linux-c6-curl
  2. linux-c6-cyrus-sasl2>0 : security/linux-c6-cyrus-sasl2
  3. linux-c6-gdk-pixbuf2>0 : graphics/linux-c6-gdk-pixbuf2
  4. linux-c6-gtk2>0 : x11-toolkits/linux-c6-gtk2
  5. linux-c6-nspr>0 : devel/linux-c6-nspr
  6. linux-c6-nss>0 : security/linux-c6-nss
  7. linux-c6-openssl-compat>0 : security/linux-c6-openssl-compat
There are no ports dependent upon this port

Configuration Options:
Options name:

USES:

pkg-message:

Master Sites:
  1. There is no master site for this port.
Port Moves

Number of commits found: 52

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
13 Dec 2016 17:51:14
Original commit files touched by this commit Revision:428522  11.2r202.644
tijl search for other commits by this committer
Update flash plugin to 24.0.0.186 and remove flash plugin 11.x ports.
10 Nov 2016 10:33:09
Original commit files touched by this commit Revision:425840  11.2r202.644
tijl search for other commits by this committer
Update flash plugin to 11.2r202.644.

MFH:		2016Q4
Security:	https://helpx.adobe.com/security/products/flash-player/apsb16-37.html
27 Oct 2016 12:53:12
Original commit files touched by this commit Revision:424761  11.2r202.643 This port version is marked as vulnerable.
tijl search for other commits by this committer
Update flash plugin to 11.2r202.643.
Remove unnecessary USES=desktop-file-utils.

PR:		213831
MFH:		2016Q4
Security:	https://helpx.adobe.com/security/products/flash-player/apsb16-36.html
22 Oct 2016 12:21:24
Original commit files touched by this commit Revision:424469  11.2r202.637 This port version is marked as vulnerable.
tijl search for other commits by this committer
Update flash plugin to 11.2r202.637.

PR:		213698
MFH:		2016Q4
Security:	https://helpx.adobe.com/security/products/flash-player/apsb16-32.html
11 Sep 2016 14:14:50
Original commit files touched by this commit Revision:421821  11.2r202.632_3 This port version is marked as vulnerable.
tijl search for other commits by this committer
Set STRIP= so INSTALL_LIB doesn't call strip(1) which in the case of GNU
strip brands the library as a FreeBSD library.

PR:		212564
07 Sep 2016 12:43:22
Original commit files touched by this commit Revision:421496  11.2r202.632_2 This port version is marked as vulnerable.
tijl search for other commits by this committer
- In Uses/linux.mk use the loop variable directly when appending to
  *_DEPENDS.  Helper variables derived from the loop variable aren't
  expanded causing *_DEPENDS to be incorrect.
- Bump all ports with more than one value in USE_LINUX.

PR:		211645
Reported by:	jkim
05 Sep 2016 19:23:42
Original commit files touched by this commit Revision:421387  11.2r202.632_1 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Replace Mk/bsd.linux-apps.mk and Mk/bsd.linux-rpm.mk with
  Mk/Uses/linux.mk.
- Replace USE_LINUX=yes with USES+=linux and USE_LINUX=(.*) with
  USES+=linux:\1 in all ports.
- Replace USE_LINUX_APPS with USE_LINUX in all ports.
- Use INSTALL_SCRIPT instead of INSTALL_PROGRAM to install scripts in some
  ports.
- When USE_LINUX_RPM is defined, simplify the way DISTFILES and EXTRACT_ONLY
  are defined.
- Remove BRANDELF_DIRS and BRANDELF_FILES handling.  In the very rare cases
  that it is still necessary ports can run ${BRANDELF} from post-patch.
- Remove AUTOMATIC_PLIST handling.  Only one port used it.
- Fix Linux MASTER_SITES.
- Replace OVERRIDE_LINUX_BASE_PORT and OVERRIDE_LINUX_NONBASE_PORTS with
  default versions framework.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
02 Aug 2016 13:33:39
Original commit files touched by this commit Revision:419479  11.2r202.632_1 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Clean up the Makefile a bit.
- Remove redundant GNOME option.
- Remove duplicate distinfo and pkg-plist files.
- Remove /compat and /compat/linux from pkg-plist.  Other Linux ports ignore
  these too, and /compat isn't necessarily a directory (see hier(7)).
01 Aug 2016 13:53:36
Original commit files touched by this commit Revision:419440  11.2r202.632 This port version is marked as vulnerable.
tijl search for other commits by this committer
Revert premature changes that snuck into r419437.
01 Aug 2016 13:07:14
Original commit files touched by this commit Revision:419437  11.2r202.632 This port version is marked as vulnerable.
tijl search for other commits by this committer
Use LINUX_REPO_ARCH instead of LINUX_RPM_ARCH when setting DISTINFO_FILE
and PLIST for Linux ports.  LINUX_RPM_ARCH is the CPU targetted by a
package and LINUX_REPO_ARCH is like our ARCH which is more suitable.  This
only affects Centos 6 ports because they are the only ones where
LINUX_REPO_ARCH != LINUX_RPM_ARCH.
16 Jul 2016 00:59:58
Original commit files touched by this commit Revision:418613  11.2r202.632 This port version is marked as vulnerable.
junovitch search for other commits by this committer
www/linux-*-flashplugin: update 11.2r202.626 -> 11.2r202.632

Security:	CVE-2016-4172
Security:	CVE-2016-4173
Security:	CVE-2016-4174
Security:	CVE-2016-4175
Security:	CVE-2016-4176
Security:	CVE-2016-4177
Security:	CVE-2016-4178
Security:	CVE-2016-4179
Security:	CVE-2016-4180
Security:	CVE-2016-4181
Security:	CVE-2016-4182
Security:	CVE-2016-4183
Security:	CVE-2016-4184
(Only the first 15 lines of the commit message are shown above View all of this commit message)
19 Jun 2016 02:57:30
Original commit files touched by this commit Revision:417098  11.2r202.626 This port version is marked as vulnerable.
junovitch search for other commits by this committer
www/linux-*-flashplugin: update 11.2r202.577 -> 11.2r202.626

PR:		209592
Reported by:	Sevan Janiyan <venture37@geeklan.co.uk>
Approved by:	port-secteam (with hat)
Security:	CVE-2016-1006, CVE-2016-1011, CVE-2016-1012, CVE-2016-1013,
		CVE-2016-1014, CVE-2016-1015, CVE-2016-1016, CVE-2016-1017,
		CVE-2016-1018, CVE-2016-1019, CVE-2016-1020, CVE-2016-1021,
		CVE-2016-1022, CVE-2016-1023, CVE-2016-1024, CVE-2016-1025,
		CVE-2016-1026, CVE-2016-1027, CVE-2016-1028, CVE-2016-1029,
		CVE-2016-1030, CVE-2016-1031, CVE-2016-1032, CVE-2016-1033,
		CVE-2016-1096, CVE-2016-1097, CVE-2016-1098, CVE-2016-1099,
		CVE-2016-1100, CVE-2016-1101, CVE-2016-1102, CVE-2016-1103,
		CVE-2016-1104, CVE-2016-1105, CVE-2016-1106, CVE-2016-1107,
		CVE-2016-1108, CVE-2016-1109, CVE-2016-1110, CVE-2016-4108,
(Only the first 15 lines of the commit message are shown above View all of this commit message)
13 Apr 2016 01:49:24
Original commit files touched by this commit Revision:413168  11.2r202.577 This port version is marked as vulnerable.
swills search for other commits by this committer
CentOS ports: for c6_64, install 32bit libraries alongside

PR:		206943
Submitted by:	xmj
01 Apr 2016 14:33:58
Original commit files touched by this commit Revision:412351  11.2r202.577 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories v, w, x, y, and z.

With hat:	portmgr
Sponsored by:	Absolight
31 Mar 2016 12:21:57
Original commit files touched by this commit Revision:412216  11.2r202.577 This port version is marked as vulnerable.
tijl search for other commits by this committer
Update flash plugin to 11.2r202.577.
10 Feb 2016 13:11:07
Original commit files touched by this commit Revision:408630  11.2r202.569 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update flash to 11.2r202.569.

MFH:		2016Q1
Security:	5d8e56c3-9e67-4d5b-81c9-3a409dfd705f
30 Jan 2016 18:30:40
Original commit files touched by this commit Revision:407537  11.2r202.559 This port version is marked as vulnerable.
miwi search for other commits by this committer
Welcome Centos 6.7

- Upgrade all linux-c6- to CentOS 6.7
- Cleanups

PR:                     205846
Submitted by:           xmj
In Collaboration with:  allanjude, netchild, xmj
Exp-run:                antoine
Sponsored by:           Perceivon Hosting Inc.
Differential Revision:  D3428

We'd like to thanks for all the feedback and comments.
29 Dec 2015 18:56:10
Original commit files touched by this commit Revision:404776  11.2r202.559 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update flash to 11.2r202.559.

MFH:		2015Q4
Security:	84c7ea88-bf04-4bdc-973b-36744bf540ab
08 Dec 2015 19:28:19
Original commit files touched by this commit Revision:403342  11.2r202.554 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update flash plugin to 11.2r202.554.

Submitted by:	xmj@
MFH:		2015Q4
Security:	c8842a84-9ddd-11e5-8c2f-c485083ca99c
14 Nov 2015 22:47:12
Original commit files touched by this commit Revision:401614  11.2r202.548 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update flash to 11.2r202.548.

MFH:		2015Q4
Security:	547fbd98-8b1f-11e5-b48b-bcaec565249c
05 Nov 2015 12:36:25
Original commit files touched by this commit Revision:400848  11.2r202.540 This port version is marked as vulnerable.
mat search for other commits by this committer
Fix ports that confused the meaning of WRKDIR and WRKSRC.

PR:		204056
Submitted by:	mat
Reviewed by:	bapt
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D2735
16 Oct 2015 16:12:56
Original commit files touched by this commit Revision:399487  11.2r202.540 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update flash to 11.2r202.540

MFH:		2015Q4
Security:	84147b46-e876-486d-b746-339ee45a8bb9
14 Oct 2015 12:51:25
Original commit files touched by this commit Revision:399258  11.2r202.535 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update flash to 11.2r202.535.

MFH:		2015Q4
Security:	a63f2c06-726b-11e5-a12b-bcaec565249c
28 Sep 2015 09:31:15
Original commit files touched by this commit Revision:398106  11.2r202.521 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update linux flash plugins to 11.2r202.521.

MFH:		2015Q3
Security:	4e3e8a50-65c1-11e5-948e-bcaec565249c
12 Aug 2015 07:35:05
Original commit files touched by this commit Revision:394008  11.2r202.508 This port version is marked as vulnerable.
kwm search for other commits by this committer
Update the f10, c6 and c6_64 of the linux flash player to 11.2r202.508

Security:	f3778328-d288-4b39-86a4-65877331eaf7
09 Aug 2015 19:14:15
Original commit files touched by this commit Revision:393817  11.2r202.491 This port version is marked as vulnerable.
netchild search for other commits by this committer
Re-commit of
64 bit linuxulator support (not activated by default):
 - most of the work was done by Alan Jude
 - all errors are mine
 - 64bit (may) have rough edges
 - I validated
    * that the 32bit part doesn't has deinstall regressions (incl. EXP runs by
      antoine)
    * 29 of 72 64bit ports ports don't have deinstall leftovers (more validation
      later, when I dare to activate the 64bit linuxulator in the kernel)
 - the infrastructure part looks mature enough to let more test-bunnies get
   some experience with the new 64 bit parts
 - to use it you shall have no linux ports installed and have to specify
   (on your own risk) the following in make.conf before installing the ports:
   OVERRIDE_LINUX_BASE_PORT=c6_64
(Only the first 15 lines of the commit message are shown above View all of this commit message)
26 Jul 2015 13:35:30
Original commit files touched by this commit Revision:392922  11.2r202.491 This port version is marked as vulnerable.
antoine search for other commits by this committer
Unbreak INDEX, reverting r392921

With hat:	portmgr
26 Jul 2015 13:06:25
Original commit files touched by this commit Revision:392921  11.2r202.491  Sanity Test Failure This port version is marked as vulnerable.
netchild search for other commits by this committer
64 bit linuxulator support (not activated by default):
 - most of the work was done by Alan Jude
 - all errors are mine
 - 64bit (may) have rough edges
 - I validated
    * that the 32bit part doesn't has deinstall regressions
    * 29 of 72 64bit ports ports don't have deinstall leftovers (more validation
      later, when I dare to activate the 64bit linuxulator in the kernel)
 - the infrastructure part looks mature enough to let more test-bunnies get
   some experience with it
 - to use it you shall have no linux ports installed and have to specify
   (on your own risk) the following in make.conf before installing the ports:
   OVERRIDE_LINUX_BASE_PORT=c6_64
   OVERRIDE_LINUX_NONBASE_PORTS=c6_64
(Only the first 15 lines of the commit message are shown above View all of this commit message)
17 Jul 2015 07:55:22
Original commit files touched by this commit Revision:392337  11.2r202.491 This port version is marked as vulnerable.
kwm search for other commits by this committer
UPdate flash plugin to 11.2r202.491.

MFH:		2015Q3
Security:	https://helpx.adobe.com/security/products/flash-player/apsb15-18.html
Security:	CVE-2015-5122, CVE-2015-5123
08 Jul 2015 18:49:03
Original commit files touched by this commit Revision:391589  11.2r202.481 This port version is marked as vulnerable.
tijl search for other commits by this committer
Update flash plugin to 11.2r202.481

MFH:		2015Q3
Security:	https://helpx.adobe.com/security/products/flash-player/apsb15-16.html
Security:	CVE-2015-5119
24 Jun 2015 09:03:39
Original commit files touched by this commit Revision:390474  11.2r202.468 This port version is marked as vulnerable.
xmj search for other commits by this committer
www/linux-*-flashplugin11: update to 11.2r202.468

- update to 11.2r202.468

Reported by:	kwm
MFH:		2015Q2
Security:	d02f6b01-1a3f-11e5-8bd6-c485083ca99c
Security:	CVE-2015-3113
Sponsored by:	Perceivon Hosting Inc.
11 Jun 2015 15:56:33
Original commit files touched by this commit Revision:389229  11.2r202.466 This port version is marked as vulnerable.
xmj search for other commits by this committer
www/linux-*-flashplugin11: update to 11.2r202.466

- update to 11.2r202.466
- fix 13 CVEs.

Reported by:	kwm@
MFH:		2015Q2
Security:	1e63db88-1050-11e5-a4df-c485083ca99c
Security:	CVE-2015-3096
Security:	CVE-2015-3097
Security:	CVE-2015-3098
Security:	CVE-2015-3099
Security:	CVE-2015-3100
Security:	CVE-2015-3101
Security:	CVE-2015-3102
Security:	CVE-2015-3103
Security:	CVE-2015-3104
Security:	CVE-2015-3105
Security:	CVE-2015-3106
Security:	CVE-2015-3107
Security:	CVE-2015-3108
Sponsored by:	Perceivon OU
13 May 2015 15:40:42
Original commit files touched by this commit Revision:386225  11.2r202.460 This port version is marked as vulnerable.
xmj search for other commits by this committer
www/linux-*-flashplugin11: update to 11.2r202.460

- update to 11.2r202.460

Requested by:	kwm
MFH:		2015Q2
Security:	e206df57-f97b-11e4-b799-c485083ca99c
Security:	CVE-2015-3044
Security:	CVE-2015-3077
Security:	CVE-2015-3078
Security:	CVE-2015-3079
Security:	CVE-2015-3080
Security:	CVE-2015-3081
Security:	CVE-2015-3082
Security:	CVE-2015-3083
Security:	CVE-2015-3084
Security:	CVE-2015-3085
Security:	CVE-2015-3086
Security:	CVE-2015-3087
Security:	CVE-2015-3088
Security:	CVE-2015-3089
Security:	CVE-2015-3090
Security:	CVE-2015-3091
Security:	CVE-2015-3092
Security:	CVE-2015-3093
17 Apr 2015 10:53:06
Original commit files touched by this commit Revision:384150  11.2r202.457 This port version is marked as vulnerable.
xmj search for other commits by this committer
www/linux-{c6,f10}-flashplugin11: Update to 11.2r202.457

- Update to 11.2r202.457

Spotted by:	kwm
MFH:		2015Q2
Security:	3364d497-e4e6-11e4-a265-c485083ca99c
25 Mar 2015 18:20:42
Original commit files touched by this commit Revision:382257  11.2r202.451_1 This port version is marked as vulnerable.
xmj search for other commits by this committer
www/linux-*-flashplugin11: set -c6 port as master port

- Make www/linux-c6-flashplugin11 master port
- Make www/linux-f10-flashplugin11 slave port
- Reduce future maintenance turnaround.

Differential Revision:	https://reviews.freebsd.org/D2128
Reviewed by:	eadler
Approved by:	koobs (mentor)
16 Mar 2015 17:02:12
Original commit files touched by this commit Revision:381428  11.2r202.451 This port version is marked as vulnerable.
xmj search for other commits by this committer
www/linux-*-flashplugin11: update to 11.2r202.451

- Update to 11.2r202.451

Differential Revision:	https://reviews.freebsd.org/D2061
Approved by:	swills (mentor)
Security:	8b3ecff5-c9b2-11e4-b71f-00bd5af88c00
Security:	CVE-2015-0332
Security:	CVE-2015-0333
Security:	CVE-2015-0334
Security:	CVE-2015-0335
Security:	CVE-2015-0336
Security:	CVE-2015-0337
Security:	CVE-2015-0338
Security:	CVE-2015-0339
Security:	CVE-2015-0340
Security:	CVE-2015-0341
Security:	CVE-2015-0342
MFH:		2015Q1
07 Feb 2015 10:00:15
Original commit files touched by this commit Revision:378579  11.2r202.442 This port version is marked as vulnerable.
xmj search for other commits by this committer
www/linux-*-flashplugin11: update to 11.2r202.442

- Update to 11.2r202.442
- Fix 0day reported in CVE-2015-0313

Differential Revision:	https://reviews.freebsd.org/D1783
Approved by:	koobs (mentor)
MFH:		2015Q1
Security:	734bcd49-aae6-11e4-a0c1-c485083ca99c
27 Jan 2015 21:16:31
Original commit files touched by this commit Revision:378021  11.2r202.440 This port version is marked as vulnerable.
tijl search for other commits by this committer
Update flash plugin to 11.2r202.440

MFH:		2015Q1
22 Jan 2015 11:25:31
Original commit files touched by this commit Revision:377649  11.2r202.438 This port version is marked as vulnerable.
tijl search for other commits by this committer
Update flash plugin to 11.2r202.438

MFH:		2015Q1
09 Dec 2014 16:35:13
Original commit files touched by this commit Revision:374406  11.2r202.425 This port version is marked as vulnerable.
tijl search for other commits by this committer
Update flash plugin to 11.2r202.418

PR:		195825
Submitted by:	pkubaj@riseup.net
09 Dec 2014 11:38:50
Original commit files touched by this commit Revision:374369  11.2r202.418_4 This port version is marked as vulnerable.
xmj search for other commits by this committer
www/linux-c6-flashplugin11: reintroduce gdkpixbuf2 dependency

- reintroduce gdkpixbuf2 dependency
  fixes regression introduced in r373192.
- bump PORTREVISION

Spotted by:	zaphod@berentweb.com
Differential Revision:	https://reviews.freebsd.org/D1268
Discussed on:	emulation@
Approved by:	koobs (mentor)
26 Nov 2014 19:48:24
Original commit files touched by this commit Revision:373458  11.2r202.418_3 This port version is marked as vulnerable.
marino search for other commits by this committer
www/linux-*-flashplugin11: convert ALSA to option, but off by default

ALSA output in Flash is fragile and doesn't work without the major
linulator update currently baking in dchagin's lemul branch.   While
waiting for that change, current ALSA to a disabled-by-default option.

PR:		195416
Submitted by:	Jan Beich
Approved by:	Continuation of recent work
26 Nov 2014 10:25:46
Original commit files touched by this commit Revision:373443  11.2r202.418_2 This port version is marked as vulnerable.
marino search for other commits by this committer
audio/linux-*-alsa-*,www/linux-*-flashplugin11: bump, fix run depends

Recent changes required a bumped PORTREVISION, do that now.  While
here, prevent partial updates of linux-*-flashplugin11 with old
linux-*-alsa-lib.

PR:		195406
Submitted by:	Jan Beich
25 Nov 2014 18:27:18
Original commit files touched by this commit Revision:373426  11.2r202.418_1 This port version is marked as vulnerable.
marino search for other commits by this committer
www/linux-*-flashplugin11: Drop libflash support now that ALSA works

PR:		192541
Submitted by:	Jan Beich
Approved by:	maintainer timeout (> 3 months)
24 Nov 2014 02:40:13
Original commit files touched by this commit Revision:373192  11.2r202.418_1 This port version is marked as vulnerable.
xmj search for other commits by this committer
graphics/linux-c6-gdk-pixbuf: rename to -pixbuf2

- Rename gdk-pixbuf to linux-c6-gdk-pixbuf2 to properly distinguish between
  linux- gdk-pixbuf 1 and 2.
- Change consumers dependencies to match.

PR: 		195120, 195121
Differential Revision:	https://reviews.freebsd.org/D1192
Submitted by:	Jan Beich <jbeich@vfemail.net>
Reviewed by:	rene (emulation)
Approved by:	swills (mentor)
Approved by:	portmgr (swills)
11 Nov 2014 17:55:13
Original commit files touched by this commit Revision:372458  11.2r202.418_1 This port version is marked as vulnerable.
jkim search for other commits by this committer
Add a missing dependency for the latest Flash plugin.

Reported by:	Piotr Kubaj (pkubaj at riseup dot net)
11 Nov 2014 15:04:09
Original commit files touched by this commit Revision:372450  11.2r202.418 This port version is marked as vulnerable.
xmj search for other commits by this committer
www/linux-{c6,f10}-flashplugin: update to 11.2r202.418

- update to 11.2r202.418

Differential Revision:	https://reviews.freebsd.org/D1143
Approved by: swills (mentor)
02 Oct 2014 18:39:37
Original commit files touched by this commit Revision:369846  11.2r202.406 This port version is marked as vulnerable.
jkim search for other commits by this committer
- Re-add PKGNAMEPREFIX for www/linux-f10-flashplugin11. [1]
- Honor LINUXBASE in pkg-plist.
- Reduce diff between linux-c6-flashplugin11 and linux-f10-flashplugin11.

Reported by:	nyan [1]
25 Sep 2014 16:16:12
Original commit files touched by this commit Revision:369267  11.2r202.406 This port version is marked as vulnerable.
xmj search for other commits by this committer
www/linux-*-flashplugin11: Fix multiple security vulnerabilities

Adobe has discovered multiple security vulnerabilities in Flash
linux-*-flashplugin-11.2r202.400. Ugrade the two Linux ports to
version .406, which fixes these.

While here:

 - Merge in eadler@'s MAINTAINER change from r369160 [1]

[1] https://svnweb.freebsd.org/changeset/ports/369160

PR:		193904
Differential Revision:	https://reviews.freebsd.org/D831
Submitted by:	Jung-uk Kim
Approved by:	koobs (mentor)
MFH:		2014Q3
Security:	ca44b64c-4453-11e4-9ea1-c485083ca99c
24 Sep 2014 04:05:45
Original commit files touched by this commit Revision:369156  11.2r202.400 This port version is marked as vulnerable.
xmj search for other commits by this committer
www/linux-c6-flashplugin11: Set correct dependency on OpenSSL

The centos 6.5-compatible version of Flashplugin currently misses a
dependency on the right OpenSSL port (security/linux-c6-openssl-compat, 0.9.8e).
Fix this by adding it to USE_LINUX_APPS.

PR: 		193872
Differential Revision:	https://reviews.freebsd.org/D820
Submitted by:	Jan Beich <jbeich@vfemail.net>
Approved by:	swills (mentor)
22 Sep 2014 11:58:29
Original commit files touched by this commit Revision:368857  11.2r202.400 This port version is marked as vulnerable.
bapt search for other commits by this committer
Add missing dependency on desktop-file-utils
Simplify plist
22 Sep 2014 10:40:01
Original commit files touched by this commit Revision:368845  11.2r202.400 This port version is marked as vulnerable.
xmj search for other commits by this committer
Update CentOS base to 6.5, add userland ports

The Fedora 10 infrastructure ports have been in use since June 2009 and, while
having served a great deed, have become unsupported upstream and hence affected
by unfixed security vulnerabilities. In addition to that, many recent Linux
binaries need newer libc / stdlibc++ versions.

This commit adds the linux-c6- userland as drop-in replacement for the -f10
infrastructure, as well as upgrading the linux_base-c6 port to CentOS 6.5.

If you want to switch to linux-c6 ports, please define at /etc/make.conf:

    OVERRIDE_LINUX_BASE_PORT=c6
    OVERRIDE_LINUX_NONBASE_PORTS=c6
(Only the first 15 lines of the commit message are shown above View all of this commit message)

Number of commits found: 52