FreshPorts - VuXML

This page displays vulnerability information about FreeBSD Ports.

The last vuln.xml file processed by FreshPorts is:

nothing found there

List all Vulnerabilities, by package

List all Vulnerabilities, by date

These are the vulnerabilities relating to the commit you have selected:

VuXML IDDescription
df45b4bd-0b7f-11e7-970f-002590263bf5moodle -- multiple vulnerabilities

Marina Glancy reports:

In addition to a number of bug fixes and small improvements, security vulnerabilities have been discovered and fixed. We highly recommend that you upgrade your sites as soon as possible. Upgrading should be very straightforward. As per our usual policy, admins of all registered Moodle sites will be notified of security issue details directly via email and we'll publish details more widely in a week.


Discovery 2017-03-13
Entry 2017-03-18
moodle29
le 2.9.9

moodle30
lt 3.0.9

moodle31
lt 3.1.5

moodle32
lt 3.2.2

https://moodle.org/news/#p1408104
3ddcb42b-5b78-11e6-b334-002590263bf5moodle -- multiple vulnerabilities

Marina Glancy reports:

  • MSA-16-0019: Glossary search displays entries without checking user permissions to view them

  • MSA-16-0020: Text injection in email headers

  • MSA-16-0021: Unenrolled user still receives event monitor notifications even though they can no longer access course


Discovery 2016-07-19
Entry 2016-08-06
moodle28
le 2.8.12

moodle29
lt 2.9.7

moodle30
lt 3.0.5

moodle31
lt 3.1.1

CVE-2016-5012
CVE-2016-5013
CVE-2016-5014
https://moodle.org/security/
f72d98d1-0b7e-11e7-970f-002590263bf5moodle -- multiple vulnerabilities

Marina Glancy reports:

  • MSA-17-0001: System file inclusion when adding own preset file in Boost theme

  • MSA-17-0002: Incorrect sanitation of attributes in forums

  • MSA-17-0003: PHPMailer vulnerability in no-reply address

  • MSA-17-0004: XSS in assignment submission page


Discovery 2017-01-17
Entry 2017-03-18
Modified 2020-06-24
moodle29
le 2.9.9

moodle30
lt 3.0.8

moodle31
lt 3.1.4

moodle32
lt 3.2.1

CVE-2017-2576
CVE-2017-2578
CVE-2016-10045
https://moodle.org/security/
2d299950-ddb0-11e5-8fa8-14dae9d210b8moodle -- multiple vulnerabilities

Marina Glancy reports:

  • MSA-16-0001: Two enrolment-related web services don't check course visibility

  • MSA-16-0002: XSS Vulnerability in course management search


Discovery 2016-01-18
Entry 2016-02-28
moodle28
lt 2.8.10

moodle29
lt 2.9.4

moodle30
lt 3.0.2

https://moodle.org/security/
CVE-2016-0724
CVE-2016-0725
a430e15d-f93f-11e5-92ce-002590263bf5moodle -- multiple vulnerabilities

Marina Glancy reports:

  • MSA-16-0003: Incorrect capability check when displaying users emails in Participants list

  • MSA-16-0004: XSS from profile fields from external db

  • MSA-16-0005: Reflected XSS in mod_data advanced search

  • MSA-16-0006: Hidden courses are shown to students in Event Monitor

  • MSA-16-0007: Non-Editing Instructor role can edit exclude checkbox in Single View

  • MSA-16-0008: External function get_calendar_events return events that pertains to hidden activities

  • MSA-16-0009: CSRF in Assignment plugin management page

  • MSA-16-0010: Enumeration of category details possible without authentication

  • MSA-16-0011: Add no referrer to links with _blank target attribute

  • MSA-16-0012: External function mod_assign_save_submission does not check due dates


Discovery 2016-03-21
Entry 2016-04-03
moodle28
lt 2.8.11

moodle29
lt 2.9.5

moodle30
lt 3.0.3

CVE-2016-2151
CVE-2016-2152
CVE-2016-2153
CVE-2016-2154
CVE-2016-2155
CVE-2016-2156
CVE-2016-2157
CVE-2016-2158
CVE-2016-2190
CVE-2016-2159
https://moodle.org/security/
ab02f981-ab9e-11e6-ae1b-002590263bf5moodle -- multiple vulnerabilities

Marina Glancy reports:

  • MSA-16-0022: Web service tokens should be invalidated when the user password is changed or forced to be changed.


Discovery 2016-09-12
Entry 2016-11-16
moodle29
lt 2.9.8

moodle30
lt 3.0.6

moodle31
lt 3.1.2

CVE-2016-7038
https://moodle.org/security/
f6565fbf-ab9e-11e6-ae1b-002590263bf5moodle -- multiple vulnerabilities

Marina Glancy reports:

  • MSA-16-0023: Question engine allows access to files that should not be available

  • MSA-16-0024: Non-admin site managers may accidentally edit admins via web services

  • MSA-16-0025: Capability to view course notes is checked in the wrong context

  • MSA-16-0026: When debugging is enabled, error exceptions returned from webservices could contain private data


Discovery 2016-11-14
Entry 2016-11-16
Modified 2016-11-27
moodle29
lt 2.9.9

moodle30
lt 3.0.7

moodle31
lt 3.1.3

CVE-2016-8642
CVE-2016-8643
CVE-2016-8644
https://moodle.org/security/
8656cf5f-4170-11e6-8dfe-002590263bf5moodle -- multiple vulnerabilities

Marina Glancy reports:

  • MSA-16-0013: Users are able to change profile fields that were locked by the administrator.

  • MSA-16-0015: Information disclosure of hidden forum names and sub-names.

  • MSA-16-0016: User can view badges of other users without proper permissions.

  • MSA-16-0017: Course idnumber not protected from teacher restore.

  • MSA-16-0018: CSRF in script marking forum posts as read.


Discovery 2016-05-18
Entry 2016-07-03
moodle28
lt 2.8.12

moodle29
lt 2.9.6

moodle30
lt 3.0.4

CVE-2016-3729
CVE-2016-3731
CVE-2016-3732
CVE-2016-3733
CVE-2016-3734
https://moodle.org/security/