notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Want a good monitor light? See my photosAll times are UTC
Ukraine
This referral link gives you 10% off a Fastmail.com account and gives me a discount on my Fastmail account.

Get notified when packages are built

A new feature has been added. FreshPorts already tracks package built by the FreeBSD project. This information is displayed on each port page. You can now get an email when FreshPorts notices a new package is available for something on one of your watch lists. However, you must opt into that. Click on Report Subscriptions on the right, and New Package Notification box, and click on Update.

Finally, under Watch Lists, click on ABI Package Subscriptions to select your ABI (e.g. FreeBSD:14:amd64) & package set (latest/quarterly) combination for a given watch list. This is what FreshPorts will look for.

Port details
py-accessible-pygments Collection of accessible pygments styles
0.0.4_1 textproc on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 0.0.4Version of this port present on the latest quarterly branch.
Maintainer: sunpoet@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2023-04-27 15:54:37
Last Update: 2024-05-13 14:08:58
Commit Hash: 8a39752
Also Listed In: python
License: BSD3CLAUSE
WWW:
https://github.com/Quansight-Labs/accessible-pygments
Description:
Accessible pygments themes includes a collection of accessible themes for pygments based on multiple open-source syntax highlighting themes. Note: What do we mean by accessible? In this context we are specially referring to themes which meet the WCAG 2.1 criteria for color contrast. Some themes included are also color-blind friendly.
Homepage    cgit ¦ Codeberg ¦ GitHub ¦ GitLab ¦ SVNWeb - no subversion history for this port

Manual pages:
FreshPorts has no man page information for this port.
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • ${PYTHON_PKGNAMEPREFIX}accessible-pygments>0:textproc/py-accessible-pygments@${PY_FLAVOR}
To install the port:
cd /usr/ports/textproc/py-accessible-pygments/ && make install clean
To add the package, run one of these commands:
  • pkg install textproc/py-accessible-pygments
  • pkg install py39-accessible-pygments
NOTE: If this package has multiple flavors (see below), then use one of them instead of the name specified above.
NOTE: This is a Python port. Instead of py39-accessible-pygments listed in the above command, you can pick from the names under the Packages section.
PKGNAME: py39-accessible-pygments
Package flavors (<flavor>: <package>)
  • py39: py39-accessible-pygments
distinfo:
TIMESTAMP = 1682354452 SHA256 (accessible-pygments-0.0.4.tar.gz) = e7b57a9b15958e9601c7e9eb07a440c813283545a20973f2574a5f453d0e953e SIZE (accessible-pygments-0.0.4.tar.gz) = 11650

Packages (timestamps in pop-ups are UTC):
py39-accessible-pygments
ABIaarch64amd64armv6armv7i386powerpcpowerpc64powerpc64le
FreeBSD:13:latest0.0.40.0.4_1-0.0.40.0.4_1---
FreeBSD:13:quarterly0.0.40.0.40.0.40.0.40.0.40.0.40.0.40.0.4
FreeBSD:14:latest0.0.40.0.4-0.0.40.0.40.0.4-0.0.4
FreeBSD:14:quarterly0.0.40.0.4-0.0.40.0.40.0.40.0.40.0.4
FreeBSD:15:latest0.0.40.0.4_1n/a0.0.4n/a0.0.40.0.40.0.4
Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. py39-pygments>=1.5 : textproc/py-pygments@py39
  2. py39-setuptools>=0 : devel/py-setuptools@py39
  3. py39-wheel>=0 : devel/py-wheel@py39
  4. python3.9 : lang/python39
  5. py39-build>=0 : devel/py-build@py39
  6. py39-installer>=0 : devel/py-installer@py39
Test dependencies:
  1. python3.9 : lang/python39
Runtime dependencies:
  1. py39-pygments>=1.5 : textproc/py-pygments@py39
  2. python3.9 : lang/python39
This port is required by:
for Run
  1. textproc/py-pydata-sphinx-theme

Configuration Options:
No options to configure
Options name:
textproc_py-accessible-pygments
USES:
python
FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (2 items)
Collapse this list.
  1. https://files.pythonhosted.org/packages/source/a/accessible-pygments/
  2. https://pypi.org/packages/source/a/accessible-pygments/
Collapse this list.

Number of commits found: 3

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
CommitCreditsLog message
0.0.4_1
13 May 2024 14:08:58
commit hash: 8a39752bc3baea155afef37b1927e28128af8718commit hash: 8a39752bc3baea155afef37b1927e28128af8718commit hash: 8a39752bc3baea155afef37b1927e28128af8718commit hash: 8a39752bc3baea155afef37b1927e28128af8718 files touched by this commit
Po-Chuan Hsieh (sunpoet) search for other commits by this committer
textproc/py-accessible-pygments: Convert to USE_PYTHON=pep517

- Bump PORTREVISION for package change
0.0.4
27 Jun 2023 19:34:34
commit hash: 3d9a815d9c5acbb71f4bb07738bdeab4879feacbcommit hash: 3d9a815d9c5acbb71f4bb07738bdeab4879feacbcommit hash: 3d9a815d9c5acbb71f4bb07738bdeab4879feacbcommit hash: 3d9a815d9c5acbb71f4bb07738bdeab4879feacb files touched by this commit
Rene Ladan (rene) search for other commits by this committer
all: remove explicit versions in USES=python for "3.x+"

The logic in USES=python will automatically convert this to 3.8+ by
itself.

Adjust two ports that only had Python 3.7 mentioned but build fine
on Python 3.8 too.

finance/quickfix: mark BROKEN with PYTHON

libtool: compile:  c++ -DHAVE_CONFIG_H -I. -I../.. -I -I. -I.. -I../.. -I../C++
-DLIBICONV_PLUG -DPYTHON_MAJOR_VERSION=3 -Wno-unused-variable
-Wno-maybe-uninitialized -O2 -pipe -DLIBICONV_PLUG -fstack-protector-strong
-fno-strict-aliasing -DLIBICONV_PLUG -Wall -ansi
-Wno-unused-command-line-argument -Wpointer-arith -Wwrite-strings
-Wno-overloaded-virtual -Wno-deprecated-declarations -Wno-deprecated -std=c++0x
-MT _quickfix_la-QuickfixPython.lo -MD -MP -MF
.deps/_quickfix_la-QuickfixPython.Tpo -c QuickfixPython.cpp  -fPIC -DPIC -o
.libs/_quickfix_la-QuickfixPython.o
warning: unknown warning option '-Wno-maybe-uninitialized'; did you mean
'-Wno-uninitialized'? [-Wunknown-warning-option]
QuickfixPython.cpp:175:11: fatal error: 'Python.h' file not found
          ^~~~~~~~~~
1 warning and 1 error generated.

Reviewed by:	portmgr, vishwin, yuri
Differential Revision:	<https://reviews.freebsd.org/D40568>
0.0.4
27 Apr 2023 15:28:04
commit hash: f0a8676195fbe2120b876307e83b04bdba1f3edbcommit hash: f0a8676195fbe2120b876307e83b04bdba1f3edbcommit hash: f0a8676195fbe2120b876307e83b04bdba1f3edbcommit hash: f0a8676195fbe2120b876307e83b04bdba1f3edb files touched by this commit
Po-Chuan Hsieh (sunpoet) search for other commits by this committer
textproc/py-accessible-pygments: Add py-accessible-pygments 0.0.4

Accessible pygments themes includes a collection of accessible themes for
pygments based on multiple open-source syntax highlighting themes.

Note: What do we mean by accessible? In this context we are specially referring
to themes which meet the WCAG 2.1 criteria for color contrast. Some themes
included are also color-blind friendly.

Number of commits found: 3