notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
NOTE: the WWW: line in pkg-descr was relocated to a WWW= line in Makefile. Each port in FreshPorts has a homepage link. Look for it right after the Description: on each port's home page.

Do I know someone who can pick up a server from 7401 E. Ben White Blvd. Austin TX?

The emphasis is on know, or recommended by someone I know. This is the original FreshPorts server, way past useful: RAID, 8GB RAM, etc. The drives need to be wiped and everything recycled.
Port details
rubygem-fluentd Fluent event collector
1.15.2 sysutils on this many watch lists=1 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch.
Maintainer: girgen@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2012-08-31 12:05:18
Last Update: 2022-09-07 21:58:51
Commit Hash: fb16dfe
People watching this port, also watch:: zrep
Also Listed In: rubygems
License: APACHE20
Description:
HomepagecgitgithubgitlabSVNWeb
pkg-plist: as obtained via: make generate-plist
Expand this list (15 items)
Collapse this list.
  1. bin/fluent-cap-ctl
  2. bin/fluent-cat
  3. bin/fluent-ctl
  4. bin/fluent-debug
  5. bin/fluent-gem
  6. bin/fluentd
  7. bin/fluent-binlog-reader
  8. bin/fluent-ca-generate
  9. bin/fluent-plugin-config-format
  10. bin/fluent-plugin-generate
  11. @sample etc/fluentd/fluent.conf.sample
  12. /usr/local/share/licenses/rubygem-fluentd-1.15.2/catalog.mk
  13. /usr/local/share/licenses/rubygem-fluentd-1.15.2/LICENSE
  14. /usr/local/share/licenses/rubygem-fluentd-1.15.2/APACHE20
  15. @dir etc/fluentd/plugin
Collapse this list.
Dependency lines:
  • rubygem-fluentd>0:sysutils/rubygem-fluentd
To install the port:
cd /usr/ports/sysutils/rubygem-fluentd/ && make install clean
To add the package, run one of these commands:
  • pkg install sysutils/rubygem-fluentd
  • pkg install rubygem-fluentd
NOTE: If this package has multiple flavors (see below), then use one of them instead of the name specified above.
PKGNAME: rubygem-fluentd
Flavors: there is no flavor information for this port.
distinfo:

Packages (timestamps in pop-ups are UTC):
rubygem-fluentd
ABIlatestquarterly
FreeBSD:11:aarch640.12.421.3.3_1
FreeBSD:11:amd641.14.11.12.3
FreeBSD:11:armv60.12.141.3.3_1
FreeBSD:11:i3861.14.11.12.3
FreeBSD:11:mipspkg-falloutpkg-fallout
FreeBSD:11:mips64pkg-falloutpkg-fallout
FreeBSD:12:aarch640.12.421.15.0
FreeBSD:12:amd641.15.21.15.0
FreeBSD:12:armv60.12.421.3.3_1
FreeBSD:12:armv70.12.421.3.3_1
FreeBSD:12:i3861.15.21.15.0
FreeBSD:12:mipspkg-falloutpkg-fallout
FreeBSD:12:mips64pkg-falloutpkg-fallout
FreeBSD:12:powerpc64pkg-fallout1.3.3_1
FreeBSD:13:aarch641.15.21.15.0
FreeBSD:13:amd641.15.21.15.0
FreeBSD:13:armv61.3.3_11.15.0
FreeBSD:13:armv71.15.21.15.0
FreeBSD:13:i3861.15.21.15.0
FreeBSD:13:mipspkg-falloutpkg-fallout
FreeBSD:13:mips64pkg-falloutpkg-fallout
FreeBSD:13:powerpc641.3.3_11.12.3
FreeBSD:13:riscv64pkg-fallout1.15.0
FreeBSD:14:aarch641.15.2pkg-fallout
FreeBSD:14:amd641.15.2pkg-fallout
FreeBSD:14:armv61.15.0pkg-fallout
FreeBSD:14:armv71.15.2pkg-fallout
FreeBSD:14:i3861.15.2pkg-fallout
FreeBSD:14:mipspkg-falloutpkg-fallout
FreeBSD:14:mips64pkg-falloutpkg-fallout
FreeBSD:14:powerpc641.3.3_1pkg-fallout
FreeBSD:14:riscv641.14.1pkg-fallout
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. ruby30 : lang/ruby30
  2. gem : devel/ruby-gems
Runtime dependencies:
  1. rubygem-bundler>=0 : sysutils/rubygem-bundler
  2. rubygem-cool.io>=1.4.5<2.0.0 : devel/rubygem-cool.io
  3. rubygem-http_parser.rb>=0.5.1<0.9.0 : net/rubygem-http_parser.rb
  4. rubygem-msgpack>=1.3.1<2.0.0 : devel/rubygem-msgpack
  5. rubygem-serverengine>=2.2.5<3.0.0 : net/rubygem-serverengine
  6. rubygem-sigdump>=0.2.2<0.3 : devel/rubygem-sigdump
  7. rubygem-strptime>=0.2.2<1.0.0 : devel/rubygem-strptime
  8. rubygem-tzinfo1>=1.0<3.0 : devel/rubygem-tzinfo1
  9. rubygem-tzinfo-data>=1.0<2 : devel/rubygem-tzinfo-data
  10. rubygem-webrick>=1.4.2<1.8.0 : www/rubygem-webrick
  11. rubygem-yajl-ruby>=1.0<2 : devel/rubygem-yajl-ruby
  12. ruby30 : lang/ruby30
  13. gem : devel/ruby-gems
Patch dependencies:
  1. ruby30 : lang/ruby30
  2. gem : devel/ruby-gems
Extract dependencies:
  1. ruby30 : lang/ruby30
This port is required by:
for Run
  1. sysutils/rubygem-fluent-mixin-plaintextformatter
  2. sysutils/rubygem-fluent-plugin-config-expander
  3. sysutils/rubygem-fluent-plugin-file-alternative
  4. sysutils/rubygem-fluent-plugin-tail-asis

Deleted ports which required this port:

Expand this list of 1 deleted port
  1. sysutils/rubygem-fluent-plugin-graylog*
  2. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://rubygems.org/downloads/
Collapse this list.
Notes from UPDATING
These upgrade notes are taken from /usr/ports/UPDATING
  • 2019-01-24
    Affects: users of sysutils/rubygem-fluentd, sysutils/fluent-bit
    Author: girgen@FreeBSD.org
    Reason: 
      The fluentd port has been upgraded from the 0.12 line to 1.3.3.  The upgrade
      is mostly non-disruptive since there is a backward compatibility with 0.12
      plugins and configuration files, but care should be taken about the order of
      server upgrades since fluentd 1.x is unable to send it's data to version 0.12
      instances.  You should carefully read
      https://docs.fluentd.org/v1.0/articles/update-from-v0.12 before performing
      any upgrade activities.
    
    

Number of commits found: 44

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
CommitCreditsLog message
07 Sep 2022 21:58:51
commit hash:fb16dfecae4a6efac9f3a78e0b759fb7a3c53de4commit hash:fb16dfecae4a6efac9f3a78e0b759fb7a3c53de4commit hash:fb16dfecae4a6efac9f3a78e0b759fb7a3c53de4 files touched by this commit
Stefan Eßer (se) search for other commits by this committer
Remove WWW entries moved into port Makefiles

Commit b7f05445c00f has added WWW entries to port Makefiles based on
WWW: lines in pkg-descr files.

This commit removes the WWW: lines of moved-over URLs from these
pkg-descr files.

Approved by:		portmgr (tcberner)
1.15.2
07 Sep 2022 21:10:59
commit hash:b7f05445c00f2625aa19b4154ebcbce5ed2daa52commit hash:b7f05445c00f2625aa19b4154ebcbce5ed2daa52commit hash:b7f05445c00f2625aa19b4154ebcbce5ed2daa52 files touched by this commit
Stefan Eßer (se) search for other commits by this committer
Add WWW entries to port Makefiles

It has been common practice to have one or more URLs at the end of the
ports' pkg-descr files, one per line and prefixed with "WWW:". These
URLs should point at a project website or other relevant resources.

Access to these URLs required processing of the pkg-descr files, and
they have often become stale over time. If more than one such URL was
present in a pkg-descr file, only the first one was tarnsfered into
the port INDEX, but for many ports only the last line did contain the
port specific URL to further information.

There have been several proposals to make a project URL available as
a macro in the ports' Makefiles, over time.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
1.15.2
22 Aug 2022 09:30:52
commit hash:e971ccd9f36eec0a853a1f7f9109a53be5176e25commit hash:e971ccd9f36eec0a853a1f7f9109a53be5176e25commit hash:e971ccd9f36eec0a853a1f7f9109a53be5176e25 files touched by this commit
Palle Girgensohn (girgen) search for other commits by this committer
sysutils/rubygem-fluentd: update to 1.15.2

Release notes:	https://github.com/fluent/fluentd/releases/tag/v1.15.2
1.15.1
08 Aug 2022 20:24:09
commit hash:7f4b056f46d4c44c26b8e8159a451bef0b2cd0dccommit hash:7f4b056f46d4c44c26b8e8159a451bef0b2cd0dccommit hash:7f4b056f46d4c44c26b8e8159a451bef0b2cd0dc files touched by this commit
Palle Girgensohn (girgen) search for other commits by this committer
sysutils/rubygem-fluentd: update to 1.15.1

Release notes:	https://github.com/fluent/fluentd/releases/tag/v1.15.1
1.15.0
02 Jul 2022 07:55:50
commit hash:4064c2b23bc2f5995f870dce6f85eb231029f4eecommit hash:4064c2b23bc2f5995f870dce6f85eb231029f4eecommit hash:4064c2b23bc2f5995f870dce6f85eb231029f4ee files touched by this commit
Palle Girgensohn (girgen) search for other commits by this committer
sysutils/rubygem-fluentd: update to 1.15.0

Release notes:	https://github.com/fluent/fluentd/releases/tag/v1.15.0
1.14.6
31 Mar 2022 14:17:36
commit hash:1a842e74c46a76b82b61e3e936d2829ffd89542acommit hash:1a842e74c46a76b82b61e3e936d2829ffd89542acommit hash:1a842e74c46a76b82b61e3e936d2829ffd89542a files touched by this commit
Palle Girgensohn (girgen) search for other commits by this committer
sysutils/rubygem-fluentd: update to 1.14.6

Release notes:	https://github.com/fluent/fluentd/releases
1.14.5
09 Feb 2022 08:42:52
commit hash:35a8361d88a73b67707b090012001ec23af004f7commit hash:35a8361d88a73b67707b090012001ec23af004f7commit hash:35a8361d88a73b67707b090012001ec23af004f7 files touched by this commit
Palle Girgensohn (girgen) search for other commits by this committer
sysutils/rubygem-fluentd: update to 1.14.5

Release notes:	https://github.com/fluent/fluentd/releases/tag/v1.14.5
1.14.1
21 Oct 2021 14:27:15
commit hash:9e890d23391bbec31b2e73718f70f46a292f7e53commit hash:9e890d23391bbec31b2e73718f70f46a292f7e53commit hash:9e890d23391bbec31b2e73718f70f46a292f7e53 files touched by this commit
Stefan Eßer (se) search for other commits by this committer
sysutils/rubygem-fluentd: Add CPE information

Approved by:	portmgr (blanket)
1.14.1
29 Sep 2021 15:12:14
commit hash:d0b63a3db9389eb1398a61c857796c670ed10b14commit hash:d0b63a3db9389eb1398a61c857796c670ed10b14commit hash:d0b63a3db9389eb1398a61c857796c670ed10b14 files touched by this commit
Palle Girgensohn (girgen) search for other commits by this committer
sysutils/rubygem-fluentd: update to 1.14.1

Reported by:	portscout
1.13.3_1
27 Sep 2021 15:56:30
commit hash:c59be564611c45e48351155e62ad23134407a6e5commit hash:c59be564611c45e48351155e62ad23134407a6e5commit hash:c59be564611c45e48351155e62ad23134407a6e5 files touched by this commit
Po-Chuan Hsieh (sunpoet) search for other commits by this committer
sysutils/rubygem-fluentd: Fix gemspec for rubygem-http_parser.rb 0.9.0 update

- Bump PORTREVISION for package change
1.13.3
13 Aug 2021 08:10:06
commit hash:7bd0307403334834dbd9ba61eaceabd9638b413ecommit hash:7bd0307403334834dbd9ba61eaceabd9638b413ecommit hash:7bd0307403334834dbd9ba61eaceabd9638b413e files touched by this commit
Palle Girgensohn (girgen) search for other commits by this committer
sysutils/rubygem-fluentd: update to 1.13.3

Submitted by:	Artyom Davidov
PR:		257300
1.12.3_1
15 Jul 2021 23:57:46
commit hash:5da7888a805756132d8b3c02abebfb5d03c31de1commit hash:5da7888a805756132d8b3c02abebfb5d03c31de1commit hash:5da7888a805756132d8b3c02abebfb5d03c31de1 files touched by this commit
Po-Chuan Hsieh (sunpoet) search for other commits by this committer
sysutils/rubygem-fluentd: Fix gemspec for rubygem-http_parser.rb 0.7.0 update

- While I'm here:
  - Update version requirement of RUN_DEPENDS
  - Sort RUN_DEPENDS
- Bump PORTREVISION for package change
1.12.3
20 May 2021 20:32:07
commit hash:5ec81f5382ab38275465d2e1ff2a9ecf70592639commit hash:5ec81f5382ab38275465d2e1ff2a9ecf70592639commit hash:5ec81f5382ab38275465d2e1ff2a9ecf70592639 files touched by this commit
Palle Girgensohn (girgen) search for other commits by this committer
sysutils/rubygem-fluentd: update to 1.12.3

Update and take maintainership.

Submitted by:   Artyom Davidov
PR:             239979
Approved by:    kuriyama@FreeBSD.org (maintainer, timeout > 1 year)
1.3.3_1
07 Apr 2021 08:09:01
commit hash:cf118ccf875508b9a1c570044c93cfcc82bd455ccommit hash:cf118ccf875508b9a1c570044c93cfcc82bd455ccommit hash:cf118ccf875508b9a1c570044c93cfcc82bd455c files touched by this commit
Mathieu Arnold (mat) search for other commits by this committer
One more small cleanup, forgotten yesterday.
Reported by:	lwhsu
1.3.3_1
06 Apr 2021 14:31:13
commit hash:135fdeebb99c3569e42d8162b265e15d29bd937dcommit hash:135fdeebb99c3569e42d8162b265e15d29bd937dcommit hash:135fdeebb99c3569e42d8162b265e15d29bd937d files touched by this commit
Mathieu Arnold (mat) search for other commits by this committer
all: Remove all other $FreeBSD keywords.
1.3.3_1
06 Apr 2021 14:31:07
commit hash:305f148f482daf30dcf728039d03d019f88344ebcommit hash:305f148f482daf30dcf728039d03d019f88344ebcommit hash:305f148f482daf30dcf728039d03d019f88344eb files touched by this commit
Mathieu Arnold (mat) search for other commits by this committer
Remove # $FreeBSD$ from Makefiles.
1.3.3_1
27 Oct 2019 11:31:16
Revision:515791Original commit files touched by this commit
sunpoet search for other commits by this committer
Change RUN_DEPENDS from rubygem-tzinfo to rubygem-tzinfo1

- Bump PORTREVISION for dependency change
1.3.3
24 Jan 2019 22:58:01
Revision:491122Original commit files touched by this commit
girgen search for other commits by this committer
Update fluentd to version 1.3.3

PR:             233939, 235179
Releasenotes:   https://github.com/fluent/fluentd/blob/master/CHANGELOG.md
Reported by:	girgen, Artyom Davidov
Submitted by:	girgen (myself)
Approved by:	maintainer (timeout, 44 days)
0.12.42
03 Dec 2018 18:56:42
Revision:486529Original commit files touched by this commit
sunpoet search for other commits by this committer
Update to 2.7.8

Changes:	https://github.com/rubygems/rubygems/blob/master/History.txt
PR:		233645
Exp-run by:	antoine
0.12.42
14 Mar 2018 14:49:39
Revision:464496Original commit files touched by this commit
swills search for other commits by this committer
sysutils/rubygem-fluentd: update to 0.12.42

PR:		225327
Submitted by:	Artyom Davidov <ard_1@mail.ru>
Approved by:	maintainer timeout (kuriyama, > 7 weeks)
0.12.14_2
30 Jul 2017 13:13:20
Revision:446927Original commit files touched by this commit
sunpoet search for other commits by this committer
Add missing RUN_DEPENDS

- Bump PORTREVISION for dependency change

PR:		220630
Reported by:	lifanov
Submitted by:	sunpoet (myself)
Approved by:	maintainer (timeout, 18 days)
0.12.14_1
11 Jul 2017 17:03:49
Revision:445536Original commit files touched by this commit
sunpoet search for other commits by this committer
Rename gemspec patch to patch-gemspec

With hat:	ruby
0.12.14_1
06 Jan 2017 22:50:43
Revision:430755Original commit files touched by this commit
swills search for other commits by this committer
sysutils/rubygem-fluentd: Patch to remove dep on string-scrub

PR:		215178
Reported by:	Yanis Guenane <yanis+freebsd@guenane.org>
Approved by:	maintainer timeout (kuriyama, >4 weeks)
MFH:		2017Q1
0.12.14
08 Nov 2016 21:32:36
Revision:425767Original commit files touched by this commit
rene search for other commits by this committer
Remove optional dependency on textproc/rubygem-string-scrub which was only
valid for Ruby 2.0
0.12.14
27 Apr 2016 21:57:32
Revision:414136Original commit files touched by this commit
swills search for other commits by this committer
Convert USES=gem:autoplist to USES=gem since autoplist is default
0.12.14
27 Apr 2016 16:36:42
Revision:414118Original commit files touched by this commit
swills search for other commits by this committer
create USES=gem and update rubygem- ports to use it

Note that for now ports still have to have USE_RUBY=yes to use USES=gem

PR:		209041
Differential Revision:	https://reviews.freebsd.org/D6070
0.12.14
01 Apr 2016 14:25:18
Revision:412349Original commit files touched by this commit
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories r, s, t, and u.

With hat:	portmgr
Sponsored by:	Absolight
0.12.14
19 Aug 2015 01:00:54
Revision:394665Original commit files touched by this commit
kuriyama search for other commits by this committer
- Upgrade to 0.12.14 and preserve stable 0.10.61 as rubygem-fluentd010.
0.10.61
27 Jul 2015 14:46:56
Revision:392983Original commit files touched by this commit
kuriyama search for other commits by this committer
- Upgrade to 0.10.61.
0.10.53_1
30 May 2015 23:11:39
Revision:388033Original commit files touched by this commit
sunpoet search for other commits by this committer
- Add LICENSE
- Regenerate patch file

Approved by:	portmgr (blanket)
0.10.53_1
21 Dec 2014 13:13:30
Revision:375158Original commit files touched by this commit
antoine search for other commits by this committer
Put back an empty dir in plist
0.10.53
20 Dec 2014 19:42:46
Revision:375112Original commit files touched by this commit
bapt search for other commits by this committer
Cleanup plist
0.10.53
25 Aug 2014 21:16:56
Revision:366153Original commit files touched by this commit
swills search for other commits by this committer
sysutils/rubygem-fluentd: update to 0.10.53, unbreak, use new rubygem-cool.io

With hat:	ruby@
0.10.35
07 Apr 2014 15:56:51
Revision:350511Original commit files touched by this commit
bapt search for other commits by this committer
Support stage
0.10.35
28 Feb 2014 19:45:27
Revision:346572Original commit files touched by this commit
antoine search for other commits by this committer
Mark more ports BROKEN
Error logs are available in the pkg-fallout archives

Reported by:	pkg-fallout since at least january 2014
0.10.35
02 Jan 2014 20:22:53
Revision:338489Original commit files touched by this commit
swills search for other commits by this committer
- Ruby 1.8 is gone, remove reference to it

With hat:	ruby@
0.10.35
20 Sep 2013 23:06:00
Revision:327772Original commit files touched by this commit
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
sysutils)
0.10.35
29 Jul 2013 14:50:30
Revision:323890Original commit files touched by this commit
kuriyama search for other commits by this committer
- Upgrade to 0.10.35.

PR:		ports/179904
Submitted by:	swills
0.10.34
06 Jun 2013 01:37:35
Revision:320044Original commit files touched by this commit
kuriyama search for other commits by this committer
- Upgrade to 0.10.34 and unbreak.

Related to:	ports/179183
0.10.30
22 Jan 2013 00:54:14
Revision:310789Original commit files touched by this commit
kuriyama search for other commits by this committer
- Upgrade to 0.10.30.
0.10.27
27 Oct 2012 10:44:57
Revision:306484Original commit files touched by this commit
kuriyama search for other commits by this committer
- Upgrade to 0.10.27.
- Install rc script and own user/group.

Feature safe: yes
0.10.25
25 Sep 2012 13:39:59
Revision:304836Original commit files touched by this commit
kuriyama search for other commits by this committer
Unbreak and mark ignore when ruby18 is installed.
0.10.25
14 Sep 2012 16:47:42
Revision:304280Original commit files touched by this commit
beat search for other commits by this committer
- Mark BROKEN: conflicting dependencies
  ===> ruby19-gems-1.8.24 depends on file: /usr/local/bin/ruby19 - found
  ===> An older version of devel/ruby-gems is already installed
(ruby18-gems-1.8.24)

Reported by:	pointyhat
0.10.25
31 Aug 2012 12:03:04
Revision:303417Original commit files touched by this commit
kuriyama search for other commits by this committer
Fix accidentally committed into devel category.  What I want is sysutils.

Number of commits found: 44