notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
NOTE: the WWW: line in pkg-descr was relocated to a WWW= line in Makefile. Each port in FreshPorts has a homepage link. Look for it right after the Description: on each port's home page.

Do I know someone who can pick up a server from 7401 E. Ben White Blvd. Austin TX?

The emphasis is on know, or recommended by someone I know. This is the original FreshPorts server, way past useful: RAID, 8GB RAM, etc. The drives need to be wiped and everything recycled.
Port details
rubygem-rbnacl4 Networking and Cryptography (NaCl) library
4.0.2 security Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch.
Deprecated DEPRECATED: Obsoleted by update of www/gitlab-ce. Please use security/rubygem-rbnacl instead.
Expired This port expired on: 2018-07-31
Maintainer: mfechner@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2018-01-05 13:22:30
Last Update: 2018-08-02 11:54:36
SVN Revision: 476231
Also Listed In: rubygems
License: MIT
Description:
HomepagecgitgithubgithubSVNWeb
pkg-plist: as obtained via: make generate-plist
Expand this list (3 items)
Collapse this list.
  1. /usr/local/share/licenses/rubygem-rbnacl4-4.0.2/catalog.mk
  2. /usr/local/share/licenses/rubygem-rbnacl4-4.0.2/LICENSE
  3. /usr/local/share/licenses/rubygem-rbnacl4-4.0.2/MIT
Collapse this list.
Dependency lines:
  • rubygem-rbnacl4>0:security/rubygem-rbnacl4
No installation instructions:
This port has been deleted.
PKGNAME: rubygem-rbnacl4
Flavors: there is no flavor information for this port.
distinfo:
No package information for this port in our database
Sometimes this happens. Not all ports have packages.

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. rubygem-bundler>=0 : sysutils/rubygem-bundler
  2. ruby24 : lang/ruby24
  3. gem24 : devel/ruby-gems
Runtime dependencies:
  1. rubygem-ffi>=0 : devel/rubygem-ffi
  2. ruby24 : lang/ruby24
  3. gem24 : devel/ruby-gems
Library dependencies:
  1. libsodium.so : security/libsodium
Patch dependencies:
  1. ruby24 : lang/ruby24
  2. gem24 : devel/ruby-gems
Extract dependencies:
  1. ruby24 : lang/ruby24
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Run

Deleted ports which required this port:

Expand this list of 1 deleted port
  1. www/gitlab*
  2. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://rubygems.global.ssl.fastly.net/gems/
Collapse this list.
Port Moves
  • port moved to security/rubygem-rbnacl on 2018-08-02
    REASON: Has expired: Obsoleted by update of www/gitlab-ce. Please use security/rubygem-rbnacl instead

Number of commits found: 4

Commit History - (may be incomplete: see SVNWeb link above for full details)
CommitCreditsLog message
4.0.2
02 Aug 2018 11:54:36
Revision:476231Original commit files touched by this commit
rene search for other commits by this committer
Remove expired ports:
2018-07-31 net/rubygem-gitaly-proto096: Obsoleted by update of www/gitlab-ce.
Please use net/rubygem-gitaly-proto instead.
2018-07-31 security/tripwire12: unfetchable
2018-07-31 security/rubygem-rbnacl4: Obsoleted by update of www/gitlab-ce.
Please use security/rubygem-rbnacl instead.
2018-07-31 www/rubygem-gon61: Obsoleted by update of www/gitlab-ce. Please use
www/rubygem-gon instead.
2018-07-31 databases/pgpool-II-33: Will be deprecated by upstream, please switch
to newer pgpool versions
2018-07-31 devel/rubygem-grape-entity060: Obsoleted by update of www/gitlab-ce.
Please use devel/rubygem-grape-entity instead.
2018-07-31 net/rubygem-gitaly-proto099: Obsoleted by update of www/gitlab-ce.
Please use net/rubygem-gitaly-proto instead.
2018-07-31 net/rubygem-gitaly-proto095: Obsoleted by update of www/gitlab-ce.
Please use net/rubygem-gitaly-proto instead.
2018-07-31 net/rubygem-omniauth-github11: Obsoleted by update of www/gitlab-ce.
Please use net/rubygem-omniauth-github instead.
2018-07-31 net/rubygem-asset_sync220: Obsoleted by update of www/gitlab-ce.
Please use net/rubygem-asset_sync instead.
2018-07-31 www/rubygem-gollum-lib-gitlab: Obsoleted by update of www/gitlab-ce.
Please use www/rubygem-gitlab-gollum-lib instead.
2018-08-01 www/py-django-threaded-multihost: Project development unmaintained
2018-08-01 www/py-django-keyedcache: Project development abandoned
2018-08-01 www/py-django-signals-ahoy: Project development unmaintained
4.0.2
16 Jul 2018 14:36:52
Revision:474739Original commit files touched by this commit
mfechner search for other commits by this committer
Deprecate ports not required by gitlab-ce and any other port anymore.

Reviewed by:	tz (mentor)
Approved by:	tz (mentor)
Differential Revision:	https://reviews.freebsd.org/D16265
4.0.2
09 May 2018 10:43:26
Revision:469442Original commit files touched by this commit
mfechner search for other commits by this committer
Changed the MAINTAINER of all my ports to have mfechner@FreeBSD.org listed.

Reviewed by:	tz (mentor)
Approved by:	tz (mentor)
Differential Revision:	https://reviews.freebsd.org/D15270
4.0.2
05 Jan 2018 13:22:23
Revision:458139Original commit files touched by this commit
swills search for other commits by this committer
security/rubygem-rbnacl4: create port

4.x version required by gitlab

PR:		224931
Submitted by:	Matthias Fechner <idefix@fechner.net> (maintainer)

Number of commits found: 4