notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Want a good monitor light? See my photosAll times are UTC
Ukraine
This referral link gives you 10% off a Fastmail.com account and gives me a discount on my Fastmail account.

Get notified when packages are built

A new feature has been added. FreshPorts already tracks package built by the FreeBSD project. This information is displayed on each port page. You can now get an email when FreshPorts notices a new package is available for something on one of your watch lists. However, you must opt into that. Click on Report Subscriptions on the right, and New Package Notification box, and click on Update.

Finally, under Watch Lists, click on ABI Package Subscriptions to select your ABI (e.g. FreeBSD:14:amd64) & package set (latest/quarterly) combination for a given watch list. This is what FreshPorts will look for.

non port: security/rubygem-omniauth-rails_csrf_protection/Makefile

Number of commits found: 3

Monday, 13 May 2024
04:04 Matthias Fechner (mfechner) search for other commits by this committer
security/rubygem-omniauth-rails_csrf_protection: update to 1.0.2

Changes:	https://github.com/cookpad/omniauth-rails_csrf_protection/releases/tag/v1.0.2
commit hash: c2b97e36f742d6f7bb506448745df35060c6270a commit hash: c2b97e36f742d6f7bb506448745df35060c6270a commit hash: c2b97e36f742d6f7bb506448745df35060c6270a commit hash: c2b97e36f742d6f7bb506448745df35060c6270a c2b97e3
Saturday, 14 Jan 2023
23:08 Muhammad Moinur Rahman (bofh) search for other commits by this committer
Mk/**ruby.mk: Switch from USE_RUBY=yes to USES=ruby

Switch from Mk/bsd.ruby.mk to Mk/Uses/ruby.mk

Notable changes are.

- Mk/bsd.ruby.mk is moved to Mk/Uses/ruby.mk.
- USE_RUBY=yes is replaced with USES=ruby.
- USE_RUBY_EXTCONF is replaced with USES=ruby:extconf.
- USE_RUBY_RDOC is replaced with USES=ruby:rdoc.
- USE_RUBY_SETUP is replaces with USES=ruby:setup.
- RUBY_NO_BUILD_DEPENDS and RUBY_NO_RUN_DEPENDS are replaced with
  USES=ruby:{build,none,run}.
- RUBY_REQUIRE isn't used anywhere, so removed.
- USES=gem now implies USES=ruby.

This is mainly the work of yasu@ at https://reviews.freebsd.org/D27863

I have just made some cosmetic changes and ran exp-run to test that the
tree is not in a BROKEN state.

Approved by:	portmgr
Differential Revision:	https://reviews.freebsd.org/D37925
commit hash: 18c6e18276691edf5274406bf82a3b06792ff9ae commit hash: 18c6e18276691edf5274406bf82a3b06792ff9ae commit hash: 18c6e18276691edf5274406bf82a3b06792ff9ae commit hash: 18c6e18276691edf5274406bf82a3b06792ff9ae 18c6e18
Monday, 7 Nov 2022
15:41 Matthias Fechner (mfechner) search for other commits by this committer
security/rubygem-omniauth-rails_csrf_protection: new port, required for
gitlab-ce
commit hash: 344c25a817dde021c682f72a4ffb3c63dbafbc3e commit hash: 344c25a817dde021c682f72a4ffb3c63dbafbc3e commit hash: 344c25a817dde021c682f72a4ffb3c63dbafbc3e commit hash: 344c25a817dde021c682f72a4ffb3c63dbafbc3e 344c25a

Number of commits found: 3