notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
Some details on the 2023-01-16 website outage.
We just rebooted with several updates: * new HMTLify code * no port maintainer is now highly visible (e.g. https://freshports.org/security/sssd/) * fixed search logic error when using plain/ text details at https://github.com/FreshPorts/freshports/releases/tag/2.2.34
Port details
packagekit-qt4 Qt4 bindings to packagekit
0.6.11_2 ports-mgmt Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch. NOTE: Slave port - quarterly revision is most likely wrong.
Deprecated DEPRECATED: Ignored for more than 5 years
Expired This port expired on: 2017-09-27
Ignore IGNORE: does not build with new polkit
Maintainer: gnome@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2010-05-10 21:19:33
Last Update: 2017-09-28 20:57:30
SVN Revision: 450874
Also Listed In: sysutils
License: not specified in port
Description:
Homepage    cgit ¦ GitHub ¦ GitHub ¦ GitLab ¦ SVNWeb
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • PackageKit-qt4>0:ports-mgmt/packagekit-qt4
No installation instructions:
This port has been deleted.
PKGNAME: PackageKit-qt4
Flavors: there is no flavor information for this port.
distinfo:

No package information for this port in our database
Sometimes this happens. Not all ports have packages. This is doubly so for new ports, like this one.
Master port: ports-mgmt/packagekit
Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. docbook2man : textproc/docbook-utils
  2. msgfmt : devel/gettext-tools
  3. gmake : devel/gmake
  4. pkgconf>=1.3.0_1 : devel/pkgconf
  5. python2.7 : lang/python27
  6. update-mime-database : misc/shared-mime-info
  7. intltool-extract : textproc/intltool
Runtime dependencies:
  1. lsof : sysutils/lsof
  2. bash : shells/bash
  3. update-mime-database : misc/shared-mime-info
Library dependencies:
  1. libdbus-glib-1.so : devel/dbus-glib
  2. libpolkit-gobject-1.so : sysutils/polkit
  3. libck-connector.so : sysutils/consolekit2
  4. libintl.so : devel/gettext-runtime
  5. libiconv.so : converters/libiconv
  6. libsqlite3.so : databases/sqlite3
  7. libglib-2.0.so : devel/glib20
  8. libintl.so : devel/gettext-runtime
  9. libgirepository-1.0.so : devel/gobject-introspection
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Libraries

Deleted ports which required this port:

Expand this list of 1 deleted port
  1. ports-mgmt/kpackagekit*
  2. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:
USES:
FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. http://www.packagekit.org/releases/
Collapse this list.
Port Moves
  • port deleted on 2017-09-28
    REASON: Has expired: Ignored for more than 5 years

Number of commits found: 10

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
This is a slave port. You may also want to view the commits to the master port: ports-mgmt/packagekit
CommitCreditsLog message
0.6.11_2
28 Sep 2017 20:57:30
Revision:450874Original commit files touched by this commit
rene search for other commits by this committer
Remove expired ports:
2017-09-27 ports-mgmt/packagekit-qt4: Ignored for more than 5 years
2017-09-27 ports-mgmt/kpackagekit: Skipped for more than 5 years
0.6.11_2
26 Aug 2017 09:40:15
Revision:448756Original commit files touched by this commit
antoine search for other commits by this committer
Deprecate kpackagekit and packagekit-qt4 and set expiration date
0.6.11_2
08 Dec 2016 16:07:33
Revision:428132Original commit files touched by this commit
tijl search for other commits by this committer
Remove libtiff.so.4 compatibility links that were added in r374303 to
prevent massive PORTREVISION bumps.  Bump dependent ports that have not
been bumped since.
0.6.11_1
12 Nov 2014 21:53:18
Revision:372504Original commit files touched by this commit
antoine search for other commits by this committer
Cleanup plist
0.6.11_1
07 Sep 2014 22:04:50
Revision:367608Original commit files touched by this commit
tijl search for other commits by this committer
- Convert to USES=execinfo libtool pathfix python
- Add INSTALL_TARGET=install-strip
0.6.11_1
01 Jul 2014 07:42:24
Revision:359964Original commit files touched by this commit
kwm search for other commits by this committer
Stagify.

Use USES=shared-mime-info for packagekit port.
0.6.11_1
20 Sep 2013 22:36:49
Revision:327762Original commit files touched by this commit
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
ports-mgmt)
0.6.11_1
25 May 2012 11:09:45
Original commit files touched by this commit
makc search for other commits by this committer
IGNORE= does not build with Qt 4.8
0.6.11_1
16 Oct 2011 22:45:18
Original commit files touched by this commit
avilla search for other commits by this committer
- Add dependency on qt4-gui.
- Bump PORTREVISION.
0.6.3
10 May 2010 21:19:08
Original commit files touched by this commit
kwm search for other commits by this committer
Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.30/ .

This release brings initial PackageKit support, Upower (replaces power
management part of hal), cuse4bsd integration with HAL and cheese, and a
faster Evolution.

Sadly GNOME 2.30.x will be the last release with FreeBSD 6.X support. This
will also be the last of the 2.x releases. The next release will be the
highly-anticipated GNOME 3.0 which will bring with it a new UI experience.

Currently, there are a few bugs with GNOME 2.30 that may be of note for our
users. Be sure to consult the UPGRADING note or the 2.30 upgrade FAQ at
http://www.freebsd.org/gnome/docs/faq230.html for specific upgrading
instructions, and the up-to-date list of known issues.
(Only the first 15 lines of the commit message are shown above View all of this commit message)

Number of commits found: 10