notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
NOTE: There is a known problem on production with searching pkg-plist - it returns no results. This problem is not present on stage.freshports.org
Port details on branch 2022Q2
vtk9 Visualization toolkit
9.2.2_1 math on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout Version of this port present on the latest quarterly branch.
Maintainer: yuri@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2020-04-26 23:25:05
Last Update: 2022-11-02 16:22:57
Commit Hash: 2edab7c
Also Listed In: graphics
License: BSD3CLAUSE
Description:
Homepage    cgit ¦ Codeberg ¦ GitHub ¦ GitLab ¦ SVNWeb
pkg-plist: as obtained via: make generate-plist
Expand this list (4 items)
Collapse this list.
  1. @ldconfig
  2. /usr/local/share/licenses/vtk9-9.2.2_1/catalog.mk
  3. /usr/local/share/licenses/vtk9-9.2.2_1/LICENSE
  4. /usr/local/share/licenses/vtk9-9.2.2_1/BSD3CLAUSE
Collapse this list.
Dependency lines:
  • vtk9>0:math/vtk9
Conflicts:
CONFLICTS:
  • vtk6
  • vtk8
Conflicts Matches:
There are no Conflicts Matches for this port. This is usually an error.
To install the port:
cd /usr/ports/math/vtk9/ && make install clean
To add the package, run one of these commands:
  • pkg install math/vtk9
  • pkg install vtk9
NOTE: If this package has multiple flavors (see below), then use one of them instead of the name specified above.
PKGNAME: vtk9
Flavors: there is no flavor information for this port.
distinfo:

Packages (timestamps in pop-ups are UTC):
vtk9
ABIlatestquarterly
FreeBSD:11:aarch64pkg-fallout9.0.1
FreeBSD:11:amd64pkg-falloutpkg-fallout
FreeBSD:11:armv6pkg-falloutpkg-fallout
FreeBSD:11:i386pkg-falloutpkg-fallout
FreeBSD:11:mipspkg-falloutpkg-fallout
FreeBSD:11:mips64pkg-falloutpkg-fallout
FreeBSD:12:aarch64pkg-fallout9.1.0_4
FreeBSD:12:amd649.2.2_19.1.0_4
FreeBSD:12:armv6pkg-falloutpkg-fallout
FreeBSD:12:armv7pkg-falloutpkg-fallout
FreeBSD:12:i3869.2.2_1pkg-fallout
FreeBSD:12:mipspkg-falloutpkg-fallout
FreeBSD:12:mips64pkg-falloutpkg-fallout
FreeBSD:12:powerpc64pkg-fallout9.0.1_2
FreeBSD:13:aarch649.2.2_19.1.0_4
FreeBSD:13:amd649.2.2_19.1.0_4
FreeBSD:13:armv6pkg-falloutpkg-fallout
FreeBSD:13:armv79.2.2_1pkg-fallout
FreeBSD:13:i3869.2.2_1pkg-fallout
FreeBSD:13:mipspkg-falloutpkg-fallout
FreeBSD:13:mips64pkg-falloutpkg-fallout
FreeBSD:13:powerpc64pkg-fallout9.0.1_4
FreeBSD:13:riscv64pkg-falloutpkg-fallout
FreeBSD:14:aarch649.2.2_1pkg-fallout
FreeBSD:14:amd649.2.2_1pkg-fallout
FreeBSD:14:armv6pkg-falloutpkg-fallout
FreeBSD:14:armv79.2.2_1pkg-fallout
FreeBSD:14:i3869.2.2_1pkg-fallout
FreeBSD:14:mipspkg-falloutpkg-fallout
FreeBSD:14:mips64pkg-falloutpkg-fallout
FreeBSD:14:powerpc649.0.1_2pkg-fallout
FreeBSD:14:riscv64pkg-falloutpkg-fallout
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. py39-mpi4py>0 : net/py-mpi4py@py39
  2. cmake : devel/cmake-core
  3. ninja : devel/ninja
  4. python3.9 : lang/python39
  5. xorgproto>=0 : x11/xorgproto
  6. xorgproto>=0 : x11/xorgproto
  7. ice.pc : x11/libICE
  8. x11.pc : x11/libX11
  9. xt.pc : x11-toolkits/libXt
  10. xext.pc : x11/libXext
  11. sm.pc : x11/libSM
  12. xcursor.pc : x11/libXcursor
  13. xfixes.pc : x11/libXfixes
  14. xrender.pc : x11/libXrender
  15. qt5-buildtools>=5.15 : devel/qt5-buildtools
  16. qt5-qmake>=5.15 : devel/qt5-qmake
  17. QtUiPlugin : x11-toolkits/qt5-uiplugin
Runtime dependencies:
  1. py39-mpi4py>0 : net/py-mpi4py@py39
  2. python3.9 : lang/python39
  3. ice.pc : x11/libICE
  4. x11.pc : x11/libX11
  5. xt.pc : x11-toolkits/libXt
  6. xext.pc : x11/libXext
  7. sm.pc : x11/libSM
  8. xcursor.pc : x11/libXcursor
  9. xfixes.pc : x11/libXfixes
  10. xrender.pc : x11/libXrender
  11. qt5-buildtools>=5.15 : devel/qt5-buildtools
  12. qt5-qmake>=5.15 : devel/qt5-qmake
  13. QtUiPlugin : x11-toolkits/qt5-uiplugin
Library dependencies:
  1. libexpat.so : textproc/expat2
  2. libfreetype.so : print/freetype2
  3. libhdf5.so : science/hdf5
  4. libnetcdf.so : science/netcdf
  5. libpng.so : graphics/png
  6. libtiff.so : graphics/tiff
  7. libGL.so : graphics/libglvnd
  8. libGLU.so : graphics/libGLU
  9. libjpeg.so : graphics/jpeg-turbo
  10. libmpi_cxx.so : net/openmpi
  11. libQt5Core.so : devel/qt5-core
  12. libQt5Qml.so : x11-toolkits/qt5-declarative
  13. libQt5Gui.so : x11-toolkits/qt5-gui
  14. libQt5Network.so : net/qt5-network
  15. libQt5OpenGL.so : graphics/qt5-opengl
  16. libQt5Sql.so : databases/qt5-sql
  17. libQt5Widgets.so : x11-toolkits/qt5-widgets
  18. libQt5X11Extras.so : x11/qt5-x11extras
This port is required by:
for Libraries
  1. cad/appcsxcad
  2. cad/csxcad
  3. cad/freecad
  4. cad/opencascade
  5. cad/qcsxcad
  6. graphics/cloudcompare
  7. graphics/f3d
Expand this list (16 items / 9 hidden - sorry, this count includes any deleted ports)
  1. Collapse this list).
  2. graphics/mirtk
  3. graphics/pcl-pointclouds
  4. graphics/py-mayavi
  5. misc/visp
  6. science/InsightToolkit
  7. science/elmerfem
  8. science/liggghts
  9. science/openems
  10. Collapse this list.

Deleted ports which required this port:

Expand this list of 1 deleted port
  1. multimedia/f3d*
  2. Collapse this list of deleted ports.
for Run
  1. graphics/py-pyvista
  2. science/paraview

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message

Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://vtk.org/files/release/9.2/
Collapse this list.

There are no commits on branch 2022Q2 for this port