notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
FreshPorts needs to find a new hosting provide willing to take a 2U chassis and host it free of charge. This is part of the FreshPorts project. Preferably in the Austin area. This is not a primary server, but it used for development.
Port details
kipi-plugin-videoslideshow Export images as Video Slide Show
4.14.0_6 graphics Deleted on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 4.14.0_6Version of this port present on the latest quarterly branch.
Maintainer: kde@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2013-04-08 17:11:23
Last Update: 2018-12-31 11:12:18
SVN Revision: 488764
Also Listed In: kde
License: GPLv2
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
Expand this list (6 items)
Collapse this list.
  1. /usr/local/share/licenses/kipi-plugin-videoslideshow-4.14.0_6/catalog.mk
  2. /usr/local/share/licenses/kipi-plugin-videoslideshow-4.14.0_6/LICENSE
  3. /usr/local/share/licenses/kipi-plugin-videoslideshow-4.14.0_6/GPLv2
  4. lib/kde4/kipiplugin_videoslideshow.so
  5. share/apps/kipi/kipiplugin_videoslideshowui.rc
  6. share/kde4/services/kipiplugin_videoslideshow.desktop
Collapse this list.
Dependency lines:
  • kipi-plugin-videoslideshow>0:graphics/kipi-plugin-videoslideshow
Conflicts:
CONFLICTS_INSTALL:
  • kipi-plugins-2.*
Conflicts Matches:
There are no Conflicts Matches for this port. This is usually an error.
No installation instructions:
This port has been deleted.
PKGNAME: kipi-plugin-videoslideshow
Flavors: there is no flavor information for this port.
distinfo:
Packages (timestamps in pop-ups are UTC):
kipi-plugin-videoslideshow
ABIlatestquarterly
FreeBSD:11:aarch644.14.0_5-
FreeBSD:11:amd64--
FreeBSD:11:armv6--
FreeBSD:11:i386--
FreeBSD:11:mips--
FreeBSD:11:mips64--
FreeBSD:12:aarch644.14.0_5-
FreeBSD:12:amd64--
FreeBSD:12:armv6--
FreeBSD:12:armv7--
FreeBSD:12:i386--
FreeBSD:12:mips--
FreeBSD:12:mips64--
FreeBSD:12:powerpc64--
FreeBSD:13:aarch64--
FreeBSD:13:amd64--
FreeBSD:13:armv6--
FreeBSD:13:armv7--
FreeBSD:13:i386--
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc64--
FreeBSD:14:aarch64--
FreeBSD:14:amd64--
FreeBSD:14:armv6--
FreeBSD:14:armv7--
FreeBSD:14:i386--
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc64--
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. cmake : devel/cmake
  2. automoc4 : devel/automoc4
  3. pkgconf>=1.3.0_1 : devel/pkgconf
  4. moc : devel/qt4-moc
  5. qmake : devel/qt4-qmake
  6. rcc : devel/qt4-rcc
  7. uic : devel/qt4-uic
Library dependencies:
  1. libMagickCore-6.so : graphics/ImageMagick6
  2. libQtGLib-2.0.so : multimedia/gstreamer1-qt@qt4
  3. libkipiplugins.so : graphics/libkipiplugins
  4. libkdecore.so : x11/kdelibs-kde4
NOTE: dependencies for deleted ports are notoriously suspect
This port is required by:
for Run

Deleted ports which required this port:

Expand this list of 1 deleted port
  1. graphics/kipi-plugins-kde4*
  2. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:

USES:

FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (36 items)
Collapse this list.
  1. ftp://ftp.cronyx.ru/pub/mirror/kde/Attic/digikam/
  2. ftp://ftp.fi.muni.cz/pub/kde/Attic/digikam/
  3. ftp://ftp.fu-berlin.de/pub/unix/X11/gui/kde/Attic/digikam/
  4. ftp://ftp.funet.fi/pub/mirrors/ftp.kde.org/pub/kde/Attic/digikam/
  5. ftp://ftp.gtlib.gatech.edu/pub/kde/Attic/digikam/
  6. ftp://ftp.heanet.ie/mirrors/ftp.kde.org/Attic/digikam/
  7. ftp://ftp.informatik.hu-berlin.de/pub/Mirrors/ftp.kde.org/Attic/digikam/
  8. ftp://ftp.kddlabs.co.jp/pub/X11/kde/Attic/digikam/
  9. ftp://ftp.lip6.fr/pub/X11/kde/Attic/digikam/
  10. ftp://ftp.mirrorservice.org/sites/ftp.kde.org/pub/kde/Attic/digikam/
  11. ftp://ftp.ntua.gr/pub/X11/kde/Attic/digikam/
  12. ftp://ftp.rz.uni-wuerzburg.de/pub/unix/kde/Attic/digikam/
  13. ftp://ftp.sayclub.com/pub/X/KDE/Attic/digikam/
  14. ftp://ftp.ussg.iu.edu/pub/kde/Attic/digikam/
  15. ftp://mirrors.dotsrc.org/kde/Attic/digikam/
  16. ftp://sunsite.icm.edu.pl/pub/unix/kde/Attic/digikam/
  17. ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/kde/Attic/digikam/
  18. http://ftp.fi.muni.cz/pub/kde/Attic/digikam/
  19. http://ftp.fi.muni.cz/pub/kde/Attic/digikam/
  20. http://ftp.funet.fi/pub/mirrors/ftp.kde.org/pub/kde/Attic/digikam/
  21. http://ftp.gtlib.gatech.edu/pub/kde/Attic/digikam/
  22. http://ftp.kddlabs.co.jp/pub/X11/kde/Attic/digikam/
  23. http://ftp.ntua.gr/pub/X11/kde/Attic/digikam/
  24. http://ftp.sayclub.com/pub/X/KDE/Attic/digikam/
  25. http://ftp.twaren.net/Unix/X/KDE/Attic/digikam/
  26. http://ftp.ussg.iu.edu/kde/Attic/digikam/
  27. http://kde.mirrors.tds.net/pub/kde/Attic/digikam/
  28. http://mirror.cc.columbia.edu/pub/software/kde/Attic/digikam/
  29. http://www-ftp.lip6.fr/pub/X11/kde/Attic/digikam/
  30. https://download.kde.org/Attic/digikam/
  31. https://ftp-stud.hs-esslingen.de/Mirrors/ftp.kde.org/pub/kde/Attic/digikam/
  32. https://ftp.heanet.ie/mirrors/ftp.kde.org/Attic/digikam/
  33. https://ftp.icm.edu.pl/pub/unix/kde/Attic/digikam/
  34. https://mirrors.dotsrc.org/kde/Attic/digikam/
  35. https://sunsite.icm.edu.pl/pub/unix/kde/Attic/digikam/
  36. https://www.mirrorservice.org/sites/ftp.kde.org/pub/kde/Attic/digikam/
Collapse this list.
Port Moves
  • port deleted on 2018-12-31
    REASON: Removed, part of expired KDE4

Number of commits found: 19

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
31 Dec 2018 11:12:18
Original commit files touched by this commit Revision:488764  4.14.0_6
rene search for other commits by this committer
Remove KDE4, part 3
graphics/kipi-plugin-acquireimages
graphics/kipi-plugin-advancedslideshow
graphics/kipi-plugin-batchprocess
graphics/kipi-plugin-debianscreenshots
graphics/kipi-plugin-dngconverter
graphics/kipi-plugin-dropbox
graphics/kipi-plugin-expoblending
graphics/kipi-plugin-facebook
graphics/kipi-plugin-flashexport
graphics/kipi-plugin-flickrexport
graphics/kipi-plugin-galleryexport
graphics/kipi-plugin-googleservices
graphics/kipi-plugin-gpssync
graphics/kipi-plugin-htmlexport
(Only the first 15 lines of the commit message are shown above View all of this commit message)
10 Nov 2018 19:57:08
Original commit files touched by this commit Revision:484640  4.14.0_6
kwm search for other commits by this committer
Update ImageMagick to 6.9.10.14 [1]

* Add PKGNAMESUFFIX and rename the directory. This was done to show
  that IM6 is not the "main" version. But still fully supported by upstream.
* Convert a number of options to optionhelpers.
* Add option for ISO/IEC 23008-12:2017 HEIF suport
* Add comment to pkg-descr explaining IM6's "legacy" tag.
* Add comment to the patch-config_policy.xml file why it still needed.

Please note that IM7 is not a drop in replacement due to library API and
command arguments changes. And as a result ports need to decide for themself
which version to use.

Chase these changes in all the ports that using IM6.

PR:		225102 (based on, only the version update) [1]
Submitted by:	Pascal Christen <pascal.christen@hostpoint.ch>
14 Apr 2018 14:02:49
Original commit files touched by this commit Revision:467319  4.14.0_5
tcberner search for other commits by this committer
multimedia/gstreamer1-qt4, multimedia/gstreamer1-qt5: create flavors

Approved by:	portmgr (mat)
Differential Revision:	https://reviews.freebsd.org/D14641
10 Feb 2018 10:29:51
Original commit files touched by this commit Revision:461375  4.14.0_4
tcberner search for other commits by this committer
Rename KDE4 meta ports

This is done for
 * consistency,
 * and to simplify the import of the newer KDE Plasma5 desktop and KDE
applications

Bumps the dependencies.

Reviewed by:	adridg
Differential Revision:	https://reviews.freebsd.org/D12979
28 Sep 2017 15:36:31
Original commit files touched by this commit Revision:450852  4.14.0_3
kwm search for other commits by this committer
ImageMagick to 6.9.9-15.

* Disable FPX (FlashPix) support by default. This image format is really
  rare these days coupled with that there are known CVE's in libfpx and
  it doesn't seem to be maintained these days. It doesn't make sense to
  keep it enabled by default anymore. [1]
* Add new option for RAW support
* Fix portscout macro to only show 6.9.x versions

Bump other ports for the shared library bumps in IM 6.

PR:		222309 [1]
Submitted by:	Anton Yuzhaninov <citrin+pr@citrin.ru> [1]
26 May 2017 08:20:19
Original commit files touched by this commit Revision:441761  4.14.0_2
kwm search for other commits by this committer
Chase ImageMagick shlib bump
25 Apr 2017 08:20:31
Original commit files touched by this commit Revision:439367  4.14.0_1
riggs search for other commits by this committer
Chase ffmpeg 3.3 update (ABI changes)

PR:		218658
Submitted by:	riggs
14 Apr 2016 19:06:41
Original commit files touched by this commit Revision:413310  4.14.0
rakuco search for other commits by this committer
Update DigiKam and related ports to 4.14.0.

This is a huge leap, as we are moving from 4.2.0 (released in August 2014) to
4.14.0 (released in October 2015). Version 4.14.0 is the last KDE4-based
release, and 5.0.0 will be based on KDE Frameworks 5.

Noteworthy port changes:
- Most patches in graphics/digikam-kde4 are no longer necessary.
- graphics/kipi-plugin-googledrive and graphics/kipi-plugin-picasaweb have
  been merged into graphics/kipi-plugin-googleservices following what
  upstream did to those plugins.
- astro/libkgeomap and graphics/libkface are no longer included in the
  DigiKam tarball and are now completely independent ports whose tarballs
  are released as part of KDE Applications.
- net/libmediawiki is neither included in the DigiKam tarball nor released
(Only the first 15 lines of the commit message are shown above View all of this commit message)
01 Apr 2016 14:00:57
Original commit files touched by this commit Revision:412346  4.2.0
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.

With hat:	portmgr
Sponsored by:	Absolight
27 Jan 2015 21:04:31
Original commit files touched by this commit Revision:378020  4.2.0
makc search for other commits by this committer
- Update digiKam and Kipi Plugins to 4.2.0
- New ports for exporting images to Dropbox and Google Drive:
	graphics/kipi-plugin-dropbox
	graphics/kipi-plugin-googledrive

Excerpt from area51 commit logs:
------------------------------------------------------------------------
r10303 | jhale | 2014-09-19 04:04:57 +0000 (Fri, 19 Sep 2014) | 13 lines

- Update digikam and friends to 4.2.0
- Drop "Enable" from Digikam options descriptions
- For kipi-plugins, only extract what we need to reduce extraction time
  and file I/O

------------------------------------------------------------------------
(Only the first 15 lines of the commit message are shown above View all of this commit message)
18 Jan 2015 21:12:43
Original commit files touched by this commit Revision:377347  3.5.0_5
kwm search for other commits by this committer
Update ImageMagick to 6.9.0.4.

- Normalize the ImageMagick library name so it stays the same regardless of
  what the 16-bit and HDRI option are set to [1]. Teach cmake to look for
  the new name. Bump ports that link to the libraries due to this.
- As a result do away with the "HALFSUPPORTED" option block, and list
  16-bit and HDRI with the other options.
- ImageMagick ships a basic SVG plugin when not using librsvg2 for SVG
  support. This basic SVG plugin needs libxml2 to work [2]. Make libxml2
  a mandatory dependency (instead of only when the SVG option was selected).
- Don't touch .keep files in the modules directory, there files there so
  it useless.

PR:		194949 [1]
PR:		195227 [2]
Requested by:	many [1]
Submitted by:	software-freebsd@interfasys.ch [2]
07 Nov 2014 09:55:23
Original commit files touched by this commit Revision:372250  3.5.0_4
kwm search for other commits by this committer
Remove * from LIB_DEPENDS lines and specify the default library name
for ImageMagick. Using '*' it is unsupported and potention bugs here.
10 Sep 2014 20:50:37
Original commit files touched by this commit Revision:367888  3.5.0_4
gerald search for other commits by this committer
Update the default version of GCC in the Ports Collection from GCC 4.7.4
to GCC 4.8.3.

Part II, Bump PORTREVISIONs.

PR:		192025
Tested by:	antoine (-exp runs)
Approved by:	portmgr (implicit)
15 Aug 2014 20:37:33
Original commit files touched by this commit Revision:365038  3.5.0_3
mandree search for other commits by this committer
Upgrade OpenEXR and ilmbase to 2.2.0.

GCC 4.2 in FreeBSD 8.X/9.X base is now too old to compile OpenEXR, so
GCC-based systems will upgrade to the default ports compiler (GCC 4.7
currently.)

Add two patches to OpenEXR to permit building it in a live system with
the older OpenEXR version installed. Bug report filed to upstream Github
at https://github.com/openexr/openexr/issues/130

Couple OpenEXR more tightly to ilmbase and require its exact .so
version.

Add UPDATING note, and bump PORTREVISION of all dependent ports.

Proto-STAGE hugin-devel, and mark it IGNORE because hugin is newer.

Approved by:	portmgr (implicit for bumping PORTREVISION on unstaged ports)
17 Jun 2014 20:05:31
Refresh Original commit files touched by this commit Revision:358176
kwm search for other commits by this committer
Update to 6.8.9-3 [1][3].

Use USES=compiler:openmp for the OPENMP option[2]
Ditch the use of perl for patching etc [4] and silence perl threaded check [6]
-delay option spurious message should be fixed [5]

JASPER option was replace by JPEG2000 for JP2k support.
Put 16BIT_PIXEL and HDRI option separate option block. These options change
  the library name, so the user needs to take this into consideration.
Use new LIB_DEPENDS syntax.
Use @sample for config files.
Sprinkle some USES=pkgconfig for some ports, since we don't pull it in
  anymore at run-time.

PR:		185462 [1]
(Only the first 15 lines of the commit message are shown above View all of this commit message)
18 Feb 2014 14:31:33
Original commit files touched by this commit Revision:344898  3.5.0_1
makc search for other commits by this committer
- Bump PORTREVISION after KDE4_PREFIX change
21 Jan 2014 18:17:24
Original commit files touched by this commit Revision:340628  3.5.0
makc search for other commits by this committer
- Update to digiKam and Kipi Plugins ports to 3.5.0
- Add new kipi-plugin port for jalbumexport
- Remove useless LATEST_LINK
- Bring stage support
- Convert to options helpers, new style LIB_DEPENDS
- Add patch to fix linking with libpgf [1]

PR:		ports/184942 [1]
Reported by:	Mike Clarke <jmc-freebsd2 at milibyte.co.uk>
20 Sep 2013 18:35:46
Original commit files touched by this commit Revision:327733  3.2.0
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
graphics)
08 Apr 2013 17:10:57
Original commit files touched by this commit Revision:315762  3.1.0
makc search for other commits by this committer
- Update to digiKam and Kipi Plugins ports to 3.1.0
- Split documentations and l10ns to separate ports
- Split kipi-plugins-kde4 port

Approved by:	portmgr (miwi)

Number of commits found: 19