notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Ukraine
FreshPorts needs to find a new hosting provide willing to take a 2U chassis and host it free of charge. This is part of the FreshPorts project. Preferably in the Austin area. This is not a primary server, but it used for development.
Port details
qemu QEMU CPU Emulator
7.0.0_1 emulators on this many watch lists=63 search for ports that depend on this port An older version of this port was marked as vulnerable. Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 6.2.0Version of this port present on the latest quarterly branch.
Maintainer: bofh@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2004-06-03 02:14:00
Last Update: 2022-04-27 13:21:01
Commit Hash: 30d01a7
People watching this port, also watch:: firefox, mplayer, zip, unzip, sudo
License: GPLv2
Description:
SVNWeb : git : Homepage
pkg-plist: as obtained via: make generate-plist
There is no configure plist information for this port.
Dependency lines:
  • qemu>0:emulators/qemu
Conflicts:
CONFLICTS_INSTALL:
  • qemu-devel
  • qemu-nox11
  • qemu-tools
  • qemu-utils
  • qemu5*
  • qemu6*
Conflicts Matches:
There are no Conflicts Matches for this port. This is usually an error.
To install the port:
cd /usr/ports/emulators/qemu/ && make install clean
To add the package, run one of these commands:
  • pkg install emulators/qemu
  • pkg install qemu
NOTE: If this package has multiple flavors (see below), then use one of them instead of the name specified above.
PKGNAME: qemu
Package flavors (<flavor>: <package>)
  • default: qemu
  • nox11: qemu-nox11
  • tools: qemu-tools
ONLY_FOR_ARCHS: amd64 powerpc64
distinfo:
Packages (timestamps in pop-ups are UTC):
qemu
ABIlatestquarterly
FreeBSD:11:aarch64--
FreeBSD:11:amd645.0.1_25.0.1_2
FreeBSD:11:armv6--
FreeBSD:11:i3865.0.1_25.0.1_2
FreeBSD:11:mips--
FreeBSD:11:mips64--
FreeBSD:12:aarch64--
FreeBSD:12:amd647.0.0_16.2.0
FreeBSD:12:armv6--
FreeBSD:12:armv7--
FreeBSD:12:i386-6.2.0
FreeBSD:12:mips--
FreeBSD:12:mips64--
FreeBSD:12:powerpc64-5.0.1
FreeBSD:13:aarch64--
FreeBSD:13:amd647.0.0_16.2.0
FreeBSD:13:armv6--
FreeBSD:13:armv7--
FreeBSD:13:i386-6.2.0
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc64-5.0.1_2
FreeBSD:14:aarch64--
FreeBSD:14:amd647.0.0_1-
FreeBSD:14:armv6--
FreeBSD:14:armv7--
FreeBSD:14:i386--
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc645.0.1-
 
qemu-nox11
ABIlatestquarterly
FreeBSD:11:aarch64--
FreeBSD:11:amd64--
FreeBSD:11:armv6--
FreeBSD:11:i386--
FreeBSD:11:mips--
FreeBSD:11:mips64--
FreeBSD:12:aarch64--
FreeBSD:12:amd647.0.0_16.2.0
FreeBSD:12:armv6--
FreeBSD:12:armv7--
FreeBSD:12:i386-6.2.0
FreeBSD:12:mips--
FreeBSD:12:mips64--
FreeBSD:12:powerpc64--
FreeBSD:13:aarch64--
FreeBSD:13:amd647.0.0_16.2.0
FreeBSD:13:armv6--
FreeBSD:13:armv7--
FreeBSD:13:i386-6.2.0
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc64--
FreeBSD:14:aarch64--
FreeBSD:14:amd647.0.0_1-
FreeBSD:14:armv6--
FreeBSD:14:armv7--
FreeBSD:14:i386--
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc64--
 
qemu-tools
ABIlatestquarterly
FreeBSD:11:aarch64--
FreeBSD:11:amd64--
FreeBSD:11:armv6--
FreeBSD:11:i386--
FreeBSD:11:mips--
FreeBSD:11:mips64--
FreeBSD:12:aarch64-6.2.0
FreeBSD:12:amd647.0.0_16.2.0
FreeBSD:12:armv6--
FreeBSD:12:armv7--
FreeBSD:12:i3867.0.0_16.2.0
FreeBSD:12:mips--
FreeBSD:12:mips64--
FreeBSD:12:powerpc64--
FreeBSD:13:aarch647.0.0_16.2.0
FreeBSD:13:amd647.0.0_16.2.0
FreeBSD:13:armv6-6.2.0
FreeBSD:13:armv7-6.2.0
FreeBSD:13:i3867.0.0_16.2.0
FreeBSD:13:mips--
FreeBSD:13:mips64--
FreeBSD:13:powerpc64--
FreeBSD:14:aarch647.0.0_1-
FreeBSD:14:amd647.0.0_1-
FreeBSD:14:armv6--
FreeBSD:14:armv7--
FreeBSD:14:i3867.0.0_1-
FreeBSD:14:mips--
FreeBSD:14:mips64--
FreeBSD:14:powerpc64--
 

Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. bash : shells/bash
  2. py38-sphinx_rtd_theme>0 : textproc/py-sphinx_rtd_theme@py38
  3. sphinx-build : textproc/py-sphinx@py38
  4. gmake>=4.3 : devel/gmake
  5. ninja : devel/ninja
  6. pkgconf>=1.3.0_1 : devel/pkgconf
  7. python3.8 : lang/python38
  8. msgfmt : devel/gettext-tools
  9. sdl2-config : devel/sdl20
  10. perl5>=5.32.r0<5.33 : lang/perl5.32
  11. xorgproto>=0 : x11/xorgproto
  12. x11.pc : x11/libX11
  13. xext.pc : x11/libXext
  14. x11.pc : x11/libX11
  15. xext.pc : x11/libXext
  16. pixman-1.pc : x11/pixman
  17. x11.pc : x11/libX11
Runtime dependencies:
  1. x11.pc : x11/libX11
  2. xext.pc : x11/libXext
  3. x11.pc : x11/libX11
  4. xext.pc : x11/libXext
  5. pixman-1.pc : x11/pixman
  6. x11.pc : x11/libX11
Library dependencies:
  1. libfdt.so : sysutils/dtc
  2. libzstd.so : archivers/zstd
  3. libepoxy.so : graphics/libepoxy
  4. libcurl.so : ftp/curl
  5. libgnutls.so : security/gnutls
  6. libxkbcommon.so : x11/libxkbcommon
  7. libpng.so : graphics/png
  8. libsasl2.so : security/cyrus-sasl2
  9. libvdeplug.so : net/vde2
  10. libatk-1.0.so : accessibility/atk
  11. libcairo.so : graphics/cairo
  12. libgdk_pixbuf-2.0.so : graphics/gdk-pixbuf2
  13. libglib-2.0.so : devel/glib20
  14. libintl.so : devel/gettext-runtime
  15. libgtk-3.so : x11-toolkits/gtk30
  16. libpango-1.0.so : x11-toolkits/pango
  17. libvte-2.91.so : x11-toolkits/vte3
  18. libiconv.so : converters/libiconv
  19. libintl.so : devel/gettext-runtime
  20. libgbm.so : graphics/mesa-libs
  21. libGL.so : graphics/libglvnd
  22. libjpeg.so : graphics/jpeg-turbo
  23. libSDL2.so : devel/sdl20
This port is required by:
for Run
  1. emulators/qemu-cheri

Deleted ports which required this port:

Expand this list of 2 deleted ports
  1. emulators/qemu-cheri128*
  2. emulators/qemu-cheri128m*
  3. Collapse this list of deleted ports.
* - deleted ports are only shown under the This port is required by section. It was harder to do for the Required section. Perhaps later...

Configuration Options:
Options name:

USES:

pkg-message:
For install:
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://download.qemu.org/
Collapse this list.
Notes from UPDATING
These upgrade notes are taken from /usr/ports/UPDATING
  • 2020-10-26
    Affects: users of emulators/qemu
    Author: bofh@FreeBSD.org
    Reason: 
      emulators/qemu has been updated to 5.0.1. Previous 4.2.X branch has
      been repocopied to emulators/qemu42. If someone wants to stick with 4.2.X
      branch please use one of the following command:
    
      # pkg install emulators/qemu42
        or
      # portmaster -o emulators/qemu42 emulators/qemu
        or
      # portupgrade -o emulators/qemu42 emulators/qemu
    
    
Expand this list (6 items)
  • 2020-07-19
    Affects: users of emulators/qemu
    Author: bofh@FreeBSD.org
    Reason: 
      emulators/qemu has been updated to 4.2.1. Previous 4.1.X branch has
      been repocopied to emulators/qemu41. If someone wants to stick with 4.1.X
      branch please use one of the following command:
    
      # pkg install emulators/qemu41
        or
      # portmaster -o emulators/qemu41 emulators/qemu
        or
      # portupgrade -o emulators/qemu41 emulators/qemu
    
    
  • 2019-11-25
    Affects: users of emulators/qemu
    Author: bofh@FreeBSD.org
    Reason: 
      emulators/qemu31 has been updated to 4.1.1. Previous 3.1.X branch has
      been repocopied to emulators/qemu31. If someone wants to stick with 3.1.X
      branch please use one of the following command:
    
      # pkg install emulators/qemu31
        or
      # portmaster -o emulators/qemu31 emulators/qemu
        or
      # portupgrade -o emulators/qemu31 emulators/qemu
    
    
  • 2019-04-19
    Affects: users of emulators/qemu
    Author: bofh@FreeBSD.org
    Reason: 
      qemu 2.X version has been moved to qemu2. If you would like to use
      2.X you should use qemu2. Otherwise you can use the new stable
      upstream branch of 3.0.X.
    
      Portmaster users will need to run this command:
    
      portmaster -o emulators/qemu2 emulators/qemu
    
    
  • 2009-12-06
    Affects: users of emulators/qemu
    Author: nox@FreeBSD.org
    Reason: 
      The port has been updated to 0.11.1, which no longer enables kqemu by
      default (if built with KQEMU knob on), now you also have to explicitly
      pass -enable-kqemu (or -kernel-kqemu as with the previous versions)
      if you want to use it.  Also note the 0.11 stable branch is the last
      qemu branch that still supports kqemu, so if you depend on reasonably
      fast emulation on FreeBSD you should start looking for alternatives
      some time soon.  (VirtualBox?)
    
    
  • 2009-03-08
    Affects: users of emulators/qemu
    Author: nox@FreeBSD.org
    Reason: 
      The port has been updated to 0.10.0, which now uses the newer
      (incompatible) kqemu-kmod-devel port that now also works for the
      32 bit "qemu" executable on amd64.  If you upgrade emulators/qemu
      with the KQEMU knob on, you have to
    
    	# pkg_delete kqemu-kmod-1\*
    
      the old kqemu version first if it is installed.
    
    
  • 2008-04-03
    Affects: users of emulators/qemu and emulators/qemu-devel
    Author: nox@FreeBSD.org
    Reason: 
      The default configuration location (qemu-ifup script etc.) has been
      changed from /etc to ${PREFIX}/etc (usually /usr/local/etc).  Move your
      files accordingly.
    
    
  • Collapse this list.
Port Moves
  • port moved here from emulators/qemu31 on 2021-10-31
    REASON: Has expired: Use emulators/qemu or emulators/qemu-devel

  • port moved here from emulators/qemu-sbruno on 2020-10-02
    REASON: Has expired: Port will be removed in favor of emulators/qemu

Number of commits found: 236 (showing only 100 on this page)

1 | 2 | 3  »  

Commit History - (may be incomplete: see SVNWeb link above for full details)
DateByDescription
27 Apr 2022 13:21:01
 files touched by this commit commit hash:30d01a77b1ff0377c47919c3982d161e7546d34f  7.0.0_1
Piotr Kubaj (pkubaj) search for other commits by this committer
emulators/qemu: fix build on powerpc64

bsd-user disabled because of no bsd-user/host/ppc64.
26 Apr 2022 12:37:23
 files touched by this commit commit hash:464c7c97f8297f200cb9a306a57fd97d6ad9e732  7.0.0_1
Muhammad Moinur Rahman (bofh) search for other commits by this committer
emulators/qemu: Fix plist for NO_X86_TARGETS

Reported by:	kib
24 Apr 2022 00:40:24
 files touched by this commit commit hash:7eac6b77c16b3a2552a94e0f14e6fcf471e27a9e  7.0.0
Muhammad Moinur Rahman (bofh) search for other commits by this committer
emulators/qemu: Update version 6.2.0=>7.0.0

Users who want to stick with 6.X branch please check UPDATING or use
qemu6. As previous qemu comes with three flavors: the default with X11
support, -nox11 without X11 support and -tools which instals only a
subset of entire qemu.

Relnotes: https://wiki.qemu.org/ChangeLog/7.0
15 Dec 2021 18:48:37
 files touched by this commit commit hash:928b73b50bf1411e915563801d82b1ed38235c3d  6.2.0
Muhammad Moinur Rahman (bofh) search for other commits by this committer
emulators/qemu: Update version 6.1.0=>6.2.0

Relnotes: https://wiki.qemu.org/ChangeLog/6.2
14 Dec 2021 13:02:26
 files touched by this commit commit hash:feb95d6a41b28e32a17aa9044b8687d83f93ef1f  6.1.0_3
Tobias Kortkamp (tobik) search for other commits by this committer
*: Clean up some things

- Fix typos
- Remove unreferenced variables
- Sort categories
- Clean up commented PORTREVISION
- Fix broken syntax

Reported by:	portscan
12 Dec 2021 23:38:43
 files touched by this commit commit hash:f52ce2807b99550bdd187a4f6dc96ca5882f2f44  6.1.0_3
Muhammad Moinur Rahman (bofh) search for other commits by this committer
emulators/qemu: UNBREAK for i386

- Fix some plist issues with default flavor
12 Dec 2021 03:19:43
 files touched by this commit commit hash:42780ffaeecd7e3ed19ddc2bdece509e1c297ca1  6.1.0_3
Muhammad Moinur Rahman (bofh) search for other commits by this committer
emulators/qemu: Add tools FLAVOR
11 Dec 2021 23:47:07
 files touched by this commit commit hash:8d18eafa625f7909693b8a166d8dac21acf61852  6.1.0_2
Muhammad Moinur Rahman (bofh) search for other commits by this committer
emulators/qemu: Add nox11 FLAVOR

- Fix build with DOCS unset [1]
PR: 250733 [1]
Reported by: xxjack12xx@gmail.com [1]
10 Dec 2021 20:39:32
 files touched by this commit commit hash:e6f5aeddaf1655f5fb55cc50541c10f814dc14d1  6.1.0_1
Muhammad Moinur Rahman (bofh) search for other commits by this committer
emulators/qemu: Use system dtc from ports

- elf2dmp depends on CURL [1]
- Fix build when fusefs-libs3 is installed [2]

PR:     260315 [2]
Reported by: kostikbel@gmail.com [1] d8zNeCFG@aon.at [2]
06 Dec 2021 01:02:48
 files touched by this commit commit hash:3f7e206ef247134840510e3a3c3dc739af518d46  6.1.0
Muhammad Moinur Rahman (bofh) search for other commits by this committer
emulators/qemu: Update version 5.0.1=>6.1.0

Relnotes: https://wiki.qemu.org/ChangeLog/6.1
10 Oct 2021 19:44:42
 files touched by this commit commit hash:2c672a4de941dc57142d867ba42396b1b64d2921  5.0.1_2
Baptiste Daroussin (bapt) search for other commits by this committer
INSTALLS_ICONS: retire the macro and rework the related dependencies

While here, make sure gtk-update-icon-cache is only on run dependency
where added as a dependency
Enforce gtk3 to depend on gtk-update-icon-cache (previously it was
inheriting the dependency)
15 Jul 2021 22:02:27
 files touched by this commit commit hash:64a800d83df28391a75317302ea47f1210bb5596  5.0.1_2
Piotr Kubaj (pkubaj) search for other commits by this committer
emulators/qemu: fix build on powerpc

Define _CALL_SYSV to fix error:
In file included from
/wrkdirs/usr/ports/emulators/qemu/work/qemu-5.0.1/tcg/tcg.c:344:                
                                                                                
                                                    
/wrkdirs/usr/ports/emulators/qemu/work/qemu-5.0.1/tcg/ppc/tcg-target.inc.c:2290:3:
error: "Unhandled abi"

Use gcc because clang hangs.
22 Jun 2021 18:53:08
 files touched by this commit commit hash:da3162c7c9f01912ba1940e188b253f2b5c7ba77  5.0.1_2
Kevin Bowling (kbowling) search for other commits by this committer
graphics/mesa-libs: Bump reverse deps for libglvnd

Per discussion with bapt on helping pkg handle the changing of these
deps and avoiding impossible upgrade senarios.

PR:		246767
Reviewed by:	manu, bapt
Approved by:	x11
Differential Revision:	https://reviews.freebsd.org/D30824
20 Apr 2021 19:46:11
 files touched by this commit commit hash:9e06cd0454806020fc8e2f11df85baf500690902  5.0.1_1
Muhammad Moinur Rahman (bofh) search for other commits by this committer
emulators/qemu: Fix build on 13

- Use ports dtc instead of packaged dtc [1]
- bin/elf2dmp apparently depends on CURL [2]
- Reduce build to only X86 architectures if X86_TARGETS is set [2]
- rx is not an X86 architecture [2]

PR:		245997 [1] 254385 [2]
Reported by:	swills [1] pstef [2]
06 Apr 2021 14:31:07
 files touched by this commit commit hash:305f148f482daf30dcf728039d03d019f88344eb  5.0.1
Mathieu Arnold (mat) search for other commits by this committer
Remove # $FreeBSD$ from Makefiles.
18 Feb 2021 15:05:28
Original commit files touched by this commit Revision:565942  5.0.1
pkubaj search for other commits by this committer
emulators/qemu: enable on powerpc64le
10 Nov 2020 01:28:38
Original commit files touched by this commit Revision:554806  5.0.1
pkubaj search for other commits by this committer
emulators/qemu: fix build on GCC architectures

Don't explicitly add -L/usr/lib, it makes gcc9 prefer /usr/lib instead of its
own libraries.
26 Oct 2020 01:30:57
Original commit files touched by this commit Revision:553312  5.0.1
bofh search for other commits by this committer
emulators/qemu: Update version 4.2.1=>5.0.1

- Add OPTION DEBUG
01 Sep 2020 22:26:49
Original commit files touched by this commit Revision:547301  4.2.1
bofh search for other commits by this committer
emulators/qemu: Fix build with OPTION DOCS disabled

PR:		230204
Submitted by:	guyyur@gmail.com
Reported by:	novel
19 Jul 2020 19:05:16
Original commit files touched by this commit Revision:542594  4.2.1
bofh search for other commits by this committer
emulators/qemu: Fix missing patch files

Reported by:	kostikbel@gmail.com
18 Jul 2020 19:42:00
Original commit files touched by this commit Revision:542523  4.2.1
bofh search for other commits by this committer
emulators/qemu: Update version 4.1.1=>4.2.1

- Add OPTION CAPSTONE [1]

PR:		247870 [1]
Reported by:	amdmi3 [1]
06 Jun 2020 10:02:12
Original commit files touched by this commit Revision:538082  4.1.1_4
bofh search for other commits by this committer
emulators/qemu: Add NCURSES option

- Add ISCSI OPTION [1]

PR:             246038 217355 [1]
Submitted by:   cy d8zNeCFG@aon.at [1]
16 May 2020 10:51:33
Original commit files touched by this commit Revision:535391  4.1.1_3
sunpoet search for other commits by this committer
Bump PORTREVISION for security/nettle shlib change
23 Apr 2020 21:39:31
Original commit files touched by this commit Revision:532712  4.1.1_2
bofh search for other commits by this committer
emulators/qemu: Fix BUILD when DOCS disabled

Reported by:	olivier
20 Mar 2020 17:29:32
Original commit files touched by this commit Revision:528790  4.1.1_1
bofh search for other commits by this committer
emulators/qemu: Fix build with lld 10.0.0

PR:		244770
Submitted by:	dim
22 Jan 2020 17:34:11
Original commit files touched by this commit Revision:523823  4.1.1_1
pkubaj search for other commits by this committer
emulators/qemu: fix build on powerpc64 elfv2

Clang doesn't like -mbig:
cc -mbig -c -o spapr-rtas.o spapr-rtas.S
cc: error: unknown argument: '-mbig'

This file doesn't seem to be built on amd64, so removing -mbig doesn't cause a
problem there. I also successfully built on powerpc64 elfv1 and it also builds.

PR:		243188
Approved by:	bofh (maintainer timeout)
07 Dec 2019 17:33:54
Original commit files touched by this commit Revision:519224  4.1.1_1
bofh search for other commits by this committer
emulators/qemu: Remove GUI dependencies from emulators/qemu-utils

PR:		242370
Submitted by:	krion
25 Nov 2019 19:57:03
Original commit files touched by this commit Revision:518421  4.1.1
bofh search for other commits by this committer
emulators/qemu: Fix USES placement

Reported by:	dch@skunkwerks.at
25 Nov 2019 11:01:43
Original commit files touched by this commit Revision:518397  4.1.1
bofh search for other commits by this committer
emulators/qemu: Updating version 3.1.1.1=>4.1.1

- 3.1.X branch has been moved to emulators/qemu31

Relnotes:	https://wiki.qemu.org/ChangeLog/4.1
08 Nov 2019 10:08:50
Original commit files touched by this commit Revision:517045  3.1.1.1
tobik search for other commits by this committer
e*: Add missing USES={gnome,sdl,xorg}
08 Oct 2019 08:24:39
Original commit files touched by this commit Revision:514056  3.1.1.1
linimon search for other commits by this committer
Add compiler:c11 to USES to fix build on GCC-based systems.

Tested on: amd64, powerpc64.

Approved by:	portmgr (tier-2 blanket)
05 Oct 2019 20:27:26
Original commit files touched by this commit Revision:513844  3.1.1.1
bofh search for other commits by this committer
emulators/qemu: Update version 3.1.1=>3.1.1.1
13 Aug 2019 16:03:12
Original commit files touched by this commit Revision:508837  3.1.1
mat search for other commits by this committer
Convert to UCL & cleanup pkg-message (categories e-g)
06 Aug 2019 09:46:44
Original commit files touched by this commit Revision:508242  3.1.1
bofh search for other commits by this committer
emulators/qemu: Update version 3.0.1=>3.1.1

- USES=gl is not always needed [1]

PR:		238364 [1]
Submitted by:	pizzamig [1]
09 Jul 2019 17:13:07
Original commit files touched by this commit Revision:506289  3.0.1_2
sunpoet search for other commits by this committer
Update security/nettle to 3.5.1

- Bump PORTREVISION of dependent ports for shlib change
- Fix build of devel/pijul [1]

Changes:	https://git.lysator.liu.se/nettle/nettle/blob/master/NEWS
PR:		238991
Exp-run by:	antoine
Thanks to:	tobik [1]
04 Jun 2019 14:17:39
Original commit files touched by this commit Revision:503475  3.0.1_1
antoine search for other commits by this committer
Switch default version of samba from 4.7 to 4.8

With hat:	portmgr
10 May 2019 13:15:47
Original commit files touched by this commit Revision:501174  3.0.1
asomers search for other commits by this committer
emulators/qemu-utils: Don't depend on GTK3 or cairo.

r499318 switched qemu from GTK2 to GTK3, accidentally making GTK3 a
dependency of qemu-utils. This commit fixes that, and also removes cairo as
a dependency for qemu-utils.

PR:		237738
Reported by:	bsam
Reviewed by:	bsam, bofh
Approved by:	bofh (qemu maintainer)
Differential Revision:	https://reviews.freebsd.org/D20202
18 Apr 2019 23:15:10
Original commit files touched by this commit Revision:499318  3.0.1
bofh search for other commits by this committer
emulators/qemu: Update version 2.12.1=>3.0.1

- Remove GNS3 OPTION
- Update GTK2 OPTION to GTK3 to use updated requirements of gtk30 and sdl20
12 Feb 2019 21:48:12
Original commit files touched by this commit Revision:492812  2.12.1_2
bofh search for other commits by this committer
emulators/qemu: Add NETMAP support

- Build qemu-guest-agent without unused libs [1]
- Fix build with DOCS disabled [2]

PR:		232949 [1] 230204 [2]
Submitted by:	zhecka@gmail.com [1] dewayne@heuristicsystems.com.au [2]
Reported by:	vmaffione
11 Nov 2018 15:30:29
Original commit files touched by this commit Revision:484695  2.12.1_1
novel search for other commits by this committer
emulators/qemu: fix build on 12 and -CURRENT

Build fails with:

hw/rdma/vmw/pvrdma_cmd.c:19:10: fatal error: 'linux/types.h' file not found

Add two upstream commits to fix this issue:

 * 72221d03b85fcfba27a47a2af08ee59150550ced to not include linux/types.h
 * 21ab34c9543fe1b6d31b3edbd01a397e7e090d00 to split PVRDMA from RDMA as
   pvrdma device can't be used on FreeBSD as mremap() system call is
   missing

PR:		232968
Reported by:	Trond.Endrestol@ximalas.info
Approved by:	portmgr (build fix blanket)
Obtained from:	upstream
MFH:		2018Q4
11 Nov 2018 02:13:11
Original commit files touched by this commit Revision:484653  2.12.1
lwhsu search for other commits by this committer
- Update to 2.12.1
- Change https MASTER_SITES
- Use xz distfile
- Remove MAKE_JOBS_UNSAFE

PR:		230972
Approved by:	maintainer timeout
02 Nov 2018 13:32:35
Original commit files touched by this commit Revision:483807  2.12.0_1
rene search for other commits by this committer
Remove compatibility code for FreeBSD < 11.2 from all ports.

Simplify some ports where DragonFlyBSD no longer needs to be special-cased.
Submitted by:	rene
Reviewed by:	bapt, jbeich
Differential Revision:	https://reviews.freebsd.org/D17724
01 Sep 2018 17:05:48
Original commit files touched by this commit Revision:478711  2.12.0_1
antoine search for other commits by this committer
Switch default version of samba to 4.7
Samba 4.6 will be discontinued in a few weeks

Reviewed by:	mat
Differential Revision:	https://reviews.freebsd.org/D16904
22 Jul 2018 02:27:08
Original commit files touched by this commit Revision:475080  2.12.0
bofh search for other commits by this committer
emulators/qemu: Update version 2.9.0>=2.12.0

- Pet portlint

Relnotes:	https://wiki.qemu.org/ChangeLog/2.12
19 Feb 2018 11:10:43
Original commit files touched by this commit Revision:462307  2.9.0_1
antoine search for other commits by this committer
Reduce dependency on the python2 metaport

PR:		225752
Submitted by:	Yasuhiro KIMURA
23 Dec 2017 07:03:21
Original commit files touched by this commit Revision:457024  2.9.0_1
antoine search for other commits by this committer
Change default version of samba from 4.4 to 4.6

Reviewed by:	mat
With hat:	portmgr
Differential Revision:	https://reviews.freebsd.org/D13529
06 Oct 2017 18:53:00
Original commit files touched by this commit Revision:451399  2.9.0
tobik search for other commits by this committer
emulators/qemu: Fix build without DOCS

- While here also add missing X11 dependencies to the GTK2 option

/usr/bin/install -c -c -m 0644 docs/qemu-qmp-ref.7
"/wrkdirs/usr/ports/emulators/qemu/work/stage/usr/local/man/man7"
install: docs/qemu-qmp-ref.7: No such file or directory
gmake[1]: *** [Makefile:576: install-doc] Error 71
gmake[1]: Leaving directory '/wrkdirs/usr/ports/emulators/qemu/work/qemu-2.9.0'

PR:		221749
Submitted by:	smh
Reviewed by:	novel
Approved by:	bofh
MFH:		2017Q4
04 Aug 2017 13:45:29
Original commit files touched by this commit Revision:447330  2.9.0
bofh search for other commits by this committer
emulators/qemu: Update version 2.8.1=>2.9.0

- Reorder LIB_DEPENDS
- Add VDE Networking OPTION [1]
- Move SAMBA CONFIGURE options to new clause from default
- Fix CONFIGURE failure [2]

PR:		220836[1], 220835[2]
submitted by:	holindho@saunalahti.fi [1][2]
Relnotes:	https://wiki.qemu.org/index.php/ChangeLog/2.9
23 May 2017 05:03:16
Original commit files touched by this commit Revision:441503  2.8.1_1
rezny search for other commits by this committer
Revision bump of all ports with USE_GL after consolidation of mesa-libs

Approved by:	swills (mentor)
Differential Revision:	https://reviews.freebsd.org/D10845
20 May 2017 12:02:07
Original commit files touched by this commit Revision:441309  2.8.1
linimon search for other commits by this committer
Mark some ports failing on power64.  In cases where the error message
was a stub, provide a real one.

While here, pet portlint.

Approved by:	portmgr (tier-2 blanket)
Reported by:	swills
12 Apr 2017 20:12:07
Original commit files touched by this commit Revision:438411  2.8.1
bofh search for other commits by this committer
emulators/qemu: Update version 2.8.0=>2.8.1
25 Mar 2017 23:37:05
Original commit files touched by this commit Revision:436925  2.8.0_3
antoine search for other commits by this committer
Switch default version of samba from 4.3 to 4.4

With hat:	portmgr
Differential Revision:	https://reviews.freebsd.org/D10131
21 Mar 2017 21:59:31
Original commit files touched by this commit Revision:436659  2.8.0_2
antoine search for other commits by this committer
- Add USES=samba to handle dependency on samba
  Valid ARGS:  build, env, lib, run (default: build,run)
- Add SAMBA_DEFAULT to bsd.default-versions.mk (default: 4.3)
- Remove obsolete samba36 ports
- Modify samba4x ports to install libsmbclient
- Convert the ports tree to USES=samba

Reviewed by:	mat
Differential Revision:	https://reviews.freebsd.org/D8919
10 Mar 2017 21:09:05
Original commit files touched by this commit Revision:435842  2.8.0_1
bofh search for other commits by this committer
emulators/qemu: Fix post-patch for CDROM_DMA option

Submitted by:	ilavsky.martin@gmail.com
10 Mar 2017 12:54:21
Original commit files touched by this commit Revision:435826  2.8.0
bofh search for other commits by this committer
emulators/qemu: Update version 2.6.1=>2.8.0

- Fix ncurses build uses to use base version and remove from CONFIGURE_ARGS
  for OPTIONS usage [1]

PR:		211973[1]
Submitted by:	ilavsky.martin@gmail.com[1]
05 Jan 2017 22:58:02
Original commit files touched by this commit Revision:430669  2.6.1_1
jbeich search for other commits by this committer
Assume "pkg-config libusb*" works after 9.x EOL

FreeBSD appears to use different pkg-config name for 0.1.x API but it
doesn't matter much as 0.1, 1.0 and 2.0 share CFLAGS/LIBS.
26 Oct 2016 13:55:23
Original commit files touched by this commit Revision:424701  2.6.1_1
amdmi3 search for other commits by this committer
- Verbosify build

Approved by:	portmgr blanket
14 Oct 2016 20:34:26
Original commit files touched by this commit Revision:423989  2.6.1_1
asomers search for other commits by this committer
Add emulators/qemu-utils

qemu-utils is a new port which installs a few miscellaneous qemu utilities
that are useful even without emulation capabilities. It is useful where
emulation is not needed, because it has far fewer dependencies than qemu.
It is equivalent to the Debian package of the same name.

Reviewed by:	sbruno, brd
Approved by:	brd (ports)
Sponsored by:	Spectra Logic Corp
Differential Revision:	https://reviews.freebsd.org/D8038
27 Aug 2016 17:15:51
Original commit files touched by this commit Revision:420986  2.6.1_1
bofh search for other commits by this committer
emulators/qemu: Unbreak in 11+ [1]

- Fix ncurses build uses to use base version and remove from CONFIGURE_ARGS
  for OPTIONS usage [2]

PR:		212057 [1] 211973 [2]
Submitted by:	mat [1]	ilavsky.martin@gmail.com [2]
19 Aug 2016 20:52:57
Original commit files touched by this commit Revision:420489  2.6.1
bofh search for other commits by this committer
emulators/qemu: Update version 2.5.1.1=>2.6.1

- Remove BSD_USER related codes
- Add NCURSES support [1]
- Fix STATIC_LINKS code to not build with X11 support

PR: 		211973 [1]
Submitted by:	ilavsky.martin@gmail.com [1]
15 Jun 2016 18:04:37
Original commit files touched by this commit Revision:416931  2.5.1.1 This port version is marked as vulnerable.
bofh search for other commits by this committer
emulators/qemu: Fix patch files which was updated in latest dist

Submitted by:	bar
10 Jun 2016 11:01:52
Original commit files touched by this commit Revision:416670  2.5.1.1 This port version is marked as vulnerable.
bofh search for other commits by this committer
emulators/qemu: Update version 2.4.0=>2.5.1.1

- Change X86_TARGETS Description
- Update pkg-plist to fix X86_TARGETS issue
31 May 2016 10:18:28
Original commit files touched by this commit Revision:416188  2.4.1_1 This port version is marked as vulnerable.
mat search for other commits by this committer
Fix build with Perl 5.25.1+.

Unescaped left brace in regex is illegal in regex.

With hat:	perl@
Sponsored by:	Absolight
19 May 2016 10:21:25
Original commit files touched by this commit Revision:415498  2.4.1_1 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Fix trailing whitespace in pkg-descrs, categories [a-f]*

Approved by:	portmgr blanket
01 Apr 2016 14:00:57
Original commit files touched by this commit Revision:412346  2.4.1_1 This port version is marked as vulnerable.
mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.

With hat:	portmgr
Sponsored by:	Absolight
27 Mar 2016 14:58:00
Original commit files touched by this commit Revision:411990  2.4.1_1 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Update security/gnutls to 3.4.10.
- Rename the LIBDANE option DANE because that's the name of the protocol
  supported by libgnutls-dane and gnutls-cli.  Also clarify the option
  description.
- Add an IDN option.
- libgnutls-openssl has been removed in 3.4.  Some ports used this library
  in their LIB_DEPENDS but no port actually required it.
- Some old API functions have been removed.  Ports that used these have been
  updated or patched to use the new API.
- Add a patch to print/cups to prevent overlinking of libgnutls.so.
- Bump PORTREVISION on dependent ports.

net-im/jabber: This port used the old API to give users fine grained
control over which crypto algorithms were used via a configuration file.
It's not immediately obvious how to port this to the new API so the port
always uses the defaults now.

www/hydra: Mark BROKEN.  This uses more removed calls than the other ports,
is said to be alpha quality and not fully functional and has been abandoned
10 years ago.

PR:		207768
Exp-run by:	antoine
Approved by:	portmgr (antoine)
26 Jan 2016 19:23:11
Original commit files touched by this commit Revision:407293  2.4.1 This port version is marked as vulnerable.
sbruno search for other commits by this committer
Typo in CONFLICTS noted by brooks.

Submitted by:	brooks
16 Dec 2015 14:15:19
Original commit files touched by this commit Revision:403864  2.4.1 This port version is marked as vulnerable.
bofh search for other commits by this committer
emulators/qemu: Update version 0.11.1=>2.4.1

- MASTER_SITES has been changed from SAVANNAH and local repo of nox@
  to new wiki.qemu.org
- Take MAINTAINERSHIP
- Updated to maintain version release with UPSTREAM. qemu-devel will be
updated to maintain with SNAPSHOTS
- Some of the patches has been converted to OPTIONSNG with post-patch
- Most of the patches are now makepatch compatible
- Converted most of the LEGACY OPTIONS to OPTIONSNG
14 Dec 2015 02:52:14
Original commit files touched by this commit Revision:403704  0.11.1_20 This port version is marked as vulnerable.
eadler search for other commits by this committer
Reset maintainer
30 Aug 2015 10:51:42
Original commit files touched by this commit Revision:395611  0.11.1_20 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Add LICENSE
- Pet portlint
- Switch to @sample

Approved by:	portmgr blanket
26 Jun 2015 19:14:41
Original commit files touched by this commit Revision:390664  0.11.1_20 This port version is marked as vulnerable.
nox search for other commits by this committer
- Apply fixes for pcnet guest to host escape vulnerability - CVE-2015-3209.
- Bump PORTREVISIONs.

PR:		201064
Submitted by:	koobs
Security:	https://vuxml.FreeBSD.org/freebsd/acd5d037-1c33-11e5-be9c-6805ca
1d3bb1.html
04 Jun 2015 09:06:33
Original commit files touched by this commit Revision:388504  0.11.1_19 This port version is marked as vulnerable.
amdmi3 search for other commits by this committer
- Add CPE info

Approved by:	portmgr blanket
17 May 2015 10:09:37
Original commit files touched by this commit Revision:386593  0.11.1_19 This port version is marked as vulnerable.
nox search for other commits by this committer
- Apply fixes for "BENOM" vulnerability - CVE-2015-3456 .
- Bump PORTREVISIONs.

PR:		200255
PR:		200256
PR:		200257
Submitted by:	venture37@geeklan.co.uk
Obtained
from:	http://git.qemu.org/?p=qemu.git;a=commitdiff;h=e907746266721f305d67bc0718795fedee2e824c
Security:	http://vuxml.FreeBSD.org/freebsd/2780e442-fc59-11e4-b18b-6805ca1d3bb1.html
14 May 2015 10:15:09
Original commit files touched by this commit Revision:386312  0.11.1_18 This port version is marked as vulnerable.
mat search for other commits by this committer
MASTER_SITES cleanup.

- Replace ${MASTER_SITE_FOO} with FOO.
- Merge MASTER_SITE_SUBDIR into MASTER_SITES when possible. (This means 99.9%
  of the time.)
- Remove occurrences of MASTER_SITE_LOCAL when no subdirectory was present and
  no hint of what it should be was present.
- Fix some logic.
- And generally, make things more simple and easy to understand.

While there, add magic values to the FESTIVAL, GENTOO, GIMP, GNUPG, QT and
SAMBA macros.

Also, replace some EXTRACT_SUFX occurences with USES=tar:*.

Checked by:	make fetch-urlall-list
With hat:	portmgr
Sponsored by:	Absolight
03 Apr 2015 11:26:50
Original commit files touched by this commit Revision:383107  0.11.1_18  Sanity Test Failure This port version is marked as vulnerable.
mat search for other commits by this committer
Remove OSVERSION checks that do not make sense any more.

For example (${OSVERSION} >= 900000 && ${OSVERSION} < 900021) is always true,
as is (${OSVERSION} > 900002 || ${OSVERSION} < 900000 && ${OSVERSION} > 800107).

Regarding patches, when an EXTRA_PATCHES is no longer needed, I remove it, when
it is always needed, I renamed it, in one case, I merged two patches.

Differential Revision:	https://reviews.freebsd.org/D2209
26 Mar 2015 21:40:34
Original commit files touched by this commit Revision:382346  0.11.1_18 This port version is marked as vulnerable.
bdrewery search for other commits by this committer
Revert my change from r381978.

The reason for it did not pan out.
23 Mar 2015 04:04:58
Original commit files touched by this commit Revision:381978  0.11.1_18 This port version is marked as vulnerable.
bdrewery search for other commits by this committer
Use BSDMAKE rather than MAKE here to ensure using /usr/bin/make.

With hat:	portmgr
19 Jan 2015 18:46:51
Original commit files touched by this commit Revision:377449  0.11.1_18 This port version is marked as vulnerable.
nox search for other commits by this committer
Fix build on 10+/i386 for when gcc49 becomes default (and fix ALL_TARGETS
on 10+/i386 while we're at it.)

PR:		196855
Submitted by:	gerald
06 Jan 2015 19:47:29
Original commit files touched by this commit Revision:376437  0.11.1_18 This port version is marked as vulnerable.
nox search for other commits by this committer
- Update emulators/qemu-sbruno to latest github snapshot, fixing
  the bsd-user targets on 8 and 9.
- Switch emulators/qemu-user-static to be slave of emulators/qemu-sbruno.
- Update emulators/qemu-devel to latest upstream release 2.2.0, now
  w/o bsd-user patches and knob again.  (Or at least until the
  patches are merged upstream...) [1]
- Add appropriate CONFLICTS to emulators/qemu too and bump its
  PORTREVISION.

Suggested by:	andrew [1] (for the benefit of testing aarch64 guests)
08 Dec 2014 16:48:41
Original commit files touched by this commit Revision:374303  0.11.1_17 This port version is marked as vulnerable.
tijl search for other commits by this committer
Replace USES=libtool:oldver with USES=libtool or USES=libtool:keepla in
the 32 ports that still use it.  Bump PORTREVISION on their dependent
ports except the ones that depend on these:

audio/libogg
audio/libvorbis
devel/pcre
ftp/curl
graphics/jpeg
graphics/libart_lgpl
graphics/tiff
textproc/expat2
textproc/libxslt

In these cases the same trick as in the recent gettext update is used.
(Only the first 15 lines of the commit message are shown above View all of this commit message)
27 Oct 2014 12:24:23
Original commit files touched by this commit Revision:371563  0.11.1_16 This port version is marked as vulnerable.
bapt search for other commits by this committer
Clean up plist
20 Sep 2014 08:44:29
Original commit files touched by this commit Revision:368629  0.11.1_16 This port version is marked as vulnerable.
nox search for other commits by this committer
- Remove ALL_TARGETS from OPTIONS_DEFAULT as target-ppc doesn't build
  with gcc48 on i386:

	work/qemu-0.11.1/target-ppc/op_helper.c: In function 'helper_fmadd':
	work/qemu-0.11.1/target-ppc/op_helper.c:1250:10: error: frame pointer required,
but reserved
	 uint64_t helper_fmadd (uint64_t arg1, uint64_t arg2, uint64_t arg3)

- Bump PORTREVISION.

Submitted by:	beefy1 via pkg-fallout
10 Sep 2014 20:50:37
Original commit files touched by this commit Revision:367888  0.11.1_15 This port version is marked as vulnerable.
gerald search for other commits by this committer
Update the default version of GCC in the Ports Collection from GCC 4.7.4
to GCC 4.8.3.

Part II, Bump PORTREVISIONs.

PR:		192025
Tested by:	antoine (-exp runs)
Approved by:	portmgr (implicit)
28 Jul 2014 18:39:29
Original commit files touched by this commit Revision:363222  0.11.1_14 This port version is marked as vulnerable.
adamw search for other commits by this committer
Rename emulators/ patch-xy patches to reflect the files they modify.
23 Jul 2014 09:54:02
Original commit files touched by this commit Revision:362645  0.11.1_14 This port version is marked as vulnerable.
tijl search for other commits by this committer
- Replace security/gnutls with security/gnutls3 and update to 3.2.15
- Bump PORTREVISION on all ports that depend on security/gnutls and
  adjust all ports that depend on security/gnutls3
- Update mail/anubis to version 4.2 which supports gnutls 3.x
- Update mail/libvmime to a development snapshot (recommended by upstream
  developers)

PR:		191274
Exp-run by:	antoine
Approved by:	portmgr (antoine)
15 Jul 2014 15:12:57
Original commit files touched by this commit Revision:361943  0.11.1_13 This port version is marked as vulnerable.
adamw search for other commits by this committer
Add DOCS to OPTIONS_DEFINE to ports that check for PORT_OPTIONS:MDOCS.
26 Jan 2014 20:19:19
Original commit files touched by this commit Revision:341274  0.11.1_13 This port version is marked as vulnerable.
marino search for other commits by this committer
emulators/qemu: Remove extraneous ".else" from previous commit
26 Jan 2014 14:49:42
Original commit files touched by this commit Revision:341193  0.11.1_13 This port version is marked as vulnerable.
nox search for other commits by this committer
- Update LIB_DEPENDS.
- Rewrite NOPORTDOCS.
- Stagify.
10 Nov 2013 20:27:06
Original commit files touched by this commit Revision:333441  0.11.1_13 This port version is marked as vulnerable.
nox search for other commits by this committer
(Attempt to) fix build with unusual locales(?).

Reported by:    AN <andy@neu.net> on -ports
20 Sep 2013 16:43:53
Original commit files touched by this commit Revision:327721  0.11.1_13 This port version is marked as vulnerable.
bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
emulators)
16 Sep 2013 16:45:35
Original commit files touched by this commit Revision:327414  0.11.1_13 This port version is marked as vulnerable.
bapt search for other commits by this committer
Convert to new perl framework
Convert USE_GMAKE to USES
14 Aug 2013 22:35:54
Original commit files touched by this commit Revision:324744  0.11.1_13  Sanity Test Failure This port version is marked as vulnerable.
ak search for other commits by this committer
- Remove MAKE_JOBS_SAFE variable

Approved by:	portmgr (bdrewery)
11 Jul 2013 16:26:27
Original commit files touched by this commit Revision:322783  0.11.1_13 This port version is marked as vulnerable.
sunpoet search for other commits by this committer
- Update to 7.31.0
- Bump PORTREVISION for ftp/curl shlib change
- Add TEST_DEPENDS
- Convert to new options framework
- Adjust options:
  - Add COOKIES
  - Add CYASSL, NSS, POLARSSL, THREADED_RESOLVER, TLS_SRP [1]
  - Add GSSAPI and SPNEGO [2]
  - Remove KERBEROS4
  - Rename LIBIDN to IDN
  - Remove TRACKMEMORY [1]
- Sort option handler
- Add SLAVEDIRS: ftp/curl-hiphop
- Cosmetic change
- Cleanup Makefile header
- While I'm here, fix typo (PORTREVSION) in x11-wm/ede/Makefile

Changes:	http://curl.haxx.se/changes.html
PR:		ports/172325 (-exp run), ports/177369 (based on) [1]
Submitted by:	Hirohisa Yamaguchi <umq@ueo.co.jp> [1], hrs (via email) [2]
Exp run by:	miwi
04 Jun 2013 21:47:59
Original commit files touched by this commit Revision:319916  0.11.1_12 This port version is marked as vulnerable.
nox search for other commits by this committer
Update pkg-message a bit for the old qemu version too.

Reminded by:	bapt
05 Feb 2013 16:17:07
Original commit files touched by this commit Revision:311722  0.11.1_12 This port version is marked as vulnerable.
novel search for other commits by this committer
- Add UPDATING entry for gnutls update
- Chase shlib version bump for dependant ports
31 Jan 2013 19:23:32
Original commit files touched by this commit Revision:311328  0.11.1_11 This port version is marked as vulnerable.
timur search for other commits by this committer
Change dependency from net/samba35 to net/samba36
06 Nov 2012 21:56:03
Original commit files touched by this commit Revision:307098  0.11.1_11 This port version is marked as vulnerable.
nox search for other commits by this committer
- Default these to USE_GCC= any after the clang switch.
- Strip Makefile headers.

Feature safe:	yes
19 Jun 2012 16:19:16
Original commit files touched by this commit   0.11.1_11 This port version is marked as vulnerable.
nox search for other commits by this committer
- Fix build after texi2html grew a new arg so -number became ambigious. [1]
- Remove double quotes from *_DESC now that make showconfig no longer
  needs them.

Submitted by:   pointyhat via linimon and pav [1]
01 Jun 2012 20:49:50
Original commit files touched by this commit   0.11.1_11 This port version is marked as vulnerable.
nox search for other commits by this committer
- Add patch to improve e1000 rx performance especially with netmap to
  emulators/qemu-devel. [1]
- Convert both qemu ports to OPTIONng.

Submitted by:   luigi [1] (original version of the patch)
Optained from:  qemu-devel mailinglist [1] (improved version of the patch)
18 Feb 2012 10:18:33
Original commit files touched by this commit   0.11.1_11 This port version is marked as vulnerable.
mva search for other commits by this committer
- Update devel/sdl12 to 1.2.15
- Update audio/sdl_mixer to 1.2.15
- Update graphics/sdl_image to 1.2.12
- Update graphics/sdl_ttf to 2.0.11
- Update graphics/sdl_gfx to 2.0.23
- Update net/sdl_net to 1.2.8
- Bump PORTREVISIONs on ports that depend on one or more packages due to
ABI and shared library version changes
- Update Mk/bsd.sdl.mk accordingly for the new shared library versions

Tested by:      exp-run by pav

Number of commits found: 236 (showing only 100 on this page)

1 | 2 | 3  »