notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Want a good monitor light? See my photosAll times are UTC
Ukraine
This referral link gives you 10% off a Fastmail.com account and gives me a discount on my Fastmail account.

Get notified when packages are built

A new feature has been added. FreshPorts already tracks package built by the FreeBSD project. This information is displayed on each port page. You can now get an email when FreshPorts notices a new package is available for something on one of your watch lists. However, you must opt into that. Click on Report Subscriptions on the right, and New Package Notification box, and click on Update.

Finally, under Watch Lists, click on ABI Package Subscriptions to select your ABI (e.g. FreeBSD:14:amd64) & package set (latest/quarterly) combination for a given watch list. This is what FreshPorts will look for.

Port details
rubygem-telesign TeleSign Ruby SDK
2.2.4 devel on this many watch lists=0 search for ports that depend on this port Find issues related to this port Report an issue related to this port View this port on Repology. pkg-fallout 2.2.4Version of this port present on the latest quarterly branch.
Maintainer: mfechner@FreeBSD.org search for ports maintained by this maintainer
Port Added: 2023-01-11 11:57:08
Last Update: 2023-01-14 23:08:33
Commit Hash: 18c6e18
Also Listed In: rubygems
License: MIT
WWW:
http://rubygems.org/gems/telesign
Description:
TeleSign Ruby SDK.
Homepage    cgit ¦ Codeberg ¦ GitHub ¦ GitLab ¦ SVNWeb - no subversion history for this port

Manual pages:
FreshPorts has no man page information for this port.
pkg-plist: as obtained via: make generate-plist
Expand this list (3 items)
Collapse this list.
  1. /usr/local/share/licenses/rubygem-telesign-2.2.4/catalog.mk
  2. /usr/local/share/licenses/rubygem-telesign-2.2.4/LICENSE
  3. /usr/local/share/licenses/rubygem-telesign-2.2.4/MIT
Collapse this list.
Dependency lines:
  • rubygem-telesign>0:devel/rubygem-telesign
To install the port:
cd /usr/ports/devel/rubygem-telesign/ && make install clean
To add the package, run one of these commands:
  • pkg install devel/rubygem-telesign
  • pkg install rubygem-telesign
NOTE: If this package has multiple flavors (see below), then use one of them instead of the name specified above.
PKGNAME: rubygem-telesign
Flavors: there is no flavor information for this port.
distinfo:
TIMESTAMP = 1669456801 SHA256 (rubygem/telesign-2.2.4.gem) = dcc6e96ea7bcb4da1e2ae786bfe7a4d670a4b5f94ae95dfcdde77d547c544c42 SIZE (rubygem/telesign-2.2.4.gem) = 8192

Packages (timestamps in pop-ups are UTC):
rubygem-telesign
ABIaarch64amd64armv6armv7i386powerpcpowerpc64powerpc64le
FreeBSD:13:latest2.2.42.2.4-2.2.42.2.4---
FreeBSD:13:quarterly2.2.42.2.42.2.42.2.42.2.42.2.42.2.42.2.4
FreeBSD:14:latest2.2.42.2.42.2.42.2.42.2.42.2.4-2.2.4
FreeBSD:14:quarterly2.2.42.2.4-2.2.42.2.42.2.42.2.42.2.4
FreeBSD:15:latest2.2.42.2.4n/a2.2.4n/a2.2.42.2.42.2.4
Dependencies
NOTE: FreshPorts displays only information on required and default dependencies. Optional dependencies are not covered.
Build dependencies:
  1. ruby30 : lang/ruby30
  2. gem : devel/ruby-gems
Runtime dependencies:
  1. rubygem-net-http-persistent>=3.0.0<5.0 : www/rubygem-net-http-persistent
  2. ruby30 : lang/ruby30
  3. gem : devel/ruby-gems
Patch dependencies:
  1. ruby30 : lang/ruby30
  2. gem : devel/ruby-gems
Extract dependencies:
  1. ruby30 : lang/ruby30
This port is required by:
for Run
  1. devel/rubygem-telesignenterprise

Configuration Options:
No options to configure
Options name:
devel_rubygem-telesign
USES:
gem
FreshPorts was unable to extract/find any pkg message
Master Sites:
Expand this list (1 items)
Collapse this list.
  1. https://rubygems.org/downloads/
Collapse this list.

Number of commits found: 2

Commit History - (may be incomplete: for full details, see links to repositories near top of page)
CommitCreditsLog message
2.2.4
14 Jan 2023 23:08:33
commit hash: 18c6e18276691edf5274406bf82a3b06792ff9aecommit hash: 18c6e18276691edf5274406bf82a3b06792ff9aecommit hash: 18c6e18276691edf5274406bf82a3b06792ff9aecommit hash: 18c6e18276691edf5274406bf82a3b06792ff9ae files touched by this commit
Muhammad Moinur Rahman (bofh) search for other commits by this committer
Mk/**ruby.mk: Switch from USE_RUBY=yes to USES=ruby

Switch from Mk/bsd.ruby.mk to Mk/Uses/ruby.mk

Notable changes are.

- Mk/bsd.ruby.mk is moved to Mk/Uses/ruby.mk.
- USE_RUBY=yes is replaced with USES=ruby.
- USE_RUBY_EXTCONF is replaced with USES=ruby:extconf.
- USE_RUBY_RDOC is replaced with USES=ruby:rdoc.
- USE_RUBY_SETUP is replaces with USES=ruby:setup.
- RUBY_NO_BUILD_DEPENDS and RUBY_NO_RUN_DEPENDS are replaced with
  USES=ruby:{build,none,run}.
- RUBY_REQUIRE isn't used anywhere, so removed.
- USES=gem now implies USES=ruby.

This is mainly the work of yasu@ at https://reviews.freebsd.org/D27863

I have just made some cosmetic changes and ran exp-run to test that the
tree is not in a BROKEN state.

Approved by:	portmgr
Differential Revision:	https://reviews.freebsd.org/D37925
2.2.4
11 Jan 2023 11:54:09
commit hash: f53e05b5ebb441fadfc29686ae1e0419fe118843commit hash: f53e05b5ebb441fadfc29686ae1e0419fe118843commit hash: f53e05b5ebb441fadfc29686ae1e0419fe118843commit hash: f53e05b5ebb441fadfc29686ae1e0419fe118843 files touched by this commit
Matthias Fechner (mfechner) search for other commits by this committer
www/gitlab-ce: add new ports required for version 15.6

Number of commits found: 2