notbugAs an Amazon Associate I earn from qualifying purchases.
Want a good read? Try FreeBSD Mastery: Jails (IT Mastery Book 15)
Want a good monitor light? See my photosAll times are UTC
Ukraine
This referral link gives you 10% off a Fastmail.com account and gives me a discount on my Fastmail account.
New feature planned: get notified when the package is available. Now is the time to contribute ideas/suggestions.
non port: devel/ninja-ide/Makefile

Number of commits found: 22

Sunday, 2 Dec 2018
15:41 rene search for other commits by this committer
Mark QT4 ports/functionality for removal on 2019-03-15

While here, chase some KDE4 ports and functionality, these are scheduled for
removal on 2018-12-31. Change the default option/flavor to QT5 where applicable
or use alternative toolkits like GTK.

Submitted by:	tcberner
Reviewed by:	adridg, jhale, rene, tcberner
Approved by:	portmgr (implicit, flavor hook)
Differential Revision:	https://reviews.freebsd.org/D17741
Original commitRevision:486467 
Thursday, 22 Nov 2018
20:18 tcberner search for other commits by this committer
pyqt: Change install directories for Python flavor support

* PyQt could not be installed for multiple Python versions at
  the same time, as there were conflicting files.

  This patch creates Python-version versioned directories for
  all these, and further installs binaries with a version number.

* Note, there might be some hickups for software that depends on
  on of the .so's provided by PyQt5, which might not be found
  anymore autmotically, and maybe need some LD-flaggery.

* Update PyQt5 to 5.10.1

* Mark www/py-qt5-webengine broken. It is unforuntately no longer
  compatible with the old qt5-webengine-5.9.4 we ship.

PR:		232745
Exp-run by:	antoine
Differential Revision:	https://reviews.freebsd.org/D8714
Original commitRevision:485614 
Monday, 19 Feb 2018
11:10 antoine search for other commits by this committer
Reduce dependency on the python2 metaport

PR:		225752
Submitted by:	Yasuhiro KIMURA
Original commitRevision:462307 
Saturday, 4 Feb 2017
13:37 tcberner search for other commits by this committer
Switch ports to use USE_PYQT=<foo> instead of using RUN_- and BUILD_DEPENDS

pyqt.mk provides USE_PYQT=<list> to depend on its components. Convert the ports
not yet using it to it.

Reviewed by:	rakuco, mat
Approved by:	rakuco (mentor)
Differential Revision:	https://reviews.freebsd.org/D9261
Original commitRevision:433310 
Tuesday, 14 Jun 2016
18:18 pi search for other commits by this committer
devel/py-qt4-core: change USE_PYQT from sip_build to sip to fix build

for those ports, unbreak:
  science/veusz
  math/qtiplot
  emulators/swine
  devel/ninja-ide

PR:		210045
Reported by:	antoine
Submitted by:	Tobias C.Berner <tcberner@gmail.com> (kde)
Original commitRevision:416904 
Friday, 10 Jun 2016
05:58 antoine search for other commits by this committer
Mark BROKEN: fails to configure

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "setup.py", line 40, in <module>
    import ninja_ide
  File "ninja_ide/__init__.py", line 48, in <module>
    import sip
ImportError: No module named sip

Reported by:	pkg-fallout
Original commitRevision:416654 
Friday, 1 Apr 2016
14:00 mat search for other commits by this committer
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.

With hat:	portmgr
Sponsored by:	Absolight
Original commitRevision:412346 
Wednesday, 6 May 2015
15:16 mat search for other commits by this committer
Update ports in the [bcd]* categories to not use GH_COMMIT.

With minor cleanups to make things simpler.

With hat:	portmgr
Sponsored by:	Absolight
Original commitRevision:385521 
Monday, 20 Oct 2014
16:04 mva search for other commits by this committer
- Convert ports of devel/ to USES=python

Approved by:	portmgr (implicit)
Original commitRevision:371280 
Wednesday, 10 Sep 2014
20:50 gerald search for other commits by this committer
Update the default version of GCC in the Ports Collection from GCC 4.7.4
to GCC 4.8.3.

Part II, Bump PORTREVISIONs.

PR:		192025
Tested by:	antoine (-exp runs)
Approved by:	portmgr (implicit)
Original commitRevision:367888 
Monday, 9 Jun 2014
10:14 mva search for other commits by this committer
- Enable stage support
- Remove easy_install dependency
- Convert to PYDISTUTILS_AUTOPLIST
- Bump PORTREVISION to enforce a cleanup for the easy_install references

With hat:	python@
Approved by:	portmgr (implicit)
Original commitRevision:357125 
Monday, 5 May 2014
09:45 bapt search for other commits by this committer
Convert all :U to :tu and :L to :tl

Since FreeBSD 8.4 and FreeBSD 9.1 make(1) do support :tu and :tl as a
replacement for :U and :L (which has been marked as deprecated)

bmake which is the default on FreeBSD 10+ only support by default
:tu/:tl a hack has been added at the time to support :U and :L to ease
migration. This hack is now not necessary anymore

Note that this makes the ports tree incompatible with make(1) from
FreeBSD 8.3 or earlier

With hat:	portmgr
Original commitRevision:352986 
Monday, 13 Jan 2014
21:00 rene search for other commits by this committer
Python cleanup:
- USE_PYTHON* = 2.X -> USE_PYTHON* = 2
- USE_PYTHON* = 2.X+ -> USE_PYTHON* = yes
Reviewed by:	python (mva, rm)
Approved by:	portmgr-lurkers (mat)
Original commitRevision:339634 
Friday, 20 Sep 2013
17:13 bapt search for other commits by this committer
Add NO_STAGE all over the place in preparation for the staging support (cat:
devel part 3)
Original commitRevision:327724 
Sunday, 14 Jul 2013
20:52 nivit search for other commits by this committer
- Add another download site
Original commitRevision:323003 
Saturday, 13 Jul 2013
22:56 nivit search for other commits by this committer
- Update to 2.3
- Add devel/py-qt4-declarative to RUN_DEPENDS
Original commitRevision:322975 
Saturday, 29 Jun 2013
05:28 nivit search for other commits by this committer
- Update to 2.2.d
- Trim Makefile header
- Remove initial article from COMMENT
- Add PYDISTUTILS_PKGVERSION
- Remove files/patch-ninja_ide__core__filesystem_notifications___init__.py
Original commitRevision:322026 
Sunday, 3 Feb 2013
18:16 makc search for other commits by this committer
Bump PORTREVISON after devel/py-sip and devel/qscintilla2 update.

x11-toolkits/py-qt:
- mark BROKEN: does not build with latest devel/py-sip
Original commitRevision:311476 
Tuesday, 11 Sep 2012
16:04 nivit search for other commits by this committer
- Update to 2.1.1
- Remove files/ninja-ide.in
- Set BUILD_DEPENDS equal to RUN_DEPENDS
- Rearrange Makefile to use GutHub as master site,
  and easy_install
- Fix format of WWW field in pkg-descr

BuildLog:	http://goo.gl/WNM1Z
Original commitRevision:304104 
Friday, 1 Jun 2012
05:26 dinoex search for other commits by this committer
- update png to 1.5.10
Original commit
Friday, 25 May 2012
01:50 makc search for other commits by this committer
Chase PyQT update
Original commit
Monday, 12 Dec 2011
17:26 nivit search for other commits by this committer
NINJA-IDE (from the recursive acronym: "Ninja-IDE Is Not Just Another IDE"),
is a cross-platform integrated development environment (IDE). NINJA-IDE runs
on *BSD, Linux/X11, Mac OS X and Windows desktop operating systems, and allows
developers to create applications for several purposes using all the tools and
utilities of NINJA-IDE, making the task of writing software easier and more
enjoyable.

WWW:    http://ninja-ide.org/
Original commit

Number of commits found: 22